Update dnf to 2.4.1-1
This commit is contained in:
parent
9087cf58a8
commit
fd06881bcf
1
.gitignore
vendored
1
.gitignore
vendored
@ -95,3 +95,4 @@
|
|||||||
/dnf-2.2.0.tar.gz
|
/dnf-2.2.0.tar.gz
|
||||||
/dnf-2.3.0.tar.gz
|
/dnf-2.3.0.tar.gz
|
||||||
/dnf-2.4.0.tar.gz
|
/dnf-2.4.0.tar.gz
|
||||||
|
/dnf-2.4.1.tar.gz
|
||||||
|
@ -1,31 +0,0 @@
|
|||||||
From fa5541bce749bc5e7a36913d3bf0ffb19b499fb8 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Jaroslav Mracek <jmracek@redhat.com>
|
|
||||||
Date: Wed, 3 May 2017 09:52:41 +0200
|
|
||||||
Subject: [PATCH] Filter out src for get_best_selector
|
|
||||||
|
|
||||||
Closes: #799
|
|
||||||
Approved by: ignatenkobrain
|
|
||||||
---
|
|
||||||
dnf/subject.py | 4 +++-
|
|
||||||
1 file changed, 3 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/dnf/subject.py b/dnf/subject.py
|
|
||||||
index d4834c08..cb754ce2 100644
|
|
||||||
--- a/dnf/subject.py
|
|
||||||
+++ b/dnf/subject.py
|
|
||||||
@@ -128,9 +128,11 @@ class Subject(object):
|
|
||||||
solution = self._get_nevra_solution(sack, forms=forms)
|
|
||||||
if solution['query']:
|
|
||||||
q = solution['query']
|
|
||||||
+ q = q.filter(arch__neq="src")
|
|
||||||
if obsoletes and solution['nevra'] and solution['nevra']._has_just_name():
|
|
||||||
q = q.union(sack.query().filter(obsoletes=q))
|
|
||||||
- return sltr.set(pkg=q)
|
|
||||||
+ if q:
|
|
||||||
+ return sltr.set(pkg=q)
|
|
||||||
|
|
||||||
return sltr
|
|
||||||
|
|
||||||
--
|
|
||||||
2.12.2
|
|
||||||
|
|
21
dnf.spec
21
dnf.spec
@ -24,8 +24,8 @@
|
|||||||
%global _docdir_fmt %{name}
|
%global _docdir_fmt %{name}
|
||||||
|
|
||||||
Name: dnf
|
Name: dnf
|
||||||
Version: 2.4.0
|
Version: 2.4.1
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Package manager forked from Yum, using libsolv as a dependency resolver
|
Summary: Package manager forked from Yum, using libsolv as a dependency resolver
|
||||||
# For a breakdown of the licensing, see PACKAGE-LICENSING
|
# For a breakdown of the licensing, see PACKAGE-LICENSING
|
||||||
License: GPLv2+ and GPLv2 and GPL
|
License: GPLv2+ and GPLv2 and GPL
|
||||||
@ -34,7 +34,6 @@ URL: https://github.com/rpm-software-management/dnf
|
|||||||
# cd dnf
|
# cd dnf
|
||||||
# tito build --tgz --tag=dnf-2.0.1-1
|
# tito build --tgz --tag=dnf-2.0.1-1
|
||||||
Source0: %{name}-%{version}.tar.gz
|
Source0: %{name}-%{version}.tar.gz
|
||||||
Patch0001: 0001-Filter-out-src-for-get_best_selector.patch
|
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
BuildRequires: cmake
|
BuildRequires: cmake
|
||||||
BuildRequires: gettext
|
BuildRequires: gettext
|
||||||
@ -333,6 +332,22 @@ popd
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu May 11 2017 Jaroslav Mracek <jmracek@redhat.com> 2.4.1-1
|
||||||
|
- bump version to 2.4.1 + update release notes (Jaroslav Mracek)
|
||||||
|
- goal: do not mark weak dependencies as userinstalled (Igor Gnatenko)
|
||||||
|
- fix typo in supplements (RhBug:1446756) (Igor Gnatenko)
|
||||||
|
- Describe present behavior of installonly_limit conf option (Jaroslav Mracek)
|
||||||
|
- Reset all transaction for groups if Base.reset() (RhBug:1446432) (Jaroslav
|
||||||
|
Mracek)
|
||||||
|
- Explain how add negative num for --latest-limit (RhBug:1446641) (Jaroslav
|
||||||
|
Mracek)
|
||||||
|
- trivial: don't duplicate option names (Igor Gnatenko)
|
||||||
|
- Add support for --userinstalled for repoquery command (RhBug:1278124)
|
||||||
|
(Jaroslav Rohel)
|
||||||
|
- Fix header of search result sections (RhBug:1301868) (Jaroslav Rohel)
|
||||||
|
- Filter out src for get_best_selector (Jaroslav Mracek)
|
||||||
|
- Add minor changes in formating of documentation (Jaroslav Mracek)
|
||||||
|
|
||||||
* Thu May 04 2017 Igor Gnatenko <ignatenko@redhat.com> - 2.4.0-2
|
* Thu May 04 2017 Igor Gnatenko <ignatenko@redhat.com> - 2.4.0-2
|
||||||
- Don't choose src packages for installation
|
- Don't choose src packages for installation
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (dnf-2.4.0.tar.gz) = efad97722ada847ccc64847de9dd697a1d2687728f42aea63bff9a690d392c2f027f01d5d51919e72a10cf7b818d99cf4e9578b715406dc1a7e079b6f5d47aab
|
SHA512 (dnf-2.4.1.tar.gz) = 818e690e133888ca1b8f4697770fb6736d595b0fdf4f22d11a5ecf8ccdfb3d0985590e8c0f96135bfce1fcb9bf23518857af460b93fa6807cd3ab4b73a8669e8
|
||||||
|
Loading…
Reference in New Issue
Block a user