Revert "Block signals during RPM transaction processing"
Reverting changes related to RPM signal blocking (RhBug:2133398) due to problems with building of other packages in Koji buildroot when these changes are included (RhBug:2236997).
This commit is contained in:
parent
684c8f18ec
commit
fb45a1ff29
@ -0,0 +1,36 @@
|
|||||||
|
From d78d79f44be227a910ec8ecf811ff5898b14f653 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Jan Kolarik <jkolarik@redhat.com>
|
||||||
|
Date: Wed, 20 Sep 2023 10:25:59 +0200
|
||||||
|
Subject: [PATCH] Revert "Block signals during RPM transaction processing"
|
||||||
|
|
||||||
|
---
|
||||||
|
dnf/base.py | 6 ------
|
||||||
|
1 file changed, 6 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/dnf/base.py b/dnf/base.py
|
||||||
|
index ff7c6fe7..7e97e212 100644
|
||||||
|
--- a/dnf/base.py
|
||||||
|
+++ b/dnf/base.py
|
||||||
|
@@ -1028,9 +1028,6 @@ class Base(object):
|
||||||
|
for display_ in cb.displays:
|
||||||
|
display_.output = False
|
||||||
|
|
||||||
|
- # block signals to disallow external interruptions of the transaction
|
||||||
|
- rpm.blockSignals(True)
|
||||||
|
-
|
||||||
|
self._plugins.run_pre_transaction()
|
||||||
|
|
||||||
|
logger.info(_('Running transaction'))
|
||||||
|
@@ -1048,9 +1045,6 @@ class Base(object):
|
||||||
|
for msg in dnf.util._post_transaction_output(self, self.transaction, _pto_callback):
|
||||||
|
logger.debug(msg)
|
||||||
|
|
||||||
|
- # unblock signals as we are done with the transaction
|
||||||
|
- rpm.blockSignals(False)
|
||||||
|
-
|
||||||
|
return tid
|
||||||
|
|
||||||
|
def _trans_error_summary(self, errstring):
|
||||||
|
--
|
||||||
|
2.41.0
|
||||||
|
|
8
dnf.spec
8
dnf.spec
@ -5,7 +5,7 @@
|
|||||||
%global hawkey_version 0.71.0
|
%global hawkey_version 0.71.0
|
||||||
%global libcomps_version 0.1.8
|
%global libcomps_version 0.1.8
|
||||||
%global libmodulemd_version 2.9.3
|
%global libmodulemd_version 2.9.3
|
||||||
%global rpm_version 4.18.0
|
%global rpm_version 4.14.0
|
||||||
|
|
||||||
# conflicts
|
# conflicts
|
||||||
%global conflicts_dnf_plugins_core_version 4.0.26
|
%global conflicts_dnf_plugins_core_version 4.0.26
|
||||||
@ -68,12 +68,13 @@ It supports RPMs, modules and comps groups & environments.
|
|||||||
|
|
||||||
Name: dnf
|
Name: dnf
|
||||||
Version: 4.17.0
|
Version: 4.17.0
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Summary: %{pkg_summary}
|
Summary: %{pkg_summary}
|
||||||
# For a breakdown of the licensing, see PACKAGE-LICENSING
|
# For a breakdown of the licensing, see PACKAGE-LICENSING
|
||||||
License: GPL-2.0-or-later AND GPL-1.0-only
|
License: GPL-2.0-or-later AND GPL-1.0-only
|
||||||
URL: https://github.com/rpm-software-management/dnf
|
URL: https://github.com/rpm-software-management/dnf
|
||||||
Source0: %{url}/archive/%{version}/%{name}-%{version}.tar.gz
|
Source0: %{url}/archive/%{version}/%{name}-%{version}.tar.gz
|
||||||
|
Patch0: 0001-Revert-Block-signals-during-RPM-transaction-processi.patch
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
BuildRequires: cmake
|
BuildRequires: cmake
|
||||||
BuildRequires: gettext
|
BuildRequires: gettext
|
||||||
@ -381,6 +382,9 @@ popd
|
|||||||
%{python3_sitelib}/%{name}/automatic/
|
%{python3_sitelib}/%{name}/automatic/
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Sep 20 2023 Jan Kolarik <jkolarik@redhat.com> - 4.17.0-2
|
||||||
|
- Revert "Block signals during RPM transaction processing" (RhBug:2236997)
|
||||||
|
|
||||||
* Fri Sep 01 2023 Jan Kolarik <jkolarik@redhat.com> - 4.17.0-1
|
* Fri Sep 01 2023 Jan Kolarik <jkolarik@redhat.com> - 4.17.0-1
|
||||||
- Update to 4.17.0
|
- Update to 4.17.0
|
||||||
- crypto: Use libdnf crypto API instead of using GnuPG/GpgME
|
- crypto: Use libdnf crypto API instead of using GnuPG/GpgME
|
||||||
|
Loading…
Reference in New Issue
Block a user