diff --git a/.gitignore b/.gitignore
index 20a854c..95b5934 100644
--- a/.gitignore
+++ b/.gitignore
@@ -82,3 +82,4 @@
 /dnf-1.1.2.tar.gz
 /dnf-1.1.3.tar.gz
 /dnf-1.1.4.tar.gz
+/dnf-1.1.5.tar.gz
diff --git a/dnf.spec b/dnf.spec
index a022796..34f9581 100644
--- a/dnf.spec
+++ b/dnf.spec
@@ -10,14 +10,13 @@
 %global py3pluginpath %{python3_sitelib}/dnf-plugins
 
 Name:		dnf
-Version:	1.1.4
-Release:	2%{?snapshot}%{?dist}
+Version:	1.1.5
+Release:	1%{?snapshot}%{?dist}
 Summary:	Package manager forked from Yum, using libsolv as a dependency resolver
 # For a breakdown of the licensing, see PACKAGE-LICENSING
 License:	GPLv2+ and GPLv2 and GPL
 URL:		https://github.com/rpm-software-management/dnf
 Source0:    https://github.com/rpm-software-management/dnf/archive/%{name}-%{version}.tar.gz
-Patch0:     stdin-fix.patch
 BuildArch:  noarch
 BuildRequires:  cmake
 BuildRequires:  gettext
@@ -138,7 +137,6 @@ Alternative CLI to "dnf upgrade" suitable for automatic, regular execution.
 
 %prep
 %setup -q -n dnf-%{version}
-%patch0 -p1
 rm -rf py3
 mkdir ../py3
 cp -a . ../py3/
@@ -183,7 +181,9 @@ make ARGS="-V" test
 popd
 
 %files -f %{name}.lang
-%doc AUTHORS README.rst COPYING PACKAGE-LICENSING
+%{!?_licensedir:%global license %doc}
+%license COPYING PACKAGE-LICENSING
+%doc AUTHORS README.rst
 %{_bindir}/dnf
 %{_mandir}/man8/dnf.8.gz
 %{_mandir}/man8/yum2dnf.8.gz
@@ -192,7 +192,8 @@ popd
 %{_var}/cache/dnf
 
 %files conf
-%doc AUTHORS README.rst COPYING PACKAGE-LICENSING
+%license COPYING PACKAGE-LICENSING
+%doc AUTHORS README.rst
 %dir %{confdir}
 %dir %{pluginconfpath}
 %dir %{confdir}/protected.d
@@ -211,19 +212,22 @@ popd
 %{_sysconfdir}/libreport/events.d/collect_dnf.conf
 
 %files -n dnf-yum
-%doc AUTHORS README.rst COPYING PACKAGE-LICENSING
+%license COPYING PACKAGE-LICENSING
+%doc AUTHORS README.rst
 %{_bindir}/yum
 %{_mandir}/man8/yum.8.gz
 
 %files -n python2-dnf
+%license COPYING PACKAGE-LICENSING
+%doc AUTHORS README.rst
 %{_bindir}/dnf-2
-%doc AUTHORS README.rst COPYING PACKAGE-LICENSING
 %exclude %{python_sitelib}/dnf/automatic
 %{python_sitelib}/dnf/
 %dir %{py2pluginpath}
 
 %files -n python3-dnf
-%doc AUTHORS README.rst COPYING PACKAGE-LICENSING
+%license COPYING PACKAGE-LICENSING
+%doc AUTHORS README.rst
 %{_bindir}/dnf-3
 %exclude %{python3_sitelib}/dnf/automatic
 %{python3_sitelib}/dnf/
@@ -231,7 +235,8 @@ popd
 %dir %{py3pluginpath}/__pycache__
 
 %files automatic
-%doc AUTHORS COPYING PACKAGE-LICENSING
+%license COPYING PACKAGE-LICENSING
+%doc AUTHORS
 %{_bindir}/dnf-automatic
 %config(noreplace) %{confdir}/automatic.conf
 %{_mandir}/man8/dnf.automatic.8.gz
@@ -270,8 +275,30 @@ exit 0
 %systemd_postun_with_restart dnf-automatic.timer
 
 %changelog
-* Fri Nov 27 2015 Michal Luscon <mluscon@redhat.com> 1.1.4-2
-- cli: don't crash if y/n and sys.stdin is None (RhBug:1278382) (Adam Williamson)
+* Thu Dec 17 2015 Michal Luscon <mluscon@redhat.com> 1.1.5-1
+- base: save group persistor only after successful transaction (RhBug:1229046)
+  (Michal Luscon)
+- base: do not clean tempfiles after remove transaction (RhBug:1282250) (Michal
+  Luscon)
+- base: clean packages that do not belong to any trans (Michal Luscon)
+- upgrade: allow group upgrade via @ syntax (RhBug:1265391) (Michal Luscon)
+- spec: Mark license files as %%license where available (Ville Skyttä)
+- Remove unused imports (Ville Skyttä)
+- Spelling fixes (Ville Skyttä)
+- Fix typos in documentation (Rob Cutmore)
+- parser: add support for braces in substitution (RhBug:1283017) (Dave
+  Johansen)
+- completion_helper: Don't omit "packages" from clean completions (Ville
+  Skyttä)
+- bash-completion: Avoid unnecessary python invocation per _dnf_helper (Ville
+  Skyttä)
+- repo: Download drpms early (RhBug:1260421) (Ville Skyttä)
+- clean: Don't hardcode list of args in two places (Ville Skyttä)
+- cli: don't crash if y/n and sys.stdin is None (RhBug:1278382) (Adam
+  Williamson)
+- sp err "environement" -> "environment" (Michael Goodwin)
+- Remove -OO from #!/usr/bin/python (RhBug:1230820) (Jaroslav Mracek)
+- cli: warn if plugins are disabled (RhBug:1280240) (Michal Luscon)
 
 * Mon Nov 16 2015 Michal Luscon <mluscon@redhat.com> 1.1.4-1
 - AUTHORS: updated (Jan Silhan)
@@ -352,7 +379,7 @@ exit 0
 - fixed downgrade with wildcard (RhBug:1234763) (Adam Salih)
 - reorganize logic of get_best_selector(s) and query (RhBug:1242946) (Adam
   Salih)
-- completion_helper: don't crash if exception was occured (RhBug:1225225) (Igor
+- completion_helper: don't crash if exception occurred (RhBug:1225225) (Igor
   Gnatenko)
 - base: expire cache if repo is not available (Michal Luscon)
 - Don't suggest --allowerasing if it is enabled (Christian Stadelmann)
@@ -432,7 +459,7 @@ exit 0
 * Fri Jul 17 2015 Michal Luscon <mluscon@redhat.com> 1.0.2-1
 - give --allowerasing hint when error occurs during resolution (RhBug:1148630)
   (Jan Silhan)
-- show --best hint with skipped packages everytime (RhBug:1176351) (Jan Silhan)
+- show --best hint with skipped packages every time (RhBug:1176351) (Jan Silhan)
 - notify about skipped packages when upgrade (RhBug:1210445) (Jan Silhan)
 - dnf-automatic: Document apply_updates=no behavior wrt keepcache (Ville
   Skyttä)
@@ -894,7 +921,7 @@ exit 0
 - cli: sort packages in the transaction summary. (Ales Kozumplik)
 - refactor: cli: massively simplify how errors are propagated from do_transaction(). (Ales Kozumplik)
 - groups: rearrange things in CLI so user has to confirm the group changes. (Ales Kozumplik)
-- groups: commiting the persistor data should only happen at one place. (Ales Kozumplik)
+- groups: committing the persistor data should only happen at one place. (Ales Kozumplik)
 - groups: visualizing the groups transactions. (Ales Kozumplik)
 - Add dnf.util.get_in() to navigate nested dicts with sequences of keys. (Ales Kozumplik)
 - group persistor: generate diffs between old and new DBs. (Ales Kozumplik)
diff --git a/sources b/sources
index a74fcb1..4603310 100644
--- a/sources
+++ b/sources
@@ -1 +1 @@
-79ae4f1206b4d30131162c9708a8bb7e  dnf-1.1.4.tar.gz
+1fbfd08f54700be565539a33be8e18f1  dnf-1.1.5.tar.gz
diff --git a/stdin-fix.patch b/stdin-fix.patch
deleted file mode 100644
index 2db4c82..0000000
--- a/stdin-fix.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-From b7c55d013542ce9e4c7775737bf454d9b10df977 Mon Sep 17 00:00:00 2001
-From: Adam Williamson <awilliam@redhat.com>
-Date: Tue, 17 Nov 2015 15:04:19 -0800
-Subject: [PATCH] cli: don't crash if y/n and sys.stdin is None (RhBug:1278382)
-
-Per https://bugzilla.redhat.com/show_bug.cgi?id=1278382 , if
-sys.stdin is somehow None (which currently seems to be the case
-when a dnf command is run in virt-builder) and a dnf command
-leads to a y/n question, dnf will crash. This should fix it.
----
- AUTHORS        | 1 +
- dnf/cli/cli.py | 2 +-
- 2 files changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/AUTHORS b/AUTHORS
-index 8e0d3be..ba95371 100644
---- a/AUTHORS
-+++ b/AUTHORS
-@@ -56,6 +56,7 @@ DNF AUTHORS
- DNF CONTRIBUTORS
- ----------------
-     Adam Salih <salih.max@gmail.com>
-+    Adam Williamson <awilliam@redhat.com>
-     Albert Uchytil <auchytil@redhat.com>
-     Alberto Ruiz <aruiz@redhat.com>
-     Baurzhan Muftakhidinov <baurthefirst@gmail.com>
-diff --git a/dnf/cli/cli.py b/dnf/cli/cli.py
-index 0918736..80cfa48 100644
---- a/dnf/cli/cli.py
-+++ b/dnf/cli/cli.py
-@@ -248,7 +248,7 @@ class BaseCli(dnf.Base):
- 
-             elif result == 1:
-                 ay = self.conf.assumeyes and not self.conf.assumeno
--                if not sys.stdin.isatty() and not ay:
-+                if (not sys.stdin or not sys.stdin.isatty()) and not ay:
-                     raise dnf.exceptions.Error(_('Refusing to automatically import keys when running ' \
-                             'unattended.\nUse "-y" to override.'))
- 
--- 
-2.4.3
-