Update dnf to 2.0.0-0.rc1.1
This commit is contained in:
parent
93d5af3254
commit
f2b8e8e422
1
.gitignore
vendored
1
.gitignore
vendored
@ -88,3 +88,4 @@
|
||||
/dnf-1.1.8.tar.gz
|
||||
/dnf-1.1.9.tar.gz
|
||||
/dnf-1.1.10-1.tar.gz
|
||||
/dnf-2.0.0.tar.gz
|
||||
|
@ -1,33 +0,0 @@
|
||||
From 61df26328ed819e4f220760a98ce31529c4ec609 Mon Sep 17 00:00:00 2001
|
||||
From: Igor Gnatenko <ignatenko@redhat.com>
|
||||
Date: Tue, 23 Aug 2016 15:17:09 +0200
|
||||
Subject: [PATCH] cli/repolist: fix showing repository name with 'disabled' arg
|
||||
(RhBug:1369459)
|
||||
|
||||
References: https://bugzilla.redhat.com/show_bug.cgi?id=1369459
|
||||
Signed-off-by: Igor Gnatenko <ignatenko@redhat.com>
|
||||
|
||||
Closes: #579
|
||||
Approved by: ignatenkobrain
|
||||
|
||||
(cherry picked from commit f41c4ebc5467f9f7b161545a5a416f0778f2ed96)
|
||||
---
|
||||
dnf/cli/commands/repolist.py | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/dnf/cli/commands/repolist.py b/dnf/cli/commands/repolist.py
|
||||
index 110db4d..0cf67f1 100644
|
||||
--- a/dnf/cli/commands/repolist.py
|
||||
+++ b/dnf/cli/commands/repolist.py
|
||||
@@ -260,7 +260,7 @@ class RepoListCommand(commands.Command):
|
||||
for (rid, rname, (ui_enabled, ui_endis_wid), ui_num) in cols:
|
||||
if arg == 'disabled': # Don't output a status column.
|
||||
print("%s %s" % (fill_exact_width(rid, id_len),
|
||||
- fill_exact_width(rname, nm_len, -nm_len)))
|
||||
+ fill_exact_width(rname, nm_len, nm_len)))
|
||||
continue
|
||||
|
||||
if ui_num:
|
||||
--
|
||||
2.9.3
|
||||
|
49
dnf.spec
49
dnf.spec
@ -1,8 +1,8 @@
|
||||
%global hawkey_min_ver 0.6.1
|
||||
%global hawkey_max_ver 0.7.0
|
||||
%global librepo_version 1.7.16
|
||||
%global libcomps_version 0.1.6
|
||||
%global rpm_version 4.12.0
|
||||
%global hawkey_version 0.7.0
|
||||
%global librepo_version 1.7.19
|
||||
%global libcomps_version 0.1.8
|
||||
%global rpm_version 4.13.0-0.rc1.29
|
||||
%global min_plugins_core 0.1.13
|
||||
%global dnf_langpacks_ver 0.15.1-6
|
||||
|
||||
%global confdir %{_sysconfdir}/%{name}
|
||||
@ -24,15 +24,13 @@
|
||||
%global _docdir_fmt %{name}
|
||||
|
||||
Name: dnf
|
||||
Version: 1.1.10
|
||||
Release: 2%{?dist}
|
||||
Version: 2.0.0
|
||||
Release: 0.rc1.1%{?dist}
|
||||
Summary: Package manager forked from Yum, using libsolv as a dependency resolver
|
||||
# For a breakdown of the licensing, see PACKAGE-LICENSING
|
||||
License: GPLv2+ and GPLv2 and GPL
|
||||
URL: https://github.com/rpm-software-management/dnf
|
||||
Source0: %{url}/archive/%{name}-%{version}-1.tar.gz
|
||||
# https://github.com/rpm-software-management/dnf/commit/61df26328ed819e4f220760a98ce31529c4ec609
|
||||
Patch0001: 0001-cli-repolist-fix-showing-repository-name-with-disabl.patch
|
||||
Source0: %{url}/archive/%{name}-%{version}/%{name}-%{version}.tar.gz
|
||||
BuildArch: noarch
|
||||
BuildRequires: cmake
|
||||
BuildRequires: gettext
|
||||
@ -64,11 +62,14 @@ Provides: dnf-command(provides)
|
||||
Provides: dnf-command(reinstall)
|
||||
Provides: dnf-command(remove)
|
||||
Provides: dnf-command(repolist)
|
||||
Provides: dnf-command(repoquery)
|
||||
Provides: dnf-command(repository-packages)
|
||||
Provides: dnf-command(search)
|
||||
Provides: dnf-command(updateinfo)
|
||||
Provides: dnf-command(upgrade)
|
||||
Provides: dnf-command(upgrade-to)
|
||||
Conflicts: python2-dnf-plugins-core < %{min_plugins_core}
|
||||
Conflicts: python3-dnf-plugins-core < %{min_plugins_core}
|
||||
|
||||
# dnf-langpacks package is retired in F25
|
||||
# to have clean upgrade path for dnf-langpacks
|
||||
@ -99,7 +100,7 @@ As a Yum CLI compatibility layer, supplies /usr/bin/yum redirecting to DNF.
|
||||
Summary: Python 2 interface to DNF
|
||||
%{?python_provide:%python_provide python2-%{name}}
|
||||
BuildRequires: python2-devel
|
||||
BuildRequires: python-hawkey >= %{hawkey_min_ver}
|
||||
BuildRequires: python-hawkey >= %{hawkey_version}
|
||||
BuildRequires: python-iniparse
|
||||
BuildRequires: python-libcomps >= %{libcomps_version}
|
||||
BuildRequires: python-librepo >= %{librepo_version}
|
||||
@ -115,8 +116,7 @@ Recommends: bash-completion
|
||||
Requires: pyliblzma
|
||||
Requires: %{name}-conf = %{version}-%{release}
|
||||
Requires: deltarpm
|
||||
Requires: python-hawkey >= %{hawkey_min_ver}
|
||||
Conflicts: python-hawkey >= %{hawkey_max_ver}
|
||||
Requires: python-hawkey >= %{hawkey_version}
|
||||
Requires: python-iniparse
|
||||
Requires: python-libcomps >= %{libcomps_version}
|
||||
Requires: python-librepo >= %{librepo_version}
|
||||
@ -140,7 +140,7 @@ Summary: Python 3 interface to DNF.
|
||||
%{?system_python_abi}
|
||||
%{?python_provide:%python_provide python3-%{name}}
|
||||
BuildRequires: python3-devel
|
||||
BuildRequires: python3-hawkey >= %{hawkey_min_ver}
|
||||
BuildRequires: python3-hawkey >= %{hawkey_version}
|
||||
BuildRequires: python3-iniparse
|
||||
BuildRequires: python3-libcomps >= %{libcomps_version}
|
||||
BuildRequires: python3-librepo >= %{librepo_version}
|
||||
@ -150,8 +150,7 @@ BuildRequires: rpm-python3 >= %{rpm_version}
|
||||
Recommends: bash-completion
|
||||
Requires: %{name}-conf = %{version}-%{release}
|
||||
Requires: deltarpm
|
||||
Requires: python3-hawkey >= %{hawkey_min_ver}
|
||||
Conflicts: python3-hawkey >= %{hawkey_max_ver}
|
||||
Requires: python3-hawkey >= %{hawkey_version}
|
||||
Requires: python3-iniparse
|
||||
Requires: python3-libcomps >= %{libcomps_version}
|
||||
Requires: python3-librepo >= %{librepo_version}
|
||||
@ -178,7 +177,7 @@ Requires(postun): systemd
|
||||
Alternative CLI to "dnf upgrade" suitable for automatic, regular execution.
|
||||
|
||||
%prep
|
||||
%autosetup -n %{name}-%{name}-%{version}-1 -p1
|
||||
%autosetup
|
||||
mkdir build
|
||||
%if %{with python3}
|
||||
mkdir build-py3
|
||||
@ -226,9 +225,6 @@ mv %{buildroot}%{_bindir}/dnf-automatic-2 %{buildroot}%{_bindir}/dnf-automatic
|
||||
%endif
|
||||
rm -vf %{buildroot}%{_bindir}/dnf-automatic-*
|
||||
|
||||
# This will eventually be the new default location for repo files
|
||||
mkdir %{buildroot}%{_sysconfdir}/distro.repos.d/
|
||||
|
||||
%check
|
||||
pushd build
|
||||
ctest -VV
|
||||
@ -248,13 +244,6 @@ popd
|
||||
%postun
|
||||
%systemd_postun_with_restart dnf-makecache.timer
|
||||
|
||||
%posttrans
|
||||
# cleanup pre-1.0.2 style cache
|
||||
for arch in %{ix86} x86_64 %{arm} aarch64 ppc %{sparc} %{alpha} s390 s390x %{power64} %{mips} ia64 ; do
|
||||
rm -rf /var/cache/dnf/$arch
|
||||
done
|
||||
exit 0
|
||||
|
||||
%post automatic
|
||||
%systemd_post dnf-automatic.timer
|
||||
|
||||
@ -264,11 +253,9 @@ exit 0
|
||||
%postun automatic
|
||||
%systemd_postun_with_restart dnf-automatic.timer
|
||||
|
||||
|
||||
%files -f %{name}.lang
|
||||
%{_bindir}/%{name}
|
||||
%if 0%{?rhel} && 0%{?rhel} <= 7
|
||||
%dir %{_sysconfdir}/bash_completion.d
|
||||
%{_sysconfdir}/bash_completion.d/%{name}
|
||||
%else
|
||||
%dir %{_datadir}/bash-completion
|
||||
@ -280,7 +267,6 @@ exit 0
|
||||
%{_unitdir}/%{name}-makecache.service
|
||||
%{_unitdir}/%{name}-makecache.timer
|
||||
%{_var}/cache/%{name}/
|
||||
%ghost %{_sysconfdir}/distro.repos.d
|
||||
|
||||
%files conf
|
||||
%license COPYING PACKAGE-LICENSING
|
||||
@ -336,6 +322,9 @@ exit 0
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Thu Sep 29 2016 Michal Luscon <mluscon@redhat.com> 2.0.0-0.rc1.1
|
||||
- See http://dnf.readthedocs.io/en/latest/release_notes.html
|
||||
|
||||
* Thu Sep 08 2016 Igor Gnatenko <ignatenko@redhat.com> - 1.1.10-2
|
||||
- Obsolete dnf-langpacks
|
||||
- Backport patch for dnf repolist disabled
|
||||
|
Loading…
Reference in New Issue
Block a user