Update dnf to 2.5.1-1
This commit is contained in:
parent
a0db35da68
commit
eaef4a5e91
1
.gitignore
vendored
1
.gitignore
vendored
@ -97,3 +97,4 @@
|
|||||||
/dnf-2.4.0.tar.gz
|
/dnf-2.4.0.tar.gz
|
||||||
/dnf-2.4.1.tar.gz
|
/dnf-2.4.1.tar.gz
|
||||||
/dnf-2.5.0.tar.gz
|
/dnf-2.5.0.tar.gz
|
||||||
|
/dnf-2.5.1.tar.gz
|
||||||
|
@ -1,104 +0,0 @@
|
|||||||
From 425da31359d46e170c7449592a67563662e53a7f Mon Sep 17 00:00:00 2001
|
|
||||||
From: Igor Gnatenko <ignatenko@redhat.com>
|
|
||||||
Date: Wed, 24 May 2017 15:14:40 +0200
|
|
||||||
Subject: [PATCH] Revert "Show progress for DRPM (RhBug:1198975)"
|
|
||||||
|
|
||||||
This reverts commit 9288d90d7fa6d0c168ec020e6a32d01185504220.
|
|
||||||
---
|
|
||||||
dnf/base.py | 4 +---
|
|
||||||
dnf/callback.py | 2 +-
|
|
||||||
dnf/cli/progress.py | 14 +++-----------
|
|
||||||
doc/api_callback.rst | 6 ++----
|
|
||||||
4 files changed, 7 insertions(+), 19 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/dnf/base.py b/dnf/base.py
|
|
||||||
index 811fdee8..ca5a1b08 100644
|
|
||||||
--- a/dnf/base.py
|
|
||||||
+++ b/dnf/base.py
|
|
||||||
@@ -1008,9 +1008,7 @@ class Base(object):
|
|
||||||
|
|
||||||
beg_download = time.time()
|
|
||||||
est_remote_size = sum(pload.download_size for pload in payloads)
|
|
||||||
- total_drpm = len(
|
|
||||||
- [payload for payload in payloads if isinstance(payload, dnf.drpm.DeltaPayload)])
|
|
||||||
- progress.start(len(payloads), est_remote_size, total_drpms=total_drpm)
|
|
||||||
+ progress.start(len(payloads), est_remote_size)
|
|
||||||
errors = dnf.repo._download_payloads(payloads, drpm)
|
|
||||||
|
|
||||||
if errors._irrecoverable:
|
|
||||||
diff --git a/dnf/callback.py b/dnf/callback.py
|
|
||||||
index e575fdb5..ea31aa61 100644
|
|
||||||
--- a/dnf/callback.py
|
|
||||||
+++ b/dnf/callback.py
|
|
||||||
@@ -88,7 +88,7 @@ class DownloadProgress(object):
|
|
||||||
|
|
||||||
pass
|
|
||||||
|
|
||||||
- def start(self, total_files, total_size, total_drpms=0):
|
|
||||||
+ def start(self, total_files, total_size):
|
|
||||||
"""Start new progress metering. :api
|
|
||||||
|
|
||||||
`total_files` the number of files that will be downloaded,
|
|
||||||
diff --git a/dnf/cli/progress.py b/dnf/cli/progress.py
|
|
||||||
index 2db6b232..8a91e429 100644
|
|
||||||
--- a/dnf/cli/progress.py
|
|
||||||
+++ b/dnf/cli/progress.py
|
|
||||||
@@ -51,11 +51,9 @@ class MultiFileProgressMeter(dnf.callback.DownloadProgress):
|
|
||||||
def message(self, msg):
|
|
||||||
dnf.util._terminal_messenger('write_flush', msg, self.fo)
|
|
||||||
|
|
||||||
- def start(self, total_files, total_size, total_drpms=0):
|
|
||||||
+ def start(self, total_files, total_size):
|
|
||||||
self.total_files = total_files
|
|
||||||
self.total_size = total_size
|
|
||||||
- self.total_drpm = total_drpms
|
|
||||||
- self.done_drpm = 0
|
|
||||||
|
|
||||||
# download state
|
|
||||||
self.done_files = 0
|
|
||||||
@@ -147,10 +145,8 @@ class MultiFileProgressMeter(dnf.callback.DownloadProgress):
|
|
||||||
size = int(payload.download_size)
|
|
||||||
|
|
||||||
# update state
|
|
||||||
- if status == dnf.callback.STATUS_MIRROR:
|
|
||||||
+ if status in (dnf.callback.STATUS_MIRROR, dnf.callback.STATUS_DRPM):
|
|
||||||
pass
|
|
||||||
- elif status == dnf.callback.STATUS_DRPM:
|
|
||||||
- self.done_drpm += 1
|
|
||||||
elif text in self.state:
|
|
||||||
start, done = self.state.pop(text)
|
|
||||||
self.active.remove(text)
|
|
||||||
@@ -163,11 +159,7 @@ class MultiFileProgressMeter(dnf.callback.DownloadProgress):
|
|
||||||
|
|
||||||
if status:
|
|
||||||
# the error message, no trimming
|
|
||||||
- if status is dnf.callback.STATUS_DRPM and self.total_drpm > 1:
|
|
||||||
- msg = '[%s %d/%d] %s: ' % (self.STATUS_2_STR[status], self.done_drpm,
|
|
||||||
- self.total_drpm, text)
|
|
||||||
- else:
|
|
||||||
- msg = '[%s] %s: ' % (self.STATUS_2_STR[status], text)
|
|
||||||
+ msg = '[%s] %s: ' % (self.STATUS_2_STR[status], text)
|
|
||||||
left = _term_width() - len(msg) - 1
|
|
||||||
msg = '%s%-*s\n' % (msg, left, err_msg)
|
|
||||||
else:
|
|
||||||
diff --git a/doc/api_callback.rst b/doc/api_callback.rst
|
|
||||||
index 5242e682..8fc44254 100644
|
|
||||||
--- a/doc/api_callback.rst
|
|
||||||
+++ b/doc/api_callback.rst
|
|
||||||
@@ -58,11 +58,9 @@
|
|
||||||
|
|
||||||
Report ongoing progress on the given `payload`. `done` is the number of bytes already downloaded from `payload`.
|
|
||||||
|
|
||||||
- .. method:: start(total_files, total_size, total_drpms=0)
|
|
||||||
+ .. method:: start(total_files, total_size)
|
|
||||||
|
|
||||||
- Report start of a download batch. `total_files` is the total number of payloads in the batch.
|
|
||||||
- `total_size` is the total number of bytes to be downloaded. `total_drpms` is the total number
|
|
||||||
- of drpms payloads in the batch.
|
|
||||||
+ Report start of a download batch. `total_files` is the total number of payloads in the batch. `total_size` is the total number of bytes to be downloaded.
|
|
||||||
|
|
||||||
.. class:: TransactionProgress
|
|
||||||
|
|
||||||
--
|
|
||||||
2.13.0
|
|
||||||
|
|
40
dnf.spec
40
dnf.spec
@ -24,8 +24,8 @@
|
|||||||
%global _docdir_fmt %{name}
|
%global _docdir_fmt %{name}
|
||||||
|
|
||||||
Name: dnf
|
Name: dnf
|
||||||
Version: 2.5.0
|
Version: 2.5.1
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Package manager forked from Yum, using libsolv as a dependency resolver
|
Summary: Package manager forked from Yum, using libsolv as a dependency resolver
|
||||||
# For a breakdown of the licensing, see PACKAGE-LICENSING
|
# For a breakdown of the licensing, see PACKAGE-LICENSING
|
||||||
License: GPLv2+ and GPLv2 and GPL
|
License: GPLv2+ and GPLv2 and GPL
|
||||||
@ -34,8 +34,6 @@ URL: https://github.com/rpm-software-management/dnf
|
|||||||
# cd dnf
|
# cd dnf
|
||||||
# tito build --tgz --tag=dnf-2.0.1-1
|
# tito build --tgz --tag=dnf-2.0.1-1
|
||||||
Source0: %{name}-%{version}.tar.gz
|
Source0: %{name}-%{version}.tar.gz
|
||||||
# Breaks API
|
|
||||||
Patch0: 0001-Revert-Show-progress-for-DRPM-RhBug-1198975.patch
|
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
BuildRequires: cmake
|
BuildRequires: cmake
|
||||||
BuildRequires: gettext
|
BuildRequires: gettext
|
||||||
@ -333,6 +331,40 @@ popd
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jun 12 2017 Jaroslav Mracek <jmracek@redhat.com> 2.5.1-1
|
||||||
|
- bump version to 2.5.1 + update release notes (Jaroslav Mracek)
|
||||||
|
- Fix: dnf update --refresh fails for repo_gpgcheck=1 (RhBug:1456419) (Daniel
|
||||||
|
Mach)
|
||||||
|
- Don't try to cut datetime message (Jaroslav Rohel)
|
||||||
|
- Use localized datetime format (RhBug:1445021) (Jaroslav Rohel)
|
||||||
|
- Work with locale date (Jaroslav Rohel)
|
||||||
|
- Use ISO 8601 time format in logfile (Jaroslav Rohel)
|
||||||
|
- Add unitest to prevent callbacks breakage (Jaroslav Mracek)
|
||||||
|
- Provide compatibility for tools that do not use total_drpms (Jaroslav Mracek)
|
||||||
|
- Requires strict usage of repoquery --recursive (Jaroslav Mracek)
|
||||||
|
- Fix output for --resolve with --installed for repoquery (Jaroslav Mracek)
|
||||||
|
- Remove unnecessary inheritance of yum conf options (Martin Hatina)
|
||||||
|
- Remove alwaysprompt option support (RhBug:1400714) (Jaroslav Rohel)
|
||||||
|
- Allow to install groups with multilib_policy=all (RhBug:1250702) (Jaroslav
|
||||||
|
Mracek)
|
||||||
|
- Redesign Base.install() to provide alternatives (Jaroslav Mracek)
|
||||||
|
- Report excludes includes into logger.debug (RhBug:1381988) (Jaroslav Mracek)
|
||||||
|
- Provide new API to parse string to NEVRA () (Jaroslav Mracek)
|
||||||
|
- Add more repoquery querytags (Jaroslav Rohel)
|
||||||
|
- Not hide tracebacks (Jaroslav Mracek)
|
||||||
|
- Solve error handling for get attr in yumdb (RhBug:1397848) (Jaroslav Mracek)
|
||||||
|
- Provide a better error if throttle to low (RhBug:1321407) (Jaroslav Mracek)
|
||||||
|
- Change timeout to 30s (RhBug:1291867) (Jaroslav Mracek)
|
||||||
|
- Add pre_transaction hook for plugins (Jaroslav Rohel)
|
||||||
|
- Not download metadata if "dnf history [info|list|userinstalled]" (Jaroslav
|
||||||
|
Mracek)
|
||||||
|
- Not download metadata if "dnf repo-pkgs <repo> list --installed" (Jaroslav
|
||||||
|
Mracek)
|
||||||
|
- Not download metadata if "dnf list --installed" (RhBug:1372895) (Jaroslav
|
||||||
|
Mracek)
|
||||||
|
- Format pkg str for repoquery --tree due to -qf (RhBug:1444751) (Jaroslav
|
||||||
|
Mracek)
|
||||||
|
|
||||||
* Wed May 24 2017 Igor Gnatenko <ignatenko@redhat.com> - 2.5.0-2
|
* Wed May 24 2017 Igor Gnatenko <ignatenko@redhat.com> - 2.5.0-2
|
||||||
- Revert patch which breaks API
|
- Revert patch which breaks API
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (dnf-2.5.0.tar.gz) = 2c7819abdbdae31f36faf90480d63395533da2919aa708e303835be832816d9e84a91de351a3b19f79af30c020ce76d4649a2e2c764a151c7db4c7924b2fc091
|
SHA512 (dnf-2.5.1.tar.gz) = 939476980437db12fb15c2178b73d7b36f785d1e2ae944c3ad1edbd9c56e9a6d392410fc1ec8682bfebf099b04ddb70cbb26aeec08e14f6634034db4f60b4469
|
||||||
|
Loading…
Reference in New Issue
Block a user