Backport patches
This commit is contained in:
parent
aeb22da079
commit
e549c1f21d
1
.dnf.metadata
Normal file
1
.dnf.metadata
Normal file
@ -0,0 +1 @@
|
||||
0697aee277730c57446b5b87bdb12456cf245203 dnf-4.14.0.tar.gz
|
1296
0012-RHEL-11345-Fix-japanese-translations.patch
Normal file
1296
0012-RHEL-11345-Fix-japanese-translations.patch
Normal file
File diff suppressed because it is too large
Load Diff
53
0013-RHEL-6396-Fix-substitution-in-kvp-in-add_new_repo.patch
Normal file
53
0013-RHEL-6396-Fix-substitution-in-kvp-in-add_new_repo.patch
Normal file
@ -0,0 +1,53 @@
|
||||
From 422794199b7b8a5f7426effc04979804cf31b6f7 Mon Sep 17 00:00:00 2001
|
||||
From: Anish Bhatt <anish.bhatt@salesforce.com>
|
||||
Date: Mon, 10 Jul 2023 10:09:17 -0700
|
||||
Subject: [PATCH] When parsing over a KVP list, do not return till the whole
|
||||
list is parsed
|
||||
|
||||
---
|
||||
dnf/repodict.py | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/dnf/repodict.py b/dnf/repodict.py
|
||||
index ffa0f8ed..82c05ac0 100644
|
||||
--- a/dnf/repodict.py
|
||||
+++ b/dnf/repodict.py
|
||||
@@ -79,8 +79,8 @@ class RepoDict(dict):
|
||||
if isinstance(value, str):
|
||||
substituted.append(
|
||||
libdnf.conf.ConfigParser.substitute(value, conf.substitutions))
|
||||
- if substituted:
|
||||
- return substituted
|
||||
+ if substituted:
|
||||
+ return substituted
|
||||
return values
|
||||
|
||||
repo = dnf.repo.Repo(repoid, conf)
|
||||
--
|
||||
2.41.0
|
||||
|
||||
|
||||
From d750fcb27686f73e352ae4575db150aa954aeb10 Mon Sep 17 00:00:00 2001
|
||||
From: Anish Bhatt <anish.bhatt@salesforce.com>
|
||||
Date: Mon, 10 Jul 2023 10:10:30 -0700
|
||||
Subject: [PATCH] Add to authors
|
||||
|
||||
---
|
||||
AUTHORS | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/AUTHORS b/AUTHORS
|
||||
index e802a51e..699a92c4 100644
|
||||
--- a/AUTHORS
|
||||
+++ b/AUTHORS
|
||||
@@ -63,6 +63,7 @@ DNF CONTRIBUTORS
|
||||
Adam Williamson <awilliam@redhat.com>
|
||||
Albert Uchytil <auchytil@redhat.com>
|
||||
Alberto Ruiz <aruiz@redhat.com>
|
||||
+ Anish Bhatt <anish.bhatt@salesforce.com>
|
||||
Baurzhan Muftakhidinov <baurthefirst@gmail.com>
|
||||
Christopher Meng <cickumqt@gmail.com>
|
||||
Daniel Mach <dmach@redhat.com>
|
||||
--
|
||||
2.41.0
|
||||
|
@ -0,0 +1,55 @@
|
||||
From cbc552f3f2ef72c8cb46e068aef841eee9206e30 Mon Sep 17 00:00:00 2001
|
||||
From: Marek Blaha <mblaha@redhat.com>
|
||||
Date: Wed, 20 Sep 2023 09:15:03 +0200
|
||||
Subject: [PATCH] base: Add obsoleters of only latest versions
|
||||
|
||||
Resolves situations where a package is in older version obsoleted, but
|
||||
there is newer (not obsoleted) version available.
|
||||
This patch covers installation of group packages and arch specific
|
||||
packages. The rest is in hawkey library.
|
||||
|
||||
Relevant bugs:
|
||||
https://bugzilla.redhat.com/show_bug.cgi?id=2183279
|
||||
https://bugzilla.redhat.com/show_bug.cgi?id=2176263
|
||||
---
|
||||
dnf/base.py | 17 +++++++++++++++--
|
||||
1 file changed, 15 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/dnf/base.py b/dnf/base.py
|
||||
index 7e97e21..50869ec 100644
|
||||
--- a/dnf/base.py
|
||||
+++ b/dnf/base.py
|
||||
@@ -1684,7 +1684,16 @@ class Base(object):
|
||||
sltr.set(provides="({} if {})".format(comps_pkg.name, comps_pkg.requires))
|
||||
else:
|
||||
if self.conf.obsoletes:
|
||||
- query = query.union(self.sack.query().filterm(obsoletes=query))
|
||||
+ # If there is no installed package in the pkgs_list, add only
|
||||
+ # obsoleters of the latest versions. Otherwise behave
|
||||
+ # consistently with upgrade and add all obsoleters.
|
||||
+ # See https://bugzilla.redhat.com/show_bug.cgi?id=2176263
|
||||
+ # for details of the problem.
|
||||
+ if query.installed():
|
||||
+ query = query.union(self.sack.query().filterm(obsoletes=query))
|
||||
+ else:
|
||||
+ query = query.union(self.sack.query().filterm(
|
||||
+ obsoletes=query.filter(latest_per_arch_by_priority=True)))
|
||||
sltr.set(pkg=query)
|
||||
self._goal.install(select=sltr, optional=not strict)
|
||||
return remove_query
|
||||
@@ -1921,7 +1930,11 @@ class Base(object):
|
||||
sltr = dnf.selector.Selector(self.sack)
|
||||
q = self.sack.query().filterm(pkg=packages)
|
||||
if self.conf.obsoletes:
|
||||
- q = q.union(self.sack.query().filterm(obsoletes=q))
|
||||
+ # use only obsoletes of the latest versions
|
||||
+ # See https://bugzilla.redhat.com/show_bug.cgi?id=2176263
|
||||
+ # for details of the problem.
|
||||
+ q = q.union(self.sack.query().filterm(
|
||||
+ obsoletes=q.filter(latest_per_arch_by_priority=True)))
|
||||
sltr = sltr.set(pkg=q)
|
||||
if reponame is not None:
|
||||
sltr = sltr.set(reponame=reponame)
|
||||
--
|
||||
libgit2 1.6.4
|
||||
|
10
dnf.spec
10
dnf.spec
@ -69,7 +69,7 @@ It supports RPMs, modules and comps groups & environments.
|
||||
|
||||
Name: dnf
|
||||
Version: 4.14.0
|
||||
Release: 8%{?dist}
|
||||
Release: 9%{?dist}
|
||||
Summary: %{pkg_summary}
|
||||
# For a breakdown of the licensing, see PACKAGE-LICENSING
|
||||
License: GPLv2+
|
||||
@ -86,6 +86,9 @@ Patch8: 0008-Omit-src-RPMs-from-check-update-RhBug-2151910.patch
|
||||
Patch9: 0009-automatic-Fix-online-detection-with-proxy-RhBz2022440.patch
|
||||
Patch10: 0010-automatic-Return-an-error-when-transaction-fails-RhB.patch
|
||||
Patch11: 0011-Document-symbols-in-dnf-history-list-output.patch
|
||||
Patch12: 0012-RHEL-11345-Fix-japanese-translations.patch
|
||||
Patch13: 0013-RHEL-6396-Fix-substitution-in-kvp-in-add_new_repo.patch
|
||||
Patch14: 0014-RHEL-6304-base-Add-obsoleters-of-only-latest-versions.patch
|
||||
|
||||
BuildArch: noarch
|
||||
BuildRequires: cmake
|
||||
@ -374,6 +377,11 @@ popd
|
||||
%{python3_sitelib}/%{name}/automatic/
|
||||
|
||||
%changelog
|
||||
* Wed Oct 25 2023 Jaroslav Rohel <jrohel@redhat.com> - 4.14.0-9
|
||||
- Fix japanese translations (RHEL-11345)
|
||||
- Fix substitution in kay-value-pair list in add_new_repo (RHEL-6396)
|
||||
- base: Add obsoleters of only latest versions (RHEL-6304)
|
||||
|
||||
* Wed Jun 28 2023 Jaroslav Rohel <jrohel@redhat.com> - 4.14.0-8
|
||||
- Return an error when transaction fails (RhBug:2170093,2212262)
|
||||
- Document symbols in `dnf history list` output (RhBug:2172067,2218113)
|
||||
|
Loading…
Reference in New Issue
Block a user