Update dnf to 1.1.3-1

This commit is contained in:
Michal Luscon 2015-10-14 18:43:41 +02:00
parent 4c11232b60
commit d83465d2e1
6 changed files with 18 additions and 350 deletions

1
.gitignore vendored
View File

@ -80,3 +80,4 @@
/dnf-1.1.0.tar.gz
/dnf-1.1.1.tar.gz
/dnf-1.1.2.tar.gz
/dnf-1.1.3.tar.gz

View File

@ -1,132 +0,0 @@
From b1c94815be71f01c314dcc26af69a19af50ee9d6 Mon Sep 17 00:00:00 2001
From: Michal Luscon <mluscon@redhat.com>
Date: Tue, 22 Sep 2015 14:16:34 +0200
Subject: [PATCH] Automatic commit of package [dnf] release [1.1.2-2].
add hawkey version requirement
revert commit #70956
---
dnf.spec | 11 +++++++----
doc/release_notes.rst | 1 -
doc/summaries_cache | 48 ++++++++++++++++++++++++++++++++++++++++++++++++
rel-eng/packages/dnf | 2 +-
4 files changed, 56 insertions(+), 6 deletions(-)
diff --git a/dnf.spec b/dnf.spec
index 966b312..ad516fa 100644
--- a/dnf.spec
+++ b/dnf.spec
@@ -1,4 +1,4 @@
-%global hawkey_version 0.6.0
+%global hawkey_version 0.6.1
%global librepo_version 1.7.16
%global libcomps_version 0.1.6
%global rpm_version 4.12.0
@@ -11,13 +11,12 @@
Name: dnf
Version: 1.1.2
-Release: 1%{?snapshot}%{?dist}
+Release: 2%{?snapshot}%{?dist}
Summary: Package manager forked from Yum, using libsolv as a dependency resolver
# For a breakdown of the licensing, see PACKAGE-LICENSING
License: GPLv2+ and GPLv2 and GPL
URL: https://github.com/rpm-software-management/dnf
-# Into distgit it is always uploaded only -1 release of sources
-Source0: https://github.com/rpm-software-management/dnf/archive/%{name}-%{version}-1.tar.gz
+Source0: https://github.com/rpm-software-management/dnf/archive/%{name}-%{version}.tar.gz
BuildArch: noarch
BuildRequires: cmake
BuildRequires: gettext
@@ -269,6 +268,10 @@ exit 0
%systemd_postun_with_restart dnf-automatic.timer
%changelog
+* Tue Sep 22 2015 Michal Luscon <mluscon@redhat.com> 1.1.2-2
+- add hawkey version requirement
+- revert commit #70956
+
* Tue Sep 22 2015 Michal Luscon <mluscon@redhat.com> 1.1.2-1
- doc: release notes 1.1.2 (Michal Luscon)
- sanitize non Unicode command attributes (RhBug:1262082) (Jan Silhan)
diff --git a/doc/release_notes.rst b/doc/release_notes.rst
index b7eac29..a459283 100644
--- a/doc/release_notes.rst
+++ b/doc/release_notes.rst
@@ -34,7 +34,6 @@ Bugs fixed in 1.1.2:
* :rhbug:`1048433`
* :rhbug:`1259650`
* :rhbug:`1260198`
-* :rhbug:`126255`
* :rhbug:`1259657`
* :rhbug:`1254982`
* :rhbug:`1261766`
diff --git a/doc/summaries_cache b/doc/summaries_cache
index b8ffe0c..2a50df7 100644
--- a/doc/summaries_cache
+++ b/doc/summaries_cache
@@ -1306,5 +1306,53 @@
[
1210289,
"RFE: Have a way to wait on dnf lock rather than terminate"
+ ],
+ [
+ 1262082,
+ "'ascii' codec can't decode byte 0xc3 in position 40: ordinal not in range(128)"
+ ],
+ [
+ 1250038,
+ "[abrt] python-dnf: completion_helper.py:84:run:IndexError: list index out of range"
+ ],
+ [
+ 1048433,
+ "RFE --downloadonly"
+ ],
+ [
+ 1259650,
+ "\"dnf provides\" or \"dnf repoquery --whatprovides\" does not support globs"
+ ],
+ [
+ 1260198,
+ "python-dnf should provide python2-dnf"
+ ],
+ [
+ 1259657,
+ "No dnf-command() provides for dnf commands"
+ ],
+ [
+ 1254982,
+ "dnf-automatic generates emails with broken charset"
+ ],
+ [
+ 1261766,
+ "RFE: way to force no metadata expiration system-wide"
+ ],
+ [
+ 1234491,
+ "[UX] dnf list installed: show repo id the package was installed from"
+ ],
+ [
+ 1256531,
+ "dnf install crashes if terminal window is too small"
+ ],
+ [
+ 1261656,
+ "DNF group update doesn't work"
+ ],
+ [
+ 1258364,
+ "Some important dnf output goes to STDERR and not to STDOUT"
]
]
\ No newline at end of file
diff --git a/rel-eng/packages/dnf b/rel-eng/packages/dnf
index 2ee0bef..584636d 100644
--- a/rel-eng/packages/dnf
+++ b/rel-eng/packages/dnf
@@ -1 +1 @@
-1.1.2-1 ./
+1.1.2-2 ./
--
2.4.3

View File

@ -1,36 +0,0 @@
From ba21747031cac8abb690de907f226b78cc7a7cb0 Mon Sep 17 00:00:00 2001
From: Michal Luscon <mluscon@redhat.com>
Date: Thu, 24 Sep 2015 11:22:49 +0200
Subject: [PATCH] Automatic commit of package [dnf] release [1.1.2-3].
Revert "completion_helper: don't get IndexError (RhBug:1250038)"
---
dnf/cli/cli.py | 12 +-----------
1 file changed, 1 insertion(+), 11 deletions(-)
diff --git a/dnf/cli/cli.py b/dnf/cli/cli.py
index 034c28a..277176e 100644
--- a/dnf/cli/cli.py
+++ b/dnf/cli/cli.py
@@ -1088,17 +1088,7 @@ class Cli(object):
2 = we've got work yet to do, onto the next stage
"""
self._process_demands()
- classTuple = (dnf.cli.commands.ListCommand,
- dnf.cli.commands.repolist.RepoListCommand,
- dnf.cli.commands.clean.CleanCommand,
- dnf.cli.commands.HistoryCommand)
- if isinstance(self.command, classTuple):
- if len(self.base.extcmds) > 1:
- return self.command.run(self.base.extcmds)
- else:
- if len(self.base.extcmds) > 0:
- return self.command.run(self.base.extcmds)
- return
+ return self.command.run(self.base.extcmds)
def print_usage(self):
return self.optparser.print_usage()
--
2.4.3

View File

@ -1,173 +0,0 @@
---
dnf/i18n.py | 21 ++++++++-------------
tests/test_i18n.py | 13 -------------
2 files changed, 8 insertions(+), 26 deletions(-)
diff --git a/dnf/i18n.py b/dnf/i18n.py
index 318a877..e6d3b4e 100644
--- a/dnf/i18n.py
+++ b/dnf/i18n.py
@@ -20,13 +20,12 @@
from __future__ import print_function
from __future__ import unicode_literals
from dnf.pycomp import (PY3, is_py3bytes, unicode, setlocale, gettext,
- gettext_setup)
+ gettext_setup, raw_input)
import locale
import os
import signal
import sys
import unicodedata
-import readline # workaround of raw_input() bug (RhBug:1258364)
"""
Centralize i18n stuff here. Must be unittested.
@@ -98,20 +97,16 @@ def setup_stdout():
return False
return True
+
def ucd_input(ucstring):
- """ Take input from user.
+ """ It uses print instead of passing the prompt to raw_input.
- What the raw_input() built-in does, but encode the prompt first
- (raw_input() won't check sys.stdout.encoding as e.g. print does, see
- test_i18n.TestInput.test_assumption()).
+ raw_input doesn't encode the passed string and the output
+ goes into stderr
"""
- if not isinstance(ucstring, unicode):
- raise TypeError("input() accepts Unicode strings")
- if PY3:
- return input(ucstring)
- enc = sys.stdout.encoding if sys.stdout.encoding else 'utf8'
- s = ucstring.encode(enc, 'strict')
- return raw_input(s)
+ print(ucstring, end='')
+ return raw_input()
+
def ucd(obj):
""" Like the builtin unicode() but tries to use a reasonable encoding. """
diff --git a/tests/test_i18n.py b/tests/test_i18n.py
index e11dfe8..2160ec7 100644
--- a/tests/test_i18n.py
+++ b/tests/test_i18n.py
@@ -78,19 +78,6 @@ class TestInput(TestCase):
# way, for instance when nosetests is run without the -s switch).
self.assertRaises(UnicodeEncodeError, raw_input, UC_TEXT)
- @unittest.skipIf(PY3, "in python3 there's no conversion in dnf.i18n.input")
- @mock.patch('sys.stdout')
- @mock.patch('__builtin__.raw_input', lambda x: x)
- def test_input(self, stdout):
- stdout.encoding = None
- s = dnf.i18n.ucd_input(UC_TEXT)
- self.assertEqual(s, UC_TEXT.encode('utf8'))
-
- stdout.encoding = 'iso-8859-2'
- s = dnf.i18n.ucd_input(UC_TEXT)
- self.assertEqual(s, UC_TEXT.encode('iso-8859-2'))
-
- self.assertRaises(TypeError, dnf.i18n.ucd_input, b"string")
class TestConversion(TestCase):
@mock.patch('dnf.i18n._guess_encoding', return_value='utf-8')
--
2.4.3
---
dnf/i18n.py | 29 +++++++++++++++--------------
1 file changed, 15 insertions(+), 14 deletions(-)
diff --git a/dnf/i18n.py b/dnf/i18n.py
index e6d3b4e..97ef800 100644
--- a/dnf/i18n.py
+++ b/dnf/i18n.py
@@ -19,8 +19,9 @@
from __future__ import print_function
from __future__ import unicode_literals
-from dnf.pycomp import (PY3, is_py3bytes, unicode, setlocale, gettext,
- gettext_setup, raw_input)
+from dnf.pycomp import unicode
+
+import dnf
import locale
import os
import signal
@@ -38,7 +39,7 @@ class UnicodeStream(object):
def write(self, s):
if not isinstance(s, str):
- s = (s.decode(self.encoding, 'replace') if PY3 else
+ s = (s.decode(self.encoding, 'replace') if dnf.pycomp.PY3 else
s.encode(self.encoding, 'replace'))
self.stream.write(s)
@@ -69,14 +70,14 @@ def _guess_encoding():
def setup_locale():
try:
- setlocale(locale.LC_ALL, '')
+ dnf.pycomp.setlocale(locale.LC_ALL, '')
# set time to C so that we output sane things in the logs (#433091)
- setlocale(locale.LC_TIME, 'C')
+ dnf.pycomp.setlocale(locale.LC_TIME, 'C')
except locale.Error as e:
# default to C locale if we get a failure.
print('Failed to set locale, defaulting to C', file=sys.stderr)
os.environ['LC_ALL'] = 'C'
- setlocale(locale.LC_ALL, 'C')
+ dnf.pycomp.setlocale(locale.LC_ALL, 'C')
def setup_stdout():
""" Check that stdout is of suitable encoding and handle the situation if
@@ -105,29 +106,29 @@ def ucd_input(ucstring):
goes into stderr
"""
print(ucstring, end='')
- return raw_input()
+ return dnf.pycomp.raw_input()
def ucd(obj):
""" Like the builtin unicode() but tries to use a reasonable encoding. """
- if PY3:
- if is_py3bytes(obj):
+ if dnf.pycomp.PY3:
+ if dnf.pycomp.is_py3bytes(obj):
return str(obj, _guess_encoding(), errors='ignore')
elif isinstance(obj, str):
return obj
return str(obj)
else:
- if isinstance(obj, unicode):
+ if isinstance(obj, dnf.pycomp.unicode):
return obj
if hasattr(obj, '__unicode__'):
# see the doc for the unicode() built-in. The logic here is: if obj
# implements __unicode__, let it take a crack at it, but handle the
# situation if it fails:
try:
- return unicode(obj)
+ return dnf.pycomp.unicode(obj)
except UnicodeError:
pass
- return unicode(str(obj), _guess_encoding(), errors='ignore')
+ return dnf.pycomp.unicode(str(obj), _guess_encoding(), errors='ignore')
# functions for formating output according to terminal width,
@@ -277,6 +278,6 @@ def textwrap_fill(text, width=70, initial_indent='', subsequent_indent=''):
return '\n'.join(ret)
# setup translation
-t = gettext.translation('dnf', fallback=True)
-_, P_ = gettext_setup(t)
+t = dnf.pycomp.gettext.translation('dnf', fallback=True)
+_, P_ = dnf.pycomp.gettext_setup(t)
--
2.4.3

View File

@ -10,16 +10,13 @@
%global py3pluginpath %{python3_sitelib}/dnf-plugins
Name: dnf
Version: 1.1.2
Release: 4%{?snapshot}%{?dist}
Version: 1.1.3
Release: 1%{?snapshot}%{?dist}
Summary: Package manager forked from Yum, using libsolv as a dependency resolver
# For a breakdown of the licensing, see PACKAGE-LICENSING
License: GPLv2+ and GPLv2 and GPL
URL: https://github.com/rpm-software-management/dnf
Source0: https://github.com/rpm-software-management/dnf/archive/%{name}-%{version}.tar.gz
Patch0: dnf-1.1.2-1-to-dnf-1.1.2-2.patch
Patch1: dnf-1.1.2-2-to-dnf-1.1.2-3.patch
Patch2: dnf-1.1.2-3-to-dnf-1.1.2-4.patch
BuildArch: noarch
BuildRequires: cmake
BuildRequires: gettext
@ -140,9 +137,6 @@ Alternative CLI to "dnf upgrade" suitable for automatic, regular execution.
%prep
%setup -q -n dnf-%{version}
%patch0 -p1
%patch1 -p1
%patch2 -p1
rm -rf py3
mkdir ../py3
cp -a . ../py3/
@ -274,6 +268,20 @@ exit 0
%systemd_postun_with_restart dnf-automatic.timer
%changelog
* Wed Oct 14 2015 Michal Luscon <mluscon@redhat.com> 1.1.3-1
- Update command_ref.rst (Jaroslav Mracek)
- Change in automatic.conf email settings to prevent email error with default
sender name (Jaroslav Mracek)
- Replace assert_called() with assert_called_with() for Py35 support (Neal
Gompa (ニール・ゴンパ))
- doc: improve documentation (Jaroslav Mracek)
- doc: update the instructions related to nightly builds (Radek Holy)
- Revert "Add the continuous integration script" (Radek Holy)
- Revert "cosmetic: ci: fix the Copr name in the README" (Radek Holy)
- Fix typo in Command.canonical's doctring (Timo Wilken)
- base: group_install is able to exclude mandatory packages
(Related:RhBug:1199868) (Jan Silhan)
* Tue Sep 30 2015 Michal Luscon <mluscon@redhat.com> 1.1.2-4
- don't import readline as it causes crashes in Anaconda
(related:RhBug:1258364)

View File

@ -1 +1 @@
ecab80a098eae26d46a65628e11b6b4e dnf-1.1.2.tar.gz
0b4fe2a0a20b6340263c1a657faf3246 dnf-1.1.3.tar.gz