Update to 4.18.0
This commit is contained in:
parent
21c9803eb3
commit
d3349d69a7
1
.gitignore
vendored
1
.gitignore
vendored
@ -159,3 +159,4 @@
|
|||||||
/dnf-4.16.1.tar.gz
|
/dnf-4.16.1.tar.gz
|
||||||
/dnf-4.16.2.tar.gz
|
/dnf-4.16.2.tar.gz
|
||||||
/dnf-4.17.0.tar.gz
|
/dnf-4.17.0.tar.gz
|
||||||
|
/dnf-4.18.0.tar.gz
|
||||||
|
@ -1,36 +0,0 @@
|
|||||||
From d78d79f44be227a910ec8ecf811ff5898b14f653 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Jan Kolarik <jkolarik@redhat.com>
|
|
||||||
Date: Wed, 20 Sep 2023 10:25:59 +0200
|
|
||||||
Subject: [PATCH] Revert "Block signals during RPM transaction processing"
|
|
||||||
|
|
||||||
---
|
|
||||||
dnf/base.py | 6 ------
|
|
||||||
1 file changed, 6 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/dnf/base.py b/dnf/base.py
|
|
||||||
index ff7c6fe7..7e97e212 100644
|
|
||||||
--- a/dnf/base.py
|
|
||||||
+++ b/dnf/base.py
|
|
||||||
@@ -1028,9 +1028,6 @@ class Base(object):
|
|
||||||
for display_ in cb.displays:
|
|
||||||
display_.output = False
|
|
||||||
|
|
||||||
- # block signals to disallow external interruptions of the transaction
|
|
||||||
- rpm.blockSignals(True)
|
|
||||||
-
|
|
||||||
self._plugins.run_pre_transaction()
|
|
||||||
|
|
||||||
logger.info(_('Running transaction'))
|
|
||||||
@@ -1048,9 +1045,6 @@ class Base(object):
|
|
||||||
for msg in dnf.util._post_transaction_output(self, self.transaction, _pto_callback):
|
|
||||||
logger.debug(msg)
|
|
||||||
|
|
||||||
- # unblock signals as we are done with the transaction
|
|
||||||
- rpm.blockSignals(False)
|
|
||||||
-
|
|
||||||
return tid
|
|
||||||
|
|
||||||
def _trans_error_summary(self, errstring):
|
|
||||||
--
|
|
||||||
2.41.0
|
|
||||||
|
|
24
dnf.spec
24
dnf.spec
@ -2,7 +2,7 @@
|
|||||||
%define __cmake_in_source_build 1
|
%define __cmake_in_source_build 1
|
||||||
|
|
||||||
# default dependencies
|
# default dependencies
|
||||||
%global hawkey_version 0.71.0
|
%global hawkey_version 0.71.1
|
||||||
%global libcomps_version 0.1.8
|
%global libcomps_version 0.1.8
|
||||||
%global libmodulemd_version 2.9.3
|
%global libmodulemd_version 2.9.3
|
||||||
%global rpm_version 4.14.0
|
%global rpm_version 4.14.0
|
||||||
@ -67,14 +67,13 @@
|
|||||||
It supports RPMs, modules and comps groups & environments.
|
It supports RPMs, modules and comps groups & environments.
|
||||||
|
|
||||||
Name: dnf
|
Name: dnf
|
||||||
Version: 4.17.0
|
Version: 4.18.0
|
||||||
Release: 6%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: %{pkg_summary}
|
Summary: %{pkg_summary}
|
||||||
# For a breakdown of the licensing, see PACKAGE-LICENSING
|
# For a breakdown of the licensing, see PACKAGE-LICENSING
|
||||||
License: GPL-2.0-or-later AND GPL-1.0-only
|
License: GPL-2.0-or-later AND GPL-1.0-only
|
||||||
URL: https://github.com/rpm-software-management/dnf
|
URL: https://github.com/rpm-software-management/dnf
|
||||||
Source0: %{url}/archive/%{version}/%{name}-%{version}.tar.gz
|
Source0: %{url}/archive/%{version}/%{name}-%{version}.tar.gz
|
||||||
Patch0: 0001-Revert-Block-signals-during-RPM-transaction-processi.patch
|
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
BuildRequires: cmake
|
BuildRequires: cmake
|
||||||
BuildRequires: gettext
|
BuildRequires: gettext
|
||||||
@ -86,6 +85,8 @@ Requires: python3-%{name} = %{version}-%{release}
|
|||||||
%if 0%{?rhel} && 0%{?rhel} <= 7
|
%if 0%{?rhel} && 0%{?rhel} <= 7
|
||||||
Requires: python-dbus
|
Requires: python-dbus
|
||||||
Requires: %{_bindir}/sqlite3
|
Requires: %{_bindir}/sqlite3
|
||||||
|
%elif 0%{?fedora}
|
||||||
|
Recommends: (%{_bindir}/sqlite3 if (bash-completion and python3-dnf-plugins-core))
|
||||||
%else
|
%else
|
||||||
Recommends: (python3-dbus if NetworkManager)
|
Recommends: (python3-dbus if NetworkManager)
|
||||||
%endif
|
%endif
|
||||||
@ -301,7 +302,6 @@ popd
|
|||||||
# If DNF5 does not obsolete DNF ownership of dnf.conf should be DNF's
|
# If DNF5 does not obsolete DNF ownership of dnf.conf should be DNF's
|
||||||
%config(noreplace) %{confdir}/%{name}.conf
|
%config(noreplace) %{confdir}/%{name}.conf
|
||||||
%endif
|
%endif
|
||||||
%config(noreplace) %{confdir}/protected.d/%{name}.conf
|
|
||||||
%config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
|
%config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
|
||||||
%ghost %attr(644,-,-) %{_localstatedir}/log/hawkey.log
|
%ghost %attr(644,-,-) %{_localstatedir}/log/hawkey.log
|
||||||
%ghost %attr(644,-,-) %{_localstatedir}/log/%{name}.log
|
%ghost %attr(644,-,-) %{_localstatedir}/log/%{name}.log
|
||||||
@ -363,6 +363,7 @@ popd
|
|||||||
%{_bindir}/%{name}-3
|
%{_bindir}/%{name}-3
|
||||||
%{_bindir}/%{name}4
|
%{_bindir}/%{name}4
|
||||||
%exclude %{python3_sitelib}/%{name}/automatic
|
%exclude %{python3_sitelib}/%{name}/automatic
|
||||||
|
%{python3_sitelib}/%{name}-*.dist-info
|
||||||
%{python3_sitelib}/%{name}/
|
%{python3_sitelib}/%{name}/
|
||||||
%dir %{py3pluginpath}
|
%dir %{py3pluginpath}
|
||||||
%dir %{py3pluginpath}/__pycache__
|
%dir %{py3pluginpath}/__pycache__
|
||||||
@ -382,6 +383,19 @@ popd
|
|||||||
%{python3_sitelib}/%{name}/automatic/
|
%{python3_sitelib}/%{name}/automatic/
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Oct 18 2023 Jan Kolarik <jkolarik@redhat.com> - 4.18.0-1
|
||||||
|
- Update to 4.18.0
|
||||||
|
- base: Add obsoleters of only latest versions (RhBug:2183279,2176263)
|
||||||
|
- comps: Fix marking a group package as installed (RhBug:2066638)
|
||||||
|
- distro-sync: Print better info message when no match (RhBug:2011850)
|
||||||
|
- Include dist-info for python3-dnf (RhBug:2239323)
|
||||||
|
- Revert "Block signals during RPM transaction processing" (RhBug:2133398)
|
||||||
|
- Do not print details of verifying (RhBug:1908253)
|
||||||
|
- Add Recommends %{_bindir}/sqlite3 for bash-completion for Fedora
|
||||||
|
- conf: Split $releasever to $releasever_major and $releasever_minor (RhBug:1789346)
|
||||||
|
- Allow DNF to be removed by DNF 5 (RhBug:2221907)
|
||||||
|
- Update translations
|
||||||
|
|
||||||
* Wed Sep 20 2023 Jan Kolarik <jkolarik@redhat.com> - 4.17.0-6
|
* Wed Sep 20 2023 Jan Kolarik <jkolarik@redhat.com> - 4.17.0-6
|
||||||
- Revert "Block signals during RPM transaction processing" (RhBug:2236997)
|
- Revert "Block signals during RPM transaction processing" (RhBug:2236997)
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (dnf-4.17.0.tar.gz) = d9d18bb5e3e0bdd77221ff886569a3210288c4fabb536c90b476351b5f53f443be86a4b4c086da168dde48718382bb1427bc9259a3241266847c7bb0940bdfb9
|
SHA512 (dnf-4.18.0.tar.gz) = 819a8da43235d779aa068909495386b4363e03f3d76bb44c48d43c555912600b0efa807e763b03c0801e4a3e3154414ad54bdcf5470b84c7c940d443e5b766d1
|
||||||
|
Loading…
Reference in New Issue
Block a user