Update to 4.2.15
This commit is contained in:
parent
46d992aee7
commit
c4f539f22f
1
.gitignore
vendored
1
.gitignore
vendored
@ -132,3 +132,4 @@
|
||||
/dnf-4.2.8.tar.gz
|
||||
/dnf-4.2.9.tar.gz
|
||||
/dnf-4.2.11.tar.gz
|
||||
/dnf-4.2.15.tar.gz
|
||||
|
@ -1,35 +0,0 @@
|
||||
From 9f9392c81dc493898dfab072cf0c7b1ae99df186 Mon Sep 17 00:00:00 2001
|
||||
From: Pavla Kratochvilova <pkratoch@redhat.com>
|
||||
Date: Wed, 13 Feb 2019 13:02:20 +0100
|
||||
Subject: [PATCH] Revert "Add best as default behavior (RhBug:1670776,1671683)"
|
||||
|
||||
---
|
||||
doc/api_conf.rst | 2 +-
|
||||
etc/dnf/dnf.conf | 1 -
|
||||
2 files changed, 1 insertion(+), 2 deletions(-)
|
||||
|
||||
diff --git a/doc/api_conf.rst b/doc/api_conf.rst
|
||||
index 9dd6a6a..f86e443 100644
|
||||
--- a/doc/api_conf.rst
|
||||
+++ b/doc/api_conf.rst
|
||||
@@ -30,7 +30,7 @@ Configurable settings of the :class:`dnf.Base` object are stored into a :class:`
|
||||
|
||||
.. attribute:: best
|
||||
|
||||
- Boolean option, ``True`` instructs the solver to either use a package with the highest available version or fail. On ``False``, do not fail if the latest version can not be installed. Default is ``True``.
|
||||
+ Boolean option, ``True`` instructs the solver to either use a package with the highest available version or fail. On ``False``, do not fail if the latest version can not be installed. Default is ``False``.
|
||||
|
||||
.. attribute:: cachedir
|
||||
|
||||
diff --git a/etc/dnf/dnf.conf b/etc/dnf/dnf.conf
|
||||
index 812c189..81b3e44 100644
|
||||
--- a/etc/dnf/dnf.conf
|
||||
+++ b/etc/dnf/dnf.conf
|
||||
@@ -2,4 +2,3 @@
|
||||
gpgcheck=1
|
||||
installonly_limit=3
|
||||
clean_requirements_on_remove=True
|
||||
-best=True
|
||||
--
|
||||
libgit2 0.27.7
|
||||
|
41
dnf.spec
41
dnf.spec
@ -1,5 +1,5 @@
|
||||
# default dependencies
|
||||
%global hawkey_version 0.35.5
|
||||
%global hawkey_version 0.37.0
|
||||
%global libcomps_version 0.1.8
|
||||
%global libmodulemd_version 1.4.0
|
||||
%global rpm_version 4.14.0
|
||||
@ -81,14 +81,13 @@
|
||||
It supports RPMs, modules and comps groups & environments.
|
||||
|
||||
Name: dnf
|
||||
Version: 4.2.11
|
||||
Release: 2%{?dist}
|
||||
Version: 4.2.15
|
||||
Release: 1%{?dist}
|
||||
Summary: %{pkg_summary}
|
||||
# For a breakdown of the licensing, see PACKAGE-LICENSING
|
||||
License: GPLv2+ and GPLv2 and GPL
|
||||
URL: https://github.com/rpm-software-management/dnf
|
||||
Source0: %{url}/archive/%{version}/%{name}-%{version}.tar.gz
|
||||
Patch0001: 0001-Revert-Add-best-as-default-behavior-RhBug16707761671683.patch
|
||||
|
||||
BuildArch: noarch
|
||||
BuildRequires: cmake
|
||||
@ -160,7 +159,7 @@ Summary: %{pkg_summary}
|
||||
%if 0%{?fedora}
|
||||
%if 0%{?fedora} >= 31
|
||||
Provides: %{name}-yum = %{version}-%{release}
|
||||
Obsoletes: %{name}-yum < %{version}-%{release}
|
||||
Obsoletes: %{name}-yum < 5
|
||||
%else
|
||||
Conflicts: yum < 3.4.3-505
|
||||
%endif
|
||||
@ -328,6 +327,13 @@ mv %{buildroot}%{_bindir}/dnf-automatic-2 %{buildroot}%{_bindir}/dnf-automatic
|
||||
%endif
|
||||
rm -vf %{buildroot}%{_bindir}/dnf-automatic-*
|
||||
|
||||
# Strict conf distribution
|
||||
%if 0%{?rhel}
|
||||
mv -f %{buildroot}%{confdir}/%{name}-strict.conf %{buildroot}%{confdir}/%{name}.conf
|
||||
%else
|
||||
rm -vf %{buildroot}%{confdir}/%{name}-strict.conf
|
||||
%endif
|
||||
|
||||
# YUM compat layer
|
||||
ln -sr %{buildroot}%{confdir}/%{name}.conf %{buildroot}%{_sysconfdir}/yum.conf
|
||||
%if %{with python3}
|
||||
@ -505,10 +511,31 @@ ln -sr %{buildroot}%{confdir}/vars %{buildroot}%{_sysconfdir}/yum/vars
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Thu Oct 01 2019 Ales Matej <amatej@redhat.com> - 4.2.11-2
|
||||
* Wed Nov 06 2019 Pavla Kratochvilova <pkratoch@redhat.com> - 4.2.15-1
|
||||
- Update to 4.2.15
|
||||
- Fix downloading local packages into destdir (RhBug:1727137)
|
||||
- Report skipped packages with identical nevra only once (RhBug:1643109)
|
||||
- Restore functionality of dnf remove --duplicates (RhBug:1674296)
|
||||
- Improve API documentation
|
||||
- Document NEVRA parsing in the man page
|
||||
- Do not wrap output when no terminal (RhBug:1577889)
|
||||
- Allow to ship alternative dnf.conf (RhBug:1752249)
|
||||
- Don't check if repo is expired if it doesn't have loaded metadata (RhBug:1745170)
|
||||
- Remove duplicate entries from "dnf search" output (RhBug:1742926)
|
||||
- Set default value of repo name attribute to repo id (RhBug:1669711)
|
||||
- Allow searching in disabled modules using "dnf module provides" (RhBug:1629667)
|
||||
- Group install takes obsoletes into account (RhBug:1761137)
|
||||
- Improve handling of vars
|
||||
- Do not load metadata for repolist commands (RhBug:1697472,1713055,1728894)
|
||||
- Fix messages for starting and failing scriptlets (RhBug:1724779)
|
||||
- Don't show older install-only pkgs updates in updateinfo (RhBug:1649383,1728004)
|
||||
- Add --ids option to the group command (RhBug:1706382)
|
||||
- Add --with_cve and --with_bz options to the updateinfo command (RhBug:1750528)
|
||||
|
||||
* Tue Oct 01 2019 Ales Matej <amatej@redhat.com> - 4.2.11-2
|
||||
- Fix required hawkey_version
|
||||
|
||||
* Thu Oct 01 2019 Ales Matej <amatej@redhat.com> - 4.2.11-1
|
||||
* Tue Oct 01 2019 Ales Matej <amatej@redhat.com> - 4.2.11-1
|
||||
- Improve modularity documentation (RhBug:1730162,1730162,1730807,1734081)
|
||||
- Fix detection whether system is running on battery (used by metadata caching timer) (RhBug:1498680)
|
||||
- New repoquery queryformat: %{reason}
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (dnf-4.2.11.tar.gz) = 894b9c23cc655fdd21d6445e92e5f2fe64b410419f0cc487220a2ddd103ab973a0f91f676cd2a1540db80a3033536034309810a9e6253f1aa95509d055883abf
|
||||
SHA512 (dnf-4.2.15.tar.gz) = dc4b58318cc4269b7211596b0361d89b6201344cc597d7196c7b4c184dd631f945927f5d52267e860e8e6a29ad64e52e6e14fc8fd8feca1d09ca2c15728d8676
|
||||
|
Loading…
Reference in New Issue
Block a user