Update to 4.2.17
This commit is contained in:
parent
26974bf508
commit
c10bc84e5d
1
.gitignore
vendored
1
.gitignore
vendored
@ -133,3 +133,4 @@
|
||||
/dnf-4.2.9.tar.gz
|
||||
/dnf-4.2.11.tar.gz
|
||||
/dnf-4.2.15.tar.gz
|
||||
/dnf-4.2.17.tar.gz
|
||||
|
@ -1,72 +0,0 @@
|
||||
From d57aa8f75350d3dfde54e419465a1a84ca72e164 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Ale=C5=A1=20Mat=C4=9Bj?= <amatej@redhat.com>
|
||||
Date: Mon, 11 Nov 2019 14:14:32 +0100
|
||||
Subject: [PATCH] Revert "Fix messages for starting and failing scriptlets
|
||||
(RhBug:1724779)"
|
||||
|
||||
This reverts commit 14c0a778def2a8a821177ebb54c9f32787bff11b.
|
||||
---
|
||||
dnf/yum/rpmtrans.py | 36 +++++-------------------------------
|
||||
1 file changed, 5 insertions(+), 31 deletions(-)
|
||||
|
||||
diff --git a/dnf/yum/rpmtrans.py b/dnf/yum/rpmtrans.py
|
||||
index 58c6101895..57f71e69bf 100644
|
||||
--- a/dnf/yum/rpmtrans.py
|
||||
+++ b/dnf/yum/rpmtrans.py
|
||||
@@ -391,21 +391,9 @@ def _scriptError(self, amount, total, key):
|
||||
scriptlet_name = rpm.tagnames.get(amount, "<unknown>")
|
||||
|
||||
transaction_list = self._extract_cbkey(key)
|
||||
- pkg_currenly_being_handled = transaction_list[0].pkg
|
||||
+ name = transaction_list[0].pkg.name
|
||||
|
||||
- if hasattr(key, "name"):
|
||||
- pkg_which_owns_this_scriptlet_name = key.name
|
||||
- else:
|
||||
- pkg_which_owns_this_scriptlet_name = key
|
||||
-
|
||||
- # In case rpm trigger runs scriptlet of some other package
|
||||
- if pkg_which_owns_this_scriptlet_name != pkg_currenly_being_handled.name:
|
||||
- msg = ("Error in %s scriptlet in rpm package %s triggered by rpm package %s"
|
||||
- % (scriptlet_name, pkg_which_owns_this_scriptlet_name,
|
||||
- pkg_currenly_being_handled))
|
||||
- else:
|
||||
- msg = ("Error in %s scriptlet in rpm package %s"
|
||||
- % (scriptlet_name, pkg_currenly_being_handled))
|
||||
+ msg = ("Error in %s scriptlet in rpm package %s" % (scriptlet_name, name))
|
||||
|
||||
for display in self.displays:
|
||||
display.error(msg)
|
||||
@@ -414,29 +402,15 @@ def _script_start(self, key):
|
||||
# TODO: this doesn't fit into libdnf TransactionItem use cases
|
||||
action = dnf.transaction.PKG_SCRIPTLET
|
||||
if key is None and self._te_list == []:
|
||||
- pkg_currenly_being_handled = 'None'
|
||||
+ pkg = 'None'
|
||||
else:
|
||||
transaction_list = self._extract_cbkey(key)
|
||||
- pkg_currenly_being_handled = transaction_list[0].pkg
|
||||
+ pkg = transaction_list[0].pkg
|
||||
complete = self.complete_actions if self.total_actions != 0 and self.complete_actions != 0 \
|
||||
else 1
|
||||
total = self.total_actions if self.total_actions != 0 and self.complete_actions != 0 else 1
|
||||
-
|
||||
- if hasattr(key, "name"):
|
||||
- pkg_which_owns_this_scriptlet_name = key.name
|
||||
- else:
|
||||
- pkg_which_owns_this_scriptlet_name = key
|
||||
-
|
||||
- # In case rpm trigger runs scriptlet of some other package
|
||||
- if pkg_which_owns_this_scriptlet_name != pkg_currenly_being_handled.name:
|
||||
- # Show only the pkg name, because we don't have the full nevra
|
||||
- # and if we search for the pkg we could show misleding information
|
||||
- pkg_or_key = pkg_which_owns_this_scriptlet_name
|
||||
- else:
|
||||
- pkg_or_key = pkg_currenly_being_handled
|
||||
-
|
||||
for display in self.displays:
|
||||
- display.progress(pkg_or_key, action, 100, 100, complete, total)
|
||||
+ display.progress(pkg, action, 100, 100, complete, total)
|
||||
|
||||
def _scriptStop(self):
|
||||
self._scriptout()
|
@ -1,61 +0,0 @@
|
||||
From 76e8e5c4b6408400e3b3e7503f97b550660a3760 Mon Sep 17 00:00:00 2001
|
||||
From: Marek Blaha <mblaha@redhat.com>
|
||||
Date: Thu, 7 Nov 2019 11:19:35 +0100
|
||||
Subject: [PATCH] Fix misplaced parenthesis
|
||||
|
||||
This can cause nice traceback when trying to install package with
|
||||
fileconflict:
|
||||
|
||||
Running transaction test
|
||||
The downloaded packages were saved in cache until the next successful transaction.
|
||||
You can remove cached packages by executing '{prog} clean packages'.
|
||||
Traceback (most recent call last):
|
||||
File "/usr/lib/python3.7/site-packages/dnf/cli/main.py", line 65, in main
|
||||
return _main(base, args, cli_class, option_parser_class)
|
||||
File "/usr/lib/python3.7/site-packages/dnf/cli/main.py", line 98, in _main
|
||||
return cli_run(cli, base)
|
||||
File "/usr/lib/python3.7/site-packages/dnf/cli/main.py", line 122, in cli_run
|
||||
ret = resolving(cli, base)
|
||||
File "/usr/lib/python3.7/site-packages/dnf/cli/main.py", line 166, in resolving
|
||||
base.do_transaction(display=displays)
|
||||
File "/usr/lib/python3.7/site-packages/dnf/cli/cli.py", line 243, in do_transaction
|
||||
tid = super(BaseCli, self).do_transaction(display)
|
||||
File "/usr/lib/python3.7/site-packages/dnf/base.py", line 856, in do_transaction
|
||||
raise dnf.exceptions.Error(errstring)
|
||||
dnf.exceptions.Error: Transaction test error:
|
||||
file /usr/bin/nitrate from install of python3-nitrate-1.5-1.fc30.noarch conflicts with file from package python2-nitrate-1.4-2.fc30.noarch
|
||||
file /usr/share/man/man1/python-nitrate.1.gz from install of python3-nitrate-1.5-1.fc30.noarch conflicts with file from package python2-nitrate-1.4-2.fc30.noarch
|
||||
|
||||
During handling of the above exception, another exception occurred:
|
||||
|
||||
Traceback (most recent call last):
|
||||
File "/usr/bin/dnf", line 58, in <module>
|
||||
main.user_main(sys.argv[1:], exit_code=True)
|
||||
File "/usr/lib/python3.7/site-packages/dnf/cli/main.py", line 191, in user_main
|
||||
errcode = main(args)
|
||||
File "/usr/lib/python3.7/site-packages/dnf/cli/main.py", line 65, in main
|
||||
return _main(base, args, cli_class, option_parser_class)
|
||||
File "/usr/lib/python3.7/site-packages/dnf/base.py", line 123, in __exit__
|
||||
self.close()
|
||||
File "/usr/lib/python3.7/site-packages/dnf/base.py", line 466, in close
|
||||
self._finalize_base()
|
||||
File "/usr/lib/python3.7/site-packages/dnf/base.py", line 445, in _finalize_base
|
||||
"'%s'."), "{prog} clean packages").format(prog=dnf.util.MAIN_PROG)
|
||||
AttributeError: 'NoneType' object has no attribute 'format'
|
||||
---
|
||||
dnf/base.py | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/dnf/base.py b/dnf/base.py
|
||||
index 59b93c3cb1..0443443d51 100644
|
||||
--- a/dnf/base.py
|
||||
+++ b/dnf/base.py
|
||||
@@ -442,7 +442,7 @@ def _finalize_base(self):
|
||||
logger.info(_("The downloaded packages were saved in cache "
|
||||
"until the next successful transaction."))
|
||||
logger.info(_("You can remove cached packages by executing "
|
||||
- "'%s'."), "{prog} clean packages").format(prog=dnf.util.MAIN_PROG)
|
||||
+ "'%s'."), "{prog} clean packages".format(prog=dnf.util.MAIN_PROG))
|
||||
|
||||
# Do not trigger the lazy creation:
|
||||
if self._history is not None:
|
33
dnf.spec
33
dnf.spec
@ -1,11 +1,11 @@
|
||||
# default dependencies
|
||||
%global hawkey_version 0.37.0
|
||||
%global hawkey_version 0.39.1
|
||||
%global libcomps_version 0.1.8
|
||||
%global libmodulemd_version 1.4.0
|
||||
%global rpm_version 4.14.0
|
||||
|
||||
# conflicts
|
||||
%global conflicts_dnf_plugins_core_version 4.0.6
|
||||
%global conflicts_dnf_plugins_core_version 4.0.12
|
||||
%global conflicts_dnf_plugins_extras_version 4.0.4
|
||||
%global conflicts_dnfdaemon_version 0.3.19
|
||||
|
||||
@ -81,18 +81,13 @@
|
||||
It supports RPMs, modules and comps groups & environments.
|
||||
|
||||
Name: dnf
|
||||
Version: 4.2.15
|
||||
Release: 2%{?dist}
|
||||
Version: 4.2.17
|
||||
Release: 1%{?dist}
|
||||
Summary: %{pkg_summary}
|
||||
# For a breakdown of the licensing, see PACKAGE-LICENSING
|
||||
License: GPLv2+ and GPLv2 and GPL
|
||||
URL: https://github.com/rpm-software-management/dnf
|
||||
Source0: %{url}/archive/%{version}/%{name}-%{version}.tar.gz
|
||||
# Temporary patch until revert is merged upstream, the fix has to be reverted because it break API
|
||||
Patch0002: 0002-Revert-Fix-messages-for-starting-and-failing-scriptlets.patch
|
||||
# Temporary patch until fix is newly released
|
||||
Patch0003: 0003-Fix-misplaced-parenthesis.patch
|
||||
|
||||
BuildArch: noarch
|
||||
BuildRequires: cmake
|
||||
BuildRequires: gettext
|
||||
@ -515,6 +510,26 @@ ln -sr %{buildroot}%{confdir}/vars %{buildroot}%{_sysconfdir}/yum/vars
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Fri Nov 29 2019 Ales Matej <amatej@redhat.com> - 4.2.17-1
|
||||
- Enable versionlock for check-update command (RhBug:1750620)
|
||||
- Add error message when no active modules matched (RhBug:1696204)
|
||||
- Log mirror failures as warning when repo load fails (RhBug:1713627)
|
||||
- dnf-automatic: Change all systemd timers to a fixed time of day (RhBug:1754609)
|
||||
- DNF can use config from the remote location (RhBug:1721091)
|
||||
- [doc] update reference to plugin documentation (RhBug:1706386)
|
||||
- [yum compatibility] Report all packages in repoinfo
|
||||
- [doc] Add definition of active/inactive module stream
|
||||
- repoquery: Add a switch to disable modular excludes
|
||||
- Report more informative messages when no match for argument (RhBug:1709563)
|
||||
- [doc] Add description of excludes in dnf
|
||||
- Report more descriptive message when removed package is excluded
|
||||
- Add module repoquery command
|
||||
- Fix assumptions about ARMv8 and the way the rpm features work (RhBug:1691430)
|
||||
- Add Requires information into module info commands
|
||||
- Enhance inheritance of transaction reasons (RhBug:1672618,1769788)
|
||||
- Make DNF compatible with FIPS mode (RhBug:1762032)
|
||||
- Return always alphabetically sorted modular profiles
|
||||
|
||||
* Tue Nov 12 2019 Ales Matej <amatej@redhat.com> - 4.2.15-2
|
||||
- Revert: Fix messages for starting and failing scriptlets (RhBug:1724779)
|
||||
- Fix traceback when trying to install package with fileconflict
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (dnf-4.2.15.tar.gz) = dc4b58318cc4269b7211596b0361d89b6201344cc597d7196c7b4c184dd631f945927f5d52267e860e8e6a29ad64e52e6e14fc8fd8feca1d09ca2c15728d8676
|
||||
SHA512 (dnf-4.2.17.tar.gz) = fd88f4bf9790a76409466f56681843826776b45a465d26bd4b2c9d2140cefeeb00dc9558c3ee4e3f750cc848aff439ca6fdb1a56c8813422bd235cd7b9677612
|
||||
|
Loading…
Reference in New Issue
Block a user