- Add link to AlmaLinux bugtracker
This commit is contained in:
parent
01a7163c23
commit
b965bdbb86
49
0001-Add-link-to-AlmaLinux-bugtracker.patch
Normal file
49
0001-Add-link-to-AlmaLinux-bugtracker.patch
Normal file
@ -0,0 +1,49 @@
|
|||||||
|
From 9e499fe783a6d7ac06b1f79b3610d2289804ec9c Mon Sep 17 00:00:00 2001
|
||||||
|
From: eabdullin <ed.abdullin.1@gmail.com>
|
||||||
|
Date: Thu, 1 Aug 2024 15:07:45 +0300
|
||||||
|
Subject: [PATCH] Add link to AlmaLinux bugtracker
|
||||||
|
|
||||||
|
---
|
||||||
|
dnf/const.py.in | 2 +-
|
||||||
|
doc/conf.py.in | 2 +-
|
||||||
|
tests/test_config.py | 3 +--
|
||||||
|
3 files changed, 3 insertions(+), 4 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/dnf/const.py.in b/dnf/const.py.in
|
||||||
|
index bcadc80..4450507 100644
|
||||||
|
--- a/dnf/const.py.in
|
||||||
|
+++ b/dnf/const.py.in
|
||||||
|
@@ -54,4 +54,4 @@ VERSION='@DNF_VERSION@'
|
||||||
|
USER_AGENT = "dnf/%s" % VERSION
|
||||||
|
|
||||||
|
BUGTRACKER_COMPONENT=NAME.lower()
|
||||||
|
-BUGTRACKER='https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora&component=%s' % BUGTRACKER_COMPONENT
|
||||||
|
+BUGTRACKER='https://bugs.almalinux.org/'
|
||||||
|
diff --git a/doc/conf.py.in b/doc/conf.py.in
|
||||||
|
index 368efe3..ba5649b 100644
|
||||||
|
--- a/doc/conf.py.in
|
||||||
|
+++ b/doc/conf.py.in
|
||||||
|
@@ -267,5 +267,5 @@ rst_prolog = """
|
||||||
|
.. _DNF: https://github.com/rpm-software-management/dnf/
|
||||||
|
.. _hawkey: http://rpm-software-management.github.io/hawkey/
|
||||||
|
.. _YUM: http://yum.baseurl.org/
|
||||||
|
-.. _bugzilla: https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora&component=dnf
|
||||||
|
+.. _bugzilla: https://bugs.almalinux.org/
|
||||||
|
"""
|
||||||
|
diff --git a/tests/test_config.py b/tests/test_config.py
|
||||||
|
index d850267..cdc4934 100644
|
||||||
|
--- a/tests/test_config.py
|
||||||
|
+++ b/tests/test_config.py
|
||||||
|
@@ -55,8 +55,7 @@ class ConfTest(tests.support.TestCase):
|
||||||
|
def test_bugtracker(self):
|
||||||
|
conf = Conf()
|
||||||
|
self.assertEqual(conf.bugtracker_url,
|
||||||
|
- "https://bugzilla.redhat.com/enter_bug.cgi" +
|
||||||
|
- "?product=Fedora&component=dnf")
|
||||||
|
+ "https://bugs.almalinux.org/")
|
||||||
|
|
||||||
|
def test_conf_from_file(self):
|
||||||
|
conf = Conf()
|
||||||
|
--
|
||||||
|
2.39.3 (Apple Git-146)
|
||||||
|
|
8
dnf.spec
8
dnf.spec
@ -68,7 +68,7 @@ It supports RPMs, modules and comps groups & environments.
|
|||||||
|
|
||||||
Name: dnf
|
Name: dnf
|
||||||
Version: 4.20.0
|
Version: 4.20.0
|
||||||
Release: 5%{?dist}
|
Release: 5%{?dist}.alma.1
|
||||||
Summary: %{pkg_summary}
|
Summary: %{pkg_summary}
|
||||||
# For a breakdown of the licensing, see PACKAGE-LICENSING
|
# For a breakdown of the licensing, see PACKAGE-LICENSING
|
||||||
License: GPL-2.0-or-later AND GPL-1.0-only
|
License: GPL-2.0-or-later AND GPL-1.0-only
|
||||||
@ -82,6 +82,9 @@ Patch5: 0005-tests-Use-PGP-keys-without-SHA-1.patch
|
|||||||
Patch6: 0006-Add-detection-for-ostree-based-systems-and-warn-user.patch
|
Patch6: 0006-Add-detection-for-ostree-based-systems-and-warn-user.patch
|
||||||
Patch7: 0007-Update-ostree-bootc-host-system-check.patch
|
Patch7: 0007-Update-ostree-bootc-host-system-check.patch
|
||||||
Patch8: 0008-Update-bootc-hosts-message-to-point-to-bootc-help.patch
|
Patch8: 0008-Update-bootc-hosts-message-to-point-to-bootc-help.patch
|
||||||
|
|
||||||
|
Patch1001: 0001-Add-link-to-AlmaLinux-bugtracker.patch
|
||||||
|
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
BuildRequires: cmake
|
BuildRequires: cmake
|
||||||
BuildRequires: gettext
|
BuildRequires: gettext
|
||||||
@ -422,6 +425,9 @@ popd
|
|||||||
%{python3_sitelib}/%{name}/automatic/
|
%{python3_sitelib}/%{name}/automatic/
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Aug 01 2024 Eduard Abdullin <eabdullin@almalinux.org> - 4.20.0-5.alma.1
|
||||||
|
- Add link to AlmaLinux bugtracker
|
||||||
|
|
||||||
* Tue Jul 23 2024 Petr Pisar <ppisar@redhat.com> - 4.20.0-5
|
* Tue Jul 23 2024 Petr Pisar <ppisar@redhat.com> - 4.20.0-5
|
||||||
- Adapt the tests to a crypto policy without SHA-1 (RHEL-50218)
|
- Adapt the tests to a crypto policy without SHA-1 (RHEL-50218)
|
||||||
- More specific error message on a locked OSTree system or a bootc system
|
- More specific error message on a locked OSTree system or a bootc system
|
||||||
|
Loading…
Reference in New Issue
Block a user