Obey repository priority configuration
This commit is contained in:
parent
a6f89576d0
commit
abfc354c03
@ -0,0 +1,28 @@
|
|||||||
|
From d068279fa27d063745544bbe009d10422eae5327 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Igor Gnatenko <ignatenko@redhat.com>
|
||||||
|
Date: Sun, 27 Aug 2017 22:12:36 +0200
|
||||||
|
Subject: [PATCH 35/50] base: set priority to hawkey repo as well
|
||||||
|
(RhBug:1470050)
|
||||||
|
|
||||||
|
References: https://bugzilla.redhat.com/show_bug.cgi?id=1470050
|
||||||
|
Reported-by: Pavel Raiskup <praiskup@redhat.com>
|
||||||
|
Signed-off-by: Igor Gnatenko <ignatenko@redhat.com>
|
||||||
|
---
|
||||||
|
dnf/base.py | 1 +
|
||||||
|
1 file changed, 1 insertion(+)
|
||||||
|
|
||||||
|
diff --git a/dnf/base.py b/dnf/base.py
|
||||||
|
index ab8812dd..0ea2f4d8 100644
|
||||||
|
--- a/dnf/base.py
|
||||||
|
+++ b/dnf/base.py
|
||||||
|
@@ -118,6 +118,7 @@ class Base(object):
|
||||||
|
hrepo.primary_fn = repo._primary_fn
|
||||||
|
hrepo.filelists_fn = repo._filelists_fn
|
||||||
|
hrepo.cost = repo.cost
|
||||||
|
+ hrepo.priority = repo.priority
|
||||||
|
if repo._presto_fn:
|
||||||
|
hrepo.presto_fn = repo._presto_fn
|
||||||
|
else:
|
||||||
|
--
|
||||||
|
2.13.5
|
||||||
|
|
7
dnf.spec
7
dnf.spec
@ -51,7 +51,7 @@
|
|||||||
|
|
||||||
Name: dnf
|
Name: dnf
|
||||||
Version: 2.6.3
|
Version: 2.6.3
|
||||||
Release: 10%{?dist}
|
Release: 11%{?dist}
|
||||||
Summary: Package manager forked from Yum, using libsolv as a dependency resolver
|
Summary: Package manager forked from Yum, using libsolv as a dependency resolver
|
||||||
# For a breakdown of the licensing, see PACKAGE-LICENSING
|
# For a breakdown of the licensing, see PACKAGE-LICENSING
|
||||||
License: GPLv2+ and GPLv2 and GPL
|
License: GPLv2+ and GPLv2 and GPL
|
||||||
@ -62,6 +62,8 @@ URL: https://github.com/rpm-software-management/dnf
|
|||||||
Source0: %{name}-%{version}.tar.gz
|
Source0: %{name}-%{version}.tar.gz
|
||||||
Patch0: %{name}-nose-use-module.patch
|
Patch0: %{name}-nose-use-module.patch
|
||||||
Patch1: 0001-Re-introduce-dnf-automatic.-service-timer.patch
|
Patch1: 0001-Re-introduce-dnf-automatic.-service-timer.patch
|
||||||
|
Patch35: 0035-base-set-priority-to-hawkey-repo-as-well-RhBug-14700.patch
|
||||||
|
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
BuildRequires: cmake
|
BuildRequires: cmake
|
||||||
BuildRequires: gettext
|
BuildRequires: gettext
|
||||||
@ -522,6 +524,9 @@ popd
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Sep 13 2017 Jeroen van Meeuwen <kanarip@fedoraproject.org> - 2.6.3-11
|
||||||
|
- Added patch to obey repository priority configuration
|
||||||
|
|
||||||
* Wed Sep 13 2017 Jaroslav Mracek <jmracek@redhat.com> - 2.6.3-10
|
* Wed Sep 13 2017 Jaroslav Mracek <jmracek@redhat.com> - 2.6.3-10
|
||||||
- Added patch to add services for dnf-automatic that were previously removed
|
- Added patch to add services for dnf-automatic that were previously removed
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user