Update to 4.12.0
This commit is contained in:
parent
d39805f422
commit
a686b9fa08
1
.gitignore
vendored
1
.gitignore
vendored
@ -150,3 +150,4 @@
|
||||
/dnf-4.10.0.tar.gz
|
||||
/dnf-4.11.0.tar.gz
|
||||
/dnf-4.11.1.tar.gz
|
||||
/dnf-4.12.0.tar.gz
|
||||
|
@ -1,37 +0,0 @@
|
||||
From 3e36c99d401530dc026712523a7c445da17ee299 Mon Sep 17 00:00:00 2001
|
||||
From: Marek Blaha <mblaha@redhat.com>
|
||||
Date: Mon, 14 Mar 2022 09:49:52 +0100
|
||||
Subject: [PATCH] Fix processing of download errors (RhBug: 2024527)
|
||||
|
||||
Users with different than english locale are not able to update their
|
||||
systems in case that some of updates are already downloaded in the dnf
|
||||
cache (e.g. using dnf-automatic).
|
||||
|
||||
The error string is taken from librepo target where it is stored
|
||||
untranslated. Therefore we need to compare untranslated versions of the
|
||||
string.
|
||||
|
||||
= changelog =
|
||||
msg: Fix download errors handling in non-english locales
|
||||
type: bugfix
|
||||
resolves: https://bugzilla.redhat.com/show_bug.cgi?id=2024527
|
||||
---
|
||||
dnf/repo.py | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/dnf/repo.py b/dnf/repo.py
|
||||
index 1822cf0..ec1a253 100644
|
||||
--- a/dnf/repo.py
|
||||
+++ b/dnf/repo.py
|
||||
@@ -108,7 +108,7 @@ def _download_payloads(payloads, drpm, fail_fast=True):
|
||||
callbacks = tgt.getCallbacks()
|
||||
payload = callbacks.package_pload
|
||||
pkg = payload.pkg
|
||||
- if err == _('Already downloaded'):
|
||||
+ if err == 'Already downloaded':
|
||||
errs._skipped.add(pkg)
|
||||
continue
|
||||
pkg.repo._repo.expire()
|
||||
--
|
||||
libgit2 1.1.0
|
||||
|
16
dnf.spec
16
dnf.spec
@ -65,14 +65,13 @@
|
||||
It supports RPMs, modules and comps groups & environments.
|
||||
|
||||
Name: dnf
|
||||
Version: 4.11.1
|
||||
Release: 3%{?dist}
|
||||
Version: 4.12.0
|
||||
Release: 1%{?dist}
|
||||
Summary: %{pkg_summary}
|
||||
# For a breakdown of the licensing, see PACKAGE-LICENSING
|
||||
License: GPLv2+
|
||||
URL: https://github.com/rpm-software-management/dnf
|
||||
Source0: %{url}/archive/%{version}/%{name}-%{version}.tar.gz
|
||||
Patch0001: 0001-Fix-processing-of-download-errors-RhBug-2024527.patch
|
||||
# Upstream commit which fixes leak of libsolv's page file descriptors.
|
||||
# https://github.com/rpm-software-management/dnf/commit/5ce5ed1ea08ad6e198c1c1642c4d9ea2db6eab86
|
||||
Patch0002: 0001-Base.reset-plug-temporary-leak-of-libsolv-s-page-fil.patch
|
||||
@ -363,6 +362,17 @@ popd
|
||||
%{python3_sitelib}/%{name}/automatic/
|
||||
|
||||
%changelog
|
||||
* Thu May 05 2022 Jaroslav Rohel <jrohel@redhat.com> - 4.12.0-1
|
||||
- Update to 4.12.0
|
||||
- dnf.conf: hint users where to find more info about defaults and other options
|
||||
- Fix unittests that relied on checksum being at the end of solvfiles
|
||||
- completion: remove unnecessary echo
|
||||
- Fix remove when no repos are enabled (RhBug:2064341)
|
||||
- Add loongarch support for dnf
|
||||
- Add spaces between words to fix typos (RhBug:2077296)
|
||||
- [doc] Improve "proxy" configuration option documentation (RhBug:2072332)
|
||||
- Fix download errors handling in non-english locales (RhBug:2024527)
|
||||
|
||||
* Thu Apr 28 2022 Richard W.M. Jones <rjones@redhat.com> - 4.11.1-3
|
||||
- Backport fix for leak of libsolv's page file descriptors
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (dnf-4.11.1.tar.gz) = 0499f1aef6e5a845856a1275dda710c4b6fe4434ada6537f2a3acbb566c0ffa123ac8a8812082f1ec5e1a5c18eabcd5e2bc711b10b5e1a77242a891e9e12ba66
|
||||
SHA512 (dnf-4.12.0.tar.gz) = 27913bce6a5251d2f7aee0122e4fb238fa6ca8906027f15108a84ceab1cfc40eb5975ac3b365506580f2ff4daedbbfa2738bde2b6107bd2fa3efc2de5dd7a129
|
||||
|
Loading…
Reference in New Issue
Block a user