Add x86_64_v2 to _BASEARCH_MAP
Add link to AlmaLinux bugtracker
This commit is contained in:
parent
33736f2fb0
commit
95c4ac16d6
49
0001-Add-link-to-AlmaLinux-bugtracker.patch
Normal file
49
0001-Add-link-to-AlmaLinux-bugtracker.patch
Normal file
@ -0,0 +1,49 @@
|
||||
From 9e499fe783a6d7ac06b1f79b3610d2289804ec9c Mon Sep 17 00:00:00 2001
|
||||
From: eabdullin <ed.abdullin.1@gmail.com>
|
||||
Date: Thu, 1 Aug 2024 15:07:45 +0300
|
||||
Subject: [PATCH] Add link to AlmaLinux bugtracker
|
||||
|
||||
---
|
||||
dnf/const.py.in | 2 +-
|
||||
doc/conf.py.in | 2 +-
|
||||
tests/test_config.py | 3 +--
|
||||
3 files changed, 3 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/dnf/const.py.in b/dnf/const.py.in
|
||||
index bcadc80..4450507 100644
|
||||
--- a/dnf/const.py.in
|
||||
+++ b/dnf/const.py.in
|
||||
@@ -54,4 +54,4 @@ VERSION='@DNF_VERSION@'
|
||||
USER_AGENT = "dnf/%s" % VERSION
|
||||
|
||||
BUGTRACKER_COMPONENT=NAME.lower()
|
||||
-BUGTRACKER='https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora&component=%s' % BUGTRACKER_COMPONENT
|
||||
+BUGTRACKER='https://bugs.almalinux.org/'
|
||||
diff --git a/doc/conf.py.in b/doc/conf.py.in
|
||||
index 368efe3..ba5649b 100644
|
||||
--- a/doc/conf.py.in
|
||||
+++ b/doc/conf.py.in
|
||||
@@ -267,5 +267,5 @@ rst_prolog = """
|
||||
.. _DNF: https://github.com/rpm-software-management/dnf/
|
||||
.. _hawkey: http://rpm-software-management.github.io/hawkey/
|
||||
.. _YUM: http://yum.baseurl.org/
|
||||
-.. _bugzilla: https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora&component=dnf
|
||||
+.. _bugzilla: https://bugs.almalinux.org/
|
||||
"""
|
||||
diff --git a/tests/test_config.py b/tests/test_config.py
|
||||
index d850267..cdc4934 100644
|
||||
--- a/tests/test_config.py
|
||||
+++ b/tests/test_config.py
|
||||
@@ -55,8 +55,7 @@ class ConfTest(tests.support.TestCase):
|
||||
def test_bugtracker(self):
|
||||
conf = Conf()
|
||||
self.assertEqual(conf.bugtracker_url,
|
||||
- "https://bugzilla.redhat.com/enter_bug.cgi" +
|
||||
- "?product=Fedora&component=dnf")
|
||||
+ "https://bugs.almalinux.org/")
|
||||
|
||||
def test_conf_from_file(self):
|
||||
conf = Conf()
|
||||
--
|
||||
2.39.3 (Apple Git-146)
|
||||
|
23
0001-Add-x86_64_v2-to-_BASEARCH_MAP.patch
Normal file
23
0001-Add-x86_64_v2-to-_BASEARCH_MAP.patch
Normal file
@ -0,0 +1,23 @@
|
||||
From 6d8db37e0f3bca78effadcdaa235914fc2970ec8 Mon Sep 17 00:00:00 2001
|
||||
From: soksanichenko <soksanichenko@almalinux.org>
|
||||
Date: Thu, 12 Sep 2024 11:26:56 +0300
|
||||
Subject: [PATCH] Add x86_64_v2 to _BASEARCH_MAP
|
||||
|
||||
---
|
||||
dnf/rpm/__init__.py | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/dnf/rpm/__init__.py b/dnf/rpm/__init__.py
|
||||
index 12efca7..69a77c8 100644
|
||||
--- a/dnf/rpm/__init__.py
|
||||
+++ b/dnf/rpm/__init__.py
|
||||
@@ -112,6 +112,7 @@ _BASEARCH_MAP = _invert({
|
||||
'sparc': ('sparc', 'sparc64', 'sparc64v', 'sparcv8', 'sparcv9',
|
||||
'sparcv9v'),
|
||||
'x86_64': ('x86_64', 'amd64', 'ia32e'),
|
||||
+ 'x86_64_v2': ('x86_64_v2',),
|
||||
})
|
||||
|
||||
|
||||
--
|
||||
2.39.3 (Apple Git-146)
|
10
dnf.spec
10
dnf.spec
@ -72,7 +72,7 @@ It supports RPMs, modules and comps groups & environments.
|
||||
|
||||
Name: dnf
|
||||
Version: 4.20.0
|
||||
Release: 12%{?dist}
|
||||
Release: 12%{?dist}.alma.1
|
||||
Summary: %{pkg_summary}
|
||||
# For a breakdown of the licensing, see PACKAGE-LICENSING
|
||||
License: GPL-2.0-or-later AND GPL-1.0-only
|
||||
@ -102,6 +102,10 @@ Patch21: 0021-doc-Document-detect_releasevers-and-update-example.patch
|
||||
Patch22: 0022-tests-Patch-detect_releasevers-not-detect_releasever.patch
|
||||
Patch23: 0023-Document-how-releasever-releasever_-major-minor-affe.patch
|
||||
|
||||
# AlmaLinux Patch
|
||||
Patch1001: 0001-Add-link-to-AlmaLinux-bugtracker.patch
|
||||
Patch1002: 0001-Add-x86_64_v2-to-_BASEARCH_MAP.patch
|
||||
|
||||
BuildArch: noarch
|
||||
BuildRequires: cmake
|
||||
BuildRequires: gettext
|
||||
@ -456,6 +460,10 @@ popd
|
||||
# bootc subpackage does not include any files
|
||||
|
||||
%changelog
|
||||
* Thu Mar 27 2025 Eduard Abdullin <eabdullin@almalinux.org> - 4.20.0-12.alma.1
|
||||
- Add x86_64_v2 to _BASEARCH_MAP
|
||||
- Add link to AlmaLinux bugtracker
|
||||
|
||||
* Fri Feb 07 2025 Carl George <carl@redhat.com> - 4.20.0-12
|
||||
- Override releasever_{major,minor} with system-release provides (RHEL-68034)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user