Fix required hawkey_version
Also remove unnecessary patch files, to fully fix previous release
This commit is contained in:
parent
671021315d
commit
7b84021fcc
@ -1,70 +0,0 @@
|
||||
From a506502d13da6087f47ed88206a2366f74515b83 Mon Sep 17 00:00:00 2001
|
||||
From: Jaroslav Mracek <jmracek@redhat.com>
|
||||
Date: Tue, 3 Sep 2019 11:01:51 +0200
|
||||
Subject: [PATCH] Keep installed packages in upgrade job (RhBug:1728252,1644241,1741381)
|
||||
|
||||
In combination with marking of job as TARGETED it prevents from
|
||||
reinstalling of modified packages with same NEVRA.
|
||||
|
||||
https://bugzilla.redhat.com/show_bug.cgi?id=1728252
|
||||
https://bugzilla.redhat.com/show_bug.cgi?id=1644241
|
||||
https://bugzilla.redhat.com/show_bug.cgi?id=1741381
|
||||
|
||||
Closes: #1474
|
||||
Approved by: m-blaha
|
||||
---
|
||||
dnf.spec | 4 ++--
|
||||
dnf/base.py | 3 ---
|
||||
dnf/module/module_base.py | 2 +-
|
||||
3 files changed, 3 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/dnf.spec b/dnf.spec
|
||||
index e490ead..a7200cc 100644
|
||||
--- a/dnf.spec
|
||||
+++ b/dnf.spec
|
||||
@@ -1,5 +1,5 @@
|
||||
# default dependencies
|
||||
-%global hawkey_version 0.35.3
|
||||
+%global hawkey_version 0.35.5
|
||||
%global libcomps_version 0.1.8
|
||||
%global libmodulemd_version 1.4.0
|
||||
%global rpm_version 4.14.0
|
||||
@@ -79,7 +79,7 @@
|
||||
It supports RPMs, modules and comps groups & environments.
|
||||
|
||||
Name: dnf
|
||||
-Version: 4.2.9
|
||||
+Version: 4.2.11
|
||||
Release: 1%{?dist}
|
||||
Summary: %{pkg_summary}
|
||||
# For a breakdown of the licensing, see PACKAGE-LICENSING
|
||||
diff --git a/dnf/base.py b/dnf/base.py
|
||||
index b0c78d3..29d3e5f 100644
|
||||
--- a/dnf/base.py
|
||||
+++ b/dnf/base.py
|
||||
@@ -1970,9 +1970,6 @@ class Base(object):
|
||||
obsoletes=q.installed().union(q.upgrades()))
|
||||
# add obsoletes into transaction
|
||||
q = q.union(obsoletes)
|
||||
- # provide only available packages to solver otherwise selection of available
|
||||
- # possibilities will be ignored
|
||||
- q = q.available()
|
||||
if reponame is not None:
|
||||
q.filterm(reponame=reponame)
|
||||
q = self._merge_update_filters(q, pkg_spec=pkg_spec)
|
||||
diff --git a/dnf/module/module_base.py b/dnf/module/module_base.py
|
||||
index c86eabe..0fe1179 100644
|
||||
--- a/dnf/module/module_base.py
|
||||
+++ b/dnf/module/module_base.py
|
||||
@@ -214,7 +214,7 @@ class ModuleBase(object):
|
||||
|
||||
if not upgrade_package_set:
|
||||
logger.error(_("Unable to match profile in argument {}").format(spec))
|
||||
- query = self.base.sack.query().available().filterm(name=upgrade_package_set)
|
||||
+ query = self.base.sack.query().filterm(name=upgrade_package_set)
|
||||
if query:
|
||||
sltr = dnf.selector.Selector(self.base.sack)
|
||||
sltr.set(pkg=query)
|
||||
--
|
||||
libgit2 0.28.2
|
||||
|
@ -1,37 +0,0 @@
|
||||
From a8a3cf4247fe374855e1ee292eb2b4bda835f690 Mon Sep 17 00:00:00 2001
|
||||
From: Jaroslav Mracek <jmracek@redhat.com>
|
||||
Date: Wed, 3 Jul 2019 12:37:57 +0200
|
||||
Subject: [PATCH] Revert consequences of Fail-Safe mechanism
|
||||
|
||||
---
|
||||
dnf/db/group.py | 2 +-
|
||||
doc/modularity.rst | 3 +--
|
||||
2 files changed, 2 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/dnf/db/group.py b/dnf/db/group.py
|
||||
index 5082c7b..065d362 100644
|
||||
--- a/dnf/db/group.py
|
||||
+++ b/dnf/db/group.py
|
||||
@@ -331,7 +331,7 @@ class RPMTransaction(object):
|
||||
else:
|
||||
raise RuntimeError("TransactionItemAction not handled: %s" % tsi.action)
|
||||
if modular_problems:
|
||||
- raise dnf.exceptions.Error(_("No available modular metadata for modular package"))
|
||||
+ logger.critical(_("No available modular metadata for modular package"))
|
||||
|
||||
return ts
|
||||
|
||||
diff --git a/doc/modularity.rst b/doc/modularity.rst
|
||||
index 83b1227..a5d0975 100644
|
||||
--- a/doc/modularity.rst
|
||||
+++ b/doc/modularity.rst
|
||||
@@ -99,5 +99,4 @@ Orphaned modular packages
|
||||
=========================
|
||||
All packages that are built as a part of a module have ``%{modularitylabel}`` RPM header set.
|
||||
If such package becomes part of RPM transaction and cannot be associated with any available
|
||||
-modulemd, DNF prevents from getting it on the system (package is available, but cannot be
|
||||
-installed, upgraded, etc.)
|
||||
+modulemd, DNF logs the issue as critical problem.
|
||||
--
|
||||
libgit2 0.27.8
|
||||
|
11
dnf.spec
11
dnf.spec
@ -1,5 +1,5 @@
|
||||
# default dependencies
|
||||
%global hawkey_version 0.35.3-3
|
||||
%global hawkey_version 0.35.5
|
||||
%global libcomps_version 0.1.8
|
||||
%global libmodulemd_version 1.4.0
|
||||
%global rpm_version 4.14.0
|
||||
@ -47,6 +47,8 @@
|
||||
%global yum_compat_level full
|
||||
%global yum_subpackage_name yum
|
||||
%if 0%{?fedora}
|
||||
# Avoid file conflict with yum < 4 in all Fedoras
|
||||
# It can be resolved by pretrans scriptlet but they are not recommended in Fedora
|
||||
%global yum_compat_level minimal
|
||||
%if 0%{?fedora} < 31
|
||||
# Avoid name conflict with yum < 4
|
||||
@ -80,7 +82,7 @@ It supports RPMs, modules and comps groups & environments.
|
||||
|
||||
Name: dnf
|
||||
Version: 4.2.11
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
Summary: %{pkg_summary}
|
||||
# For a breakdown of the licensing, see PACKAGE-LICENSING
|
||||
License: GPLv2+ and GPLv2 and GPL
|
||||
@ -503,6 +505,9 @@ ln -sr %{buildroot}%{confdir}/vars %{buildroot}%{_sysconfdir}/yum/vars
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Thu Oct 01 2019 Ales Matej <amatej@redhat.com> - 4.2.11-2
|
||||
- Fix required hawkey_version
|
||||
|
||||
* Thu Oct 01 2019 Ales Matej <amatej@redhat.com> - 4.2.11-1
|
||||
- Improve modularity documentation (RhBug:1730162,1730162,1730807,1734081)
|
||||
- Fix detection whether system is running on battery (used by metadata caching timer) (RhBug:1498680)
|
||||
@ -515,7 +520,7 @@ ln -sr %{buildroot}%{confdir}/vars %{buildroot}%{_sysconfdir}/yum/vars
|
||||
- dnf-automatic now respects versionlock excludes (RhBug:1746562)
|
||||
- Fully enable the modular fail safe mechanism (RhBug:1616167)
|
||||
|
||||
* Thu Sep 10 2019 Jaroslav Mracek <jmracek@redhat.com> - 4.2.9-3
|
||||
* Tue Sep 10 2019 Jaroslav Mracek <jmracek@redhat.com> - 4.2.9-3
|
||||
- Backport patch to fix reinstalling packages with a different buildtime
|
||||
|
||||
* Fri Aug 16 2019 Miro Hrončok <mhroncok@redhat.com> - 4.2.9-2
|
||||
|
Loading…
Reference in New Issue
Block a user