Add patch fixing the installation of completion_helper.py

Fix #1695853

Signed-off-by: Robert-André Mauchin <zebob.m@gmail.com>
This commit is contained in:
Robert-André Mauchin 2019-04-04 15:33:33 +02:00
parent 93696aea7f
commit 5c5ace422c
2 changed files with 41 additions and 1 deletions

View File

@ -0,0 +1,34 @@
From d78a76e621b5e7a95b074b86ab5b8fb80d0db40c Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Robert-Andr=C3=A9=20Mauchin?= <zebob.m@gmail.com>
Date: Thu, 4 Apr 2019 15:08:59 +0200
Subject: [PATCH] Fix the installation of completion_helper.py
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Change introduced in df19a47d672b09683cc03620a41114cd4239e prevents the
installation of completion_helper.py on Fedora 30.
Bug report: https://bugzilla.redhat.com/show_bug.cgi?id=1695853
Signed-off-by: Robert-André Mauchin <zebob.m@gmail.com>
---
dnf/cli/CMakeLists.txt | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/dnf/cli/CMakeLists.txt b/dnf/cli/CMakeLists.txt
index 5e335d0c..a32305bc 100644
--- a/dnf/cli/CMakeLists.txt
+++ b/dnf/cli/CMakeLists.txt
@@ -1,4 +1,6 @@
FILE(GLOB cli_SRCS *.py)
INSTALL (FILES ${cli_SRCS} DESTINATION ${PYTHON_INSTALL_DIR}/dnf/cli)
+# completion_helper.py is generated so the glob alone won't see it:
+INSTALL (FILES completion_helper.py DESTINATION ${PYTHON_INSTALL_DIR}/dnf/cli)
-ADD_SUBDIRECTORY (commands)
\ No newline at end of file
+ADD_SUBDIRECTORY (commands)
--
2.21.0

View File

@ -80,13 +80,15 @@ It supports RPMs, modules and comps groups & environments.
Name: dnf
Version: 4.2.2
Release: 1%{?dist}
Release: 2%{?dist}
Summary: %{pkg_summary}
# For a breakdown of the licensing, see PACKAGE-LICENSING
License: GPLv2+ and GPLv2 and GPL
URL: https://github.com/rpm-software-management/dnf
Source0: %{url}/archive/%{version}/%{name}-%{version}.tar.gz
Patch0001: 0001-Revert-Add-best-as-default-behavior-RhBug16707761671683.patch
# https://github.com/rpm-software-management/dnf/pull/1367
Patch0002: 0001-Fix-the-installation-of-completion_helper.py.patch
BuildArch: noarch
BuildRequires: cmake
BuildRequires: gettext
@ -499,6 +501,10 @@ ln -sr %{buildroot}%{confdir}/vars %{buildroot}%{_sysconfdir}/yum/vars
%endif
%changelog
* Thu Apr 04 15:15:12 CET 2019 Robert-André Mauchin <zebob.m@gmail.com> - 4.2.2-2
- Add patch fixing the installation of completion_helper.py
- Fix #1695853
* Wed Mar 27 2019 Pavla Kratochvilova <pkratoch@redhat.com> - 4.2.2-1
- [conf] Use environment variables prefixed with DNF_VAR_
- Enhance documentation of --whatdepends option (RhBug:1687070)