foo
Signed-off-by: Igor Gnatenko <ignatenko@redhat.com>
This commit is contained in:
parent
3def2e5d3d
commit
3eb943f561
@ -0,0 +1,33 @@
|
|||||||
|
From 61df26328ed819e4f220760a98ce31529c4ec609 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Igor Gnatenko <ignatenko@redhat.com>
|
||||||
|
Date: Tue, 23 Aug 2016 15:17:09 +0200
|
||||||
|
Subject: [PATCH] cli/repolist: fix showing repository name with 'disabled' arg
|
||||||
|
(RhBug:1369459)
|
||||||
|
|
||||||
|
References: https://bugzilla.redhat.com/show_bug.cgi?id=1369459
|
||||||
|
Signed-off-by: Igor Gnatenko <ignatenko@redhat.com>
|
||||||
|
|
||||||
|
Closes: #579
|
||||||
|
Approved by: ignatenkobrain
|
||||||
|
|
||||||
|
(cherry picked from commit f41c4ebc5467f9f7b161545a5a416f0778f2ed96)
|
||||||
|
---
|
||||||
|
dnf/cli/commands/repolist.py | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/dnf/cli/commands/repolist.py b/dnf/cli/commands/repolist.py
|
||||||
|
index 110db4d..0cf67f1 100644
|
||||||
|
--- a/dnf/cli/commands/repolist.py
|
||||||
|
+++ b/dnf/cli/commands/repolist.py
|
||||||
|
@@ -260,7 +260,7 @@ class RepoListCommand(commands.Command):
|
||||||
|
for (rid, rname, (ui_enabled, ui_endis_wid), ui_num) in cols:
|
||||||
|
if arg == 'disabled': # Don't output a status column.
|
||||||
|
print("%s %s" % (fill_exact_width(rid, id_len),
|
||||||
|
- fill_exact_width(rname, nm_len, -nm_len)))
|
||||||
|
+ fill_exact_width(rname, nm_len, nm_len)))
|
||||||
|
continue
|
||||||
|
|
||||||
|
if ui_num:
|
||||||
|
--
|
||||||
|
2.9.3
|
||||||
|
|
31
dnf.spec
31
dnf.spec
@ -1,7 +1,9 @@
|
|||||||
%global hawkey_version 0.6.1
|
%global hawkey_min_ver 0.6.1
|
||||||
|
%global hawkey_max_ver 0.7.0
|
||||||
%global librepo_version 1.7.16
|
%global librepo_version 1.7.16
|
||||||
%global libcomps_version 0.1.6
|
%global libcomps_version 0.1.6
|
||||||
%global rpm_version 4.12.0
|
%global rpm_version 4.12.0
|
||||||
|
%global dnf_langpacks_ver 0.15.1-6
|
||||||
|
|
||||||
%global confdir %{_sysconfdir}/%{name}
|
%global confdir %{_sysconfdir}/%{name}
|
||||||
|
|
||||||
@ -23,12 +25,14 @@
|
|||||||
|
|
||||||
Name: dnf
|
Name: dnf
|
||||||
Version: 1.1.10
|
Version: 1.1.10
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Summary: Package manager forked from Yum, using libsolv as a dependency resolver
|
Summary: Package manager forked from Yum, using libsolv as a dependency resolver
|
||||||
# For a breakdown of the licensing, see PACKAGE-LICENSING
|
# For a breakdown of the licensing, see PACKAGE-LICENSING
|
||||||
License: GPLv2+ and GPLv2 and GPL
|
License: GPLv2+ and GPLv2 and GPL
|
||||||
URL: https://github.com/rpm-software-management/dnf
|
URL: https://github.com/rpm-software-management/dnf
|
||||||
Source0: %{url}/archive/%{name}-%{version}-1.tar.gz
|
Source0: %{url}/archive/%{name}-%{version}-1.tar.gz
|
||||||
|
# https://github.com/rpm-software-management/dnf/commit/61df26328ed819e4f220760a98ce31529c4ec609
|
||||||
|
Patch0001: 0001-cli-repolist-fix-showing-repository-name-with-disabl.patch
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
BuildRequires: cmake
|
BuildRequires: cmake
|
||||||
BuildRequires: gettext
|
BuildRequires: gettext
|
||||||
@ -66,12 +70,19 @@ Provides: dnf-command(updateinfo)
|
|||||||
Provides: dnf-command(upgrade)
|
Provides: dnf-command(upgrade)
|
||||||
Provides: dnf-command(upgrade-to)
|
Provides: dnf-command(upgrade-to)
|
||||||
|
|
||||||
|
# dnf-langpacks package is retired in F25
|
||||||
|
# to have clean upgrade path for dnf-langpacks
|
||||||
|
Obsoletes: dnf-langpacks < %{dnf_langpacks_ver}
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Package manager forked from Yum, using libsolv as a dependency resolver.
|
Package manager forked from Yum, using libsolv as a dependency resolver.
|
||||||
|
|
||||||
%package conf
|
%package conf
|
||||||
Summary: Configuration files for DNF
|
Summary: Configuration files for DNF
|
||||||
Requires: libreport-filesystem
|
Requires: libreport-filesystem
|
||||||
|
# dnf-langpacks package is retired in F25
|
||||||
|
# to have clean upgrade path for dnf-langpacks
|
||||||
|
Obsoletes: dnf-langpacks-conf < %{dnf_langpacks_ver}
|
||||||
|
|
||||||
%description conf
|
%description conf
|
||||||
Configuration files for DNF.
|
Configuration files for DNF.
|
||||||
@ -88,7 +99,7 @@ As a Yum CLI compatibility layer, supplies /usr/bin/yum redirecting to DNF.
|
|||||||
Summary: Python 2 interface to DNF
|
Summary: Python 2 interface to DNF
|
||||||
%{?python_provide:%python_provide python2-%{name}}
|
%{?python_provide:%python_provide python2-%{name}}
|
||||||
BuildRequires: python2-devel
|
BuildRequires: python2-devel
|
||||||
BuildRequires: python-hawkey >= %{hawkey_version}
|
BuildRequires: python-hawkey >= %{hawkey_min_ver}
|
||||||
BuildRequires: python-iniparse
|
BuildRequires: python-iniparse
|
||||||
BuildRequires: python-libcomps >= %{libcomps_version}
|
BuildRequires: python-libcomps >= %{libcomps_version}
|
||||||
BuildRequires: python-librepo >= %{librepo_version}
|
BuildRequires: python-librepo >= %{librepo_version}
|
||||||
@ -104,7 +115,8 @@ Recommends: bash-completion
|
|||||||
Requires: pyliblzma
|
Requires: pyliblzma
|
||||||
Requires: %{name}-conf = %{version}-%{release}
|
Requires: %{name}-conf = %{version}-%{release}
|
||||||
Requires: deltarpm
|
Requires: deltarpm
|
||||||
Requires: python-hawkey >= %{hawkey_version}
|
Requires: python-hawkey >= %{hawkey_min_ver}
|
||||||
|
Conflicts: python-hawkey >= %{hawkey_max_ver}
|
||||||
Requires: python-iniparse
|
Requires: python-iniparse
|
||||||
Requires: python-libcomps >= %{libcomps_version}
|
Requires: python-libcomps >= %{libcomps_version}
|
||||||
Requires: python-librepo >= %{librepo_version}
|
Requires: python-librepo >= %{librepo_version}
|
||||||
@ -115,6 +127,9 @@ Requires: python2-pygpgme
|
|||||||
%endif
|
%endif
|
||||||
Requires: rpm-plugin-systemd-inhibit
|
Requires: rpm-plugin-systemd-inhibit
|
||||||
Requires: rpm-python >= %{rpm_version}
|
Requires: rpm-python >= %{rpm_version}
|
||||||
|
# dnf-langpacks package is retired in F25
|
||||||
|
# to have clean upgrade path for dnf-langpacks
|
||||||
|
Obsoletes: python-dnf-langpacks < %{dnf_langpacks_ver}
|
||||||
|
|
||||||
%description -n python2-%{name}
|
%description -n python2-%{name}
|
||||||
Python 2 interface to DNF.
|
Python 2 interface to DNF.
|
||||||
@ -125,7 +140,7 @@ Summary: Python 3 interface to DNF.
|
|||||||
%{?system_python_abi}
|
%{?system_python_abi}
|
||||||
%{?python_provide:%python_provide python3-%{name}}
|
%{?python_provide:%python_provide python3-%{name}}
|
||||||
BuildRequires: python3-devel
|
BuildRequires: python3-devel
|
||||||
BuildRequires: python3-hawkey >= %{hawkey_version}
|
BuildRequires: python3-hawkey >= %{hawkey_min_ver}
|
||||||
BuildRequires: python3-iniparse
|
BuildRequires: python3-iniparse
|
||||||
BuildRequires: python3-libcomps >= %{libcomps_version}
|
BuildRequires: python3-libcomps >= %{libcomps_version}
|
||||||
BuildRequires: python3-librepo >= %{librepo_version}
|
BuildRequires: python3-librepo >= %{librepo_version}
|
||||||
@ -135,13 +150,17 @@ BuildRequires: rpm-python3 >= %{rpm_version}
|
|||||||
Recommends: bash-completion
|
Recommends: bash-completion
|
||||||
Requires: %{name}-conf = %{version}-%{release}
|
Requires: %{name}-conf = %{version}-%{release}
|
||||||
Requires: deltarpm
|
Requires: deltarpm
|
||||||
Requires: python3-hawkey >= %{hawkey_version}
|
Requires: python3-hawkey >= %{hawkey_min_ver}
|
||||||
|
Conflicts: python3-hawkey >= %{hawkey_max_ver}
|
||||||
Requires: python3-iniparse
|
Requires: python3-iniparse
|
||||||
Requires: python3-libcomps >= %{libcomps_version}
|
Requires: python3-libcomps >= %{libcomps_version}
|
||||||
Requires: python3-librepo >= %{librepo_version}
|
Requires: python3-librepo >= %{librepo_version}
|
||||||
Requires: python3-pygpgme
|
Requires: python3-pygpgme
|
||||||
Requires: rpm-plugin-systemd-inhibit
|
Requires: rpm-plugin-systemd-inhibit
|
||||||
Requires: rpm-python3 >= %{rpm_version}
|
Requires: rpm-python3 >= %{rpm_version}
|
||||||
|
# dnf-langpacks package is retired in F25
|
||||||
|
# to have clean upgrade path for dnf-langpacks
|
||||||
|
Obsoletes: python3-dnf-langpacks < %{dnf_langpacks_ver}
|
||||||
|
|
||||||
%description -n python3-%{name}
|
%description -n python3-%{name}
|
||||||
Python 3 interface to DNF.
|
Python 3 interface to DNF.
|
||||||
|
Loading…
Reference in New Issue
Block a user