Fix defaults loading.
This commit is contained in:
parent
0111d57b73
commit
34d90c0e5d
22
0004-Fix-defaults-loading.patch
Normal file
22
0004-Fix-defaults-loading.patch
Normal file
@ -0,0 +1,22 @@
|
|||||||
|
From 5842971b6df574b214806fcc286114813d370e1d Mon Sep 17 00:00:00 2001
|
||||||
|
From: Daniel Mach <dmach@redhat.com>
|
||||||
|
Date: Wed, 18 Apr 2018 16:13:59 +0200
|
||||||
|
Subject: [PATCH] Fix defaults loading.
|
||||||
|
|
||||||
|
---
|
||||||
|
dnf/module/metadata_loader.py | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/dnf/module/metadata_loader.py b/dnf/module/metadata_loader.py
|
||||||
|
index 78e7f051..150b66f0 100644
|
||||||
|
--- a/dnf/module/metadata_loader.py
|
||||||
|
+++ b/dnf/module/metadata_loader.py
|
||||||
|
@@ -61,4 +61,4 @@ class ModuleMetadataLoader(object):
|
||||||
|
if PY3:
|
||||||
|
modules_yaml = modules_yaml.decode("utf-8")
|
||||||
|
|
||||||
|
- return Modulemd.Module.new_all_from_string(modules_yaml)
|
||||||
|
+ return Modulemd.Module.new_all_from_string_ext(modules_yaml)
|
||||||
|
--
|
||||||
|
2.17.0
|
||||||
|
|
6
dnf.spec
6
dnf.spec
@ -28,7 +28,7 @@
|
|||||||
|
|
||||||
Name: dnf
|
Name: dnf
|
||||||
Version: 2.7.5
|
Version: 2.7.5
|
||||||
Release: 11%{?dist}
|
Release: 12%{?dist}
|
||||||
Summary: Package manager forked from Yum, using libsolv as a dependency resolver
|
Summary: Package manager forked from Yum, using libsolv as a dependency resolver
|
||||||
# For a breakdown of the licensing, see PACKAGE-LICENSING
|
# For a breakdown of the licensing, see PACKAGE-LICENSING
|
||||||
License: GPLv2+ and GPLv2 and GPL
|
License: GPLv2+ and GPLv2 and GPL
|
||||||
@ -37,6 +37,7 @@ Source0: %{url}/archive/%{version}/%{name}-%{version}-modularity-4.tar.gz
|
|||||||
Patch0: 0001-Allow-to-set-cacheonly-from-commands-and-conf-RhBug-.patch
|
Patch0: 0001-Allow-to-set-cacheonly-from-commands-and-conf-RhBug-.patch
|
||||||
Patch1: 0002-Remove-redundant-conf-option-cacheonly.patch
|
Patch1: 0002-Remove-redundant-conf-option-cacheonly.patch
|
||||||
Patch2: 0003-Remove-unnecessary-code-for-set-cacheonly.patch
|
Patch2: 0003-Remove-unnecessary-code-for-set-cacheonly.patch
|
||||||
|
Patch3: 0004-Fix-defaults-loading.patch
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
BuildRequires: cmake
|
BuildRequires: cmake
|
||||||
BuildRequires: gettext
|
BuildRequires: gettext
|
||||||
@ -395,6 +396,9 @@ popd
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Apr 18 2018 Daniel Mach <dmach@redhat.com> - 2.7.5-12
|
||||||
|
- Fix defaults loading.
|
||||||
|
|
||||||
* Tue Apr 17 2018 Martin Hatina <mhatina@redhat.com> - 2.7.5-11
|
* Tue Apr 17 2018 Martin Hatina <mhatina@redhat.com> - 2.7.5-11
|
||||||
- Rebase to dnf from dnf-2-modularity-4 release.
|
- Rebase to dnf from dnf-2-modularity-4 release.
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user