Apply util-Correctly-source-errno.EEXIST patch
This commit is contained in:
parent
de7ff8dc13
commit
1aff495edc
33
0004-util-Correctly-source-errno.EEXIST.patch
Normal file
33
0004-util-Correctly-source-errno.EEXIST.patch
Normal file
@ -0,0 +1,33 @@
|
||||
From 199fc9cb11ff004fc752b58b7177aaf8d7fcedfd Mon Sep 17 00:00:00 2001
|
||||
From: Neal Gompa <ngompa13@gmail.com>
|
||||
Date: Sat, 3 Mar 2018 12:44:54 -0500
|
||||
Subject: [PATCH] util: Correctly source errno.EEXIST
|
||||
|
||||
---
|
||||
dnf/util.py | 3 ++-
|
||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/dnf/util.py b/dnf/util.py
|
||||
index ab7fd279..d0f1a4f2 100644
|
||||
--- a/dnf/util.py
|
||||
+++ b/dnf/util.py
|
||||
@@ -28,6 +28,7 @@ from functools import reduce
|
||||
import dnf
|
||||
import dnf.const
|
||||
import dnf.pycomp
|
||||
+import errno
|
||||
import itertools
|
||||
import librepo
|
||||
import locale
|
||||
@@ -120,7 +121,7 @@ def ensure_dir(dname):
|
||||
try:
|
||||
os.makedirs(dname, mode=0o755)
|
||||
except OSError as e:
|
||||
- if e.errno != os.errno.EEXIST or not os.path.isdir(dname):
|
||||
+ if e.errno != errno.EEXIST or not os.path.isdir(dname):
|
||||
raise e
|
||||
|
||||
def empty(iterable):
|
||||
--
|
||||
2.17.0
|
||||
|
8
dnf.spec
8
dnf.spec
@ -72,7 +72,7 @@ It supports RPMs, modules and comps groups & environments.
|
||||
|
||||
Name: dnf
|
||||
Version: 2.7.5
|
||||
Release: 15%{?dist}
|
||||
Release: 16%{?dist}
|
||||
Summary: %{pkg_summary}
|
||||
# For a breakdown of the licensing, see PACKAGE-LICENSING
|
||||
License: GPLv2+ and GPLv2 and GPL
|
||||
@ -81,6 +81,7 @@ Source0: %{url}/archive/%{version}/%{name}-%{version}-modularity-6.tar.gz
|
||||
Patch0: 0001-Allow-to-set-cacheonly-from-commands-and-conf-RhBug-.patch
|
||||
Patch1: 0002-Remove-redundant-conf-option-cacheonly.patch
|
||||
Patch2: 0003-Remove-unnecessary-code-for-set-cacheonly.patch
|
||||
Patch3: 0004-util-Correctly-source-errno.EEXIST.patch
|
||||
BuildArch: noarch
|
||||
BuildRequires: cmake
|
||||
BuildRequires: gettext
|
||||
@ -462,7 +463,10 @@ rm -vf %{buildroot}%{_bindir}/dnf-automatic-*
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon May 28 2018 Martin Hatina <mhatina@redhat.com> - 2.7.5.15
|
||||
* Tue May 29 2018 Martin Hatina <mhatina@redhat.com> - 2.7.5-16
|
||||
- Apply util-Correctly-source-errno.EEXIST patch
|
||||
|
||||
* Mon May 28 2018 Martin Hatina <mhatina@redhat.com> - 2.7.5-15
|
||||
- Do not require libdnf
|
||||
|
||||
* Fri May 25 2018 Martin Hatina <mhatina@redhat.com> - 2.7.5-14
|
||||
|
Loading…
Reference in New Issue
Block a user