import dnf-plugin-spacewalk-2.8.5-11.module+el8.0.0.z+3494+e6f475f6
This commit is contained in:
parent
5c2f2390d8
commit
6f1293d6c5
@ -0,0 +1,37 @@
|
||||
diff --git a/dnf-plugin-spacewalk.spec b/dnf-plugin-spacewalk.spec
|
||||
index d2c31fa..ae9fecb 100644
|
||||
--- a/dnf-plugin-spacewalk.spec
|
||||
+++ b/dnf-plugin-spacewalk.spec
|
||||
@@ -12,7 +12,7 @@
|
||||
Summary: DNF plugin for Spacewalk
|
||||
Name: dnf-plugin-spacewalk
|
||||
Version: 2.8.5
|
||||
-Release: 10%{?dist}
|
||||
+Release: 11%{?dist}
|
||||
License: GPLv2
|
||||
Source0: https://github.com/spacewalkproject/spacewalk/archive/%{name}-%{version}.tar.gz
|
||||
URL: https://github.com/spacewalkproject/spacewalk
|
||||
@@ -113,6 +113,9 @@ install -m 644 actions/errata.py %{buildroot}%{python3_sitelib}/rhn/actions/
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
+* Wed Jun 19 2019 Michael Mraka <michael.mraka@redhat.com> 2.8.5-11
|
||||
+- Resolves: #1701222 - ignore broken json cache
|
||||
+
|
||||
* Wed Apr 03 2019 Michael Mraka <michael.mraka@redhat.com> 2.8.5-10
|
||||
- Resolves: #1673445 - changed wording to refer to Red Hat Satellite
|
||||
|
||||
diff --git a/spacewalk.py b/spacewalk.py
|
||||
index 89e7822..1e5255f 100644
|
||||
--- a/spacewalk.py
|
||||
+++ b/spacewalk.py
|
||||
@@ -186,6 +186,9 @@ class Spacewalk(dnf.Plugin):
|
||||
except (FileNotFoundError, IOError) as e:
|
||||
if e.errno != errno.ENOENT:
|
||||
raise
|
||||
+ except json.decoder.JSONDecodeError as e:
|
||||
+ pass # ignore broken json and recreate it later
|
||||
+
|
||||
return {}
|
||||
|
||||
def _write_channels_file(self, var):
|
@ -0,0 +1,52 @@
|
||||
diff --git a/dnf-plugin-spacewalk.spec b/dnf-plugin-spacewalk.spec
|
||||
index fd42348..d2c31fa 100644
|
||||
--- a/dnf-plugin-spacewalk.spec
|
||||
+++ b/dnf-plugin-spacewalk.spec
|
||||
@@ -12,7 +12,7 @@
|
||||
Summary: DNF plugin for Spacewalk
|
||||
Name: dnf-plugin-spacewalk
|
||||
Version: 2.8.5
|
||||
-Release: 9%{?dist}
|
||||
+Release: 10%{?dist}
|
||||
License: GPLv2
|
||||
Source0: https://github.com/spacewalkproject/spacewalk/archive/%{name}-%{version}.tar.gz
|
||||
URL: https://github.com/spacewalkproject/spacewalk
|
||||
@@ -113,6 +113,9 @@ install -m 644 actions/errata.py %{buildroot}%{python3_sitelib}/rhn/actions/
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
+* Wed Apr 03 2019 Michael Mraka <michael.mraka@redhat.com> 2.8.5-10
|
||||
+- Resolves: #1673445 - changed wording to refer to Red Hat Satellite
|
||||
+
|
||||
* Wed Dec 19 2018 Michael Mraka <michael.mraka@redhat.com> 2.8.5-9
|
||||
- Resolves: #1660552 - report and fail gracefully if not root
|
||||
- logger.warn() has been obsoleted
|
||||
diff --git a/spacewalk.py b/spacewalk.py
|
||||
index 1e60eef..89e7822 100644
|
||||
--- a/spacewalk.py
|
||||
+++ b/spacewalk.py
|
||||
@@ -38,17 +38,17 @@ from up2date_client import up2dateErrors
|
||||
|
||||
STORED_CHANNELS_NAME = '_spacewalk.json'
|
||||
|
||||
-RHN_DISABLED = _("Spacewalk based repositories will be disabled.")
|
||||
-CHANNELS_DISABLED = _("Spacewalk channel support will be disabled.")
|
||||
-COMMUNICATION_ERROR = _("There was an error communicating with Spacewalk server.")
|
||||
-NOT_REGISTERED_ERROR = _("This system is not registered with Spacewalk server.")
|
||||
+RHN_DISABLED = _("Red Hat Satellite or Spacewalk based repositories will be disabled.")
|
||||
+CHANNELS_DISABLED = _("Red Hat Satellite or Spacewalk channel support will be disabled.")
|
||||
+COMMUNICATION_ERROR = _("There was an error communicating with Red Hat Satellite or Spacewalk server.")
|
||||
+NOT_REGISTERED_ERROR = _("This system is not registered with Red Hat Satellite or Spacewalk server.")
|
||||
NOT_SUBSCRIBED_ERROR = _("This system is not subscribed to any channels.")
|
||||
NO_SYSTEM_ID_ERROR = _("SystemId could not be acquired.")
|
||||
USE_RHNREGISTER = _("You can use rhn_register to register.")
|
||||
-UPDATES_FROM_SPACEWALK = _("This system is receiving updates from Spacewalk server.")
|
||||
-GPG_KEY_REJECTED = _("For security reasons packages from Spacewalk based repositories can be verified only with locally installed gpg keys. GPG key '%s' has been rejected.")
|
||||
+UPDATES_FROM_SPACEWALK = _("This system is receiving updates from Red Hat Satellite or Spacewalk server.")
|
||||
+GPG_KEY_REJECTED = _("For security reasons packages from Red Hat Satellite or Spacewalk based repositories can be verified only with locally installed gpg keys. GPG key '%s' has been rejected.")
|
||||
PROFILE_NOT_SENT = _("Package profile information could not be sent.")
|
||||
-MISSING_HEADER = _("Missing required login information for Spacewalk: %s")
|
||||
+MISSING_HEADER = _("Missing required login information for Red Hat Satellite or Spacewalk: %s")
|
||||
MUST_BE_ROOT = _('Spacewalk plugin has to be run under with the root privileges.')
|
||||
|
||||
class Spacewalk(dnf.Plugin):
|
@ -12,7 +12,7 @@
|
||||
Summary: DNF plugin for Spacewalk
|
||||
Name: dnf-plugin-spacewalk
|
||||
Version: 2.8.5
|
||||
Release: 9%{?dist}
|
||||
Release: 11%{?dist}
|
||||
License: GPLv2
|
||||
Source0: https://github.com/spacewalkproject/spacewalk/archive/%{name}-%{version}.tar.gz
|
||||
Patch0: dnf-plugin-spacewalk-2.8.5-1-to-dnf-plugin-spacewalk-2.8.5-2-el8.patch
|
||||
@ -23,6 +23,8 @@ Patch4: dnf-plugin-spacewalk-2.8.5-5-el8-to-dnf-plugin-spacewalk-2.8.5-6-el8.pat
|
||||
Patch5: dnf-plugin-spacewalk-2.8.5-6-el8-to-dnf-plugin-spacewalk-2.8.5-7-el8.patch
|
||||
Patch6: dnf-plugin-spacewalk-2.8.5-7-el8-to-dnf-plugin-spacewalk-2.8.5-8-el8.patch
|
||||
Patch7: dnf-plugin-spacewalk-2.8.5-8-el8-to-dnf-plugin-spacewalk-2.8.5-9-el8.patch
|
||||
Patch8: dnf-plugin-spacewalk-2.8.5-9-el8-to-dnf-plugin-spacewalk-2.8.5-10-el8.patch
|
||||
Patch9: dnf-plugin-spacewalk-2.8.5-10-el8-to-dnf-plugin-spacewalk-2.8.5-11-el8.patch
|
||||
URL: https://github.com/spacewalkproject/spacewalk
|
||||
BuildArch: noarch
|
||||
|
||||
@ -76,6 +78,8 @@ Python 3 specific files for %{name}.
|
||||
%patch5 -p1
|
||||
%patch6 -p1
|
||||
%patch7 -p1
|
||||
%patch8 -p1
|
||||
%patch9 -p1
|
||||
|
||||
%build
|
||||
|
||||
@ -129,6 +133,12 @@ install -m 644 actions/errata.py %{buildroot}%{python3_sitelib}/rhn/actions/
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Jun 19 2019 Michael Mraka <michael.mraka@redhat.com> 2.8.5-11
|
||||
- Resolves: #1701222 - ignore broken json cache
|
||||
|
||||
* Wed Apr 03 2019 Michael Mraka <michael.mraka@redhat.com> 2.8.5-10
|
||||
- Resolves: #1673445 - changed wording to refer to Red Hat Satellite
|
||||
|
||||
* Wed Dec 19 2018 Michael Mraka <michael.mraka@redhat.com> 2.8.5-9
|
||||
- Resolves: #1660552 - report and fail gracefully if not root
|
||||
- logger.warn() has been obsoleted
|
||||
|
Loading…
Reference in New Issue
Block a user