- Update to upstream 2.11 release. (#623047)
* Wed Jan 19 2011 Anton Arapov <anton@redhat.com> - 1:2.11-1 - Update to upstream 2.11 release. (#623047)
This commit is contained in:
parent
d83d739b4b
commit
16b7906fa0
1
.gitignore
vendored
1
.gitignore
vendored
@ -1 +1,2 @@
|
||||
dmidecode-2.10.tar.bz2
|
||||
/dmidecode-2.11.tar.bz2
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- dmidecode/dmioem.c~ 2008/10/28 09:41:07 1.9
|
||||
+++ dmidecode/dmioem.c 2009/07/27 12:07:39 1.10
|
||||
@@ -41,7 +41,7 @@
|
||||
*/
|
||||
void dmi_set_vendor(const char *s)
|
||||
{
|
||||
- if (strcmp(s, "HP") == 0)
|
||||
+ if (strcmp(s, "HP") == 0 || strcmp(s, "Hewlett-Packard") == 0)
|
||||
dmi_vendor = VENDOR_HP;
|
||||
}
|
||||
|
@ -1,16 +0,0 @@
|
||||
--- dmidecode/dmidecode.c~ 2009/06/19 11:55:35 1.142
|
||||
+++ dmidecode/dmidecode.c 2009/07/27 12:20:01 1.143
|
||||
@@ -1042,10 +1042,11 @@
|
||||
"Socket LGA775",
|
||||
"Socket S1",
|
||||
"Socket AM2",
|
||||
- "Socket F (1207)" /* 0x18 */
|
||||
+ "Socket F (1207)",
|
||||
+ "Socket LGA1366" /* 0x19 */
|
||||
};
|
||||
|
||||
- if (code >= 0x01 && code <= 0x18)
|
||||
+ if (code >= 0x01 && code <= 0x19)
|
||||
return upgrade[code - 0x01];
|
||||
return out_of_spec;
|
||||
}
|
@ -1,12 +0,0 @@
|
||||
diff -urpN dmidecode-2.10.orig/Makefile dmidecode-2.10/Makefile
|
||||
--- dmidecode-2.10.orig/Makefile 2010-10-15 12:20:39.315427049 +0200
|
||||
+++ dmidecode-2.10/Makefile 2010-10-15 12:20:48.290424691 +0200
|
||||
@@ -39,7 +39,7 @@ PROGRAMS += $(shell test `uname -m 2>/de
|
||||
# BSD make doesn't understand the $(shell) syntax above, it wants the !=
|
||||
# syntax below. GNU make ignores the line below so in the end both BSD
|
||||
# make and GNU make are happy.
|
||||
-PROGRAMS != echo dmidecode ; test `uname -m 2>/dev/null` != ia64 && echo biosdecode ownership vpddecode
|
||||
+# PROGRAMS != echo dmidecode ; test `uname -m 2>/dev/null` != ia64 && echo biosdecode ownership vpddecode
|
||||
|
||||
all : $(PROGRAMS)
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- dmidecode/dmidecode.c~ 2009/04/30 08:19:37 1.141
|
||||
+++ dmidecode/dmidecode.c 2009/06/19 11:55:35 1.142
|
||||
@@ -2007,7 +2007,7 @@
|
||||
|
||||
static void dmi_memory_array_capacity(u32 code)
|
||||
{
|
||||
- if (code == 0x8000000)
|
||||
+ if (code == 0x80000000)
|
||||
printf(" Unknown");
|
||||
else
|
||||
{
|
@ -1,120 +0,0 @@
|
||||
dmidecode: additions from smbios 2.6.1 spec update
|
||||
|
||||
Tested on an HP DL360G6 with LGA1366 socket cpus, PCI-E Gen 2 slots
|
||||
and DDR3 memory, no longer returns any <OUT OF SPEC> info.
|
||||
|
||||
Signed-off-by: Jarod Wilson <jarod@redhat.com>
|
||||
|
||||
---
|
||||
dmidecode.c | 49 ++++++++++++++++++++++++++++++++++++++++++-------
|
||||
1 file changed, 42 insertions(+), 7 deletions(-)
|
||||
|
||||
diff -Naurp dmidecode-2.10.orig/dmidecode.c dmidecode-2.10/dmidecode.c
|
||||
--- dmidecode-2.10.orig/dmidecode.c 2009-08-27 09:20:45.933991764 -0400
|
||||
+++ dmidecode-2.10/dmidecode.c 2009-08-27 09:21:15.516869134 -0400
|
||||
@@ -361,7 +361,7 @@ static void dmi_system_uuid(const u8 *p,
|
||||
|
||||
static const char *dmi_system_wake_up_type(u8 code)
|
||||
{
|
||||
- /* 3.3.2.1 */
|
||||
+ /* 3.3.2.2 */
|
||||
static const char *type[] = {
|
||||
"Reserved", /* 0x00 */
|
||||
"Other",
|
||||
@@ -719,6 +719,12 @@ static const char *dmi_processor_family(
|
||||
{ 0xA9, "Quad-Core Xeon 5400" }, /* From CIM_Processor.Family */
|
||||
{ 0xAA, "Quad-Core Xeon" }, /* From CIM_Processor.Family */
|
||||
|
||||
+ { 0xAB, "Dual-Core Xeon 5200" },
|
||||
+ { 0xAC, "Dual-Core Xeon 7200" },
|
||||
+ { 0xAD, "Quad-Core Xeon 7300" },
|
||||
+ { 0xAE, "Quad-Core Xeon 7400" },
|
||||
+ { 0xAF, "Multi-Core Xeon 7400" },
|
||||
+
|
||||
{ 0xB0, "Pentium III Xeon" },
|
||||
{ 0xB1, "Pentium III Speedstep" },
|
||||
{ 0xB2, "Pentium 4" },
|
||||
@@ -741,6 +747,8 @@ static const char *dmi_processor_family(
|
||||
{ 0xC3, "Core 2 Extreme Mobile" }, /* From CIM_Processor.Family */
|
||||
{ 0xC4, "Core 2 Duo Mobile" }, /* From CIM_Processor.Family */
|
||||
{ 0xC5, "Core 2 Solo Mobile" }, /* From CIM_Processor.Family */
|
||||
+ { 0xC6, "Core i7" },
|
||||
+ { 0xC7, "Dual-Core Celeron" },
|
||||
|
||||
{ 0xC8, "IBM390" },
|
||||
{ 0xC9, "G4" },
|
||||
@@ -753,6 +761,17 @@ static const char *dmi_processor_family(
|
||||
{ 0xD4, "C7" },
|
||||
{ 0xD5, "Eden" },
|
||||
|
||||
+ { 0xD6, "Multi-Core Xeon" },
|
||||
+ { 0xD7, "Dual-Core Xeon 3xxx" },
|
||||
+ { 0xD8, "Quad-Core Xeon 3xxx" },
|
||||
+
|
||||
+ { 0xDA, "Dual-Core Xeon 5xxx" },
|
||||
+ { 0xDB, "Quad-Core Xeon 5xxx" },
|
||||
+
|
||||
+ { 0xDD, "Dual-Core Xeon 7xxx" },
|
||||
+ { 0xDD, "Quad-Core Xeon 7xxx" },
|
||||
+ { 0xDD, "Multi-Core Xeon 7xxx" },
|
||||
+
|
||||
{ 0xE6, "Embedded Opteron Quad-Core" }, /* From CIM_Processor.Family */
|
||||
{ 0xE7, "Phenom Triple-Core" }, /* From CIM_Processor.Family */
|
||||
{ 0xE8, "Turion Ultra Dual-Core Mobile" }, /* From CIM_Processor.Family */
|
||||
@@ -1383,10 +1402,15 @@ static const char *dmi_cache_associativi
|
||||
"4-way Set-associative",
|
||||
"Fully Associative",
|
||||
"8-way Set-associative",
|
||||
- "16-way Set-associative" /* 0x08 */
|
||||
+ "16-way Set-associative",
|
||||
+ "12-way Set-associative",
|
||||
+ "24-way Set-associative",
|
||||
+ "32-way Set-associative",
|
||||
+ "48-way Set-associative",
|
||||
+ "64-way Set-associative" /* 0x0D */
|
||||
};
|
||||
|
||||
- if (code >= 0x01 && code <= 0x08)
|
||||
+ if (code >= 0x01 && code <= 0x0D)
|
||||
return type[code - 0x01];
|
||||
return out_of_spec;
|
||||
}
|
||||
@@ -1544,12 +1568,18 @@ static const char *dmi_slot_type(u8 code
|
||||
"PCI Express x2",
|
||||
"PCI Express x4",
|
||||
"PCI Express x8",
|
||||
- "PCI Express x16" /* 0xAA */
|
||||
+ "PCI Express x16", /* 0xAA */
|
||||
+ "PCI Express Gen 2",
|
||||
+ "PCI Express Gen 2 x1",
|
||||
+ "PCI Express Gen 2 x2",
|
||||
+ "PCI Express Gen 2 x4",
|
||||
+ "PCI Express Gen 2 x8",
|
||||
+ "PCI Express Gen 2 x16", /* 0xB0 */
|
||||
};
|
||||
|
||||
if (code >= 0x01 && code <= 0x13)
|
||||
return type[code - 0x01];
|
||||
- if (code >= 0xA0 && code <= 0xAA)
|
||||
+ if (code >= 0xA0 && code <= 0xB0)
|
||||
return type_0xA0[code - 0xA0];
|
||||
return out_of_spec;
|
||||
}
|
||||
@@ -2120,10 +2150,15 @@ static const char *dmi_memory_device_typ
|
||||
"RDRAM",
|
||||
"DDR",
|
||||
"DDR2",
|
||||
- "DDR2 FB-DIMM" /* 0x14 */
|
||||
+ "DDR2 FB-DIMM",
|
||||
+ "Reserved",
|
||||
+ "Reserved",
|
||||
+ "Reserved",
|
||||
+ "DDR3",
|
||||
+ "FBD2", /* 0x19 */
|
||||
};
|
||||
|
||||
- if (code >= 0x01 && code <= 0x14)
|
||||
+ if (code >= 0x01 && code <= 0x19)
|
||||
return type[code - 0x01];
|
||||
return out_of_spec;
|
||||
}
|
@ -1,25 +0,0 @@
|
||||
--- dmidecode/dmidecode.c~ 2008/11/14 10:27:31 1.140
|
||||
+++ dmidecode/dmidecode.c 2009/04/30 08:19:37 1.141
|
||||
@@ -66,6 +66,8 @@
|
||||
#define out_of_spec "<OUT OF SPEC>"
|
||||
static const char *bad_index = "<BAD INDEX>";
|
||||
|
||||
+#define SUPPORTED_SMBIOS_VER 0x0206
|
||||
+
|
||||
/*
|
||||
* Type-independant Stuff
|
||||
*/
|
||||
@@ -4005,6 +4007,13 @@
|
||||
u8 *data;
|
||||
int i = 0;
|
||||
|
||||
+ if (ver > SUPPORTED_SMBIOS_VER)
|
||||
+ {
|
||||
+ printf("# SMBIOS implementations newer than version %u.%u are not\n"
|
||||
+ "# fully supported by this version of dmidecode.\n",
|
||||
+ SUPPORTED_SMBIOS_VER >> 8, SUPPORTED_SMBIOS_VER & 0xFF);
|
||||
+ }
|
||||
+
|
||||
if (opt.flags & FLAG_DUMP_BIN)
|
||||
{
|
||||
dmi_table_dump(base, len, devmem);
|
@ -1,17 +1,11 @@
|
||||
Summary: Tool to analyse BIOS DMI data
|
||||
Name: dmidecode
|
||||
Version: 2.10
|
||||
Release: 2%{?dist}
|
||||
Version: 2.11
|
||||
Release: 1%{?dist}
|
||||
Epoch: 1
|
||||
Group: System Environment/Base
|
||||
License: GPLv2+
|
||||
Source0: %{name}-%{version}.tar.bz2
|
||||
Patch0: dmidecode-add-hewlett-packard-to-dmioem.patch
|
||||
Patch1: dmidecode-recognize-more-memory.patch
|
||||
Patch2: dmidecode-add-socket-lga1366.patch
|
||||
Patch3: dmidecode-warn-on-unsupported-smbios-version.patch
|
||||
Patch4: dmidecode-smbios-2.6.1-updates.patch
|
||||
Patch5: dmidecode-makefile-fix.patch
|
||||
URL: http://www.nongnu.org/dmidecode/
|
||||
Buildroot: %{_tmppath}/%{name}-%{version}-root
|
||||
BuildRequires: automake autoconf
|
||||
@ -30,12 +24,6 @@ I/O ports (e.g. serial, parallel, USB).
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
%patch4 -p1
|
||||
%patch5 -p1
|
||||
|
||||
%build
|
||||
make %{?_smp_mflags} CFLAGS="$RPM_OPT_FLAGS"
|
||||
@ -59,13 +47,17 @@ rm -rf ${buildroot}
|
||||
%{_mandir}/man8/*
|
||||
|
||||
%changelog
|
||||
* Mon Nov 08 2010 Prarit Bhargava <prarit@redhat.com> - 1:2.1.0-3
|
||||
* Wed Jan 19 2011 Anton Arapov <anton@redhat.com> - 1:2.11-1
|
||||
- Update to upstream 2.11 release. (#623047)
|
||||
- Fix the changelog's NVR.
|
||||
|
||||
* Mon Nov 08 2010 Prarit Bhargava <prarit@redhat.com> - 1:2.10-3
|
||||
- updated kernel.spec for review [BZ 225698]
|
||||
|
||||
* Fri Oct 15 2010 Anton Arapov <aarapov@redhat.com> - 1:2.1.0-2
|
||||
* Fri Oct 15 2010 Anton Arapov <aarapov@redhat.com> - 1:2.10-2
|
||||
- Does not build with gnu make v3.82+ (#631407)
|
||||
|
||||
* Fri Dec 18 2009 Prarit Bhargava <prarit@redhat.com> - 1:2.1.0-1.40
|
||||
* Fri Dec 18 2009 Prarit Bhargava <prarit@redhat.com> - 1:2.10-1.40
|
||||
- Fix rpmlint errors in specfile
|
||||
|
||||
* Fri Aug 28 2009 Jarod Wilson <jarod@redhat.com> - 1:2.10-1.39
|
||||
|
Loading…
Reference in New Issue
Block a user