40 lines
1.0 KiB
Diff
40 lines
1.0 KiB
Diff
From 5afd9fdc0ef202633f57abc063a5a2c6cef1d61d Mon Sep 17 00:00:00 2001
|
|
From: David Teigland <teigland@redhat.com>
|
|
Date: Wed, 28 Jul 2021 16:12:43 -0500
|
|
Subject: [PATCH] stonith_helper: fix build
|
|
|
|
include stdlib
|
|
use pkg-config to get pacemaker headers
|
|
---
|
|
fence/Makefile | 1 +
|
|
fence/stonith_helper.c | 1 +
|
|
2 files changed, 2 insertions(+)
|
|
|
|
diff --git a/fence/Makefile b/fence/Makefile
|
|
index b927879eb141..1f6dd6b2c40e 100644
|
|
--- a/fence/Makefile
|
|
+++ b/fence/Makefile
|
|
@@ -20,6 +20,7 @@ CFLAGS += -D_GNU_SOURCE -O2 -ggdb \
|
|
CFLAGS += -fPIE -DPIE
|
|
CFLAGS += `xml2-config --cflags`
|
|
CFLAGS += -I../include
|
|
+CFLAGS += $(shell pkg-config --cflags pacemaker-fencing)
|
|
|
|
LDFLAGS += -Wl,-z,relro -pie
|
|
LDFLAGS += `xml2-config --libs`
|
|
diff --git a/fence/stonith_helper.c b/fence/stonith_helper.c
|
|
index 3a0768af2830..b1db352ae04f 100644
|
|
--- a/fence/stonith_helper.c
|
|
+++ b/fence/stonith_helper.c
|
|
@@ -8,6 +8,7 @@
|
|
|
|
#include <stdio.h>
|
|
#include <stdint.h>
|
|
+#include <stdlib.h>
|
|
#include <string.h>
|
|
#include <unistd.h>
|
|
#include <syslog.h>
|
|
--
|
|
2.7.5
|
|
|