import dlm-4.1.1-1.el9

This commit is contained in:
CentOS Sources 2022-01-11 12:55:19 -05:00 committed by Stepan Oksanichenko
parent 28dc36aa07
commit 9d49fe906a
4 changed files with 13 additions and 49 deletions

View File

@ -1 +1 @@
3655865fa215e6b50e6b82ba66cb13f2d8005f67 SOURCES/dlm-4.0.9.tar.gz
a8fef90c11d7da2a9420eb19aab221952686881c SOURCES/dlm-4.1.1.tar.gz

2
.gitignore vendored
View File

@ -1 +1 @@
SOURCES/dlm-4.0.9.tar.gz
SOURCES/dlm-4.1.1.tar.gz

View File

@ -1,39 +0,0 @@
From 5afd9fdc0ef202633f57abc063a5a2c6cef1d61d Mon Sep 17 00:00:00 2001
From: David Teigland <teigland@redhat.com>
Date: Wed, 28 Jul 2021 16:12:43 -0500
Subject: [PATCH] stonith_helper: fix build
include stdlib
use pkg-config to get pacemaker headers
---
fence/Makefile | 1 +
fence/stonith_helper.c | 1 +
2 files changed, 2 insertions(+)
diff --git a/fence/Makefile b/fence/Makefile
index b927879eb141..1f6dd6b2c40e 100644
--- a/fence/Makefile
+++ b/fence/Makefile
@@ -20,6 +20,7 @@ CFLAGS += -D_GNU_SOURCE -O2 -ggdb \
CFLAGS += -fPIE -DPIE
CFLAGS += `xml2-config --cflags`
CFLAGS += -I../include
+CFLAGS += $(shell pkg-config --cflags pacemaker-fencing)
LDFLAGS += -Wl,-z,relro -pie
LDFLAGS += `xml2-config --libs`
diff --git a/fence/stonith_helper.c b/fence/stonith_helper.c
index 3a0768af2830..b1db352ae04f 100644
--- a/fence/stonith_helper.c
+++ b/fence/stonith_helper.c
@@ -8,6 +8,7 @@
#include <stdio.h>
#include <stdint.h>
+#include <stdlib.h>
#include <string.h>
#include <unistd.h>
#include <syslog.h>
--
2.7.5

View File

@ -1,13 +1,13 @@
Name: dlm
Version: 4.0.9
Release: 7%{?dist}
Version: 4.1.1
Release: 1%{?dist}
License: GPLv2 and GPLv2+ and LGPLv2+
# For a breakdown of the licensing, see README.license
Summary: Kernel Distributed Lock Manager control daemon and tool
URL: https://fedorahosted.org/cluster
Summary: dlm control daemon and tool
URL: https://pagure.io/dlm
BuildRequires: gcc
BuildRequires: glibc-kernheaders
BuildRequires: corosynclib-devel >= 1.99.9
BuildRequires: corosynclib-devel >= 3.1.0
BuildRequires: pacemaker-libs-devel >= 1.1.7
BuildRequires: libxml2-devel
BuildRequires: systemd-units
@ -15,14 +15,14 @@ BuildRequires: systemd-devel
BuildRequires: make
Source0: https://releases.pagure.org/dlm/%{name}-%{version}.tar.gz
Patch0: 0001-stonith_helper-fix-build.patch
# Patch0: 0001-foo.patch
%if 0%{?rhel} && 0%{?rhel} <= 7
ExclusiveArch: i686 x86_64
%endif
Requires: %{name}-lib = %{version}-%{release}
Requires: corosync >= 1.99.9
Requires: corosync >= 3.1.0
%{?fedora:Requires: kernel-modules-extra}
Requires(post): systemd-units
Requires(preun): systemd-units
@ -34,7 +34,7 @@ The kernel dlm requires a user daemon to control membership.
%prep
%setup -q
%patch0 -p1 -b .0001-stonith_helper-fix-build.patch
# %patch0 -p1 -b .0001-foo.patch
%build
# upstream does not require configure
@ -99,6 +99,9 @@ developing applications that use %{name}.
%{_libdir}/pkgconfig/*.pc
%changelog
* Mon Nov 15 2021 David Teigland <teigland@redhat.com> - 4.1.1-1
- new upstream version
* Wed Aug 25 2021 David Teigland <teigland@redhat.com> - 4.0.9-7
- fix pacemaker header