new upstream release

This commit is contained in:
David Teigland 2022-10-18 09:27:04 -05:00
parent 8658ec6c26
commit 7e670ff6d6
4 changed files with 82 additions and 8 deletions

1
.gitignore vendored
View File

@ -11,3 +11,4 @@
/dlm-4.0.6.tar.gz /dlm-4.0.6.tar.gz
/dlm-4.0.9.tar.gz /dlm-4.0.9.tar.gz
/dlm-4.1.0.tar.gz /dlm-4.1.0.tar.gz
/dlm-4.2.0.tar.gz

View File

@ -0,0 +1,70 @@
From 4cfb7b21a88f0ae32d97ea4cbb0c7419b88f397d Mon Sep 17 00:00:00 2001
From: Alexander Aring <aahringo@redhat.com>
Date: Wed, 12 Oct 2022 12:44:03 -0400
Subject: [PATCH] Revert "treewide: add -fcf-protection=full to CFLAGS"
This reverts commit 215aedf1fdff58c62fe596284948590965acc85c.
---
dlm_controld/Makefile | 2 +-
dlm_tool/Makefile | 2 +-
fence/Makefile | 2 +-
libdlm/Makefile | 4 ++--
4 files changed, 5 insertions(+), 5 deletions(-)
diff --git a/dlm_controld/Makefile b/dlm_controld/Makefile
index ec8c360cc853..9cf7152f60ab 100644
--- a/dlm_controld/Makefile
+++ b/dlm_controld/Makefile
@@ -43,7 +43,7 @@ CFLAGS += -D_GNU_SOURCE -O2 -ggdb \
-Wno-sign-compare -Wno-unused-parameter -Wp,-D_FORTIFY_SOURCE=2 \
-fexceptions -fasynchronous-unwind-tables -fdiagnostics-show-option \
-Wp,-D_GLIBCXX_ASSERTIONS -fstack-protector-strong \
- -fstack-clash-protection -fcf-protection=full
+ -fstack-clash-protection
BIN_CFLAGS += $(CFLAGS) -fPIE -DPIE
BIN_CFLAGS += -I../include -I../libdlm
diff --git a/dlm_tool/Makefile b/dlm_tool/Makefile
index 57629c731771..1c3d61d5c860 100644
--- a/dlm_tool/Makefile
+++ b/dlm_tool/Makefile
@@ -15,7 +15,7 @@ CFLAGS += -D_GNU_SOURCE -O2 -ggdb \
-Wno-sign-compare -Wno-unused-parameter -Wp,-D_FORTIFY_SOURCE=2 \
-fexceptions -fasynchronous-unwind-tables -fdiagnostics-show-option \
-Wp,-D_GLIBCXX_ASSERTIONS -fstack-protector-strong \
- -fstack-clash-protection -fcf-protection=full
+ -fstack-clash-protection
CFLAGS += -fPIE -DPIE
CFLAGS += -I../include -I../libdlm -I../dlm_controld
diff --git a/fence/Makefile b/fence/Makefile
index 446f4eaac9f9..ee4dfb886d4c 100644
--- a/fence/Makefile
+++ b/fence/Makefile
@@ -15,7 +15,7 @@ CFLAGS += -D_GNU_SOURCE -O2 -ggdb \
-Wno-sign-compare -Wno-unused-parameter -Wp,-D_FORTIFY_SOURCE=2 \
-fexceptions -fasynchronous-unwind-tables -fdiagnostics-show-option \
-Wp,-D_GLIBCXX_ASSERTIONS -fstack-protector-strong \
- -fstack-clash-protection -fcf-protection=full
+ -fstack-clash-protection
CFLAGS += -fPIE -DPIE
CFLAGS += -I../include
diff --git a/libdlm/Makefile b/libdlm/Makefile
index 823fdaa94073..5069ccf1f7f9 100644
--- a/libdlm/Makefile
+++ b/libdlm/Makefile
@@ -80,8 +80,8 @@ CFLAGS += -D_GNU_SOURCE -O2 -ggdb \
-fdiagnostics-show-option \
-fPIC
-LIB_CFLAGS += $(CFLAGS) -D_REENTRANT -fcf-protection=full
-LLT_CFLAGS += $(CFLAGS) -fcf-protection=full
+LIB_CFLAGS += $(CFLAGS) -D_REENTRANT
+LLT_CFLAGS += $(CFLAGS)
LIB_LDFLAGS += $(LDFLAGS) -lpthread -Wl,-z,now
LLT_LDFLAGS += $(LDFLAGS) -Wl,-z,now
--
2.7.5

View File

@ -1,13 +1,13 @@
Name: dlm Name: dlm
Version: 4.1.0 Version: 4.2.0
Release: 7%{?dist} Release: 1%{?dist}
License: GPLv2 and GPLv2+ and LGPLv2+ License: GPLv2 and GPLv2+ and LGPLv2+
# For a breakdown of the licensing, see README.license # For a breakdown of the licensing, see README.license
Summary: Kernel Distributed Lock Manager control daemon and tool Summary: dlm control daemon and tool
URL: https://fedorahosted.org/cluster URL: https://pagure.io/dlm
BuildRequires: gcc BuildRequires: gcc
BuildRequires: glibc-kernheaders BuildRequires: glibc-kernheaders
BuildRequires: corosynclib-devel >= 1.99.9 BuildRequires: corosynclib-devel >= 3.1.0
BuildRequires: pacemaker-libs-devel >= 1.1.7 BuildRequires: pacemaker-libs-devel >= 1.1.7
BuildRequires: libxml2-devel BuildRequires: libxml2-devel
BuildRequires: systemd-units BuildRequires: systemd-units
@ -15,7 +15,7 @@ BuildRequires: systemd-devel
BuildRequires: make BuildRequires: make
Source0: https://releases.pagure.org/dlm/%{name}-%{version}.tar.gz Source0: https://releases.pagure.org/dlm/%{name}-%{version}.tar.gz
Patch0: 0001-stonith_helper-fix-build.patch Patch0: 0001-Revert-treewide-add-fcf-protection-full-to-CFLAGS.patch
%if 0%{?rhel} && 0%{?rhel} <= 7 %if 0%{?rhel} && 0%{?rhel} <= 7
ExclusiveArch: i686 x86_64 ExclusiveArch: i686 x86_64
@ -34,7 +34,7 @@ The kernel dlm requires a user daemon to control membership.
%prep %prep
%setup -q %setup -q
%patch0 -p1 -b .0001-stonith_helper-fix-build.patch %patch0 -p1 -b .backup0
%build %build
# upstream does not require configure # upstream does not require configure
@ -99,6 +99,9 @@ developing applications that use %{name}.
%{_libdir}/pkgconfig/*.pc %{_libdir}/pkgconfig/*.pc
%changelog %changelog
* Tue Oct 18 2022 David Teigland <teigland@redhat.com> - 4.2.0-1
- new upstream version
* Thu Jul 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 4.1.0-7 * Thu Jul 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 4.1.0-7
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild

View File

@ -1 +1 @@
SHA512 (dlm-4.1.0.tar.gz) = 472bc095fe6b977b7e6208403a950240b305a5855c33ad4a24caa88e6cfa9634c41e57cc0bd4a584b261103a73091870c3674044b55993b47e58b26e8d52f807 SHA512 (dlm-4.2.0.tar.gz) = b437373d292a6020c47bec2d2c3d630460332d2f0158033d719d156e3a6bead9bd37452ef7679da2cbac5d96a9d056a7daff203e45ddfe6dab47cc230abf48b9