Resolves: rhbz#2133827
This commit is contained in:
parent
c1e552fece
commit
6e326c369f
1
.gitignore
vendored
1
.gitignore
vendored
@ -11,3 +11,4 @@
|
||||
/dlm-4.0.6.tar.gz
|
||||
/dlm-4.0.9.tar.gz
|
||||
/dlm-4.1.1.tar.gz
|
||||
/dlm-4.2.0.tar.gz
|
||||
|
70
0001-Revert-treewide-add-fcf-protection-full-to-CFLAGS.patch
Normal file
70
0001-Revert-treewide-add-fcf-protection-full-to-CFLAGS.patch
Normal file
@ -0,0 +1,70 @@
|
||||
From 4cfb7b21a88f0ae32d97ea4cbb0c7419b88f397d Mon Sep 17 00:00:00 2001
|
||||
From: Alexander Aring <aahringo@redhat.com>
|
||||
Date: Wed, 12 Oct 2022 12:44:03 -0400
|
||||
Subject: [PATCH] Revert "treewide: add -fcf-protection=full to CFLAGS"
|
||||
|
||||
This reverts commit 215aedf1fdff58c62fe596284948590965acc85c.
|
||||
---
|
||||
dlm_controld/Makefile | 2 +-
|
||||
dlm_tool/Makefile | 2 +-
|
||||
fence/Makefile | 2 +-
|
||||
libdlm/Makefile | 4 ++--
|
||||
4 files changed, 5 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/dlm_controld/Makefile b/dlm_controld/Makefile
|
||||
index ec8c360cc853..9cf7152f60ab 100644
|
||||
--- a/dlm_controld/Makefile
|
||||
+++ b/dlm_controld/Makefile
|
||||
@@ -43,7 +43,7 @@ CFLAGS += -D_GNU_SOURCE -O2 -ggdb \
|
||||
-Wno-sign-compare -Wno-unused-parameter -Wp,-D_FORTIFY_SOURCE=2 \
|
||||
-fexceptions -fasynchronous-unwind-tables -fdiagnostics-show-option \
|
||||
-Wp,-D_GLIBCXX_ASSERTIONS -fstack-protector-strong \
|
||||
- -fstack-clash-protection -fcf-protection=full
|
||||
+ -fstack-clash-protection
|
||||
|
||||
BIN_CFLAGS += $(CFLAGS) -fPIE -DPIE
|
||||
BIN_CFLAGS += -I../include -I../libdlm
|
||||
diff --git a/dlm_tool/Makefile b/dlm_tool/Makefile
|
||||
index 57629c731771..1c3d61d5c860 100644
|
||||
--- a/dlm_tool/Makefile
|
||||
+++ b/dlm_tool/Makefile
|
||||
@@ -15,7 +15,7 @@ CFLAGS += -D_GNU_SOURCE -O2 -ggdb \
|
||||
-Wno-sign-compare -Wno-unused-parameter -Wp,-D_FORTIFY_SOURCE=2 \
|
||||
-fexceptions -fasynchronous-unwind-tables -fdiagnostics-show-option \
|
||||
-Wp,-D_GLIBCXX_ASSERTIONS -fstack-protector-strong \
|
||||
- -fstack-clash-protection -fcf-protection=full
|
||||
+ -fstack-clash-protection
|
||||
|
||||
CFLAGS += -fPIE -DPIE
|
||||
CFLAGS += -I../include -I../libdlm -I../dlm_controld
|
||||
diff --git a/fence/Makefile b/fence/Makefile
|
||||
index 446f4eaac9f9..ee4dfb886d4c 100644
|
||||
--- a/fence/Makefile
|
||||
+++ b/fence/Makefile
|
||||
@@ -15,7 +15,7 @@ CFLAGS += -D_GNU_SOURCE -O2 -ggdb \
|
||||
-Wno-sign-compare -Wno-unused-parameter -Wp,-D_FORTIFY_SOURCE=2 \
|
||||
-fexceptions -fasynchronous-unwind-tables -fdiagnostics-show-option \
|
||||
-Wp,-D_GLIBCXX_ASSERTIONS -fstack-protector-strong \
|
||||
- -fstack-clash-protection -fcf-protection=full
|
||||
+ -fstack-clash-protection
|
||||
|
||||
CFLAGS += -fPIE -DPIE
|
||||
CFLAGS += -I../include
|
||||
diff --git a/libdlm/Makefile b/libdlm/Makefile
|
||||
index 823fdaa94073..5069ccf1f7f9 100644
|
||||
--- a/libdlm/Makefile
|
||||
+++ b/libdlm/Makefile
|
||||
@@ -80,8 +80,8 @@ CFLAGS += -D_GNU_SOURCE -O2 -ggdb \
|
||||
-fdiagnostics-show-option \
|
||||
-fPIC
|
||||
|
||||
-LIB_CFLAGS += $(CFLAGS) -D_REENTRANT -fcf-protection=full
|
||||
-LLT_CFLAGS += $(CFLAGS) -fcf-protection=full
|
||||
+LIB_CFLAGS += $(CFLAGS) -D_REENTRANT
|
||||
+LLT_CFLAGS += $(CFLAGS)
|
||||
|
||||
LIB_LDFLAGS += $(LDFLAGS) -lpthread -Wl,-z,now
|
||||
LLT_LDFLAGS += $(LDFLAGS) -Wl,-z,now
|
||||
--
|
||||
2.7.5
|
||||
|
14
dlm.spec
14
dlm.spec
@ -1,6 +1,6 @@
|
||||
Name: dlm
|
||||
Version: 4.1.1
|
||||
Release: 2%{?dist}
|
||||
Version: 4.2.0
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2 and GPLv2+ and LGPLv2+
|
||||
# For a breakdown of the licensing, see README.license
|
||||
Summary: dlm control daemon and tool
|
||||
@ -15,10 +15,7 @@ BuildRequires: systemd-devel
|
||||
BuildRequires: make
|
||||
Source0: https://releases.pagure.org/dlm/%{name}-%{version}.tar.gz
|
||||
|
||||
Patch0: 0001-dlm_controld-fix-printf-args-in-log-messages.patch
|
||||
Patch1: 0002-stonith_helper-Don-t-link-dlm_stonith-against-libxml.patch
|
||||
Patch2: 0003-treewide-do-always-Wl-z-now-in-LDFLAGS.patch
|
||||
|
||||
Patch0: 0001-Revert-treewide-add-fcf-protection-full-to-CFLAGS.patch
|
||||
|
||||
%if 0%{?rhel} && 0%{?rhel} <= 7
|
||||
ExclusiveArch: i686 x86_64
|
||||
@ -38,8 +35,6 @@ The kernel dlm requires a user daemon to control membership.
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .backup0
|
||||
%patch1 -p1 -b .backup1
|
||||
%patch2 -p1 -b .backup2
|
||||
|
||||
%build
|
||||
# upstream does not require configure
|
||||
@ -104,6 +99,9 @@ developing applications that use %{name}.
|
||||
%{_libdir}/pkgconfig/*.pc
|
||||
|
||||
%changelog
|
||||
* Wed Oct 12 2022 David Teigland <teigland@redhat.com> - 4.2.0-1
|
||||
- new upstream version
|
||||
|
||||
* Tue Feb 15 2022 David Teigland <teigland@redhat.com> - 4.1.1-2
|
||||
- compiler warnings and makefile flags
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (dlm-4.1.1.tar.gz) = f2ed349b7be263f060de9c1341db8f998a61885ff1a58b36f251dd6810795dc9d917c6573f16bacfde4dd4df321d5a88a2f5f92ff4bc8fa93fedb57ed52db00b
|
||||
SHA512 (dlm-4.2.0.tar.gz) = b437373d292a6020c47bec2d2c3d630460332d2f0158033d719d156e3a6bead9bd37452ef7679da2cbac5d96a9d056a7daff203e45ddfe6dab47cc230abf48b9
|
||||
|
Loading…
Reference in New Issue
Block a user