fix pacemaker headers
This commit is contained in:
parent
07e76e5de6
commit
6d6dd3ab98
39
0001-stonith_helper-fix-build.patch
Normal file
39
0001-stonith_helper-fix-build.patch
Normal file
@ -0,0 +1,39 @@
|
|||||||
|
From 5afd9fdc0ef202633f57abc063a5a2c6cef1d61d Mon Sep 17 00:00:00 2001
|
||||||
|
From: David Teigland <teigland@redhat.com>
|
||||||
|
Date: Wed, 28 Jul 2021 16:12:43 -0500
|
||||||
|
Subject: [PATCH] stonith_helper: fix build
|
||||||
|
|
||||||
|
include stdlib
|
||||||
|
use pkg-config to get pacemaker headers
|
||||||
|
---
|
||||||
|
fence/Makefile | 1 +
|
||||||
|
fence/stonith_helper.c | 1 +
|
||||||
|
2 files changed, 2 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/fence/Makefile b/fence/Makefile
|
||||||
|
index b927879eb141..1f6dd6b2c40e 100644
|
||||||
|
--- a/fence/Makefile
|
||||||
|
+++ b/fence/Makefile
|
||||||
|
@@ -20,6 +20,7 @@ CFLAGS += -D_GNU_SOURCE -O2 -ggdb \
|
||||||
|
CFLAGS += -fPIE -DPIE
|
||||||
|
CFLAGS += `xml2-config --cflags`
|
||||||
|
CFLAGS += -I../include
|
||||||
|
+CFLAGS += $(shell pkg-config --cflags pacemaker-fencing)
|
||||||
|
|
||||||
|
LDFLAGS += -Wl,-z,relro -pie
|
||||||
|
LDFLAGS += `xml2-config --libs`
|
||||||
|
diff --git a/fence/stonith_helper.c b/fence/stonith_helper.c
|
||||||
|
index 3a0768af2830..b1db352ae04f 100644
|
||||||
|
--- a/fence/stonith_helper.c
|
||||||
|
+++ b/fence/stonith_helper.c
|
||||||
|
@@ -8,6 +8,7 @@
|
||||||
|
|
||||||
|
#include <stdio.h>
|
||||||
|
#include <stdint.h>
|
||||||
|
+#include <stdlib.h>
|
||||||
|
#include <string.h>
|
||||||
|
#include <unistd.h>
|
||||||
|
#include <syslog.h>
|
||||||
|
--
|
||||||
|
2.7.5
|
||||||
|
|
9
dlm.spec
9
dlm.spec
@ -1,6 +1,6 @@
|
|||||||
Name: dlm
|
Name: dlm
|
||||||
Version: 4.1.0
|
Version: 4.1.0
|
||||||
Release: 3%{?dist}
|
Release: 4%{?dist}
|
||||||
License: GPLv2 and GPLv2+ and LGPLv2+
|
License: GPLv2 and GPLv2+ and LGPLv2+
|
||||||
# For a breakdown of the licensing, see README.license
|
# For a breakdown of the licensing, see README.license
|
||||||
Summary: Kernel Distributed Lock Manager control daemon and tool
|
Summary: Kernel Distributed Lock Manager control daemon and tool
|
||||||
@ -15,7 +15,7 @@ BuildRequires: systemd-devel
|
|||||||
BuildRequires: make
|
BuildRequires: make
|
||||||
Source0: https://releases.pagure.org/dlm/%{name}-%{version}.tar.gz
|
Source0: https://releases.pagure.org/dlm/%{name}-%{version}.tar.gz
|
||||||
|
|
||||||
# Patch0: 0001-foo.patch
|
Patch0: 0001-stonith_helper-fix-build.patch
|
||||||
|
|
||||||
%if 0%{?rhel} && 0%{?rhel} <= 7
|
%if 0%{?rhel} && 0%{?rhel} <= 7
|
||||||
ExclusiveArch: i686 x86_64
|
ExclusiveArch: i686 x86_64
|
||||||
@ -34,7 +34,7 @@ The kernel dlm requires a user daemon to control membership.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
# %patch0 -p1 -b .0001-foo.patch
|
%patch0 -p1 -b .0001-stonith_helper-fix-build.patch
|
||||||
|
|
||||||
%build
|
%build
|
||||||
# upstream does not require configure
|
# upstream does not require configure
|
||||||
@ -99,6 +99,9 @@ developing applications that use %{name}.
|
|||||||
%{_libdir}/pkgconfig/*.pc
|
%{_libdir}/pkgconfig/*.pc
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Aug 02 2021 David Teigland <teigland@redhat.com> - 4.1.0-4
|
||||||
|
- fix pacemaker headers
|
||||||
|
|
||||||
* Wed Jul 21 2021 Fedora Release Engineering <releng@fedoraproject.org> - 4.1.0-3
|
* Wed Jul 21 2021 Fedora Release Engineering <releng@fedoraproject.org> - 4.1.0-3
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user