import dleyna-renderer-0.6.0-3.el8
This commit is contained in:
parent
3900841759
commit
e905c17685
264
SOURCES/0001-Add-a-manual.patch
Normal file
264
SOURCES/0001-Add-a-manual.patch
Normal file
@ -0,0 +1,264 @@
|
|||||||
|
From d80c3cbfaae6683e0e1685e5337b7dfe3a36692a Mon Sep 17 00:00:00 2001
|
||||||
|
From: Debarshi Ray <debarshir@freedesktop.org>
|
||||||
|
Date: Mon, 22 Jun 2020 17:02:42 +0200
|
||||||
|
Subject: [PATCH] Add a manual
|
||||||
|
|
||||||
|
https://github.com/phako/dleyna-renderer/pull/1
|
||||||
|
---
|
||||||
|
Makefile.am | 2 +-
|
||||||
|
configure.ac | 6 +
|
||||||
|
doc/Makefile.am | 18 +++
|
||||||
|
doc/dleyna-renderer-service.conf.xml | 182 +++++++++++++++++++++++++++
|
||||||
|
4 files changed, 207 insertions(+), 1 deletion(-)
|
||||||
|
create mode 100644 doc/Makefile.am
|
||||||
|
create mode 100644 doc/dleyna-renderer-service.conf.xml
|
||||||
|
|
||||||
|
diff --git a/Makefile.am b/Makefile.am
|
||||||
|
index 200e1967f0e5..35bd628faf47 100644
|
||||||
|
--- a/Makefile.am
|
||||||
|
+++ b/Makefile.am
|
||||||
|
@@ -1,4 +1,4 @@
|
||||||
|
-SUBDIRS = libdleyna/renderer
|
||||||
|
+SUBDIRS = doc libdleyna/renderer
|
||||||
|
|
||||||
|
if BUILD_SERVER
|
||||||
|
SUBDIRS += server
|
||||||
|
diff --git a/configure.ac b/configure.ac
|
||||||
|
index 271ee92ead00..4d96903c67a3 100644
|
||||||
|
--- a/configure.ac
|
||||||
|
+++ b/configure.ac
|
||||||
|
@@ -34,6 +34,11 @@ LT_PREREQ([2.2.6])
|
||||||
|
LT_INIT([dlopen disable-static])
|
||||||
|
LT_LANG([C])
|
||||||
|
|
||||||
|
+AC_PATH_PROG([XSLTPROC], [xsltproc])
|
||||||
|
+if test -z "$XSLTPROC"; then
|
||||||
|
+ AC_MSG_ERROR([xsltproc not found])
|
||||||
|
+fi
|
||||||
|
+
|
||||||
|
# Checks for libraries.
|
||||||
|
PKG_PROG_PKG_CONFIG(0.16)
|
||||||
|
PKG_CHECK_MODULES([GLIB], [glib-2.0 >= 2.28])
|
||||||
|
@@ -231,6 +236,7 @@ AC_SUBST([with_log_level])
|
||||||
|
AC_SUBST([with_log_type])
|
||||||
|
|
||||||
|
AC_CONFIG_FILES([Makefile \
|
||||||
|
+ doc/Makefile \
|
||||||
|
libdleyna/renderer/Makefile \
|
||||||
|
libdleyna/renderer/dleyna-renderer-service.conf \
|
||||||
|
server/dleyna-renderer-service-1.0.pc \
|
||||||
|
diff --git a/doc/Makefile.am b/doc/Makefile.am
|
||||||
|
new file mode 100644
|
||||||
|
index 000000000000..80069b1c82e7
|
||||||
|
--- /dev/null
|
||||||
|
+++ b/doc/Makefile.am
|
||||||
|
@@ -0,0 +1,18 @@
|
||||||
|
+XSLTPROC_FLAGS = \
|
||||||
|
+ --nonet \
|
||||||
|
+ --stringparam man.output.quietly 1 \
|
||||||
|
+ --stringparam funcsynopsis.style ansi \
|
||||||
|
+ --stringparam man.authors.section.enabled 0 \
|
||||||
|
+ --stringparam man.copyright.section.enabled 0
|
||||||
|
+
|
||||||
|
+.xml.5:
|
||||||
|
+ $(AM_V_GEN) $(XSLTPROC) $(XSLTPROC_FLAGS) http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl $<
|
||||||
|
+
|
||||||
|
+man_MANS = \
|
||||||
|
+ dleyna-renderer-service.conf.5
|
||||||
|
+
|
||||||
|
+xml_files = $(man_MANS:.5=.xml)
|
||||||
|
+
|
||||||
|
+EXTRA_DIST = $(xml_files)
|
||||||
|
+
|
||||||
|
+CLEANFILES = $(man_MANS)
|
||||||
|
diff --git a/doc/dleyna-renderer-service.conf.xml b/doc/dleyna-renderer-service.conf.xml
|
||||||
|
new file mode 100644
|
||||||
|
index 000000000000..e6be27411cf9
|
||||||
|
--- /dev/null
|
||||||
|
+++ b/doc/dleyna-renderer-service.conf.xml
|
||||||
|
@@ -0,0 +1,182 @@
|
||||||
|
+<?xml version="1.0" encoding="UTF-8"?>
|
||||||
|
+<refentry id="dleyna-renderer-service.conf.5">
|
||||||
|
+ <refentryinfo>
|
||||||
|
+ <title>dleyna-renderer-service.conf</title>
|
||||||
|
+ <date>June 2020</date>
|
||||||
|
+ <productname>dLeyna</productname>
|
||||||
|
+ </refentryinfo>
|
||||||
|
+
|
||||||
|
+ <refmeta>
|
||||||
|
+ <refentrytitle>dleyna-renderer-service.conf</refentrytitle>
|
||||||
|
+ <manvolnum>5</manvolnum>
|
||||||
|
+ <refmiscinfo class="manual">Linux Programmer's Manual</refmiscinfo>
|
||||||
|
+ </refmeta>
|
||||||
|
+
|
||||||
|
+ <refnamediv>
|
||||||
|
+ <refname>dleyna-renderer-service.conf</refname>
|
||||||
|
+ <refpurpose>Configuration file for dleyna-renderer</refpurpose>
|
||||||
|
+ </refnamediv>
|
||||||
|
+
|
||||||
|
+ <refsynopsisdiv>
|
||||||
|
+ <cmdsynopsis>
|
||||||
|
+ <command>/etc/dleyna-renderer-service.conf</command>
|
||||||
|
+ </cmdsynopsis>
|
||||||
|
+ </refsynopsisdiv>
|
||||||
|
+
|
||||||
|
+
|
||||||
|
+ <refsect1>
|
||||||
|
+ <title>DESCRIPTION</title>
|
||||||
|
+ <para>
|
||||||
|
+ The <command>dleyna-renderer-service</command> program provides the
|
||||||
|
+ <emphasis>com.intel.dleyna-renderer</emphasis> name on the session
|
||||||
|
+ message bus. It is a service for discovering and manipulating DLNA
|
||||||
|
+ Digital Media Renderers (or DMRs).
|
||||||
|
+ </para>
|
||||||
|
+ <para>
|
||||||
|
+ Users or administrators should never need to start this daemon as it will
|
||||||
|
+ be automatically started by
|
||||||
|
+ <citerefentry><refentrytitle>dbus-daemon</refentrytitle><manvolnum>1</manvolnum></citerefentry>
|
||||||
|
+ whenever a process sends a D-Bus message to the
|
||||||
|
+ <emphasis>com.intel.dleyna-renderer</emphasis> name on the session bus.
|
||||||
|
+ </para>
|
||||||
|
+ <para>
|
||||||
|
+ This file can be used to configure the behaviour of the
|
||||||
|
+ <command>dleyna-renderer-service</command> program.
|
||||||
|
+ </para>
|
||||||
|
+ </refsect1>
|
||||||
|
+
|
||||||
|
+ <refsect1>
|
||||||
|
+ <title>FILE FORMAT</title>
|
||||||
|
+ <para>
|
||||||
|
+ The configuration file format is the so-called key file (sort of
|
||||||
|
+ ini-style) format. It consists of sections (or groups) of key-value
|
||||||
|
+ Lines beginning with a '#' and blank lines are considered comments.
|
||||||
|
+ Sections are started by a header line containing the section enclosed
|
||||||
|
+ in '[' and ']', and ended implicitly by the start of the next section
|
||||||
|
+ or the end of the file. Each key-value pair must be contained in a
|
||||||
|
+ section.
|
||||||
|
+ </para>
|
||||||
|
+ </refsect1>
|
||||||
|
+
|
||||||
|
+ <refsect1>
|
||||||
|
+ <title>GENERAL SECTION</title>
|
||||||
|
+ <variablelist>
|
||||||
|
+ <varlistentry>
|
||||||
|
+ <term><option>connector-name=dbus</option></term>
|
||||||
|
+ <listitem>
|
||||||
|
+ <para>
|
||||||
|
+ The name of the inter-process communication method to be used.
|
||||||
|
+ The only supported value is <emphasis>dbus</emphasis>.
|
||||||
|
+ </para>
|
||||||
|
+ </listitem>
|
||||||
|
+ </varlistentry>
|
||||||
|
+ <varlistentry>
|
||||||
|
+ <term><option>never-quit=false|true</option></term>
|
||||||
|
+ <listitem>
|
||||||
|
+ <para>
|
||||||
|
+ Whether the process should stay alive forever or quit when the
|
||||||
|
+ last client disconnects. The default value is
|
||||||
|
+ <emphasis>false</emphasis>.
|
||||||
|
+ </para>
|
||||||
|
+ </listitem>
|
||||||
|
+ </varlistentry>
|
||||||
|
+ <varlistentry>
|
||||||
|
+ <term><option>port</option></term>
|
||||||
|
+ <listitem>
|
||||||
|
+ <para>
|
||||||
|
+ Source port for Simple Service Discovery Protocol (or SSDP)
|
||||||
|
+ messages. The default value is <emphasis>0</emphasis> which
|
||||||
|
+ means that a random available port will be used.
|
||||||
|
+ </para>
|
||||||
|
+ </listitem>
|
||||||
|
+ </varlistentry>
|
||||||
|
+ <varlistentry>
|
||||||
|
+ <term><option>push-host-port</option></term>
|
||||||
|
+ <listitem>
|
||||||
|
+ <para>
|
||||||
|
+ Port for push host file server. The default value is
|
||||||
|
+ <emphasis>0</emphasis> which means that a random available
|
||||||
|
+ port will be used.
|
||||||
|
+ </para>
|
||||||
|
+ </listitem>
|
||||||
|
+ </varlistentry>
|
||||||
|
+ </variablelist>
|
||||||
|
+ </refsect1>
|
||||||
|
+
|
||||||
|
+ <refsect1>
|
||||||
|
+ <title>LOG SECTION</title>
|
||||||
|
+ <variablelist>
|
||||||
|
+ <varlistentry>
|
||||||
|
+ <term><option>log-type=0|1|2</option></term>
|
||||||
|
+ <listitem>
|
||||||
|
+ <para>
|
||||||
|
+ The logging method to be used. Three technologies are supported.
|
||||||
|
+ 0 for syslog, 1 for GLib, and 2 for file. The default value is
|
||||||
|
+ <emphasis>0</emphasis>.
|
||||||
|
+ </para>
|
||||||
|
+ </listitem>
|
||||||
|
+ </varlistentry>
|
||||||
|
+ <varlistentry>
|
||||||
|
+ <term><option>log-level=0|1|2|...|8</option></term>
|
||||||
|
+ <listitem>
|
||||||
|
+ <para>
|
||||||
|
+ Comma-separated list of logging levels. The levels are 1 for
|
||||||
|
+ critical, 2 for error, 3 for warning, 4 for message, 5 for info
|
||||||
|
+ and 6 for debug. 0 excludes all levels, 7 is a combination of
|
||||||
|
+ critical, error and info, and 8 includes all levels.
|
||||||
|
+ </para>
|
||||||
|
+ <para>
|
||||||
|
+ The default value is <emphasis>7</emphasis>.
|
||||||
|
+ </para>
|
||||||
|
+ </listitem>
|
||||||
|
+ </varlistentry>
|
||||||
|
+ </variablelist>
|
||||||
|
+ </refsect1>
|
||||||
|
+
|
||||||
|
+ <refsect1>
|
||||||
|
+ <title>NETF SECTION</title>
|
||||||
|
+ <variablelist>
|
||||||
|
+ <varlistentry>
|
||||||
|
+ <term><option>netf-enabled=false|true</option></term>
|
||||||
|
+ <listitem>
|
||||||
|
+ <para>
|
||||||
|
+ Whether network filtering should be enabled or not. The default
|
||||||
|
+ values is <emphasis>false</emphasis>.
|
||||||
|
+ </para>
|
||||||
|
+ </listitem>
|
||||||
|
+ </varlistentry>
|
||||||
|
+ <varlistentry>
|
||||||
|
+ <term><option>netf-list</option></term>
|
||||||
|
+ <listitem>
|
||||||
|
+ <para>
|
||||||
|
+ Comma-separated list of interface names, service set identifiers
|
||||||
|
+ (or SSIDs), and Internet Protocol (or IP) addresses. If network
|
||||||
|
+ filtering is requested but the list is empty, then filtering
|
||||||
|
+ remains disabled.
|
||||||
|
+ </para>
|
||||||
|
+ <para>
|
||||||
|
+ The list is empty by default.
|
||||||
|
+ </para>
|
||||||
|
+ </listitem>
|
||||||
|
+ </varlistentry>
|
||||||
|
+ </variablelist>
|
||||||
|
+ </refsect1>
|
||||||
|
+
|
||||||
|
+ <refsect1>
|
||||||
|
+ <title>BUGS</title>
|
||||||
|
+ <para>
|
||||||
|
+ Please send bug reports to either the distribution bug tracker
|
||||||
|
+ or the upstream bug tracker at
|
||||||
|
+ <ulink url="https://github.com/intel/dleyna-renderer/issues"></ulink>.
|
||||||
|
+ </para>
|
||||||
|
+ </refsect1>
|
||||||
|
+
|
||||||
|
+ <refsect1>
|
||||||
|
+ <title>SEE ALSO</title>
|
||||||
|
+ <para>
|
||||||
|
+ <citerefentry>
|
||||||
|
+ <refentrytitle>dbus-daemon</refentrytitle><manvolnum>1</manvolnum>
|
||||||
|
+ </citerefentry>
|
||||||
|
+ </para>
|
||||||
|
+ </refsect1>
|
||||||
|
+</refentry>
|
||||||
|
--
|
||||||
|
2.25.4
|
||||||
|
|
@ -2,7 +2,7 @@
|
|||||||
|
|
||||||
Name: dleyna-renderer
|
Name: dleyna-renderer
|
||||||
Version: 0.6.0
|
Version: 0.6.0
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
Summary: Service for interacting with Digital Media Renderers
|
Summary: Service for interacting with Digital Media Renderers
|
||||||
|
|
||||||
License: LGPLv2
|
License: LGPLv2
|
||||||
@ -12,9 +12,14 @@ Source0: https://01.org/sites/default/files/downloads/dleyna/%{name}-%{ve
|
|||||||
# https://bugzilla.gnome.org/show_bug.cgi?id=741257
|
# https://bugzilla.gnome.org/show_bug.cgi?id=741257
|
||||||
Patch0: 0001-UPnP-Disconnect-signal-handlers-during-destruction.patch
|
Patch0: 0001-UPnP-Disconnect-signal-handlers-during-destruction.patch
|
||||||
|
|
||||||
|
# https://bugzilla.redhat.com/show_bug.cgi?id=1612579
|
||||||
|
Patch1: 0001-Add-a-manual.patch
|
||||||
|
|
||||||
BuildRequires: autoconf
|
BuildRequires: autoconf
|
||||||
BuildRequires: automake
|
BuildRequires: automake
|
||||||
|
BuildRequires: docbook-style-xsl
|
||||||
BuildRequires: libtool
|
BuildRequires: libtool
|
||||||
|
BuildRequires: libxslt
|
||||||
BuildRequires: pkgconfig
|
BuildRequires: pkgconfig
|
||||||
BuildRequires: pkgconfig(dleyna-core-1.0)
|
BuildRequires: pkgconfig(dleyna-core-1.0)
|
||||||
BuildRequires: pkgconfig(gio-2.0)
|
BuildRequires: pkgconfig(gio-2.0)
|
||||||
@ -44,6 +49,7 @@ developing applications that use %{name}.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1
|
%patch0 -p1
|
||||||
|
%patch1 -p1
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -74,6 +80,8 @@ rm -f $RPM_BUILD_ROOT/%{_libdir}/%{name}/libdleyna-renderer-%{api}.so
|
|||||||
%doc ChangeLog
|
%doc ChangeLog
|
||||||
%doc README
|
%doc README
|
||||||
%{_datadir}/dbus-1/services/com.intel.%{name}.service
|
%{_datadir}/dbus-1/services/com.intel.%{name}.service
|
||||||
|
%{_datadir}/man/man5/%{name}-service.conf.5*
|
||||||
|
|
||||||
|
|
||||||
%dir %{_libdir}/%{name}
|
%dir %{_libdir}/%{name}
|
||||||
%{_libdir}/%{name}/libdleyna-renderer-%{api}.so.*
|
%{_libdir}/%{name}/libdleyna-renderer-%{api}.so.*
|
||||||
@ -86,6 +94,10 @@ rm -f $RPM_BUILD_ROOT/%{_libdir}/%{name}/libdleyna-renderer-%{api}.so
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Aug 23 2020 Debarshi Ray <rishi@fedoraproject.org> - 0.6.0-3
|
||||||
|
- Add a manual
|
||||||
|
Resolves: #1612579
|
||||||
|
|
||||||
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.0-2
|
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.0-2
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user