diff --git a/.gitignore b/.gitignore
index 18c5d72..72f4318 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1 +1,3 @@
/3.2.1.tar.gz
+/3.3.2.tar.gz
+/disruptor-3.3.2.pom
diff --git a/disruptor-3.2.1.pom b/disruptor-3.2.1.pom
deleted file mode 100644
index 00924bb..0000000
--- a/disruptor-3.2.1.pom
+++ /dev/null
@@ -1,49 +0,0 @@
-
-
- 4.0.0
- com.lmax
- disruptor
- 3.2.1
- Disruptor Framework
- Disruptor - Concurrent Programming Framework
- http://lmax-exchange.github.com/disruptor
-
-
- The Apache Software License, Version 2.0
- http://www.apache.org/licenses/LICENSE-2.0.txt
- repo
-
-
-
-
- team
- LMAX Disruptor Development Team
- lmax-disruptor@googlegroups.com
-
-
-
- scm:git@github.com:LMAX-Exchange/disruptor.git
- scm:git@github.com:LMAX-Exchange/disruptor.git
-
-
-
- org.jmock
- jmock-junit4
- 2.5.1
- test
-
-
- org.jmock
- jmock-legacy
- 2.5.1
- test
-
-
- junit
- junit
- 4.5
- test
-
-
-
diff --git a/disruptor.spec b/disruptor.spec
index 27cc574..480694c 100644
--- a/disruptor.spec
+++ b/disruptor.spec
@@ -1,14 +1,15 @@
Name: disruptor
-Version: 3.2.1
-Release: 3%{?dist}
+Version: 3.3.2
+Release: 1%{?dist}
Summary: Concurrent Programming Framework
License: ASL 2.0
URL: http://lmax-exchange.github.io/disruptor/
Source0: https://github.com/LMAX-Exchange/disruptor/archive/%{version}.tar.gz
Source1: http://repo1.maven.org/maven2/com/lmax/%{name}/%{version}/%{name}-%{version}.pom
-# test deps
+BuildRequires: maven-local
BuildRequires: mvn(junit:junit)
+BuildRequires: mvn(org.apache.felix:maven-bundle-plugin)
BuildRequires: mvn(org.jmock:jmock-junit4)
BuildRequires: mvn(org.jmock:jmock-legacy)
@@ -18,10 +19,6 @@ BuildRequires: mvn(org.jmock:jmock-legacy)
BuildRequires: mvn(com.google.caliper:caliper:0.5-rc1)
%endif
-# NOTE: the project is buildable with gradle by default
-BuildRequires: maven-local
-BuildRequires: maven-plugin-bundle
-
BuildArch: noarch
%description
@@ -35,53 +32,40 @@ This package contains javadoc for %{name}.
%prep
%setup -q
-
+# Cleanup
find . -name "*.class" -print -delete
find . -name "*.jar" -type f -print -delete
cp -p %{SOURCE1} pom.xml
-%pom_xpath_inject "pom:project" "
-
-"
-
-%pom_xpath_inject "pom:project/pom:build" '
-
-
- org.apache.felix
- maven-bundle-plugin
- any
- true
-
-
- %{url}
- ${project.name}
- LMAX Disruptor Development Team
-
-
-
-
- bundle-manifest
- process-classes
-
- manifest
-
-
-
-
-'
-%pom_add_plugin org.apache.maven.plugins:maven-jar-plugin . '
+# Add OSGi support
+%pom_xpath_inject "pom:project" "bundle"
+%pom_add_plugin org.apache.felix:maven-bundle-plugin:2.3.7 . '
+true
-
- ${project.build.outputDirectory}/META-INF/MANIFEST.MF
-
-'
+
+ %{url}
+ ${project.name}
+ LMAX Disruptor Development Team
+
+
+
+
+ bundle-manifest
+ process-classes
+
+ manifest
+
+
+'
# fail to compile cause: incompatible hamcrest apis
rm -r src/test/java/com/lmax/disruptor/RingBufferTest.java \
src/test/java/com/lmax/disruptor/RingBufferEventMatcher.java
# Failed to stop thread: Thread[com.lmax.disruptor.BatchEventProcessor@1d057a39,5,main]
rm -r src/test/java/com/lmax/disruptor/dsl/DisruptorTest.java
+# Test fails due to incompatible jmock version
+rm -f src/test/java/com/lmax/disruptor/EventPollerTest.java
%mvn_file :%{name} %{name}
@@ -100,6 +84,9 @@ rm -r src/test/java/com/lmax/disruptor/dsl/DisruptorTest.java
%license LICENCE.txt
%changelog
+* Wed Jun 3 2015 Mikolaj Izdebski - 3.3.2-1
+- Update to upstream version 3.3.2
+
* Sun Feb 01 2015 gil cattaneo 3.2.1-3
- introduce license macro
diff --git a/sources b/sources
index 6e4a11f..b8915c3 100644
--- a/sources
+++ b/sources
@@ -1 +1,2 @@
-ad9f2b4e790a570c453f867892d6cc0d 3.2.1.tar.gz
+19d62995cf09f719987f8287448cd50c 3.3.2.tar.gz
+124366e0513f62b948ba8b364a5c14e5 disruptor-3.3.2.pom