diff --git a/.gitignore b/.gitignore
index e69de29..18c5d72 100644
--- a/.gitignore
+++ b/.gitignore
@@ -0,0 +1 @@
+/3.2.1.tar.gz
diff --git a/disruptor-3.2.1.pom b/disruptor-3.2.1.pom
new file mode 100644
index 0000000..00924bb
--- /dev/null
+++ b/disruptor-3.2.1.pom
@@ -0,0 +1,49 @@
+
+
+ 4.0.0
+ com.lmax
+ disruptor
+ 3.2.1
+ Disruptor Framework
+ Disruptor - Concurrent Programming Framework
+ http://lmax-exchange.github.com/disruptor
+
+
+ The Apache Software License, Version 2.0
+ http://www.apache.org/licenses/LICENSE-2.0.txt
+ repo
+
+
+
+
+ team
+ LMAX Disruptor Development Team
+ lmax-disruptor@googlegroups.com
+
+
+
+ scm:git@github.com:LMAX-Exchange/disruptor.git
+ scm:git@github.com:LMAX-Exchange/disruptor.git
+
+
+
+ org.jmock
+ jmock-junit4
+ 2.5.1
+ test
+
+
+ org.jmock
+ jmock-legacy
+ 2.5.1
+ test
+
+
+ junit
+ junit
+ 4.5
+ test
+
+
+
diff --git a/disruptor.spec b/disruptor.spec
new file mode 100644
index 0000000..e697452
--- /dev/null
+++ b/disruptor.spec
@@ -0,0 +1,106 @@
+Name: disruptor
+Version: 3.2.1
+Release: 1%{?dist}
+Summary: Concurrent Programming Framework
+License: ASL 2.0
+URL: http://lmax-exchange.github.io/disruptor/
+Source0: https://github.com/LMAX-Exchange/disruptor/archive/%{version}.tar.gz
+Source1: http://repo1.maven.org/maven2/com/lmax/%{name}/%{version}/%{name}-%{version}.pom
+
+BuildRequires: java-devel
+
+# test deps
+BuildRequires: mvn(junit:junit)
+BuildRequires: mvn(org.jmock:jmock-junit4)
+BuildRequires: mvn(org.jmock:jmock-legacy)
+
+%if 0
+# Unavailable performance test deps
+# lib/test/hdrhistogram-1.0-SNAPSHOT.jar
+BuildRequires: mvn(com.google.caliper:caliper:0.5-rc1)
+%endif
+
+# NOTE: the project is buildable with gradle by default
+BuildRequires: maven-local
+BuildRequires: maven-plugin-bundle
+BuildRequires: maven-surefire-provider-junit4
+
+BuildArch: noarch
+
+%description
+A High Performance Inter-Thread Messaging Library.
+
+%package javadoc
+Summary: Javadoc for %{name}
+
+%description javadoc
+This package contains javadoc for %{name}.
+
+%prep
+%setup -q
+
+find . -name "*.class" -print -delete
+find . -name "*.jar" -type f -print -delete
+
+cp -p %{SOURCE1} pom.xml
+%pom_xpath_inject "pom:project" "
+
+
+"
+
+%pom_xpath_inject "pom:project/pom:build" '
+
+
+ org.apache.felix
+ maven-bundle-plugin
+ any
+ true
+
+
+ %{url}
+ ${project.name}
+ LMAX Disruptor Development Team
+
+
+
+
+ bundle-manifest
+ process-classes
+
+ manifest
+
+
+
+
+'
+%pom_add_plugin org.apache.maven.plugins:maven-jar-plugin . '
+
+
+ ${project.build.outputDirectory}/META-INF/MANIFEST.MF
+
+'
+
+# fail to compile cause: incompatible hamcrest apis
+rm -r src/test/java/com/lmax/disruptor/RingBufferTest.java \
+ src/test/java/com/lmax/disruptor/RingBufferEventMatcher.java
+
+%build
+
+%mvn_file :%{name} %{name}
+%mvn_build -- -Dproject.build.sourceEncoding=UTF-8
+
+%install
+%mvn_install
+
+%files -f .mfiles
+%doc LICENCE.txt README.md
+
+%files javadoc -f .mfiles-javadoc
+%doc LICENCE.txt
+
+%changelog
+* Mon Apr 21 2014 gil cattaneo 3.2.1-1
+- update to 3.2.1
+
+* Wed Aug 14 2013 gil cattaneo 3.2.0-1
+- initial rpm
diff --git a/sources b/sources
index e69de29..6e4a11f 100644
--- a/sources
+++ b/sources
@@ -0,0 +1 @@
+ad9f2b4e790a570c453f867892d6cc0d 3.2.1.tar.gz