Import rpm: 12e5d262fc3450cb1d485469469991652a79c357
This commit is contained in:
commit
28a9ba0617
1
.fmf/version
Normal file
1
.fmf/version
Normal file
@ -0,0 +1 @@
|
||||
1
|
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/disruptor-3.4.4.tar.gz
|
21
disruptor-3.3.2-jmock.patch
Normal file
21
disruptor-3.3.2-jmock.patch
Normal file
@ -0,0 +1,21 @@
|
||||
--- disruptor-3.3.2/src/test/java/com/lmax/disruptor/BatchEventProcessorTest.java 2015-02-25 10:09:57.000000000 +0100
|
||||
+++ disruptor-3.3.2/src/test/java/com/lmax/disruptor/BatchEventProcessorTest.java.jmock 2015-06-03 15:52:43.997446568 +0200
|
||||
@@ -23,6 +23,7 @@
|
||||
import org.jmock.api.Action;
|
||||
import org.jmock.api.Invocation;
|
||||
import org.jmock.integration.junit4.JMock;
|
||||
+import org.jmock.lib.concurrent.Synchroniser;
|
||||
import org.junit.Test;
|
||||
import org.junit.runner.RunWith;
|
||||
|
||||
@@ -35,7 +36,9 @@
|
||||
@RunWith(JMock.class)
|
||||
public final class BatchEventProcessorTest
|
||||
{
|
||||
- private final Mockery context = new Mockery();
|
||||
+ private final Mockery context = new Mockery() {{
|
||||
+ setThreadingPolicy(new Synchroniser());
|
||||
+ }};
|
||||
private final Sequence lifecycleSequence = context.sequence("lifecycleSequence");
|
||||
private final CountDownLatch latch = new CountDownLatch(1);
|
||||
|
37
disruptor-3.4.4.pom
Normal file
37
disruptor-3.4.4.pom
Normal file
@ -0,0 +1,37 @@
|
||||
<?xml version="1.0" encoding="UTF-8"?>
|
||||
<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
|
||||
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
|
||||
<modelVersion>4.0.0</modelVersion>
|
||||
<groupId>com.lmax</groupId>
|
||||
<artifactId>disruptor</artifactId>
|
||||
<version>3.4.4</version>
|
||||
<name>Disruptor Framework</name>
|
||||
<description>Disruptor - Concurrent Programming Framework</description>
|
||||
<url>http://lmax-exchange.github.com/disruptor</url>
|
||||
<licenses>
|
||||
<license>
|
||||
<name>The Apache Software License, Version 2.0</name>
|
||||
<url>http://www.apache.org/licenses/LICENSE-2.0.txt</url>
|
||||
<distribution>repo</distribution>
|
||||
</license>
|
||||
</licenses>
|
||||
<developers>
|
||||
<developer>
|
||||
<id>team</id>
|
||||
<name>LMAX Disruptor Development Team</name>
|
||||
<email>lmax-disruptor@googlegroups.com</email>
|
||||
</developer>
|
||||
</developers>
|
||||
<scm>
|
||||
<connection>scm:git@github.com:LMAX-Exchange/disruptor.git</connection>
|
||||
<url>scm:git@github.com:LMAX-Exchange/disruptor.git</url>
|
||||
</scm>
|
||||
<dependencies>
|
||||
<dependency>
|
||||
<groupId>junit</groupId>
|
||||
<artifactId>junit</artifactId>
|
||||
<version>4.12</version>
|
||||
<scope>test</scope>
|
||||
</dependency>
|
||||
</dependencies>
|
||||
</project>
|
152
disruptor.spec
Normal file
152
disruptor.spec
Normal file
@ -0,0 +1,152 @@
|
||||
Name: disruptor
|
||||
Version: 3.4.4
|
||||
Release: 2%{?dist}
|
||||
Summary: Concurrent Programming Framework
|
||||
License: ASL 2.0
|
||||
URL: https://lmax-exchange.github.io/disruptor/
|
||||
BuildArch: noarch
|
||||
|
||||
Source0: https://github.com/LMAX-Exchange/disruptor/archive/%{version}/%{name}-%{version}.tar.gz
|
||||
Source1: https://repo1.maven.org/maven2/com/lmax/%{name}/%{version}/%{name}-%{version}.pom
|
||||
|
||||
BuildRequires: maven-local-openjdk8
|
||||
BuildRequires: mvn(junit:junit)
|
||||
BuildRequires: mvn(org.apache.felix:maven-bundle-plugin)
|
||||
|
||||
%description
|
||||
A High Performance Inter-Thread Messaging Library.
|
||||
|
||||
%package javadoc
|
||||
Summary: Javadoc for %{name}
|
||||
|
||||
%description javadoc
|
||||
This package contains javadoc for %{name}.
|
||||
|
||||
%prep
|
||||
%autosetup
|
||||
# Cleanup
|
||||
find . -name "*.class" -print -delete
|
||||
find . -name "*.jar" -type f -print -delete
|
||||
|
||||
cp -p %{SOURCE1} pom.xml
|
||||
|
||||
# Add OSGi support
|
||||
%pom_xpath_inject "pom:project" "<packaging>bundle</packaging>"
|
||||
%pom_add_plugin org.apache.felix:maven-bundle-plugin:2.3.7 . '
|
||||
<extensions>true</extensions>
|
||||
<configuration>
|
||||
<instructions>
|
||||
<Bundle-DocURL>%{url}</Bundle-DocURL>
|
||||
<Bundle-Name>${project.name}</Bundle-Name>
|
||||
<Bundle-Vendor>LMAX Disruptor Development Team</Bundle-Vendor>
|
||||
</instructions>
|
||||
</configuration>
|
||||
<executions>
|
||||
<execution>
|
||||
<id>bundle-manifest</id>
|
||||
<phase>process-classes</phase>
|
||||
<goals>
|
||||
<goal>manifest</goal>
|
||||
</goals>
|
||||
</execution>
|
||||
</executions>'
|
||||
|
||||
# fail to compile cause: incompatible hamcrest apis
|
||||
rm -r src/test/java/com/lmax/disruptor/RingBufferTest.java \
|
||||
src/test/java/com/lmax/disruptor/RingBufferEventMatcher.java
|
||||
# Failed to stop thread: Thread[com.lmax.disruptor.BatchEventProcessor@1d057a39,5,main]
|
||||
rm -r src/test/java/com/lmax/disruptor/dsl/DisruptorTest.java
|
||||
# Test fails due to incompatible jmock version
|
||||
#rm -f src/test/java/com/lmax/disruptor/EventPollerTest.java
|
||||
|
||||
%mvn_file :%{name} %{name}
|
||||
|
||||
%build
|
||||
|
||||
%mvn_build -- -Dproject.build.sourceEncoding=UTF-8 -Dmaven.compiler.source=1.8 -Dmaven.compiler.target=1.8
|
||||
|
||||
%install
|
||||
%mvn_install
|
||||
|
||||
%files -f .mfiles
|
||||
%doc README.md
|
||||
%license LICENCE.txt
|
||||
|
||||
%files javadoc -f .mfiles-javadoc
|
||||
%license LICENCE.txt
|
||||
|
||||
%changelog
|
||||
* Wed Feb 23 2022 Mikolaj Izdebski <mizdebsk@redhat.com> - 3.4.4-2
|
||||
- Build with OpenJDK 8
|
||||
|
||||
* Mon Dec 13 2021 Sérgio Basto <sergio@serjux.com> - 3.4.4-1
|
||||
- Update disruptor to 3.4.4 (#1953941)
|
||||
|
||||
* Wed Jul 21 2021 Fedora Release Engineering <releng@fedoraproject.org> - 3.4.2-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||
|
||||
* Mon Jun 28 2021 Mikolaj Izdebski <mizdebsk@redhat.com> - 3.4.2-5
|
||||
- Remove unneeded buildrequires on jmock and hamcrest
|
||||
|
||||
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 3.4.2-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Mon Jul 27 2020 Fedora Release Engineering <releng@fedoraproject.org> - 3.4.2-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Fri Jul 10 2020 Jiri Vanek <jvanek@redhat.com> - 3.4.2-2
|
||||
- Rebuilt for JDK-11, see https://fedoraproject.org/wiki/Changes/Java11
|
||||
|
||||
* Tue May 12 2020 Alexander Scheel <ascheel@redhat.com> - 3.4.2-1
|
||||
- Rebase to disruptor upstream release v3.4.2
|
||||
|
||||
* Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 3.3.6-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Wed Jul 24 2019 Fedora Release Engineering <releng@fedoraproject.org> - 3.3.6-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 3.3.6-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Thu Jul 12 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.3.6-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.3.6-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.3.6-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.3.6-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Fri Nov 11 2016 gil cattaneo <puntogil@libero.it> 3.3.6-1
|
||||
- update to 3.3.6
|
||||
|
||||
* Thu Jun 23 2016 gil cattaneo <puntogil@libero.it> 3.3.4-1
|
||||
- update to 3.3.4
|
||||
|
||||
* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 3.3.2-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.3.2-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Wed Jun 03 2015 gil cattaneo <puntogil@libero.it> 3.3.2-2
|
||||
- build fix for jmock 2.8.1
|
||||
|
||||
* Wed Jun 3 2015 Mikolaj Izdebski <mizdebsk@redhat.com> - 3.3.2-1
|
||||
- Update to upstream version 3.3.2
|
||||
|
||||
* Sun Feb 01 2015 gil cattaneo <puntogil@libero.it> 3.2.1-3
|
||||
- introduce license macro
|
||||
|
||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Mon Apr 21 2014 gil cattaneo <puntogil@libero.it> 3.2.1-1
|
||||
- update to 3.2.1
|
||||
|
||||
* Wed Aug 14 2013 gil cattaneo <puntogil@libero.it> 3.2.0-1
|
||||
- initial rpm
|
7
gating.yaml
Normal file
7
gating.yaml
Normal file
@ -0,0 +1,7 @@
|
||||
--- !Policy
|
||||
product_versions:
|
||||
- rhel-9
|
||||
decision_contexts:
|
||||
- osci_compose_gate
|
||||
rules:
|
||||
- !PassingTestCaseRule {test_case_name: osci.brew-build.tier0.functional}
|
51
plans/Smoke.java
Normal file
51
plans/Smoke.java
Normal file
@ -0,0 +1,51 @@
|
||||
import com.lmax.disruptor.dsl.Disruptor;
|
||||
import com.lmax.disruptor.EventFactory;
|
||||
import com.lmax.disruptor.RingBuffer;
|
||||
import com.lmax.disruptor.util.DaemonThreadFactory;
|
||||
import java.nio.ByteBuffer;
|
||||
|
||||
class LongEvent
|
||||
{
|
||||
private long value;
|
||||
|
||||
public void set(long value)
|
||||
{
|
||||
this.value = value;
|
||||
}
|
||||
}
|
||||
|
||||
class LongEventFactory implements EventFactory<LongEvent>
|
||||
{
|
||||
public LongEvent newInstance()
|
||||
{
|
||||
return new LongEvent();
|
||||
}
|
||||
}
|
||||
|
||||
public class Smoke
|
||||
{
|
||||
public static void main(String[] args) throws Exception
|
||||
{
|
||||
System.out.println("SMOKE TEST START");
|
||||
|
||||
int bufferSize = 1024;
|
||||
|
||||
Disruptor<LongEvent> disruptor =
|
||||
new Disruptor<>(LongEvent::new, bufferSize, DaemonThreadFactory.INSTANCE);
|
||||
|
||||
disruptor.handleEventsWith((event, sequence, endOfBatch) ->
|
||||
System.out.println("Event: " + event));
|
||||
disruptor.start();
|
||||
|
||||
RingBuffer<LongEvent> ringBuffer = disruptor.getRingBuffer();
|
||||
ByteBuffer bb = ByteBuffer.allocate(8);
|
||||
for (long l = 0; l < 10; l++)
|
||||
{
|
||||
bb.putLong(0, l);
|
||||
ringBuffer.publishEvent((event, sequence, buffer) -> event.set(buffer.getLong(0)), bb);
|
||||
Thread.sleep(100);
|
||||
}
|
||||
|
||||
System.out.println("SMOKE TEST COMPLETE");
|
||||
}
|
||||
}
|
8
plans/smoke.fmf
Normal file
8
plans/smoke.fmf
Normal file
@ -0,0 +1,8 @@
|
||||
summary: Basic smoke test
|
||||
prepare:
|
||||
how: install
|
||||
package: java-1.8.0-openjdk-devel
|
||||
execute:
|
||||
script:
|
||||
- /usr/lib/jvm/java-1.8.0-openjdk/bin/javac -cp /usr/share/java/disruptor.jar plans/Smoke.java
|
||||
- /usr/lib/jvm/java-1.8.0-openjdk/bin/java -cp /usr/share/java/disruptor.jar:plans Smoke
|
Loading…
Reference in New Issue
Block a user