Add a patch to fix INI on 32bits

This commit is contained in:
Jakub Hrozek 2013-03-28 20:36:13 +01:00
parent 4841ae0f08
commit b9a46df048
3 changed files with 31 additions and 28 deletions

View File

@ -1,27 +0,0 @@
From 41a7811b2a4e07a30701508bbbb4b16d4ce1e0ba Mon Sep 17 00:00:00 2001
From: Jakub Hrozek <jhrozek@redhat.com>
Date: Mon, 25 Mar 2013 11:03:19 +0100
Subject: [PATCH] Include AM_PROG_AR in configure.ac to get rid of warnings
---
configure.ac | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/configure.ac b/configure.ac
index 2e22e8a6aaac271dfa4841c17f98411967e09fd9..8f0f1244ecaa627c1d1543407344e5c31b3eeb6b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5,7 +5,9 @@ AC_INIT([ding-libs],
AC_CONFIG_SRCDIR([README])
AC_CONFIG_AUX_DIR([build])
AM_INIT_AUTOMAKE([-Wall -Werror foreign])
-AC_PROG_CC
+AM_PROG_CC_C_O
+m4_pattern_allow([AM_PROG_AR])
+AM_PROG_AR
AC_PROG_LIBTOOL
AC_CONFIG_MACRO_DIR([m4])
AC_PROG_INSTALL
--
1.8.1.4

View File

@ -0,0 +1,25 @@
From 04130842ae8fb7952e5055dfe8769d6ecf47aafa Mon Sep 17 00:00:00 2001
From: Jakub Hrozek <jhrozek@redhat.com>
Date: Thu, 28 Mar 2013 15:09:29 -0400
Subject: [PATCH] Remove spurious cast
---
ini/ini_get_valueobj.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/ini/ini_get_valueobj.c b/ini/ini_get_valueobj.c
index a7efe95bee97702905e2b17dbd85ad29d815a6e4..dad99329aa4b518772f23a14b919445a1dd3c00e 100644
--- a/ini/ini_get_valueobj.c
+++ b/ini/ini_get_valueobj.c
@@ -224,7 +224,7 @@ int ini_get_config_valueobj(const char *section,
return EOK;
}
- if ((hash == (unsigned long int)col_get_item_hash(item)) &&
+ if ((hash == col_get_item_hash(item)) &&
(strncasecmp(col_get_item_property(item, &len), name, name_len) == 0) &&
(len == name_len)) {
TRACE_INFO_STRING("Item is found", name);
--
1.8.0

View File

@ -1,6 +1,6 @@
Name: ding-libs
Version: 0.3.0
Release: 1%{?dist}
Release: 2%{?dist}
Summary: "Ding is not GLib" assorted utility libraries
Group: Development/Libraries
License: LGPLv3+
@ -16,6 +16,7 @@ BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
%global ini_config_version 1.0.0
### Patches ###
Patch0001: 0001-Remove-spurious-cast.patch
### Dependencies ###
# ding-libs is a meta-package that will pull in all of its own
@ -315,6 +316,7 @@ structure
%prep
%setup -q
%patch0001 -p1 -b .cast
%build
autoreconf -ivf
@ -349,6 +351,9 @@ rm -f */doc/html/installdox
rm -rf $RPM_BUILD_ROOT
%changelog
* Thu Mar 28 2013 Jakub Hrozek <jhrozek@redhat.com> - 0.3.0-2
- Remove cast to allow INI to work on 32bits
* Thu Mar 28 2013 Jakub Hrozek <jhrozek@redhat.com> - 0.3.0-1
- New upstream release 0.3.0
- https://fedorahosted.org/sssd/wiki/Releases/DingNotes-0.3.0