update to 1.1-20110707
This commit is contained in:
parent
e1daeceff6
commit
2235d82fcd
1
.gitignore
vendored
1
.gitignore
vendored
@ -1 +1,2 @@
|
|||||||
dialog-1.1-20100428.tgz
|
dialog-1.1-20100428.tgz
|
||||||
|
/dialog-1.1-20110707.tgz
|
||||||
|
@ -1,23 +0,0 @@
|
|||||||
--- dialog-1.1-20070227/dialog-config.in.incdir 2007-02-28 11:58:55.000000000 +0100
|
|
||||||
+++ dialog-1.1-20070227/dialog-config.in 2007-02-28 12:01:32.000000000 +0100
|
|
||||||
@@ -35,7 +35,7 @@
|
|
||||||
libdir="@libdir@"
|
|
||||||
datadir="@datadir@"
|
|
||||||
mandir="@mandir@"
|
|
||||||
-
|
|
||||||
+includedir="@includedir@"
|
|
||||||
THIS="dialog"
|
|
||||||
|
|
||||||
test $# = 0 && exec @SHELL@ $0 --error
|
|
||||||
@@ -67,10 +67,7 @@
|
|
||||||
;;
|
|
||||||
# compile/link
|
|
||||||
--cflags)
|
|
||||||
- INCS=
|
|
||||||
- if test "${prefix}/include" != /usr/include ; then
|
|
||||||
- INCS="-I${prefix}/include"
|
|
||||||
- fi
|
|
||||||
+ INCS="-I$includedir"
|
|
||||||
sed -e 's,^[ ]*,,' -e 's, [ ]*, ,g' -e 's,[ ]*$,,' <<-ENDECHO
|
|
||||||
$INCS
|
|
||||||
ENDECHO
|
|
@ -1,17 +0,0 @@
|
|||||||
diff -up dialog-1.1-20071028/makefile.in.libs dialog-1.1-20071028/makefile.in
|
|
||||||
--- dialog-1.1-20071028/makefile.in.libs 2007-07-04 21:33:35.000000000 +0200
|
|
||||||
+++ dialog-1.1-20071028/makefile.in 2007-10-30 17:17:46.000000000 +0100
|
|
||||||
@@ -122,11 +122,11 @@ dialog$o \
|
|
||||||
$(OBJECTS) : $(srcdir)/dialog.h $(srcdir)/dlg_keys.h dlg_config.h VERSION
|
|
||||||
|
|
||||||
$(LIB) : $(LIB_OBJECT)
|
|
||||||
- $(LIBTOOL_CREATE) $(LIB) $(LIB_OBJECT)
|
|
||||||
+ $(LIBTOOL_CREATE) $(LIB) $(LIB_OBJECT) $(LIBS)
|
|
||||||
$(RANLIB) $@
|
|
||||||
|
|
||||||
dialog$x : $(LIB) dialog$o @INTLDIR_MAKE@ @INTLLIBS@
|
|
||||||
- $(LINK) -o $@ dialog$o -L. -ldialog $(LDFLAGS) $(LIBS)
|
|
||||||
+ $(LINK) -o $@ dialog$o -L. -ldialog $(LDFLAGS)
|
|
||||||
|
|
||||||
clean \
|
|
||||||
distclean \
|
|
@ -1,32 +0,0 @@
|
|||||||
diff -up dialog-1.1-20071028/dialog-config.in.multilib dialog-1.1-20071028/dialog-config.in
|
|
||||||
--- dialog-1.1-20071028/dialog-config.in.multilib 2007-11-05 11:50:35.000000000 +0100
|
|
||||||
+++ dialog-1.1-20071028/dialog-config.in 2007-11-05 11:50:35.000000000 +0100
|
|
||||||
@@ -32,7 +32,7 @@ prefix="@prefix@"
|
|
||||||
exec_prefix="@exec_prefix@"
|
|
||||||
|
|
||||||
bindir="@bindir@"
|
|
||||||
-libdir="@libdir@"
|
|
||||||
+libdir=
|
|
||||||
datadir="@datadir@"
|
|
||||||
mandir="@mandir@"
|
|
||||||
includedir="@includedir@"
|
|
||||||
@@ -74,7 +74,7 @@ ENDECHO
|
|
||||||
;;
|
|
||||||
--libs)
|
|
||||||
sed -e 's,^[ ]*,,' -e 's, [ ]*, ,g' -e 's,[ ]*$,,' <<-ENDECHO
|
|
||||||
- -L${exec_prefix}/lib -l${THIS} @LIBS@
|
|
||||||
+ -l${THIS}
|
|
||||||
ENDECHO
|
|
||||||
;;
|
|
||||||
# identification
|
|
||||||
diff -up dialog-1.1-20071028/headers-sh.in.multilib dialog-1.1-20071028/headers-sh.in
|
|
||||||
--- dialog-1.1-20071028/headers-sh.in.multilib 2007-07-05 02:20:18.000000000 +0200
|
|
||||||
+++ dialog-1.1-20071028/headers-sh.in 2007-11-05 12:28:24.000000000 +0100
|
|
||||||
@@ -118,6 +118,7 @@ EOF
|
|
||||||
echo "s/\\<$name\\>/${PKGNAME}_$name/g" >>$TMPSED
|
|
||||||
done
|
|
||||||
|
|
||||||
+ echo '/_FILE_OFFSET_BITS/d' >>$TMPSED
|
|
||||||
# reduce the count if possible, since some old sed's limit is 100 lines
|
|
||||||
sort -u $TMPSED >headers.tmp
|
|
||||||
mv headers.tmp $TMPSED
|
|
23
dialog-incdir.patch
Normal file
23
dialog-incdir.patch
Normal file
@ -0,0 +1,23 @@
|
|||||||
|
diff -up dialog-1.1-20110707/dialog-config.in.incdir dialog-1.1-20110707/dialog-config.in
|
||||||
|
--- dialog-1.1-20110707/dialog-config.in.incdir 2011-01-06 10:38:03.000000000 +0100
|
||||||
|
+++ dialog-1.1-20110707/dialog-config.in 2011-07-26 13:00:02.692038027 +0200
|
||||||
|
@@ -35,6 +35,7 @@ bindir="@bindir@"
|
||||||
|
libdir="@libdir@"
|
||||||
|
datadir="@datadir@"
|
||||||
|
mandir="@mandir@"
|
||||||
|
+includedir="@includedir@"
|
||||||
|
|
||||||
|
THIS="@PACKAGE@"
|
||||||
|
|
||||||
|
@@ -67,10 +68,7 @@ while test $# -gt 0; do
|
||||||
|
;;
|
||||||
|
# compile/link
|
||||||
|
--cflags)
|
||||||
|
- INCS=
|
||||||
|
- if test "${prefix}/include" != /usr/include ; then
|
||||||
|
- INCS="-I${prefix}/include"
|
||||||
|
- fi
|
||||||
|
+ INCS="-I$includedir"
|
||||||
|
sed -e 's,^[ ]*,,' -e 's, [ ]*, ,g' -e 's,[ ]*$,,' <<-ENDECHO
|
||||||
|
$INCS
|
||||||
|
ENDECHO
|
17
dialog-libs.patch
Normal file
17
dialog-libs.patch
Normal file
@ -0,0 +1,17 @@
|
|||||||
|
diff -up dialog-1.1-20110707/makefile.in.libs dialog-1.1-20110707/makefile.in
|
||||||
|
--- dialog-1.1-20110707/makefile.in.libs 2011-06-25 02:27:56.000000000 +0200
|
||||||
|
+++ dialog-1.1-20110707/makefile.in 2011-07-26 13:04:50.389183890 +0200
|
||||||
|
@@ -176,11 +176,11 @@ dialog$o \
|
||||||
|
$(OBJECTS) : $(srcdir)/dialog.h $(srcdir)/dlg_keys.h dlg_config.h VERSION
|
||||||
|
|
||||||
|
$(LIB) : $(LIB_OBJECT)
|
||||||
|
- $(LIBTOOL_CREATE) $(LIB) $(LIB_OBJECT)
|
||||||
|
+ $(LIBTOOL_CREATE) $(LIB) $(LIB_OBJECT) $(LIBS)
|
||||||
|
$(RANLIB) $@
|
||||||
|
|
||||||
|
dialog$x : $(LIB) dialog$o @INTLDIR_MAKE@ @INTLLIBS@
|
||||||
|
- $(LINK) -o $@ dialog$o -L. -l@PACKAGE@ $(LDFLAGS) $(LIBS)
|
||||||
|
+ $(LINK) -o $@ dialog$o -L. -l@PACKAGE@ $(LDFLAGS)
|
||||||
|
|
||||||
|
clean \
|
||||||
|
distclean \
|
32
dialog-multilib.patch
Normal file
32
dialog-multilib.patch
Normal file
@ -0,0 +1,32 @@
|
|||||||
|
diff -up dialog-1.1-20110707/dialog-config.in.multilib dialog-1.1-20110707/dialog-config.in
|
||||||
|
--- dialog-1.1-20110707/dialog-config.in.multilib 2011-07-26 13:01:29.929082616 +0200
|
||||||
|
+++ dialog-1.1-20110707/dialog-config.in 2011-07-26 13:01:29.932082618 +0200
|
||||||
|
@@ -32,7 +32,7 @@ prefix="@prefix@"
|
||||||
|
exec_prefix="@exec_prefix@"
|
||||||
|
|
||||||
|
bindir="@bindir@"
|
||||||
|
-libdir="@libdir@"
|
||||||
|
+libdir=
|
||||||
|
datadir="@datadir@"
|
||||||
|
mandir="@mandir@"
|
||||||
|
includedir="@includedir@"
|
||||||
|
@@ -75,7 +75,7 @@ ENDECHO
|
||||||
|
;;
|
||||||
|
--libs)
|
||||||
|
sed -e 's,^[ ]*,,' -e 's, [ ]*, ,g' -e 's,[ ]*$,,' <<-ENDECHO
|
||||||
|
- -L${exec_prefix}/lib -l${THIS} @LIBS@
|
||||||
|
+ -l${THIS}
|
||||||
|
ENDECHO
|
||||||
|
;;
|
||||||
|
# identification
|
||||||
|
diff -up dialog-1.1-20110707/headers-sh.in.multilib dialog-1.1-20110707/headers-sh.in
|
||||||
|
--- dialog-1.1-20110707/headers-sh.in.multilib 2011-01-06 10:38:25.000000000 +0100
|
||||||
|
+++ dialog-1.1-20110707/headers-sh.in 2011-07-26 13:02:44.177120225 +0200
|
||||||
|
@@ -127,6 +127,7 @@ EOF
|
||||||
|
echo "s,#include <${pkgname}_,#include <${PACKAGE}/${pkgname}_," >>$TMPSED
|
||||||
|
fi
|
||||||
|
|
||||||
|
+ echo '/_FILE_OFFSET_BITS/d' >>$TMPSED
|
||||||
|
# reduce the count if possible, since some old sed's limit is 100 lines
|
||||||
|
sort -u $TMPSED >headers.tmp
|
||||||
|
mv headers.tmp $TMPSED
|
13
dialog.spec
13
dialog.spec
@ -1,17 +1,17 @@
|
|||||||
Summary: A utility for creating TTY dialog boxes
|
Summary: A utility for creating TTY dialog boxes
|
||||||
Name: dialog
|
Name: dialog
|
||||||
%define dialogsubversion 20100428
|
%define dialogsubversion 20110707
|
||||||
Version: 1.1
|
Version: 1.1
|
||||||
Release: 12.%{dialogsubversion}%{?dist}
|
Release: 13.%{dialogsubversion}%{?dist}
|
||||||
License: LGPLv2
|
License: LGPLv2
|
||||||
Group: Applications/System
|
Group: Applications/System
|
||||||
URL: http://invisible-island.net/dialog/dialog.html
|
URL: http://invisible-island.net/dialog/dialog.html
|
||||||
Source: ftp://invisible-island.net/dialog/dialog-%{version}-%{dialogsubversion}.tgz
|
Source: ftp://invisible-island.net/dialog/dialog-%{version}-%{dialogsubversion}.tgz
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
BuildRequires: ncurses-devel gettext findutils libtool
|
BuildRequires: ncurses-devel gettext findutils libtool
|
||||||
Patch1: dialog-1.1-20070227-incdir.patch
|
Patch1: dialog-incdir.patch
|
||||||
Patch2: dialog-1.1-20071028-multilib.patch
|
Patch2: dialog-multilib.patch
|
||||||
Patch3: dialog-1.1-20071028-libs.patch
|
Patch3: dialog-libs.patch
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Dialog is a utility that allows you to show dialog boxes (containing
|
Dialog is a utility that allows you to show dialog boxes (containing
|
||||||
@ -86,6 +86,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_mandir}/man3/dialog.*
|
%{_mandir}/man3/dialog.*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jul 26 2011 Miroslav Lichvar <mlichvar@redhat.com> - 1.1-13.20110707
|
||||||
|
- update to 1.1-20110707
|
||||||
|
|
||||||
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1-12.20100428
|
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1-12.20100428
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user