4bf24c8243
- Had to rename the -T option to -timeout as ISC is now using -T - Allow package rebuilders to easily enable DHCPv6 support with: rpmbuild --with DHCPv6 dhcp.spec Note that Fedora is still using the 'dhcpv6' package, but some users may want to experiment with the ISC DHCPv6 implementation locally.
35 lines
1.2 KiB
Diff
35 lines
1.2 KiB
Diff
diff -up dhcp-4.1.0/client/clparse.c.requested dhcp-4.1.0/client/clparse.c
|
|
--- dhcp-4.1.0/client/clparse.c.requested 2009-01-06 10:40:46.000000000 -1000
|
|
+++ dhcp-4.1.0/client/clparse.c 2009-01-06 10:40:47.000000000 -1000
|
|
@@ -37,7 +37,7 @@
|
|
|
|
struct client_config top_level_config;
|
|
|
|
-#define NUM_DEFAULT_REQUESTED_OPTS 9
|
|
+#define NUM_DEFAULT_REQUESTED_OPTS 12
|
|
struct option *default_requested_options[NUM_DEFAULT_REQUESTED_OPTS + 1];
|
|
|
|
static void parse_client_default_duid(struct parse *cfile);
|
|
@@ -111,6 +111,21 @@ isc_result_t read_client_conf ()
|
|
option_code_hash_lookup(&default_requested_options[8],
|
|
dhcpv6_universe.code_hash, &code, 0, MDL);
|
|
|
|
+ /* 10 */
|
|
+ code = DHO_NIS_DOMAIN;
|
|
+ option_code_hash_lookup(&default_requested_options[9],
|
|
+ dhcp_universe.code_hash, &code, 0, MDL);
|
|
+
|
|
+ /* 11 */
|
|
+ code = DHO_NIS_SERVERS;
|
|
+ option_code_hash_lookup(&default_requested_options[10],
|
|
+ dhcp_universe.code_hash, &code, 0, MDL);
|
|
+
|
|
+ /* 12 */
|
|
+ code = DHO_NTP_SERVERS;
|
|
+ option_code_hash_lookup(&default_requested_options[11],
|
|
+ dhcp_universe.code_hash, &code, 0, MDL);
|
|
+
|
|
for (code = 0 ; code < NUM_DEFAULT_REQUESTED_OPTS ; code++) {
|
|
if (default_requested_options[code] == NULL)
|
|
log_fatal("Unable to find option definition for "
|