4bf24c8243
- Had to rename the -T option to -timeout as ISC is now using -T - Allow package rebuilders to easily enable DHCPv6 support with: rpmbuild --with DHCPv6 dhcp.spec Note that Fedora is still using the 'dhcpv6' package, but some users may want to experiment with the ISC DHCPv6 implementation locally.
46 lines
1.4 KiB
Diff
46 lines
1.4 KiB
Diff
diff -up dhcp-4.1.0/includes/dhcpd.h.paths dhcp-4.1.0/includes/dhcpd.h
|
|
--- dhcp-4.1.0/includes/dhcpd.h.paths 2009-01-06 11:52:57.000000000 -1000
|
|
+++ dhcp-4.1.0/includes/dhcpd.h 2009-01-06 11:52:57.000000000 -1000
|
|
@@ -1340,15 +1340,15 @@ typedef unsigned char option_mask [16];
|
|
#else /* !DEBUG */
|
|
|
|
#ifndef _PATH_DHCPD_CONF
|
|
-#define _PATH_DHCPD_CONF "/etc/dhcpd.conf"
|
|
+#define _PATH_DHCPD_CONF "/etc/dhcp/dhcpd.conf"
|
|
#endif /* DEBUG */
|
|
|
|
#ifndef _PATH_DHCPD_DB
|
|
-#define _PATH_DHCPD_DB LOCALSTATEDIR"/db/dhcpd.leases"
|
|
+#define _PATH_DHCPD_DB LOCALSTATEDIR"/dhcpd/dhcpd.leases"
|
|
#endif
|
|
|
|
#ifndef _PATH_DHCPD6_DB
|
|
-#define _PATH_DHCPD6_DB LOCALSTATEDIR"/db/dhcpd6.leases"
|
|
+#define _PATH_DHCPD6_DB LOCALSTATEDIR"/dhcpd/dhcpd6.leases"
|
|
#endif
|
|
|
|
#ifndef _PATH_DHCPD_PID
|
|
@@ -1362,7 +1362,7 @@ typedef unsigned char option_mask [16];
|
|
#endif /* DEBUG */
|
|
|
|
#ifndef _PATH_DHCLIENT_CONF
|
|
-#define _PATH_DHCLIENT_CONF "/etc/dhclient.conf"
|
|
+#define _PATH_DHCLIENT_CONF "/etc/dhcp/dhclient.conf"
|
|
#endif
|
|
|
|
#ifndef _PATH_DHCLIENT_SCRIPT
|
|
@@ -1378,11 +1378,11 @@ typedef unsigned char option_mask [16];
|
|
#endif
|
|
|
|
#ifndef _PATH_DHCLIENT_DB
|
|
-#define _PATH_DHCLIENT_DB LOCALSTATEDIR"/db/dhclient.leases"
|
|
+#define _PATH_DHCLIENT_DB LOCALSTATEDIR"/dhclient/dhclient.leases"
|
|
#endif
|
|
|
|
#ifndef _PATH_DHCLIENT6_DB
|
|
-#define _PATH_DHCLIENT6_DB LOCALSTATEDIR"/db/dhclient6.leases"
|
|
+#define _PATH_DHCLIENT6_DB LOCALSTATEDIR"/dhclient/dhclient6.leases"
|
|
#endif
|
|
|
|
#ifndef _PATH_RESOLV_CONF
|