4bf24c8243
- Had to rename the -T option to -timeout as ISC is now using -T - Allow package rebuilders to easily enable DHCPv6 support with: rpmbuild --with DHCPv6 dhcp.spec Note that Fedora is still using the 'dhcpv6' package, but some users may want to experiment with the ISC DHCPv6 implementation locally.
24 lines
955 B
Diff
24 lines
955 B
Diff
diff -up dhcp-4.1.0/server/confpars.c.failover dhcp-4.1.0/server/confpars.c
|
|
--- dhcp-4.1.0/server/confpars.c.failover 2009-01-06 10:24:38.000000000 -1000
|
|
+++ dhcp-4.1.0/server/confpars.c 2009-01-06 10:24:38.000000000 -1000
|
|
@@ -1142,10 +1142,17 @@ void parse_failover_peer (cfile, group,
|
|
parse_warn (cfile, "peer address may not be omitted");
|
|
|
|
/* XXX - when/if we get a port number assigned, just set as default */
|
|
+ /* See Red Hat Bugzilla 167292:
|
|
+ * we do now: dhcp-failover 647/tcp
|
|
+ * dhcp-failover 647/udp
|
|
+ * dhcp-failover 847/tcp
|
|
+ * dhcp-failover 847/udp
|
|
+ * IANA registration by Bernard Volz <volz@cisco.com>
|
|
+ */
|
|
if (!peer -> me.port)
|
|
- parse_warn (cfile, "local port may not be omitted");
|
|
+ peer -> me.port = 647;
|
|
if (!peer -> partner.port)
|
|
- parse_warn (cfile, "peer port may not be omitted");
|
|
+ peer -> partner.port = 847;
|
|
|
|
if (peer -> i_am == primary) {
|
|
if (!peer -> hba) {
|