Merge branch 'f21'
This commit is contained in:
commit
ffddd72865
59
dhcp-bind996.patch
Normal file
59
dhcp-bind996.patch
Normal file
@ -0,0 +1,59 @@
|
||||
From 1dceab6c75ce7bad309da9114d9e7f518291a955 Mon Sep 17 00:00:00 2001
|
||||
From: Shawn Routhier <sar@isc.org>
|
||||
Date: Wed, 10 Sep 2014 20:26:40 -0700
|
||||
Subject: [PATCH] [master] Remove unneeded defines for errors
|
||||
|
||||
As part of 4.2.0 we renamed a number of errors but continued
|
||||
to include the old ones in case somebody was building something
|
||||
using our libraries. This #ifdefs them and by defaults removes them
|
||||
from the compile.
|
||||
---
|
||||
diff --git a/includes/omapip/result.h b/includes/omapip/result.h
|
||||
index 3e4cf6a..ae5f7d6 100644
|
||||
--- a/includes/omapip/result.h
|
||||
+++ b/includes/omapip/result.h
|
||||
@@ -80,13 +80,13 @@
|
||||
|
||||
// Included for historical reasons, these should be removed as
|
||||
// soon as reasonable
|
||||
+#ifdef INCLUDE_OLD_DHCP_ISC_ERROR_CODES
|
||||
#define ISC_R_HOSTUNKNOWN DHCP_R_HOSTUNKNOWN
|
||||
#define ISC_R_VERSIONMISMATCH DHCP_R_VERSIONMISMATCH
|
||||
#define ISC_R_PROTOCOLERROR DHCP_R_PROTOCOLERROR
|
||||
#define ISC_R_INVALIDARG DHCP_R_INVALIDARG
|
||||
#define ISC_R_NOTYET DHCP_R_NOTYET
|
||||
#define ISC_R_UNCHANGED DHCP_R_UNCHANGED
|
||||
-#define ISC_R_MULTIPLE DHCP_R_MULTIPLE
|
||||
#define ISC_R_KEYCONFLICT DHCP_R_KEYCONFLICT
|
||||
#define ISC_R_BADPARSE DHCP_R_BADPARSE
|
||||
#define ISC_R_NOKEYS DHCP_R_NOKEYS
|
||||
@@ -113,6 +113,7 @@
|
||||
#define ISC_R_NOT_EQUAL DHCP_R_NOT_EQUAL
|
||||
#define ISC_R_CONNRESET DHCP_R_CONNRESET
|
||||
#define ISC_R_UNKNOWNATTRIBUTE DHCP_R_UNKNOWNATTRIBUTE
|
||||
+#endif
|
||||
|
||||
isc_result_t
|
||||
dhcp_result_register(void);
|
||||
diff --git a/includes/site.h b/includes/site.h
|
||||
index d87b309..19a2e11 100644
|
||||
--- a/includes/site.h
|
||||
+++ b/includes/site.h
|
||||
@@ -304,6 +304,14 @@
|
||||
removal of this define. Use at your own risk. */
|
||||
/* #define ENABLE_GENTLE_SHUTDOWN */
|
||||
|
||||
+/* Include old error codes. This is provided in case you
|
||||
+ are building an external program similar to omshell for
|
||||
+ which you need the ISC_R_* error codes. You should switch
|
||||
+ to DHCP_R_* error codes for those that have been defined
|
||||
+ (see includes/omapip/result.h). The extra defines and
|
||||
+ this option will be removed at some time. */
|
||||
+/* #define INCLUDE_OLD_DHCP_ISC_ERROR_CODES */
|
||||
+
|
||||
/* Include definitions for various options. In general these
|
||||
should be left as is, but if you have already defined one
|
||||
of these and prefer your definition you can comment the
|
||||
--
|
||||
2.1.0
|
||||
|
16
dhcp-skip-vlan.patch
Normal file
16
dhcp-skip-vlan.patch
Normal file
@ -0,0 +1,16 @@
|
||||
diff -up dhcp-4.3.1/common/lpf.c.vlan dhcp-4.3.1/common/lpf.c
|
||||
--- dhcp-4.3.1/common/lpf.c.vlan 2014-10-08 19:06:17.963118201 +0200
|
||||
+++ dhcp-4.3.1/common/lpf.c 2014-10-08 19:07:17.086276536 +0200
|
||||
@@ -543,6 +543,12 @@ ssize_t receive_packet (interface, buf,
|
||||
if (cmsg->cmsg_level == SOL_PACKET &&
|
||||
cmsg->cmsg_type == PACKET_AUXDATA) {
|
||||
struct tpacket_auxdata *aux = (void *)CMSG_DATA(cmsg);
|
||||
+ /* if listening on plain interface we can see vlan traffic as well.
|
||||
+ skip vlan traffic if tagged. If we are listening on vlan interfaces
|
||||
+ as well we will see the traffic again but without the tag
|
||||
+ */
|
||||
+ if (aux->tp_vlan_tci != 0)
|
||||
+ return 0;
|
||||
nocsum = aux->tp_status & TP_STATUS_CSUMNOTREADY;
|
||||
}
|
||||
}
|
17
dhcp.spec
17
dhcp.spec
@ -18,7 +18,7 @@
|
||||
Summary: Dynamic host configuration protocol software
|
||||
Name: dhcp
|
||||
Version: 4.3.1
|
||||
Release: 10%{?dist}
|
||||
Release: 11%{?dist}
|
||||
# NEVER CHANGE THE EPOCH on this package. The previous maintainer (prior to
|
||||
# dcantrell maintaining the package) made incorrect use of the epoch and
|
||||
# that's why it is at 12 now. It should have never been used, but it was.
|
||||
@ -74,6 +74,9 @@ Patch34: dhcp-no-subnet-error2info.patch
|
||||
Patch35: dhcp-ffff-checksum.patch
|
||||
Patch36: dhcp-sd_notify.patch
|
||||
Patch37: dhcp-dhc6-life.patch
|
||||
Patch38: dhcp-skip-vlan.patch
|
||||
|
||||
Patch100: dhcp-bind996.patch
|
||||
|
||||
BuildRequires: autoconf
|
||||
BuildRequires: automake
|
||||
@ -357,6 +360,14 @@ rm -rf includes/isc-dhcp
|
||||
# (Submitted to dhcp-bugs@isc.org - [ISC-Bugs #37084])
|
||||
%patch37 -p1 -b .life
|
||||
|
||||
# dhcpd generates spurious responses when seeing requests from vlans on plain interface (#1150587)
|
||||
# (Submitted to dhcp-bugs@isc.org - [ISC-Bugs #37415])
|
||||
%patch38 -p1 -b .vlan
|
||||
|
||||
|
||||
# to build against bind-9.9.6
|
||||
%patch100 -p1 -b .bind996
|
||||
|
||||
# Update paths in all man pages
|
||||
for page in client/dhclient.conf.5 client/dhclient.leases.5 \
|
||||
client/dhclient-script.8 client/dhclient.8 ; do
|
||||
@ -651,6 +662,10 @@ done
|
||||
%doc doc/html/
|
||||
|
||||
%changelog
|
||||
* Wed Oct 08 2014 Jiri Popelka <jpopelka@redhat.com> - 12:4.3.1-11
|
||||
- dhcpd generates spurious responses when seeing requests
|
||||
from vlans on plain interface (#1150587)
|
||||
|
||||
* Fri Oct 03 2014 Tomas Hozza <thozza@redhat.com> - 12:4.3.1-10
|
||||
- rebuild against bind-9.9.6
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user