- Remove dhcptables.pl from the source package
- Mark libres.a symbols hidden (#198496) - Set DT_SONAME on libdhcp4client to libdhcp4client-VERSION.so.0 - Make function definition for dst_hmac_md5_init() match the prototype
This commit is contained in:
parent
1403c6d0b2
commit
fc985eca96
@ -1,5 +1,5 @@
|
||||
--- dhcp-3.0.5/client/dhclient.c.libdhcp4client 2006-11-29 10:50:20.000000000 -0500
|
||||
+++ dhcp-3.0.5/client/dhclient.c 2006-11-29 10:50:20.000000000 -0500
|
||||
--- dhcp-3.0.5/client/dhclient.c.libdhcp4client 2007-01-29 17:02:31.000000000 -0500
|
||||
+++ dhcp-3.0.5/client/dhclient.c 2007-01-29 17:02:32.000000000 -0500
|
||||
@@ -78,7 +78,9 @@
|
||||
int extended_option_environment = 0;
|
||||
#endif
|
||||
@ -587,8 +587,8 @@
|
||||
ddns_dhcid, client_identifier;
|
||||
struct option_cache *oc;
|
||||
int ignorep;
|
||||
--- dhcp-3.0.5/common/alloc.c.libdhcp4client 2006-11-29 10:50:20.000000000 -0500
|
||||
+++ dhcp-3.0.5/common/alloc.c 2006-11-29 10:50:20.000000000 -0500
|
||||
--- dhcp-3.0.5/common/alloc.c.libdhcp4client 2007-01-29 17:02:31.000000000 -0500
|
||||
+++ dhcp-3.0.5/common/alloc.c 2007-01-29 17:02:32.000000000 -0500
|
||||
@@ -48,7 +48,6 @@
|
||||
const char *file;
|
||||
int line;
|
||||
@ -669,8 +669,8 @@
|
||||
struct dns_zone *d;
|
||||
|
||||
if (!ptr) {
|
||||
--- dhcp-3.0.5/common/discover.c.libdhcp4client 2006-11-29 10:50:20.000000000 -0500
|
||||
+++ dhcp-3.0.5/common/discover.c 2006-11-29 10:50:20.000000000 -0500
|
||||
--- dhcp-3.0.5/common/discover.c.libdhcp4client 2007-01-29 17:02:31.000000000 -0500
|
||||
+++ dhcp-3.0.5/common/discover.c 2007-01-29 17:02:32.000000000 -0500
|
||||
@@ -120,28 +120,30 @@
|
||||
For each interface that's of type INET and not the loopback interface,
|
||||
register that interface with the network I/O software, figure out what
|
||||
@ -761,7 +761,7 @@
|
||||
|
||||
if (h -> type != dhcp_type_interface)
|
||||
--- dhcp-3.0.5/common/lpf.c.libdhcp4client 2004-11-24 12:39:15.000000000 -0500
|
||||
+++ dhcp-3.0.5/common/lpf.c 2006-11-29 10:50:20.000000000 -0500
|
||||
+++ dhcp-3.0.5/common/lpf.c 2007-01-29 17:02:32.000000000 -0500
|
||||
@@ -69,8 +69,6 @@
|
||||
struct interface_info *info;
|
||||
{
|
||||
@ -787,8 +787,8 @@
|
||||
int length = 0;
|
||||
int offset = 0;
|
||||
unsigned char ibuf [1536];
|
||||
--- dhcp-3.0.5/dst/hmac_link.c.libdhcp4client 2001-02-22 02:22:08.000000000 -0500
|
||||
+++ dhcp-3.0.5/dst/hmac_link.c 2006-11-29 10:50:20.000000000 -0500
|
||||
--- dhcp-3.0.5/dst/hmac_link.c.libdhcp4client 2007-01-29 17:02:31.000000000 -0500
|
||||
+++ dhcp-3.0.5/dst/hmac_link.c 2007-01-29 17:02:32.000000000 -0500
|
||||
@@ -38,6 +38,10 @@
|
||||
|
||||
#include "dst_internal.h"
|
||||
@ -875,8 +875,390 @@
|
||||
if (dst_t_func[KEY_HMAC_MD5] == NULL)
|
||||
return (0);
|
||||
memset(dst_t_func[KEY_HMAC_MD5], 0, sizeof(struct dst_func));
|
||||
--- dhcp-3.0.5/dst/md5_dgst.c.libdhcp4client 2004-06-14 14:50:06.000000000 -0400
|
||||
+++ dhcp-3.0.5/dst/md5_dgst.c 2007-01-29 17:02:32.000000000 -0500
|
||||
@@ -65,7 +65,7 @@
|
||||
|
||||
#ifdef USE_MD5 /* Added by ogud@tis.com 1998/1/26 */
|
||||
|
||||
-const char *MD5_version="MD5 part of SSLeay 0.8.1 19-Jul-1997";
|
||||
+const char *MD5_version __attribute__((visibility ("hidden"))) ="MD5 part of SSLeay 0.8.1 19-Jul-1997";
|
||||
|
||||
/* Implemented from RFC1321 The MD5 Message-Digest Algorithm
|
||||
*/
|
||||
@@ -81,6 +81,7 @@
|
||||
static void md5_block();
|
||||
#endif
|
||||
|
||||
+__attribute__((visibility ("hidden")))
|
||||
void MD5_Init(c)
|
||||
MD5_CTX *c;
|
||||
{
|
||||
@@ -93,6 +94,7 @@
|
||||
c->num=0;
|
||||
}
|
||||
|
||||
+__attribute__((visibility ("hidden")))
|
||||
void MD5_Update(c, data, len)
|
||||
MD5_CTX *c;
|
||||
const register unsigned char *data;
|
||||
@@ -298,6 +300,7 @@
|
||||
c->D+=D&0xffffffffL;
|
||||
}
|
||||
|
||||
+__attribute__((visibility ("hidden")))
|
||||
void MD5_Final(md, c)
|
||||
unsigned char *md;
|
||||
MD5_CTX *c;
|
||||
--- dhcp-3.0.5/minires/ns_date.c.libdhcp4client 2004-06-10 13:59:40.000000000 -0400
|
||||
+++ dhcp-3.0.5/minires/ns_date.c 2007-01-29 17:02:32.000000000 -0500
|
||||
@@ -56,6 +56,7 @@
|
||||
1 January 1970 (GMT assumed). Format is yyyymmddhhmmss, all
|
||||
digits required, no spaces allowed. */
|
||||
|
||||
+__attribute__((visibility ("hidden")))
|
||||
u_int32_t
|
||||
ns_datetosecs(const char *cp, int *errp) {
|
||||
struct tm time;
|
||||
--- dhcp-3.0.5/minires/ns_verify.c.libdhcp4client 2004-06-10 13:59:42.000000000 -0400
|
||||
+++ dhcp-3.0.5/minires/ns_verify.c 2007-01-29 17:05:45.000000000 -0500
|
||||
@@ -61,6 +61,7 @@
|
||||
|
||||
/* Public. */
|
||||
|
||||
+__attribute__((visibility ("hidden")))
|
||||
u_char *
|
||||
ns_find_tsig(u_char *msg, u_char *eom) {
|
||||
HEADER *hp = (HEADER *)msg;
|
||||
@@ -137,6 +138,7 @@
|
||||
* - TSIG verification succeeds, error set to BADSIG (ns_r_badsig)
|
||||
* - TSIG verification succeeds, error set to BADTIME (ns_r_badtime)
|
||||
*/
|
||||
+__attribute__((visibility ("hidden")))
|
||||
isc_result_t
|
||||
ns_verify(u_char *msg, unsigned *msglen, void *k,
|
||||
const u_char *querysig, unsigned querysiglen,
|
||||
--- dhcp-3.0.5/minires/ns_parse.c.libdhcp4client 2004-06-10 13:59:40.000000000 -0400
|
||||
+++ dhcp-3.0.5/minires/ns_parse.c 2007-01-29 17:02:32.000000000 -0500
|
||||
@@ -47,7 +47,7 @@
|
||||
/* Public. */
|
||||
|
||||
/* These need to be in the same order as the nres.h:ns_flag enum. */
|
||||
-struct _ns_flagdata _ns_flagdata[16] = {
|
||||
+struct _ns_flagdata _ns_flagdata[16] __attribute__((visibility ("hidden"))) = {
|
||||
{ 0x8000, 15 }, /* qr. */
|
||||
{ 0x7800, 11 }, /* opcode. */
|
||||
{ 0x0400, 10 }, /* aa. */
|
||||
@@ -66,6 +66,7 @@
|
||||
{ 0x0000, 0 }, /* expansion (6/6). */
|
||||
};
|
||||
|
||||
+__attribute__((visibility ("hidden")))
|
||||
isc_result_t
|
||||
ns_skiprr(const u_char *ptr, const u_char *eom, ns_sect section, int count,
|
||||
int *rc) {
|
||||
@@ -94,6 +95,7 @@
|
||||
return ISC_R_SUCCESS;
|
||||
}
|
||||
|
||||
+__attribute__((visibility ("hidden")))
|
||||
isc_result_t
|
||||
ns_initparse(const u_char *msg, unsigned msglen, ns_msg *handle) {
|
||||
const u_char *eom = msg + msglen;
|
||||
@@ -136,6 +138,7 @@
|
||||
return ISC_R_SUCCESS;
|
||||
}
|
||||
|
||||
+__attribute__((visibility ("hidden")))
|
||||
isc_result_t
|
||||
ns_parserr(ns_msg *handle, ns_sect section, int rrnum, ns_rr *rr) {
|
||||
int b;
|
||||
--- dhcp-3.0.5/minires/ns_samedomain.c.libdhcp4client 2004-06-10 13:59:41.000000000 -0400
|
||||
+++ dhcp-3.0.5/minires/ns_samedomain.c 2007-01-29 17:02:32.000000000 -0500
|
||||
@@ -53,6 +53,7 @@
|
||||
* but NOT in "bar.top"
|
||||
*/
|
||||
|
||||
+__attribute__((visibility ("hidden")))
|
||||
int
|
||||
ns_samedomain(const char *a, const char *b) {
|
||||
size_t la, lb;
|
||||
@@ -152,6 +153,7 @@
|
||||
* ns_subdomain(a, b)
|
||||
* is "a" a subdomain of "b"?
|
||||
*/
|
||||
+__attribute__((visibility ("hidden")))
|
||||
int
|
||||
ns_subdomain(const char *a, const char *b) {
|
||||
return (ns_samename(a, b) != 1 && ns_samedomain(a, b));
|
||||
@@ -169,6 +171,7 @@
|
||||
* foo\\. -> foo\\.
|
||||
*/
|
||||
|
||||
+__attribute__((visibility ("hidden")))
|
||||
isc_result_t
|
||||
ns_makecanon(const char *src, char *dst, size_t dstsize) {
|
||||
size_t n = strlen(src);
|
||||
@@ -198,6 +201,7 @@
|
||||
* 1 if names are the same
|
||||
*/
|
||||
|
||||
+__attribute__((visibility ("hidden")))
|
||||
int
|
||||
ns_samename(const char *a, const char *b) {
|
||||
char ta[NS_MAXDNAME], tb[NS_MAXDNAME];
|
||||
--- dhcp-3.0.5/minires/ns_name.c.libdhcp4client 2007-01-29 17:02:31.000000000 -0500
|
||||
+++ dhcp-3.0.5/minires/ns_name.c 2007-01-29 17:02:32.000000000 -0500
|
||||
@@ -60,6 +60,7 @@
|
||||
* The root is returned as "."
|
||||
* All other domains are returned in non absolute form
|
||||
*/
|
||||
+__attribute__((visibility ("hidden")))
|
||||
int
|
||||
ns_name_ntop(const u_char *src, char *dst, size_t dstsiz) {
|
||||
const u_char *cp;
|
||||
@@ -146,6 +147,7 @@
|
||||
* Enforces label and domain length limits.
|
||||
*/
|
||||
|
||||
+__attribute__((visibility ("hidden")))
|
||||
int
|
||||
ns_name_pton(const char *src, u_char *dst, size_t dstsiz) {
|
||||
u_char *label, *bp, *eom;
|
||||
@@ -255,6 +257,7 @@
|
||||
* Enforces label and domain length limits.
|
||||
*/
|
||||
|
||||
+__attribute__((visibility ("hidden")))
|
||||
int
|
||||
ns_name_ntol(const u_char *src, u_char *dst, size_t dstsiz) {
|
||||
const u_char *cp;
|
||||
@@ -299,6 +302,7 @@
|
||||
* return:
|
||||
* -1 if it fails, or consumed octets if it succeeds.
|
||||
*/
|
||||
+__attribute__((visibility ("hidden")))
|
||||
int
|
||||
ns_name_unpack(const u_char *msg, const u_char *eom, const u_char *src,
|
||||
u_char *dst, size_t dstsiz)
|
||||
@@ -387,6 +391,7 @@
|
||||
* try to compress names. If 'lastdnptr' is NULL, we don't update the
|
||||
* list.
|
||||
*/
|
||||
+__attribute__((visibility ("hidden")))
|
||||
int
|
||||
ns_name_pack(const u_char *src, u_char *dst, unsigned dstsiz,
|
||||
const u_char **dnptrs, const u_char **lastdnptr)
|
||||
@@ -479,6 +484,7 @@
|
||||
* note:
|
||||
* Root domain returns as "." not "".
|
||||
*/
|
||||
+__attribute__((visibility ("hidden")))
|
||||
int
|
||||
ns_name_uncompress(const u_char *msg, const u_char *eom, const u_char *src,
|
||||
char *dst, size_t dstsiz)
|
||||
@@ -507,6 +513,7 @@
|
||||
* If 'dnptr' is NULL, we don't try to compress names. If 'lastdnptr'
|
||||
* is NULL, we don't update the list.
|
||||
*/
|
||||
+__attribute__((visibility ("hidden")))
|
||||
int
|
||||
ns_name_compress(const char *src, u_char *dst, size_t dstsiz,
|
||||
const u_char **dnptrs, const u_char **lastdnptr)
|
||||
@@ -524,6 +531,7 @@
|
||||
* return:
|
||||
* 0 on success, -1 (with errno set) on failure.
|
||||
*/
|
||||
+__attribute__((visibility ("hidden")))
|
||||
int
|
||||
ns_name_skip(const u_char **ptrptr, const u_char *eom) {
|
||||
const u_char *cp;
|
||||
--- dhcp-3.0.5/minires/ns_sign.c.libdhcp4client 2004-06-10 13:59:42.000000000 -0400
|
||||
+++ dhcp-3.0.5/minires/ns_sign.c 2007-01-29 17:02:32.000000000 -0500
|
||||
@@ -78,6 +78,7 @@
|
||||
* - bad key / sign failed (-BADKEY)
|
||||
* - not enough space (NS_TSIG_ERROR_NO_SPACE)
|
||||
*/
|
||||
+__attribute__((visibility ("hidden")))
|
||||
isc_result_t
|
||||
ns_sign(u_char *msg, unsigned *msglen, unsigned msgsize, int error, void *k,
|
||||
const u_char *querysig, unsigned querysiglen, u_char *sig,
|
||||
--- dhcp-3.0.5/minires/res_comp.c.libdhcp4client 2007-01-29 17:02:31.000000000 -0500
|
||||
+++ dhcp-3.0.5/minires/res_comp.c 2007-01-29 17:02:32.000000000 -0500
|
||||
@@ -103,6 +103,7 @@
|
||||
* 'exp_dn' is a pointer to a buffer of size 'length' for the result.
|
||||
* Return size of compressed name or -1 if there was an error.
|
||||
*/
|
||||
+__attribute__((visibility ("hidden")))
|
||||
int
|
||||
dn_expand(const u_char *msg, const u_char *eom, const u_char *src,
|
||||
char *dst, unsigned dstsiz)
|
||||
@@ -119,6 +120,7 @@
|
||||
* Return the size of the compressed name or -1.
|
||||
* 'length' is the size of the array pointed to by 'comp_dn'.
|
||||
*/
|
||||
+__attribute__((visibility ("hidden")))
|
||||
int
|
||||
dn_comp(const char *src, u_char *dst, unsigned dstsiz,
|
||||
u_char **dnptrs, u_char **lastdnptr)
|
||||
@@ -131,6 +133,7 @@
|
||||
/*
|
||||
* Skip over a compressed domain name. Return the size or -1.
|
||||
*/
|
||||
+__attribute__((visibility ("hidden")))
|
||||
int
|
||||
dn_skipname(const u_char *ptr, const u_char *eom) {
|
||||
const u_char *saveptr = ptr;
|
||||
--- dhcp-3.0.5/minires/res_mkupdate.c.libdhcp4client 2007-01-29 17:02:32.000000000 -0500
|
||||
+++ dhcp-3.0.5/minires/res_mkupdate.c 2007-01-29 17:02:32.000000000 -0500
|
||||
@@ -936,6 +936,7 @@
|
||||
|
||||
static struct valuelist *servicelist, *protolist;
|
||||
|
||||
+__attribute__((visibility ("hidden")))
|
||||
void
|
||||
res_buildservicelist() {
|
||||
struct servent *sp;
|
||||
@@ -968,6 +969,7 @@
|
||||
endservent();
|
||||
}
|
||||
|
||||
+__attribute__((visibility ("hidden")))
|
||||
void
|
||||
res_destroyservicelist() {
|
||||
struct valuelist *slp, *slp_next;
|
||||
@@ -981,6 +983,7 @@
|
||||
servicelist = (struct valuelist *)0;
|
||||
}
|
||||
|
||||
+__attribute__((visibility ("hidden")))
|
||||
void
|
||||
res_buildprotolist() {
|
||||
struct protoent *pp;
|
||||
@@ -1010,6 +1013,7 @@
|
||||
endprotoent();
|
||||
}
|
||||
|
||||
+__attribute__((visibility ("hidden")))
|
||||
void
|
||||
res_destroyprotolist() {
|
||||
struct valuelist *plp, *plp_next;
|
||||
@@ -1047,6 +1051,7 @@
|
||||
/*
|
||||
* Convert service name or (ascii) number to int.
|
||||
*/
|
||||
+__attribute__((visibility ("hidden")))
|
||||
int
|
||||
res_servicenumber(const char *p) {
|
||||
if (servicelist == (struct valuelist *)0)
|
||||
@@ -1057,6 +1062,7 @@
|
||||
/*
|
||||
* Convert protocol name or (ascii) number to int.
|
||||
*/
|
||||
+__attribute__((visibility ("hidden")))
|
||||
int
|
||||
res_protocolnumber(const char *p) {
|
||||
if (protolist == (struct valuelist *)0)
|
||||
@@ -1115,6 +1121,7 @@
|
||||
return (0);
|
||||
}
|
||||
|
||||
+__attribute__((visibility ("hidden")))
|
||||
const char *
|
||||
res_protocolname(int num) {
|
||||
static char number[8];
|
||||
@@ -1130,6 +1137,7 @@
|
||||
return (pp->p_name);
|
||||
}
|
||||
|
||||
+__attribute__((visibility ("hidden")))
|
||||
const char *
|
||||
res_servicename(u_int16_t port, const char *proto) { /* Host byte order. */
|
||||
static char number[8];
|
||||
--- dhcp-3.0.5/minires/res_findzonecut.c.libdhcp4client 2004-06-10 13:59:43.000000000 -0400
|
||||
+++ dhcp-3.0.5/minires/res_findzonecut.c 2007-01-29 17:02:32.000000000 -0500
|
||||
@@ -139,6 +139,7 @@
|
||||
* keep going. for the NS and A queries this means we just give up.
|
||||
*/
|
||||
|
||||
+__attribute__((visibility ("hidden")))
|
||||
isc_result_t
|
||||
res_findzonecut(res_state statp, const char *dname, ns_class class, int opts,
|
||||
char *zname, size_t zsize, struct in_addr *addrs, int naddrs,
|
||||
--- dhcp-3.0.5/minires/res_send.c.libdhcp4client 2004-06-10 13:59:44.000000000 -0400
|
||||
+++ dhcp-3.0.5/minires/res_send.c 2007-01-29 17:02:32.000000000 -0500
|
||||
@@ -128,6 +128,7 @@
|
||||
* author:
|
||||
* paul vixie, 29may94
|
||||
*/
|
||||
+__attribute__((visibility ("hidden")))
|
||||
int
|
||||
res_ourserver_p(const res_state statp, const struct sockaddr_in *inp) {
|
||||
struct sockaddr_in ina;
|
||||
@@ -158,6 +159,7 @@
|
||||
* author:
|
||||
* paul vixie, 29may94
|
||||
*/
|
||||
+__attribute__((visibility ("hidden")))
|
||||
int
|
||||
res_nameinquery(const char *name, int type, int class,
|
||||
const u_char *buf, const u_char *eom)
|
||||
@@ -195,6 +197,7 @@
|
||||
* author:
|
||||
* paul vixie, 29may94
|
||||
*/
|
||||
+__attribute__((visibility ("hidden")))
|
||||
int
|
||||
res_queriesmatch(const u_char *buf1, const u_char *eom1,
|
||||
const u_char *buf2, const u_char *eom2)
|
||||
@@ -233,6 +236,7 @@
|
||||
return (1);
|
||||
}
|
||||
|
||||
+__attribute__((visibility ("hidden")))
|
||||
isc_result_t
|
||||
res_nsend(res_state statp,
|
||||
double *buf, unsigned buflen,
|
||||
@@ -832,6 +836,7 @@
|
||||
*
|
||||
* This routine is not expected to be user visible.
|
||||
*/
|
||||
+__attribute__((visibility ("hidden")))
|
||||
void
|
||||
res_nclose(res_state statp) {
|
||||
if (statp->_sock >= 0) {
|
||||
--- dhcp-3.0.5/minires/res_mkquery.c.libdhcp4client 2004-06-10 13:59:43.000000000 -0400
|
||||
+++ dhcp-3.0.5/minires/res_mkquery.c 2007-01-29 17:02:32.000000000 -0500
|
||||
@@ -96,6 +96,7 @@
|
||||
* Form all types of queries.
|
||||
* Returns the size of the result or -1.
|
||||
*/
|
||||
+__attribute__((visibility ("hidden")))
|
||||
isc_result_t
|
||||
res_nmkquery(res_state statp,
|
||||
int op, /* opcode of query */
|
||||
--- dhcp-3.0.5/minires/res_sendsigned.c.libdhcp4client 2004-06-10 13:59:44.000000000 -0400
|
||||
+++ dhcp-3.0.5/minires/res_sendsigned.c 2007-01-29 17:02:32.000000000 -0500
|
||||
@@ -41,6 +41,7 @@
|
||||
#include <isc-dhcp/dst.h>
|
||||
|
||||
/* res_nsendsigned */
|
||||
+__attribute__((visibility ("hidden")))
|
||||
isc_result_t
|
||||
res_nsendsigned(res_state statp,
|
||||
double *msg, unsigned msglen, ns_tsig_key *key,
|
||||
--- dhcp-3.0.5/minires/res_init.c.libdhcp4client 2007-01-29 17:02:31.000000000 -0500
|
||||
+++ dhcp-3.0.5/minires/res_init.c 2007-01-29 17:02:32.000000000 -0500
|
||||
@@ -484,6 +484,7 @@
|
||||
}
|
||||
#endif
|
||||
|
||||
+__attribute__((visibility ("hidden")))
|
||||
u_int
|
||||
res_randomid(void) {
|
||||
struct timeval now;
|
||||
--- dhcp-3.0.5/omapip/alloc.c.libdhcp4client 2006-02-22 17:43:27.000000000 -0500
|
||||
+++ dhcp-3.0.5/omapip/alloc.c 2006-11-29 10:50:20.000000000 -0500
|
||||
+++ dhcp-3.0.5/omapip/alloc.c 2007-01-29 17:02:32.000000000 -0500
|
||||
@@ -40,6 +40,41 @@
|
||||
|
||||
#include <omapip/omapip_p.h>
|
||||
@ -948,8 +1330,8 @@
|
||||
}
|
||||
|
||||
#if defined (DEBUG_MEMORY_LEAKAGE) || defined (DEBUG_MALLOC_POOL) || \
|
||||
--- dhcp-3.0.5/omapip/dispatch.c.libdhcp4client 2006-11-29 10:50:20.000000000 -0500
|
||||
+++ dhcp-3.0.5/omapip/dispatch.c 2006-11-29 10:50:20.000000000 -0500
|
||||
--- dhcp-3.0.5/omapip/dispatch.c.libdhcp4client 2007-01-29 17:02:31.000000000 -0500
|
||||
+++ dhcp-3.0.5/omapip/dispatch.c 2007-01-29 17:02:32.000000000 -0500
|
||||
@@ -34,7 +34,7 @@
|
||||
|
||||
#include <omapip/omapip_p.h>
|
||||
@ -959,8 +1341,8 @@
|
||||
TIME cur_time;
|
||||
|
||||
OMAPI_OBJECT_ALLOC (omapi_io,
|
||||
--- dhcp-3.0.5/omapip/errwarn.c.libdhcp4client 2006-11-29 10:50:20.000000000 -0500
|
||||
+++ dhcp-3.0.5/omapip/errwarn.c 2006-11-29 10:50:20.000000000 -0500
|
||||
--- dhcp-3.0.5/omapip/errwarn.c.libdhcp4client 2007-01-29 17:02:31.000000000 -0500
|
||||
+++ dhcp-3.0.5/omapip/errwarn.c 2007-01-29 17:02:32.000000000 -0500
|
||||
@@ -39,6 +39,11 @@
|
||||
#include <omapip/omapip_p.h>
|
||||
#include <errno.h>
|
||||
@ -1083,7 +1465,7 @@
|
||||
}
|
||||
|
||||
--- dhcp-3.0.5/configure.libdhcp4client 2004-09-10 17:02:30.000000000 -0400
|
||||
+++ dhcp-3.0.5/configure 2006-11-29 10:50:20.000000000 -0500
|
||||
+++ dhcp-3.0.5/configure 2007-01-29 17:02:32.000000000 -0500
|
||||
@@ -246,7 +246,7 @@
|
||||
fi
|
||||
|
||||
@ -1093,9 +1475,9 @@
|
||||
fi
|
||||
|
||||
for foo in $dirs; do
|
||||
--- /dev/null 2006-11-25 13:38:58.174646239 -0500
|
||||
+++ dhcp-3.0.5/libdhcp4client/Makefile.dist 2006-11-29 10:51:12.000000000 -0500
|
||||
@@ -0,0 +1,104 @@
|
||||
--- /dev/null 2007-01-28 13:50:40.723776703 -0500
|
||||
+++ dhcp-3.0.5/libdhcp4client/Makefile.dist 2007-01-29 17:02:32.000000000 -0500
|
||||
@@ -0,0 +1,127 @@
|
||||
+# Makefile.dist for libdhcp4client
|
||||
+#
|
||||
+# We get the libdhcp4client library from the patched ISC source code. We
|
||||
@ -1106,23 +1488,45 @@
|
||||
+#
|
||||
+# David Cantrell <dcantrell@redhat.com>
|
||||
+
|
||||
+PROGS = libdhcp4client.a libdhcp4client.so.1
|
||||
+HDRS = dhcp4client.h libdhcp_control.h
|
||||
+SRCS = client_dhclient.c common_alloc.c common_discover.c dst_hmac_link.c \
|
||||
+ omapip_alloc.c omapip_errwarn.c common_tables.c common_options.c \
|
||||
+ common_dispatch.c common_tree.c omapip_hash.c omapip_dispatch.c \
|
||||
+ omapip_support.c omapip_trace.c common_ctrace.c common_print.c \
|
||||
+ common_socket.c common_inet.c omapip_auth.c omapip_buffer.c \
|
||||
+ omapip_connection.c omapip_generic.c omapip_array.c omapip_listener.c \
|
||||
+ omapip_message.c omapip_protocol.c omapip_toisc.c omapip_mrtrace.c \
|
||||
+ client_clparse.c common_memory.c omapip_convert.c common_parse.c \
|
||||
+ common_conflex.c common_bpf.c common_dlpi.c common_lpf.c common_nit.c \
|
||||
+ common_upf.c common_packet.c common_dns.c common_comapi.c \
|
||||
+ dst_dst_api.c dst_base64.c common_ethernet.c common_tr.c \
|
||||
+ dst_dst_support.c common_execute.c omapip_result.c omapip_handle.c \
|
||||
+ dst_prandom.c dst_md5_dgst.c
|
||||
+# What version of ISC DHCP is this?
|
||||
+VER = $(shell grep DHCP_VERSION ../../includes/version.h | head -1 | cut -d '"' -f 2 | cut -d 'V' -f 2 | cut -d '-' -f 1)
|
||||
+
|
||||
+PROGS = libdhcp4client.a libdhcp4client-$(VER).so.0
|
||||
+
|
||||
+# NOTE: The ordering of these file lists is important! We are using the
|
||||
+# whole program optimization features of gcc, so the order matters here.
|
||||
+
|
||||
+# Source files shared by all objects
|
||||
+COMMON_SRCS = client_clparse.c client_dhclient.c common_alloc.c common_bpf.c \
|
||||
+ common_comapi.c common_conflex.c common_discover.c \
|
||||
+ common_dispatch.c common_dns.c common_ethernet.c \
|
||||
+ common_execute.c common_inet.c common_lpf.c common_memory.c \
|
||||
+ common_options.c common_packet.c common_parse.c common_print.c \
|
||||
+ common_socket.c common_tables.c common_tr.c common_tree.c \
|
||||
+ dst_dst_api.c dst_base64.c dst_hmac_link.c dst_md5_dgst.c \
|
||||
+ omapip_alloc.c omapip_array.c omapip_auth.c omapip_buffer.c \
|
||||
+ omapip_connection.c omapip_convert.c omapip_dispatch.c \
|
||||
+ omapip_errwarn.c omapip_handle.c omapip_hash.c \
|
||||
+ omapip_listener.c omapip_mrtrace.c omapip_result.c \
|
||||
+ omapip_support.c omapip_toisc.c omapip_trace.c
|
||||
+
|
||||
+# Source files for libdhcp4client.o
|
||||
+CLIENT_SRCS = common_ctrace.c common_dlpi.c common_nit.c common_upf.c \
|
||||
+ dst_dst_support.c dst_prandom.c omapip_generic.c \
|
||||
+ omapip_message.c omapip_protocol.c
|
||||
+
|
||||
+# Source files for libres.o (minires)
|
||||
+MINIRES_SRCS = minires_ns_date.c minires_ns_name.c minires_ns_parse.c \
|
||||
+ minires_ns_samedomain.c minires_ns_sign.c minires_ns_verify.c \
|
||||
+ minires_res_comp.c minires_res_findzonecut.c \
|
||||
+ minires_res_init.c minires_res_mkquery.c \
|
||||
+ minires_res_mkupdate.c minires_res_query.c minires_res_send.c \
|
||||
+ minires_res_sendsigned.c minires_res_update.c
|
||||
+
|
||||
+HDRS = dhcp4client.h libdhcp_control.h
|
||||
+SRCS = $(COMMON_SRCS) $(CLIENT_SRCS)
|
||||
+OBJS = $(SRCS:.c=.o)
|
||||
+
|
||||
+OBJS = $(SRCS:.c=.o)
|
||||
+INCLUDES = -I$(TOP) -I$(TOP)/includes -I$(TOP)/dst -I.
|
||||
+CFLAGS = $(DEBUG) $(PREDEFINES) $(INCLUDES) $(COPTS) \
|
||||
+ -DCLIENT_PATH=${CLIENT_PATH} -DLIBDHCP -DUSE_MD5
|
||||
@ -1130,8 +1534,8 @@
|
||||
+all: $(PROGS)
|
||||
+
|
||||
+install: all
|
||||
+ install -p -m 0755 -D libdhcp4client.so.1 $(DESTDIR)$(LIBDIR)/libdhcp4client.so.1
|
||||
+ ln -sf libdhcp4client.so.1 $(DESTDIR)/$(LIBDIR)/libdhcp4client.so
|
||||
+ install -p -m 0755 -D libdhcp4client-$(VER).so.0 $(DESTDIR)$(LIBDIR)/libdhcp4client-$(VER).so.0
|
||||
+ ln -sf libdhcp4client-$(VER).so.0 $(DESTDIR)/$(LIBDIR)/libdhcp4client.so
|
||||
+ install -p -m 0644 -D libdhcp4client.a $(DESTDIR)$(LIBDIR)/libdhcp4client.a
|
||||
+ install -p -m 0644 -D dhcp4client.h $(DESTDIR)$(INCDIR)/dhcp4client/dhcp4client.h
|
||||
+ install -p -m 0644 -D libdhcp_control.h $(DESTDIR)$(INCDIR)/dhcp4client/libdhcp_control.h
|
||||
@ -1190,18 +1594,19 @@
|
||||
+ ln ../minires/libres.a .; \
|
||||
+ $(AR) x libres.a
|
||||
+
|
||||
+# Create the libraries
|
||||
+# minires/res_query.o contains an undefined symbol __h_errno_set, is not
|
||||
+# used by any dhcp code, and is optimized out by the linker when producing
|
||||
+# the dhclient executable or a shared library
|
||||
+libdhcp4client.a: $(OBJS) libres.a
|
||||
+ $(AR) crus $@ $(OBJS) `$(AR) t libres.a | grep -v res_query.o`
|
||||
+
|
||||
+libdhcp4client.so.1: $(OBJS) libres.a
|
||||
+libdhcp4client-$(VER).so.0: $(OBJS) libres.a
|
||||
+ $(CC) -shared -o $@ -Wl,-soname,$@ $(OBJS) `$(AR) t libres.a | grep -v res_query.o`
|
||||
+
|
||||
+# Dependencies (semi-automatically-generated)
|
||||
--- /dev/null 2006-11-25 13:38:58.174646239 -0500
|
||||
+++ dhcp-3.0.5/libdhcp4client/dhcp4client.h 2006-11-29 10:50:20.000000000 -0500
|
||||
--- /dev/null 2007-01-28 13:50:40.723776703 -0500
|
||||
+++ dhcp-3.0.5/libdhcp4client/dhcp4client.h 2007-01-29 17:02:32.000000000 -0500
|
||||
@@ -0,0 +1,24 @@
|
||||
+/* dhcp4client.h
|
||||
+ *
|
||||
@ -1227,8 +1632,8 @@
|
||||
+extern int dhcpv4_client( struct libdhcp_control_s *dhc_ctl, int argc, char **argv, char **envp);
|
||||
+ /* The ISC IPv4 DHCP client main() function .
|
||||
+ */
|
||||
--- /dev/null 2006-11-25 13:38:58.174646239 -0500
|
||||
+++ dhcp-3.0.5/libdhcp4client/libdhcp_control.h 2006-11-29 10:50:20.000000000 -0500
|
||||
--- /dev/null 2007-01-28 13:50:40.723776703 -0500
|
||||
+++ dhcp-3.0.5/libdhcp4client/libdhcp_control.h 2007-01-29 17:02:32.000000000 -0500
|
||||
@@ -0,0 +1,102 @@
|
||||
+/* libdhcp_control.h
|
||||
+ *
|
||||
@ -1333,7 +1738,7 @@
|
||||
+
|
||||
+#endif
|
||||
--- dhcp-3.0.5/Makefile.dist.libdhcp4client 2004-06-10 13:59:10.000000000 -0400
|
||||
+++ dhcp-3.0.5/Makefile.dist 2006-11-29 10:50:20.000000000 -0500
|
||||
+++ dhcp-3.0.5/Makefile.dist 2007-01-29 17:02:32.000000000 -0500
|
||||
@@ -22,7 +22,7 @@
|
||||
# http://www.isc.org/
|
||||
|
||||
|
32
dhcp.spec
32
dhcp.spec
@ -8,7 +8,7 @@
|
||||
Summary: DHCP (Dynamic Host Configuration Protocol) server and relay agent.
|
||||
Name: dhcp
|
||||
Version: 3.0.5
|
||||
Release: 8%{?dist}
|
||||
Release: 9%{?dist}
|
||||
Epoch: 12
|
||||
License: distributable
|
||||
Group: System Environment/Daemons
|
||||
@ -19,7 +19,6 @@ Source2: dhcpd.init
|
||||
Source3: dhcrelay.init
|
||||
Source4: dhcpd.conf
|
||||
Source5: libdhcp4client.pc
|
||||
Source6: dhcptables.pl
|
||||
|
||||
Patch0: dhcp-3.0.5-extended-new-option-info.patch
|
||||
Patch1: dhcp-3.0.5-Makefile.patch
|
||||
@ -32,9 +31,11 @@ Patch7: dhcp-3.0.5-includes.patch
|
||||
Patch8: dhcp-3.0.5-omapip.patch
|
||||
Patch9: dhcp-3.0.5-minires.patch
|
||||
Patch10: dhcp-3.0.5-server.patch
|
||||
Patch11: dhcp-3.0.5-libdhcp4client.patch
|
||||
Patch12: dhcp-3.0.5-timeouts.patch
|
||||
Patch13: dhcp-3.0.5-fix-warnings.patch
|
||||
Patch11: dhcp-3.0.5-timeouts.patch
|
||||
Patch12: dhcp-3.0.5-fix-warnings.patch
|
||||
|
||||
# adds libdhcp4client to the ISC code base
|
||||
Patch50: dhcp-3.0.5-libdhcp4client.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
Requires(post): chkconfig, coreutils
|
||||
@ -134,14 +135,14 @@ client library .
|
||||
# Patches for the server/ subdirectory
|
||||
%patch10 -p1 -b .server
|
||||
|
||||
# Add the libdhcp4client target (library version of dhclient)
|
||||
%patch11 -p1 -b .libdhcp4client
|
||||
|
||||
# Fix up timeout handling in dhclient and libdhcp4client
|
||||
%patch12 -p1 -b .timeouts
|
||||
%patch11 -p1 -b .timeouts
|
||||
|
||||
# Fix up anything that fails -Wall -Werror
|
||||
%patch13 -p1 -b .warnings
|
||||
%patch12 -p1 -b .warnings
|
||||
|
||||
# Add the libdhcp4client target (library version of dhclient)
|
||||
%patch50 -p1 -b .libdhcp4client
|
||||
|
||||
%build
|
||||
cp %SOURCE1 .
|
||||
@ -159,6 +160,9 @@ cat <<EOF >>includes/site.h
|
||||
#define _PATH_DHCLIENT_DB "%{_localstatedir}/lib/dhclient/dhclient.leases"
|
||||
EOF
|
||||
|
||||
# Enable extended option info patch and set fortify source to 0 so that we
|
||||
# don't get inline functions that we don't want (for libdhcp4client)
|
||||
RPM_OPT_FLAGS="$(echo $RPM_OPT_FLAGS | sed -e 's/_FORTIFY_SOURCE=[0-9]/_FORTIFY_SOURCE=0/g')"
|
||||
RPM_OPT_FLAGS="$RPM_OPT_FLAGS -fPIC -Werror -Dlint -DEXTENDED_NEW_OPTION_INFO"
|
||||
|
||||
# DO NOT use the %%configure macro because this configure script is not autognu
|
||||
@ -330,7 +334,7 @@ exit 0
|
||||
|
||||
%files -n libdhcp4client
|
||||
%defattr(0755,root,root,0755)
|
||||
%{_libdir}/libdhcp4client.so.*
|
||||
%{_libdir}/libdhcp4client-%{version}.so.*
|
||||
|
||||
%files -n libdhcp4client-devel
|
||||
%defattr(0644,root,root,0755)
|
||||
@ -340,6 +344,12 @@ exit 0
|
||||
%{_libdir}/libdhcp4client.so
|
||||
|
||||
%changelog
|
||||
* Mon Jan 29 2007 David Cantrell <dcantrell@redhat.com> - 12:3.0.5-9
|
||||
- Remove dhcptables.pl from the source package
|
||||
- Mark libres.a symbols hidden (#198496)
|
||||
- Set DT_SONAME on libdhcp4client to libdhcp4client-VERSION.so.0
|
||||
- Make function definition for dst_hmac_md5_init() match the prototype
|
||||
|
||||
* Wed Nov 29 2006 David Cantrell <dcantrell@redhat.com> - 12:3.0.5-8
|
||||
- Roll md5 patch in to libdhcp4client patch since it's related
|
||||
- Do not overwrite /etc/ntp/step-tickers (#217663)
|
||||
|
Loading…
Reference in New Issue
Block a user