- Restrict interface names given on the dhcpd command line to length
IFNAMSIZ or shorter (#441524)
This commit is contained in:
parent
84c00d5bf3
commit
f4c359e5e8
12
dhcp-4.1.0-IFNAMSIZ.patch
Normal file
12
dhcp-4.1.0-IFNAMSIZ.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -up dhcp-4.1.0/server/dhcpd.c.ifnamsiz dhcp-4.1.0/server/dhcpd.c
|
||||||
|
--- dhcp-4.1.0/server/dhcpd.c.ifnamsiz 2009-04-20 16:35:30.000000000 -1000
|
||||||
|
+++ dhcp-4.1.0/server/dhcpd.c 2009-04-20 15:45:15.000000000 -1000
|
||||||
|
@@ -401,7 +401,7 @@ main(int argc, char **argv) {
|
||||||
|
log_fatal ("Insufficient memory to %s %s: %s",
|
||||||
|
"record interface", argv [i],
|
||||||
|
isc_result_totext (result));
|
||||||
|
- strcpy (tmp -> name, argv [i]);
|
||||||
|
+ strncpy (tmp -> name, argv [i], sizeof (tmp -> name));
|
||||||
|
if (interfaces) {
|
||||||
|
interface_reference (&tmp -> next,
|
||||||
|
interfaces, MDL);
|
10
dhcp.spec
10
dhcp.spec
@ -10,7 +10,7 @@
|
|||||||
Summary: Dynamic host configuration protocol software
|
Summary: Dynamic host configuration protocol software
|
||||||
Name: dhcp
|
Name: dhcp
|
||||||
Version: 4.1.0
|
Version: 4.1.0
|
||||||
Release: 18%{?dist}
|
Release: 19%{?dist}
|
||||||
# NEVER CHANGE THE EPOCH on this package. The previous maintainer (prior to
|
# NEVER CHANGE THE EPOCH on this package. The previous maintainer (prior to
|
||||||
# dcantrell maintaining the package) made incorrect use of the epoch and
|
# dcantrell maintaining the package) made incorrect use of the epoch and
|
||||||
# that's why it is at 12 now. It should have never been used, but it was.
|
# that's why it is at 12 now. It should have never been used, but it was.
|
||||||
@ -45,6 +45,7 @@ Patch15: %{name}-4.1.0-garbage-chars.patch
|
|||||||
Patch16: %{name}-4.1.0-port-validation.patch
|
Patch16: %{name}-4.1.0-port-validation.patch
|
||||||
Patch17: %{name}-4.1.0-invalid-dhclient-conf.patch
|
Patch17: %{name}-4.1.0-invalid-dhclient-conf.patch
|
||||||
Patch18: %{name}-4.1.0-missing-ipv6-not-fatal.patch
|
Patch18: %{name}-4.1.0-missing-ipv6-not-fatal.patch
|
||||||
|
Patch19: %{name}-4.1.0-IFNAMSIZ.patch
|
||||||
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
BuildRequires: autoconf
|
BuildRequires: autoconf
|
||||||
@ -187,6 +188,9 @@ libdhcpctl and libomapi static libraries are also included in this package.
|
|||||||
# (Submitted to dhcp-bugs@isc.org - [ISC-Bugs #19367]
|
# (Submitted to dhcp-bugs@isc.org - [ISC-Bugs #19367]
|
||||||
%patch18 -p1
|
%patch18 -p1
|
||||||
|
|
||||||
|
# Read only up to IFNAMSIZ characters for the interface name in dhcpd (#441524)
|
||||||
|
%patch19 -p1
|
||||||
|
|
||||||
# Copy in documentation and example scripts for LDAP patch to dhcpd
|
# Copy in documentation and example scripts for LDAP patch to dhcpd
|
||||||
%{__install} -p -m 0755 ldap-for-dhcp-%{ldappatchver}/dhcpd-conf-to-ldap contrib/
|
%{__install} -p -m 0755 ldap-for-dhcp-%{ldappatchver}/dhcpd-conf-to-ldap contrib/
|
||||||
|
|
||||||
@ -419,6 +423,10 @@ fi
|
|||||||
%attr(0644,root,root) %{_mandir}/man3/omapi.3.gz
|
%attr(0644,root,root) %{_mandir}/man3/omapi.3.gz
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Apr 20 2009 David Cantrell <dcantrell@redhat.com> - 12:4.1.0-19
|
||||||
|
- Restrict interface names given on the dhcpd command line to length
|
||||||
|
IFNAMSIZ or shorter (#441524)
|
||||||
|
|
||||||
* Mon Apr 20 2009 David Cantrell <dcantrell@redhat.com> - 12:4.1.0-18
|
* Mon Apr 20 2009 David Cantrell <dcantrell@redhat.com> - 12:4.1.0-18
|
||||||
- Make dhclient-script work with pre-configured wireless interfaces (#491157)
|
- Make dhclient-script work with pre-configured wireless interfaces (#491157)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user