4.2.1rc1
This commit is contained in:
parent
b95a0d94b4
commit
b2f01851dc
1
.gitignore
vendored
1
.gitignore
vendored
@ -1 +1,2 @@
|
|||||||
/dhcp-4.2.1b1.tar.gz
|
/dhcp-4.2.1b1.tar.gz
|
||||||
|
/dhcp-4.2.1rc1.tar.gz
|
||||||
|
@ -1,10 +0,0 @@
|
|||||||
diff -up dhcp-4.2.0-P2/common/Makefile.am.ldap-configuration dhcp-4.2.0-P2/common/Makefile.am
|
|
||||||
--- dhcp-4.2.0-P2/common/Makefile.am.ldap-configuration 2011-01-13 17:54:14.000000000 +0100
|
|
||||||
+++ dhcp-4.2.0-P2/common/Makefile.am 2011-01-13 17:54:14.000000000 +0100
|
|
||||||
@@ -1,5 +1,5 @@
|
|
||||||
AM_CPPFLAGS = -I.. -DLOCALSTATEDIR='"@localstatedir@"'
|
|
||||||
-AM_CFLAGS = -fpic
|
|
||||||
+AM_CFLAGS = $(LDAP_CFLAGS) -fpic
|
|
||||||
|
|
||||||
noinst_LIBRARIES = libdhcp.a
|
|
||||||
libdhcp_a_SOURCES = alloc.c bpf.c comapi.c conflex.c ctrace.c discover.c \
|
|
@ -1,12 +0,0 @@
|
|||||||
diff -up dhcp-4.2.0-P2/omapip/protocol.c.omapi dhcp-4.2.0-P2/omapip/protocol.c
|
|
||||||
--- dhcp-4.2.0-P2/omapip/protocol.c.omapi 2009-11-20 02:49:02.000000000 +0100
|
|
||||||
+++ dhcp-4.2.0-P2/omapip/protocol.c 2011-01-03 16:30:25.000000000 +0100
|
|
||||||
@@ -386,7 +386,7 @@ isc_result_t omapi_protocol_signal_handl
|
|
||||||
/* Should only receive these when opening the initial authenticator. */
|
|
||||||
if (!strcmp (name, "status")) {
|
|
||||||
status = va_arg (ap, isc_result_t);
|
|
||||||
- if (status != ISC_R_SUCCESS) {
|
|
||||||
+ if ((status != ISC_R_SUCCESS) && (status >= ISC_RESULTCLASS_DHCP)) {
|
|
||||||
omapi_signal_in (h -> inner, "status", status,
|
|
||||||
(omapi_object_t *)0);
|
|
||||||
omapi_disconnect (p -> outer, 1);
|
|
@ -1,12 +0,0 @@
|
|||||||
diff -up dhcp-4.2.0/configure.ac.ldap dhcp-4.2.0/configure.ac
|
|
||||||
--- dhcp-4.2.0/configure.ac.ldap 2010-07-10 05:25:51.000000000 +0200
|
|
||||||
+++ dhcp-4.2.0/configure.ac 2010-07-21 13:06:20.000000000 +0200
|
|
||||||
@@ -521,6 +521,8 @@ AC_ARG_WITH(ldapcrypto,
|
|
||||||
if test x$ldap = xyes || test x$ldapcrypto = xyes ; then
|
|
||||||
AC_SEARCH_LIBS(ldap_initialize, [ldap], ,
|
|
||||||
AC_MSG_FAILURE([*** Cannot find ldap_initialize with -lldap - do you need to install an OpenLDAP2 Devel package?]))
|
|
||||||
+ AC_SEARCH_LIBS(ber_pvt_opt_on, [lber], ,
|
|
||||||
+ AC_MSG_FAILURE([*** Cannot find ber_pvt_opt_on with -llber - do you need to install an OpenLDAP2 Devel package?]))
|
|
||||||
|
|
||||||
if test x$ldapcrypto = xyes ; then
|
|
||||||
AC_SUBST(LDAP_CFLAGS, ["-DLDAP_CONFIGURATION -DLDAP_USE_SSL"])
|
|
@ -1,6 +1,6 @@
|
|||||||
diff -up dhcp-4.2.1b1/bind/Makefile.PIE-RELRO dhcp-4.2.1b1/bind/Makefile
|
diff -up dhcp-4.2.1rc1/bind/Makefile.PIE-RELRO dhcp-4.2.1rc1/bind/Makefile
|
||||||
--- dhcp-4.2.1b1/bind/Makefile.PIE-RELRO 2011-01-21 01:11:42.000000000 +0100
|
--- dhcp-4.2.1rc1/bind/Makefile.PIE-RELRO 2011-02-18 20:59:02.000000000 +0100
|
||||||
+++ dhcp-4.2.1b1/bind/Makefile 2011-01-28 08:50:13.000000000 +0100
|
+++ dhcp-4.2.1rc1/bind/Makefile 2011-02-23 10:56:35.000000000 +0100
|
||||||
@@ -45,7 +45,7 @@ all:
|
@@ -45,7 +45,7 @@ all:
|
||||||
# Currently disable the epoll and devpoll options as they don't interact
|
# Currently disable the epoll and devpoll options as they don't interact
|
||||||
# well with the DHCP code.
|
# well with the DHCP code.
|
||||||
@ -10,9 +10,9 @@ diff -up dhcp-4.2.1b1/bind/Makefile.PIE-RELRO dhcp-4.2.1b1/bind/Makefile
|
|||||||
|
|
||||||
# Build the export libraries
|
# Build the export libraries
|
||||||
@echo Building BIND Export libraries - this takes some time.
|
@echo Building BIND Export libraries - this takes some time.
|
||||||
diff -up dhcp-4.2.1b1/client/Makefile.am.PIE-RELRO dhcp-4.2.1b1/client/Makefile.am
|
diff -up dhcp-4.2.1rc1/client/Makefile.am.PIE-RELRO dhcp-4.2.1rc1/client/Makefile.am
|
||||||
--- dhcp-4.2.1b1/client/Makefile.am.PIE-RELRO 2011-01-28 08:47:43.000000000 +0100
|
--- dhcp-4.2.1rc1/client/Makefile.am.PIE-RELRO 2011-02-23 10:56:35.000000000 +0100
|
||||||
+++ dhcp-4.2.1b1/client/Makefile.am 2011-01-28 08:51:57.000000000 +0100
|
+++ dhcp-4.2.1rc1/client/Makefile.am 2011-02-23 10:56:35.000000000 +0100
|
||||||
@@ -4,15 +4,11 @@ dhclient_SOURCES = clparse.c dhclient.c
|
@@ -4,15 +4,11 @@ dhclient_SOURCES = clparse.c dhclient.c
|
||||||
scripts/bsdos scripts/freebsd scripts/linux scripts/macos \
|
scripts/bsdos scripts/freebsd scripts/linux scripts/macos \
|
||||||
scripts/netbsd scripts/nextstep scripts/openbsd \
|
scripts/netbsd scripts/nextstep scripts/openbsd \
|
||||||
@ -33,18 +33,19 @@ diff -up dhcp-4.2.1b1/client/Makefile.am.PIE-RELRO dhcp-4.2.1b1/client/Makefile.
|
|||||||
-dhc6.o: dhc6.c
|
-dhc6.o: dhc6.c
|
||||||
- $(COMPILE) -DCLIENT_PATH='"PATH=$(sbindir):/sbin:/bin:/usr/sbin:/usr/bin"' \
|
- $(COMPILE) -DCLIENT_PATH='"PATH=$(sbindir):/sbin:/bin:/usr/sbin:/usr/bin"' \
|
||||||
- -DLOCALSTATEDIR='"$(localstatedir)"' -c dhc6.c
|
- -DLOCALSTATEDIR='"$(localstatedir)"' -c dhc6.c
|
||||||
diff -up dhcp-4.2.1b1/common/Makefile.am.PIE-RELRO dhcp-4.2.1b1/common/Makefile.am
|
diff -up dhcp-4.2.1rc1/common/Makefile.am.PIE-RELRO dhcp-4.2.1rc1/common/Makefile.am
|
||||||
--- dhcp-4.2.1b1/common/Makefile.am.PIE-RELRO 2009-10-28 05:12:29.000000000 +0100
|
--- dhcp-4.2.1rc1/common/Makefile.am.PIE-RELRO 2011-02-18 19:44:42.000000000 +0100
|
||||||
+++ dhcp-4.2.1b1/common/Makefile.am 2011-01-28 08:47:43.000000000 +0100
|
+++ dhcp-4.2.1rc1/common/Makefile.am 2011-02-23 10:59:39.000000000 +0100
|
||||||
@@ -1,4 +1,5 @@
|
@@ -1,5 +1,5 @@
|
||||||
AM_CPPFLAGS = -I.. -DLOCALSTATEDIR='"@localstatedir@"'
|
AM_CPPFLAGS = -I.. -DLOCALSTATEDIR='"@localstatedir@"'
|
||||||
+AM_CFLAGS = -fpic
|
-AM_CFLAGS = $(LDAP_CFLAGS)
|
||||||
|
+AM_CFLAGS = $(LDAP_CFLAGS) -fpic
|
||||||
|
|
||||||
noinst_LIBRARIES = libdhcp.a
|
noinst_LIBRARIES = libdhcp.a
|
||||||
libdhcp_a_SOURCES = alloc.c bpf.c comapi.c conflex.c ctrace.c discover.c \
|
libdhcp_a_SOURCES = alloc.c bpf.c comapi.c conflex.c ctrace.c discover.c \
|
||||||
diff -up dhcp-4.2.1b1/omapip/Makefile.am.PIE-RELRO dhcp-4.2.1b1/omapip/Makefile.am
|
diff -up dhcp-4.2.1rc1/omapip/Makefile.am.PIE-RELRO dhcp-4.2.1rc1/omapip/Makefile.am
|
||||||
--- dhcp-4.2.1b1/omapip/Makefile.am.PIE-RELRO 2010-02-12 01:13:54.000000000 +0100
|
--- dhcp-4.2.1rc1/omapip/Makefile.am.PIE-RELRO 2010-02-12 01:13:54.000000000 +0100
|
||||||
+++ dhcp-4.2.1b1/omapip/Makefile.am 2011-01-28 08:47:43.000000000 +0100
|
+++ dhcp-4.2.1rc1/omapip/Makefile.am 2011-02-23 10:56:35.000000000 +0100
|
||||||
@@ -1,3 +1,5 @@
|
@@ -1,3 +1,5 @@
|
||||||
+AM_CFLAGS = -fpic
|
+AM_CFLAGS = -fpic
|
||||||
+
|
+
|
||||||
@ -58,9 +59,9 @@ diff -up dhcp-4.2.1b1/omapip/Makefile.am.PIE-RELRO dhcp-4.2.1b1/omapip/Makefile.
|
|||||||
+svtest_CFLAGS = -fpie
|
+svtest_CFLAGS = -fpie
|
||||||
svtest_LDADD = libomapi.a ../bind/lib/libdns.a ../bind/lib/libisc.a
|
svtest_LDADD = libomapi.a ../bind/lib/libdns.a ../bind/lib/libisc.a
|
||||||
|
|
||||||
diff -up dhcp-4.2.1b1/relay/Makefile.am.PIE-RELRO dhcp-4.2.1b1/relay/Makefile.am
|
diff -up dhcp-4.2.1rc1/relay/Makefile.am.PIE-RELRO dhcp-4.2.1rc1/relay/Makefile.am
|
||||||
--- dhcp-4.2.1b1/relay/Makefile.am.PIE-RELRO 2009-10-28 05:12:30.000000000 +0100
|
--- dhcp-4.2.1rc1/relay/Makefile.am.PIE-RELRO 2009-10-28 05:12:30.000000000 +0100
|
||||||
+++ dhcp-4.2.1b1/relay/Makefile.am 2011-01-28 08:47:43.000000000 +0100
|
+++ dhcp-4.2.1rc1/relay/Makefile.am 2011-02-23 10:56:35.000000000 +0100
|
||||||
@@ -2,8 +2,11 @@ AM_CPPFLAGS = -DLOCALSTATEDIR='"@localst
|
@@ -2,8 +2,11 @@ AM_CPPFLAGS = -DLOCALSTATEDIR='"@localst
|
||||||
|
|
||||||
sbin_PROGRAMS = dhcrelay
|
sbin_PROGRAMS = dhcrelay
|
||||||
@ -73,9 +74,9 @@ diff -up dhcp-4.2.1b1/relay/Makefile.am.PIE-RELRO dhcp-4.2.1b1/relay/Makefile.am
|
|||||||
man_MANS = dhcrelay.8
|
man_MANS = dhcrelay.8
|
||||||
EXTRA_DIST = $(man_MANS)
|
EXTRA_DIST = $(man_MANS)
|
||||||
|
|
||||||
diff -up dhcp-4.2.1b1/server/Makefile.am.PIE-RELRO dhcp-4.2.1b1/server/Makefile.am
|
diff -up dhcp-4.2.1rc1/server/Makefile.am.PIE-RELRO dhcp-4.2.1rc1/server/Makefile.am
|
||||||
--- dhcp-4.2.1b1/server/Makefile.am.PIE-RELRO 2010-03-24 22:49:47.000000000 +0100
|
--- dhcp-4.2.1rc1/server/Makefile.am.PIE-RELRO 2010-03-24 22:49:47.000000000 +0100
|
||||||
+++ dhcp-4.2.1b1/server/Makefile.am 2011-01-28 08:47:43.000000000 +0100
|
+++ dhcp-4.2.1rc1/server/Makefile.am 2011-02-23 10:56:35.000000000 +0100
|
||||||
@@ -6,10 +6,11 @@ dhcpd_SOURCES = dhcpd.c dhcp.c bootp.c c
|
@@ -6,10 +6,11 @@ dhcpd_SOURCES = dhcpd.c dhcp.c bootp.c c
|
||||||
omapi.c mdb.c stables.c salloc.c ddns.c dhcpleasequery.c \
|
omapi.c mdb.c stables.c salloc.c ddns.c dhcpleasequery.c \
|
||||||
dhcpv6.c mdb6.c ldap.c ldap_casa.c
|
dhcpv6.c mdb6.c ldap.c ldap_casa.c
|
||||||
|
@ -145,6 +145,18 @@ diff -up dhcp-4.2.1b1/client/dhclient.conf.5.man dhcp-4.2.1b1/client/dhclient.co
|
|||||||
require subnet-mask, domain-name-servers;
|
require subnet-mask, domain-name-servers;
|
||||||
script "CLIENTBINDIR/dhclient-script";
|
script "CLIENTBINDIR/dhclient-script";
|
||||||
media "media 10baseT/UTP", "media 10base2/BNC";
|
media "media 10baseT/UTP", "media 10base2/BNC";
|
||||||
|
diff -up dhcp-4.2.1b1/client/dhclient.leases.5.man dhcp-4.2.1b1/client/dhclient.leases.5
|
||||||
|
--- dhcp-4.2.1b1/client/dhclient.leases.5.man 2010-07-06 21:03:11.000000000 +0200
|
||||||
|
+++ dhcp-4.2.1b1/client/dhclient.leases.5 2011-02-09 12:01:48.000000000 +0100
|
||||||
|
@@ -39,7 +39,7 @@ database of leases that it has acquired
|
||||||
|
database is a free-form ASCII file containing one valid declaration
|
||||||
|
per lease. If more than one declaration appears for a given lease,
|
||||||
|
the last one in the file is used. The file is written as a log, so
|
||||||
|
-this is not an unusual occurrance.
|
||||||
|
+this is not an unusual occurrence.
|
||||||
|
.PP
|
||||||
|
The format of the lease declarations is described in
|
||||||
|
.B dhclient.conf(5).
|
||||||
diff -up dhcp-4.2.1b1/client/dhclient-script.8.man dhcp-4.2.1b1/client/dhclient-script.8
|
diff -up dhcp-4.2.1b1/client/dhclient-script.8.man dhcp-4.2.1b1/client/dhclient-script.8
|
||||||
--- dhcp-4.2.1b1/client/dhclient-script.8.man 2010-07-06 21:03:11.000000000 +0200
|
--- dhcp-4.2.1b1/client/dhclient-script.8.man 2010-07-06 21:03:11.000000000 +0200
|
||||||
+++ dhcp-4.2.1b1/client/dhclient-script.8 2011-01-27 18:24:44.000000000 +0100
|
+++ dhcp-4.2.1b1/client/dhclient-script.8 2011-01-27 18:24:44.000000000 +0100
|
||||||
|
23
dhcp.spec
23
dhcp.spec
@ -7,7 +7,7 @@
|
|||||||
# Patch version
|
# Patch version
|
||||||
#%global patchver P2
|
#%global patchver P2
|
||||||
# Pre-Release version
|
# Pre-Release version
|
||||||
%global prever b1
|
%global prever rc1
|
||||||
|
|
||||||
#%define VERSION %{version}-%{patchver}
|
#%define VERSION %{version}-%{patchver}
|
||||||
%global VERSION %{version}%{prever}
|
%global VERSION %{version}%{prever}
|
||||||
@ -15,7 +15,7 @@
|
|||||||
Summary: Dynamic host configuration protocol software
|
Summary: Dynamic host configuration protocol software
|
||||||
Name: dhcp
|
Name: dhcp
|
||||||
Version: 4.2.1
|
Version: 4.2.1
|
||||||
Release: 0.5.%{prever}%{?dist}
|
Release: 0.6.%{prever}%{?dist}
|
||||||
# NEVER CHANGE THE EPOCH on this package. The previous maintainer (prior to
|
# NEVER CHANGE THE EPOCH on this package. The previous maintainer (prior to
|
||||||
# dcantrell maintaining the package) made incorrect use of the epoch and
|
# dcantrell maintaining the package) made incorrect use of the epoch and
|
||||||
# that's why it is at 12 now. It should have never been used, but it was.
|
# that's why it is at 12 now. It should have never been used, but it was.
|
||||||
@ -42,7 +42,6 @@ Patch1: dhcp-4.2.0-options.patch
|
|||||||
Patch2: dhcp-4.2.0-release-by-ifup.patch
|
Patch2: dhcp-4.2.0-release-by-ifup.patch
|
||||||
Patch3: dhcp-4.2.0-dhclient-decline-backoff.patch
|
Patch3: dhcp-4.2.0-dhclient-decline-backoff.patch
|
||||||
Patch4: dhcp-4.2.0-unicast-bootp.patch
|
Patch4: dhcp-4.2.0-unicast-bootp.patch
|
||||||
Patch5: dhcp-4.2.0-ldap.patch
|
|
||||||
Patch6: dhcp-4.2.0-dhclient-usage.patch
|
Patch6: dhcp-4.2.0-dhclient-usage.patch
|
||||||
Patch7: dhcp-4.2.0-default-requested-options.patch
|
Patch7: dhcp-4.2.0-default-requested-options.patch
|
||||||
Patch8: dhcp-4.2.0-xen-checksum.patch
|
Patch8: dhcp-4.2.0-xen-checksum.patch
|
||||||
@ -68,8 +67,6 @@ Patch28: dhcp-4.2.0-noprefixavail.patch
|
|||||||
Patch29: dhcp420-rh637017.patch
|
Patch29: dhcp420-rh637017.patch
|
||||||
Patch30: dhcp420-sharedlib.patch
|
Patch30: dhcp420-sharedlib.patch
|
||||||
Patch31: dhcp-4.2.0-PPP.patch
|
Patch31: dhcp-4.2.0-PPP.patch
|
||||||
Patch32: dhcp-4.2.0-P2-omapi.patch
|
|
||||||
Patch33: dhcp-4.2.0-P2-ldap-configuration.patch
|
|
||||||
|
|
||||||
BuildRequires: autoconf
|
BuildRequires: autoconf
|
||||||
BuildRequires: automake
|
BuildRequires: automake
|
||||||
@ -94,7 +91,7 @@ Provides: dhcpv6 = 2.0.0alpha4-2
|
|||||||
|
|
||||||
# In _docdir we ship some perl scripts and module from contrib subdirectory.
|
# In _docdir we ship some perl scripts and module from contrib subdirectory.
|
||||||
# Because nothing under _docdir is allowed to "require" anything,
|
# Because nothing under _docdir is allowed to "require" anything,
|
||||||
# preventing anything under _docdir from being scanned. (#674058)
|
# prevent _docdir from being scanned. (#674058)
|
||||||
%filter_requires_in %{_docdir}
|
%filter_requires_in %{_docdir}
|
||||||
%filter_setup
|
%filter_setup
|
||||||
|
|
||||||
@ -197,9 +194,6 @@ rm bind/bind.tar.gz
|
|||||||
# (Submitted to dhcp-bugs@isc.org - [ISC-Bugs #19146])
|
# (Submitted to dhcp-bugs@isc.org - [ISC-Bugs #19146])
|
||||||
%patch4 -p1 -b .unicast
|
%patch4 -p1 -b .unicast
|
||||||
|
|
||||||
# Search for liblber in configure.ac (#564810)
|
|
||||||
%patch5 -p1 -b .ldap
|
|
||||||
|
|
||||||
# Update the usage screen for dhclient(8) indicating new options
|
# Update the usage screen for dhclient(8) indicating new options
|
||||||
# Use printf() rather than log_info() to display the information
|
# Use printf() rather than log_info() to display the information
|
||||||
# Also, return EXIT_FAILURE when the usage() screen is displayed (stop parsing)
|
# Also, return EXIT_FAILURE when the usage() screen is displayed (stop parsing)
|
||||||
@ -302,13 +296,6 @@ rm bind/bind.tar.gz
|
|||||||
# DHCPv6 over PPP support (#626514)
|
# DHCPv6 over PPP support (#626514)
|
||||||
%patch31 -p1 -b .PPP
|
%patch31 -p1 -b .PPP
|
||||||
|
|
||||||
# Fix OMAPI (#666441)
|
|
||||||
%patch32 -p1 -b .omapi
|
|
||||||
|
|
||||||
# Fix loading of configuration when LDAP is used (#668276)
|
|
||||||
# (Submitted to dhcp-bugs@isc.org - [ISC-Bugs #22888])
|
|
||||||
%patch33 -p1 -b .ldap-configuration
|
|
||||||
|
|
||||||
# Copy in the Fedora/RHEL dhclient script
|
# Copy in the Fedora/RHEL dhclient script
|
||||||
%{__install} -p -m 0755 %{SOURCE4} client/scripts/linux
|
%{__install} -p -m 0755 %{SOURCE4} client/scripts/linux
|
||||||
%{__install} -p -m 0644 %{SOURCE5} .
|
%{__install} -p -m 0644 %{SOURCE5} .
|
||||||
@ -642,6 +629,10 @@ fi
|
|||||||
%attr(0644,root,root) %{_mandir}/man3/omapi.3.gz
|
%attr(0644,root,root) %{_mandir}/man3/omapi.3.gz
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Feb 23 2011 Jiri Popelka <jpopelka@redhat.com> - 12:4.2.1-0.6.rc1
|
||||||
|
- 4.2.1rc1
|
||||||
|
- Fixed typo in dhclient.leases(5) (#676284)
|
||||||
|
|
||||||
* Mon Feb 21 2011 Adam Tkac <atkac redhat com> - 12:4.2.1-0.5.b1
|
* Mon Feb 21 2011 Adam Tkac <atkac redhat com> - 12:4.2.1-0.5.b1
|
||||||
- rebuild against new bind-libs-lite
|
- rebuild against new bind-libs-lite
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user