- Install libdhcp_control.h to /usr/include/isc-dhcp/libdhcp_control.h

- Update libdhcp4client patch to use new libdhcp_control.h location
- Remove __fedora_contrib/ subdirectory in /usr/share/doc/dhcp-3.1.0,
    install those docs to /usr/share/doc/dhcp-3.1.0
This commit is contained in:
David Cantrell 2007-10-24 19:22:41 +00:00
parent cf6e8aca85
commit adafcc2149
5 changed files with 72 additions and 52 deletions

View File

@ -50,7 +50,7 @@ DHCP_HEADERS = dhcpd.h cdefs.h osdep.h arpa/nameser.h minires/minires.h \
minires/res_update.h omapip/convert.h omapip/hash.h \ minires/res_update.h omapip/convert.h omapip/hash.h \
omapip/trace.h omapip/trace.h
HDRS = dhcp4client.h libdhcp_control.h HDRS = dhcp4client.h
SRCS = $(COMMON_SRCS) $(CLIENT_SRCS) SRCS = $(COMMON_SRCS) $(CLIENT_SRCS)
OBJS = $(SRCS:.c=.o) OBJS = $(SRCS:.c=.o)
@ -65,7 +65,6 @@ install: all
ln -sf libdhcp4client-$(VER).so.0 $(DESTDIR)/$(LIBDIR)/libdhcp4client.so ln -sf libdhcp4client-$(VER).so.0 $(DESTDIR)/$(LIBDIR)/libdhcp4client.so
install -p -m 0644 -D libdhcp4client.a $(DESTDIR)$(LIBDIR)/libdhcp4client.a install -p -m 0644 -D libdhcp4client.a $(DESTDIR)$(LIBDIR)/libdhcp4client.a
install -p -m 0644 -D dhcp4client.h $(DESTDIR)$(INCDIR)/dhcp4client/dhcp4client.h install -p -m 0644 -D dhcp4client.h $(DESTDIR)$(INCDIR)/dhcp4client/dhcp4client.h
install -p -m 0644 -D libdhcp_control.h $(DESTDIR)$(INCDIR)/dhcp4client/libdhcp_control.h
for hdr in $(DHCP_HEADERS) ; do \ for hdr in $(DHCP_HEADERS) ; do \
install -p -m 0644 -D $(TOP)/includes/$${hdr} $(DESTDIR)$(INCDIR)/dhcp4client/$${hdr} ; \ install -p -m 0644 -D $(TOP)/includes/$${hdr} $(DESTDIR)$(INCDIR)/dhcp4client/$${hdr} ; \
done done

View File

@ -1,6 +1,6 @@
diff -up dhcp-3.1.0/omapip/dispatch.c.libdhcp4client dhcp-3.1.0/omapip/dispatch.c diff -up dhcp-3.1.0/omapip/dispatch.c.libdhcp4client dhcp-3.1.0/omapip/dispatch.c
--- dhcp-3.1.0/omapip/dispatch.c.libdhcp4client 2005-03-17 15:15:21.000000000 -0500 --- dhcp-3.1.0/omapip/dispatch.c.libdhcp4client 2005-03-17 15:15:21.000000000 -0500
+++ dhcp-3.1.0/omapip/dispatch.c 2007-10-22 16:00:15.000000000 -0400 +++ dhcp-3.1.0/omapip/dispatch.c 2007-10-24 14:55:56.000000000 -0400
@@ -34,7 +34,7 @@ @@ -34,7 +34,7 @@
#include <omapip/omapip_p.h> #include <omapip/omapip_p.h>
@ -11,14 +11,14 @@ diff -up dhcp-3.1.0/omapip/dispatch.c.libdhcp4client dhcp-3.1.0/omapip/dispatch.
OMAPI_OBJECT_ALLOC (omapi_io, OMAPI_OBJECT_ALLOC (omapi_io,
diff -up dhcp-3.1.0/omapip/errwarn.c.libdhcp4client dhcp-3.1.0/omapip/errwarn.c diff -up dhcp-3.1.0/omapip/errwarn.c.libdhcp4client dhcp-3.1.0/omapip/errwarn.c
--- dhcp-3.1.0/omapip/errwarn.c.libdhcp4client 2007-10-22 15:55:40.000000000 -0400 --- dhcp-3.1.0/omapip/errwarn.c.libdhcp4client 2007-10-24 14:55:56.000000000 -0400
+++ dhcp-3.1.0/omapip/errwarn.c 2007-10-22 16:00:30.000000000 -0400 +++ dhcp-3.1.0/omapip/errwarn.c 2007-10-24 14:57:16.000000000 -0400
@@ -39,6 +39,11 @@ static char copyright[] = @@ -39,6 +39,11 @@ static char copyright[] =
#include <omapip/omapip_p.h> #include <omapip/omapip_p.h>
#include <errno.h> #include <errno.h>
+#ifdef LIBDHCP +#ifdef LIBDHCP
+#include <libdhcp_control.h> +#include <isc-dhcp/libdhcp_control.h>
+extern LIBDHCP_Control *libdhcp_control; +extern LIBDHCP_Control *libdhcp_control;
+#endif +#endif
+ +
@ -132,7 +132,7 @@ diff -up dhcp-3.1.0/omapip/errwarn.c.libdhcp4client dhcp-3.1.0/omapip/errwarn.c
diff -up dhcp-3.1.0/omapip/alloc.c.libdhcp4client dhcp-3.1.0/omapip/alloc.c diff -up dhcp-3.1.0/omapip/alloc.c.libdhcp4client dhcp-3.1.0/omapip/alloc.c
--- dhcp-3.1.0/omapip/alloc.c.libdhcp4client 2006-02-24 18:16:30.000000000 -0500 --- dhcp-3.1.0/omapip/alloc.c.libdhcp4client 2006-02-24 18:16:30.000000000 -0500
+++ dhcp-3.1.0/omapip/alloc.c 2007-10-22 16:00:03.000000000 -0400 +++ dhcp-3.1.0/omapip/alloc.c 2007-10-24 14:55:56.000000000 -0400
@@ -40,6 +40,33 @@ static char copyright[] = @@ -40,6 +40,33 @@ static char copyright[] =
#include <omapip/omapip_p.h> #include <omapip/omapip_p.h>
@ -190,7 +190,7 @@ diff -up dhcp-3.1.0/omapip/alloc.c.libdhcp4client dhcp-3.1.0/omapip/alloc.c
#if defined (DEBUG_MEMORY_LEAKAGE) || defined (DEBUG_MALLOC_POOL) || \ #if defined (DEBUG_MEMORY_LEAKAGE) || defined (DEBUG_MALLOC_POOL) || \
diff -up dhcp-3.1.0/configure.libdhcp4client dhcp-3.1.0/configure diff -up dhcp-3.1.0/configure.libdhcp4client dhcp-3.1.0/configure
--- dhcp-3.1.0/configure.libdhcp4client 2005-03-17 15:14:55.000000000 -0500 --- dhcp-3.1.0/configure.libdhcp4client 2005-03-17 15:14:55.000000000 -0500
+++ dhcp-3.1.0/configure 2007-10-22 15:59:07.000000000 -0400 +++ dhcp-3.1.0/configure 2007-10-24 14:55:56.000000000 -0400
@@ -246,7 +246,7 @@ if [ ! -d $workname ]; then @@ -246,7 +246,7 @@ if [ ! -d $workname ]; then
fi fi
@ -202,7 +202,7 @@ diff -up dhcp-3.1.0/configure.libdhcp4client dhcp-3.1.0/configure
for foo in $dirs; do for foo in $dirs; do
diff -up dhcp-3.1.0/dst/hmac_link.c.libdhcp4client dhcp-3.1.0/dst/hmac_link.c diff -up dhcp-3.1.0/dst/hmac_link.c.libdhcp4client dhcp-3.1.0/dst/hmac_link.c
--- dhcp-3.1.0/dst/hmac_link.c.libdhcp4client 2001-02-22 02:22:08.000000000 -0500 --- dhcp-3.1.0/dst/hmac_link.c.libdhcp4client 2001-02-22 02:22:08.000000000 -0500
+++ dhcp-3.1.0/dst/hmac_link.c 2007-10-22 15:59:24.000000000 -0400 +++ dhcp-3.1.0/dst/hmac_link.c 2007-10-24 14:55:56.000000000 -0400
@@ -38,6 +38,10 @@ static const char rcsid[] = "$Header: /p @@ -38,6 +38,10 @@ static const char rcsid[] = "$Header: /p
#include "dst_internal.h" #include "dst_internal.h"
@ -290,7 +290,7 @@ diff -up dhcp-3.1.0/dst/hmac_link.c.libdhcp4client dhcp-3.1.0/dst/hmac_link.c
memset(dst_t_func[KEY_HMAC_MD5], 0, sizeof(struct dst_func)); memset(dst_t_func[KEY_HMAC_MD5], 0, sizeof(struct dst_func));
diff -up dhcp-3.1.0/common/discover.c.libdhcp4client dhcp-3.1.0/common/discover.c diff -up dhcp-3.1.0/common/discover.c.libdhcp4client dhcp-3.1.0/common/discover.c
--- dhcp-3.1.0/common/discover.c.libdhcp4client 2006-11-07 18:41:39.000000000 -0500 --- dhcp-3.1.0/common/discover.c.libdhcp4client 2006-11-07 18:41:39.000000000 -0500
+++ dhcp-3.1.0/common/discover.c 2007-10-22 15:58:09.000000000 -0400 +++ dhcp-3.1.0/common/discover.c 2007-10-24 14:55:56.000000000 -0400
@@ -121,6 +121,10 @@ isc_result_t interface_initialize (omapi @@ -121,6 +121,10 @@ isc_result_t interface_initialize (omapi
register that interface with the network I/O software, figure out what register that interface with the network I/O software, figure out what
subnet it's on, and add it to the list of interfaces. */ subnet it's on, and add it to the list of interfaces. */
@ -332,7 +332,7 @@ diff -up dhcp-3.1.0/common/discover.c.libdhcp4client dhcp-3.1.0/common/discover.
if (fallback_interface) { if (fallback_interface) {
diff -up dhcp-3.1.0/common/tree.c.libdhcp4client dhcp-3.1.0/common/tree.c diff -up dhcp-3.1.0/common/tree.c.libdhcp4client dhcp-3.1.0/common/tree.c
--- dhcp-3.1.0/common/tree.c.libdhcp4client 2007-02-14 17:41:22.000000000 -0500 --- dhcp-3.1.0/common/tree.c.libdhcp4client 2007-02-14 17:41:22.000000000 -0500
+++ dhcp-3.1.0/common/tree.c 2007-10-22 15:58:54.000000000 -0400 +++ dhcp-3.1.0/common/tree.c 2007-10-24 14:55:56.000000000 -0400
@@ -41,7 +41,7 @@ static char copyright[] = @@ -41,7 +41,7 @@ static char copyright[] =
#include <omapip/omapip_p.h> #include <omapip/omapip_p.h>
#include <ctype.h> #include <ctype.h>
@ -352,7 +352,7 @@ diff -up dhcp-3.1.0/common/tree.c.libdhcp4client dhcp-3.1.0/common/tree.c
struct data_string *result; struct data_string *result;
diff -up dhcp-3.1.0/common/options.c.libdhcp4client dhcp-3.1.0/common/options.c diff -up dhcp-3.1.0/common/options.c.libdhcp4client dhcp-3.1.0/common/options.c
--- dhcp-3.1.0/common/options.c.libdhcp4client 2007-05-23 15:26:22.000000000 -0400 --- dhcp-3.1.0/common/options.c.libdhcp4client 2007-05-23 15:26:22.000000000 -0400
+++ dhcp-3.1.0/common/options.c 2007-10-22 15:58:39.000000000 -0400 +++ dhcp-3.1.0/common/options.c 2007-10-24 14:55:56.000000000 -0400
@@ -2501,6 +2501,7 @@ int fqdn_option_space_encapsulate (resul @@ -2501,6 +2501,7 @@ int fqdn_option_space_encapsulate (resul
return 1; return 1;
} }
@ -362,8 +362,8 @@ diff -up dhcp-3.1.0/common/options.c.libdhcp4client dhcp-3.1.0/common/options.c
struct client_state *client_state, struct client_state *client_state,
struct option_state *in_options, struct option_state *in_options,
diff -up dhcp-3.1.0/common/dispatch.c.libdhcp4client dhcp-3.1.0/common/dispatch.c diff -up dhcp-3.1.0/common/dispatch.c.libdhcp4client dhcp-3.1.0/common/dispatch.c
--- dhcp-3.1.0/common/dispatch.c.libdhcp4client 2007-10-22 15:55:40.000000000 -0400 --- dhcp-3.1.0/common/dispatch.c.libdhcp4client 2007-10-24 14:55:56.000000000 -0400
+++ dhcp-3.1.0/common/dispatch.c 2007-10-22 15:58:24.000000000 -0400 +++ dhcp-3.1.0/common/dispatch.c 2007-10-24 14:55:56.000000000 -0400
@@ -39,8 +39,24 @@ static char copyright[] = @@ -39,8 +39,24 @@ static char copyright[] =
#include "dhcpd.h" #include "dhcpd.h"
@ -635,7 +635,7 @@ diff -up dhcp-3.1.0/common/dispatch.c.libdhcp4client dhcp-3.1.0/common/dispatch.
} }
diff -up dhcp-3.1.0/common/alloc.c.libdhcp4client dhcp-3.1.0/common/alloc.c diff -up dhcp-3.1.0/common/alloc.c.libdhcp4client dhcp-3.1.0/common/alloc.c
--- dhcp-3.1.0/common/alloc.c.libdhcp4client 2006-06-01 16:23:17.000000000 -0400 --- dhcp-3.1.0/common/alloc.c.libdhcp4client 2006-06-01 16:23:17.000000000 -0400
+++ dhcp-3.1.0/common/alloc.c 2007-10-22 15:57:53.000000000 -0400 +++ dhcp-3.1.0/common/alloc.c 2007-10-24 14:55:56.000000000 -0400
@@ -1013,7 +1013,11 @@ int executable_statement_reference (ptr, @@ -1013,7 +1013,11 @@ int executable_statement_reference (ptr,
return 1; return 1;
} }
@ -649,8 +649,8 @@ diff -up dhcp-3.1.0/common/alloc.c.libdhcp4client dhcp-3.1.0/common/alloc.c
#if defined (DEBUG_MEMORY_LEAKAGE) || \ #if defined (DEBUG_MEMORY_LEAKAGE) || \
defined (DEBUG_MEMORY_LEAKAGE_ON_EXIT) defined (DEBUG_MEMORY_LEAKAGE_ON_EXIT)
diff -up dhcp-3.1.0/includes/dhcpd.h.libdhcp4client dhcp-3.1.0/includes/dhcpd.h diff -up dhcp-3.1.0/includes/dhcpd.h.libdhcp4client dhcp-3.1.0/includes/dhcpd.h
--- dhcp-3.1.0/includes/dhcpd.h.libdhcp4client 2007-10-22 15:55:40.000000000 -0400 --- dhcp-3.1.0/includes/dhcpd.h.libdhcp4client 2007-10-24 14:55:56.000000000 -0400
+++ dhcp-3.1.0/includes/dhcpd.h 2007-10-22 15:59:51.000000000 -0400 +++ dhcp-3.1.0/includes/dhcpd.h 2007-10-24 14:55:56.000000000 -0400
@@ -1000,14 +1000,6 @@ struct hardware_link { @@ -1000,14 +1000,6 @@ struct hardware_link {
typedef void (*tvref_t)(void *, void *, const char *, int); typedef void (*tvref_t)(void *, void *, const char *, int);
@ -675,8 +675,8 @@ diff -up dhcp-3.1.0/includes/dhcpd.h.libdhcp4client dhcp-3.1.0/includes/dhcpd.h
#if defined (TRACING) #if defined (TRACING)
trace_type_t *interface_trace; trace_type_t *interface_trace;
diff -up dhcp-3.1.0/client/dhclient.c.libdhcp4client dhcp-3.1.0/client/dhclient.c diff -up dhcp-3.1.0/client/dhclient.c.libdhcp4client dhcp-3.1.0/client/dhclient.c
--- dhcp-3.1.0/client/dhclient.c.libdhcp4client 2007-10-22 15:55:40.000000000 -0400 --- dhcp-3.1.0/client/dhclient.c.libdhcp4client 2007-10-24 14:55:56.000000000 -0400
+++ dhcp-3.1.0/client/dhclient.c 2007-10-22 16:08:09.000000000 -0400 +++ dhcp-3.1.0/client/dhclient.c 2007-10-24 14:56:20.000000000 -0400
@@ -82,14 +82,50 @@ int quiet=0; @@ -82,14 +82,50 @@ int quiet=0;
int nowait=0; int nowait=0;
int bootp_broadcast_always = 0; int bootp_broadcast_always = 0;
@ -690,7 +690,7 @@ diff -up dhcp-3.1.0/client/dhclient.c.libdhcp4client dhcp-3.1.0/client/dhclient.
static void usage PROTO ((void)); static void usage PROTO ((void));
+#ifdef LIBDHCP +#ifdef LIBDHCP
+#include "libdhcp_control.h" +#include "isc-dhcp/libdhcp_control.h"
+LIBDHCP_Control *libdhcp_control; +LIBDHCP_Control *libdhcp_control;
+static void libdhcp_dispatch(void) +static void libdhcp_dispatch(void)
+{ +{
@ -1079,7 +1079,7 @@ diff -up dhcp-3.1.0/client/dhclient.c.libdhcp4client dhcp-3.1.0/client/dhclient.
diff -up dhcp-3.1.0/Makefile.dist.libdhcp4client dhcp-3.1.0/Makefile.dist diff -up dhcp-3.1.0/Makefile.dist.libdhcp4client dhcp-3.1.0/Makefile.dist
--- dhcp-3.1.0/Makefile.dist.libdhcp4client 2005-03-17 15:14:54.000000000 -0500 --- dhcp-3.1.0/Makefile.dist.libdhcp4client 2005-03-17 15:14:54.000000000 -0500
+++ dhcp-3.1.0/Makefile.dist 2007-10-22 15:57:26.000000000 -0400 +++ dhcp-3.1.0/Makefile.dist 2007-10-24 14:55:56.000000000 -0400
@@ -22,7 +22,7 @@ @@ -22,7 +22,7 @@
# http://www.isc.org/ # http://www.isc.org/

View File

@ -13,7 +13,7 @@
Summary: DHCP (Dynamic Host Configuration Protocol) server and relay agent Summary: DHCP (Dynamic Host Configuration Protocol) server and relay agent
Name: dhcp Name: dhcp
Version: 3.1.0 Version: 3.1.0
Release: 3%{?dist} Release: 4%{?dist}
# NEVER CHANGE THE EPOCH on this package. The previous maintainer made # NEVER CHANGE THE EPOCH on this package. The previous maintainer made
# incorrect use of the epoch and that's why it is at 12 now. It should have # incorrect use of the epoch and that's why it is at 12 now. It should have
# never been used, but it was. So we are stuck with it. # never been used, but it was. So we are stuck with it.
@ -251,7 +251,9 @@ libdhcp4client.
%{__mkdir} -p libdhcp4client %{__mkdir} -p libdhcp4client
%{__install} -p -m 0644 %SOURCE10 libdhcp4client %{__install} -p -m 0644 %SOURCE10 libdhcp4client
%{__install} -p -m 0644 %SOURCE11 libdhcp4client %{__install} -p -m 0644 %SOURCE11 libdhcp4client
%{__install} -p -m 0644 %SOURCE12 libdhcp4client
# Copy in libdhcp_control.h to the isc-dhcp includes directory
%{__install} -p -m 0644 %SOURCE12 includes/isc-dhcp
# Ensure we don't pick up Perl as a dependency from the scripts and modules # Ensure we don't pick up Perl as a dependency from the scripts and modules
# in the contrib directory (we copy this to /usr/share/doc in the final # in the contrib directory (we copy this to /usr/share/doc in the final
@ -260,6 +262,7 @@ libdhcp4client.
%{__chmod} -x __fedora_contrib/3.0b1-lease-convert %{__chmod} -x __fedora_contrib/3.0b1-lease-convert
%{__chmod} -x __fedora_contrib/dhcpd-conf-to-ldap %{__chmod} -x __fedora_contrib/dhcpd-conf-to-ldap
%{__mv} __fedora_contrib/ms2isc/Registry.pm __fedora_contrib/ms2isc/Registry.perlmodule %{__mv} __fedora_contrib/ms2isc/Registry.pm __fedora_contrib/ms2isc/Registry.perlmodule
%{__rm} -f __fedora_contrib/dhcp.spec
# We want UNIX-style line endings # We want UNIX-style line endings
%{__sed} -i -e 's/\r//' __fedora_contrib/ms2isc/readme.txt %{__sed} -i -e 's/\r//' __fedora_contrib/ms2isc/readme.txt
@ -303,6 +306,7 @@ CC="%{__cc}" ./configure \
%{__mkdir} -p %{buildroot}%{_sysconfdir}/sysconfig %{__mkdir} -p %{buildroot}%{_sysconfdir}/sysconfig
%{__make} install DESTDIR=%{buildroot} %{__make} install DESTDIR=%{buildroot}
%{__install} -p -m 0644 %SOURCE12 %{buildroot}%{_includedir}/isc-dhcp
%{__mkdir} -p %{buildroot}%{_initrddir} %{__mkdir} -p %{buildroot}%{_initrddir}
%{__install} -p -m 0755 %SOURCE2 %{buildroot}%{_initrddir}/dhcpd %{__install} -p -m 0755 %SOURCE2 %{buildroot}%{_initrddir}/dhcpd
@ -373,7 +377,7 @@ fi
%files %files
%defattr(-,root,root,-) %defattr(-,root,root,-)
%doc README README.ldap RELNOTES dhcpd.conf.sample doc/IANA-arp-parameters %doc README README.ldap RELNOTES dhcpd.conf.sample doc/IANA-arp-parameters
%doc doc/IANA-arp-parameters doc/api+protocol doc/*.txt __fedora_contrib %doc doc/IANA-arp-parameters doc/api+protocol doc/*.txt __fedora_contrib/*
%dir %{_localstatedir}/lib/dhcpd %dir %{_localstatedir}/lib/dhcpd
%verify(not size md5 mtime) %config(noreplace) %{_localstatedir}/lib/dhcpd/dhcpd.leases %verify(not size md5 mtime) %config(noreplace) %{_localstatedir}/lib/dhcpd/dhcpd.leases
%config(noreplace) %{_sysconfdir}/sysconfig/dhcpd %config(noreplace) %{_sysconfdir}/sysconfig/dhcpd
@ -435,6 +439,12 @@ fi
%{_libdir}/libdhcp4client.a %{_libdir}/libdhcp4client.a
%changelog %changelog
* Wed Oct 24 2007 David Cantrell <dcantrell@redhat.com> - 12:3.1.0-4
- Install libdhcp_control.h to /usr/include/isc-dhcp/libdhcp_control.h
- Update libdhcp4client patch to use new libdhcp_control.h location
- Remove __fedora_contrib/ subdirectory in /usr/share/doc/dhcp-3.1.0,
install those docs to /usr/share/doc/dhcp-3.1.0
* Wed Oct 24 2007 David Cantrell <dcantrell@redhat.com> - 12:3.1.0-3 * Wed Oct 24 2007 David Cantrell <dcantrell@redhat.com> - 12:3.1.0-3
- Remove ISC.Cflags variable from libdhcp4client.pc - Remove ISC.Cflags variable from libdhcp4client.pc

View File

@ -1,24 +1,29 @@
/* dhcp4client.h /* dhcp4client.h
* *
* Interface to the ISC dhcp IPv4 client libdhcp4client library. * Interface to the ISC dhcp IPv4 client libdhcp4client library.
* *
* Copyright (C) 2006 Red Hat, Inc. All rights reserved.
* *
* Copyright(C) Jason Vas Dias <jvdias@redhat.com> Red Hat Inc. May 2006 * This copyrighted material is made available to anyone wishing to use,
* modify, copy, or redistribute it subject to the terms and conditions of
* the GNU General Public License v.2, or (at your option) any later version.
* This program is distributed in the hope that it will be useful, but WITHOUT
* ANY WARRANTY expressed or implied, including the implied warranties of
* MERCHANTABILITY or FITNESS FOR A * PARTICULAR PURPOSE. See the GNU General
* Public License for more details. You should have received a copy of the
* GNU General Public License along with this program; if not, write to the
* Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA
* 02110-1301, USA. Any Red Hat trademarks that are incorporated in the
* source code or documentation are not subject to the GNU General Public
* License and may only be used or replicated with the express permission of
* Red Hat, Inc.
* *
* This program is free software; you can redistribute it and/or modify * Red Hat Author(s): Jason Vas Dias
* it under the terms of the GNU General Public License as published by * David Cantrell
* the Free Software Foundation at
* http://www.fsf.org/licensing/licenses/gpl.txt
* and included in this software distribution as the "LICENSE" file.
*
* This program is distributed in the hope that it will be useful,
* but WITHOUT ANY WARRANTY; without even the implied warranty of
* MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
* GNU General Public License for more details.
*/ */
/* include libdhcp_control.h or libdhcp.h for this */ /* include libdhcp_control.h or libdhcp.h for this */
struct libdhcp_control_s; extern struct libdhcp_control_s;
/* The ISC IPv4 DHCP client main() function */ /* The ISC IPv4 DHCP client main() function */
extern int dhcpv4_client(struct libdhcp_control_s *dhc_ctl, extern int dhcpv4_client(struct libdhcp_control_s *dhc_ctl,

View File

@ -1,24 +1,30 @@
/* libdhcp_control.h /* libdhcp_control.h
* *
* DHCP client control API for libdhcp, a minimal interface to the * DHCP client control API for libdhcp, a minimal interface to the
* ISC dhcp IPv4 client libdhcp4client library, * ISC dhcp IPv4 client libdhcp4client library,
* and to the dhcpv6 DHCPv6 client libdhcp6client library. * and to the dhcpv6 DHCPv6 client libdhcp6client library.
* *
* Each DHCP client library must include this file to be controlled * Each DHCP client library must include this file to be controlled
* by libdhcp. * by libdhcp.
* *
* Copyright(C) Jason Vas Dias <jvdias@redhat.com> Red Hat Inc. May 2006 * Copyright (C) 2006 Red Hat, Inc. All rights reserved.
* *
* This program is free software; you can redistribute it and/or modify * This copyrighted material is made available to anyone wishing to use,
* it under the terms of the GNU General Public License as published by * modify, copy, or redistribute it subject to the terms and conditions of
* the Free Software Foundation at * the GNU General Public License v.2, or (at your option) any later version.
* http://www.fsf.org/licensing/licenses/gpl.txt * This program is distributed in the hope that it will be useful, but WITHOUT
* and included in this software distribution as the "LICENSE" file. * ANY WARRANTY expressed or implied, including the implied warranties of
* MERCHANTABILITY or FITNESS FOR A * PARTICULAR PURPOSE. See the GNU General
* Public License for more details. You should have received a copy of the
* GNU General Public License along with this program; if not, write to the
* Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA
* 02110-1301, USA. Any Red Hat trademarks that are incorporated in the
* source code or documentation are not subject to the GNU General Public
* License and may only be used or replicated with the express permission of
* Red Hat, Inc.
* *
* This program is distributed in the hope that it will be useful, * Red Hat Author(s): Jason Vas Dias
* but WITHOUT ANY WARRANTY; without even the implied warranty of * David Cantrell
* MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
* GNU General Public License for more details.
*/ */
#ifndef LIBDHCP_CONTROL_H #ifndef LIBDHCP_CONTROL_H
#define LIBDHCP_CONTROL_H #define LIBDHCP_CONTROL_H