Fix OMAPI (#666441)
This commit is contained in:
parent
5d3b86d844
commit
a396b806f1
12
dhcp-4.2.0-P2-omapi.patch
Normal file
12
dhcp-4.2.0-P2-omapi.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -up dhcp-4.2.0-P2/omapip/protocol.c.omapi dhcp-4.2.0-P2/omapip/protocol.c
|
||||||
|
--- dhcp-4.2.0-P2/omapip/protocol.c.omapi 2009-11-20 02:49:02.000000000 +0100
|
||||||
|
+++ dhcp-4.2.0-P2/omapip/protocol.c 2011-01-03 16:30:25.000000000 +0100
|
||||||
|
@@ -386,7 +386,7 @@ isc_result_t omapi_protocol_signal_handl
|
||||||
|
/* Should only receive these when opening the initial authenticator. */
|
||||||
|
if (!strcmp (name, "status")) {
|
||||||
|
status = va_arg (ap, isc_result_t);
|
||||||
|
- if (status != ISC_R_SUCCESS) {
|
||||||
|
+ if ((status != ISC_R_SUCCESS) && (status >= ISC_RESULTCLASS_DHCP)) {
|
||||||
|
omapi_signal_in (h -> inner, "status", status,
|
||||||
|
(omapi_object_t *)0);
|
||||||
|
omapi_disconnect (p -> outer, 1);
|
11
dhcp.spec
11
dhcp.spec
@ -12,7 +12,7 @@
|
|||||||
Summary: Dynamic host configuration protocol software
|
Summary: Dynamic host configuration protocol software
|
||||||
Name: dhcp
|
Name: dhcp
|
||||||
Version: 4.2.0
|
Version: 4.2.0
|
||||||
Release: 24.%{patchver}%{?dist}
|
Release: 25.%{patchver}%{?dist}
|
||||||
# NEVER CHANGE THE EPOCH on this package. The previous maintainer (prior to
|
# NEVER CHANGE THE EPOCH on this package. The previous maintainer (prior to
|
||||||
# dcantrell maintaining the package) made incorrect use of the epoch and
|
# dcantrell maintaining the package) made incorrect use of the epoch and
|
||||||
# that's why it is at 12 now. It should have never been used, but it was.
|
# that's why it is at 12 now. It should have never been used, but it was.
|
||||||
@ -69,6 +69,7 @@ Patch31: dhcp-4.2.0-noprefixavail.patch
|
|||||||
Patch32: dhcp420-rh637017.patch
|
Patch32: dhcp420-rh637017.patch
|
||||||
Patch33: dhcp420-sharedlib.patch
|
Patch33: dhcp420-sharedlib.patch
|
||||||
Patch34: dhcp-4.2.0-PPP.patch
|
Patch34: dhcp-4.2.0-PPP.patch
|
||||||
|
Patch35: dhcp-4.2.0-P2-omapi.patch
|
||||||
|
|
||||||
BuildRequires: autoconf
|
BuildRequires: autoconf
|
||||||
BuildRequires: automake
|
BuildRequires: automake
|
||||||
@ -299,12 +300,17 @@ rm bind/bind.tar.gz
|
|||||||
# (Submitted to dhcp-bugs@isc.org - [ISC-Bugs #22676])
|
# (Submitted to dhcp-bugs@isc.org - [ISC-Bugs #22676])
|
||||||
%patch31 -p1 -b .noprefixavail
|
%patch31 -p1 -b .noprefixavail
|
||||||
|
|
||||||
|
# Fire away bundled BIND source.
|
||||||
%patch32 -p1 -b .rh637017
|
%patch32 -p1 -b .rh637017
|
||||||
|
#Build dhcp's libraries as shared libs instead of static libs.
|
||||||
%patch33 -p1 -b .sharedlib
|
%patch33 -p1 -b .sharedlib
|
||||||
|
|
||||||
# DHCPv6 over PPP support (#626514)
|
# DHCPv6 over PPP support (#626514)
|
||||||
%patch34 -p1 -b .PPP
|
%patch34 -p1 -b .PPP
|
||||||
|
|
||||||
|
# Fix OMAPI (#666441)
|
||||||
|
%patch35 -p1 -b .omapi
|
||||||
|
|
||||||
# Copy in the Fedora/RHEL dhclient script
|
# Copy in the Fedora/RHEL dhclient script
|
||||||
%{__install} -p -m 0755 %{SOURCE4} client/scripts/linux
|
%{__install} -p -m 0755 %{SOURCE4} client/scripts/linux
|
||||||
%{__install} -p -m 0644 %{SOURCE5} .
|
%{__install} -p -m 0644 %{SOURCE5} .
|
||||||
@ -652,6 +658,9 @@ fi
|
|||||||
%attr(0644,root,root) %{_mandir}/man3/omapi.3.gz
|
%attr(0644,root,root) %{_mandir}/man3/omapi.3.gz
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jan 03 2011 Jiri Popelka <jpopelka@redhat.com> - 12:4.2.0-25.P2
|
||||||
|
- Fix OMAPI (#666441)
|
||||||
|
|
||||||
* Tue Dec 21 2010 Jiri Popelka <jpopelka@redhat.com> - 12:4.2.0-24.P2
|
* Tue Dec 21 2010 Jiri Popelka <jpopelka@redhat.com> - 12:4.2.0-24.P2
|
||||||
- Provide default /etc/dhcp/dhclient.conf
|
- Provide default /etc/dhcp/dhclient.conf
|
||||||
- Client always sends dhcp-client-identifier (#560361)
|
- Client always sends dhcp-client-identifier (#560361)
|
||||||
|
Loading…
Reference in New Issue
Block a user