make it actually build
This commit is contained in:
parent
e83fb19c51
commit
9ca3958959
25
dhcp-430a1.patch
Normal file
25
dhcp-430a1.patch
Normal file
@ -0,0 +1,25 @@
|
|||||||
|
From ed7aa33898bfcf5a37f5b730897611a18f6a929b Mon Sep 17 00:00:00 2001
|
||||||
|
From: Jiri Popelka <jpopelka@redhat.com>
|
||||||
|
Date: Tue, 7 Jan 2014 12:13:46 +0100
|
||||||
|
Subject: [PATCH] missing comma in ldap.c
|
||||||
|
|
||||||
|
---
|
||||||
|
server/ldap.c | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/server/ldap.c b/server/ldap.c
|
||||||
|
index efbc874..2994106 100644
|
||||||
|
--- a/server/ldap.c
|
||||||
|
+++ b/server/ldap.c
|
||||||
|
@@ -628,7 +628,7 @@ ldap_start (void)
|
||||||
|
options = NULL;
|
||||||
|
option_state_allocate (&options, MDL);
|
||||||
|
|
||||||
|
- execute_statements_in_scope (NULL, NULL, NULL, NULL, NULL
|
||||||
|
+ execute_statements_in_scope (NULL, NULL, NULL, NULL, NULL,
|
||||||
|
options, &global_scope, root_group,
|
||||||
|
NULL, NULL);
|
||||||
|
|
||||||
|
--
|
||||||
|
1.8.4.2
|
||||||
|
|
@ -35,7 +35,7 @@ diff -up dhcp-4.3.0a1/server/dhcpv6.c.UseMulticast dhcp-4.3.0a1/server/dhcpv6.c
|
|||||||
+ }
|
+ }
|
||||||
+
|
+
|
||||||
+ execute_statements_in_scope(NULL, NULL, NULL, NULL, NULL,
|
+ execute_statements_in_scope(NULL, NULL, NULL, NULL, NULL,
|
||||||
+ opt_state, &global_scope, root_group, NULL);
|
+ opt_state, &global_scope, root_group, NULL, NULL);
|
||||||
+
|
+
|
||||||
+ oc = lookup_option(&dhcpv6_universe, opt_state, D6O_UNICAST);
|
+ oc = lookup_option(&dhcpv6_universe, opt_state, D6O_UNICAST);
|
||||||
+ unicast_option_defined = (oc != NULL);
|
+ unicast_option_defined = (oc != NULL);
|
||||||
|
10
dhcp.spec
10
dhcp.spec
@ -18,7 +18,7 @@
|
|||||||
Summary: Dynamic host configuration protocol software
|
Summary: Dynamic host configuration protocol software
|
||||||
Name: dhcp
|
Name: dhcp
|
||||||
Version: 4.3.0
|
Version: 4.3.0
|
||||||
Release: 0.1.%{prever}%{?dist}
|
Release: 0.2.%{prever}%{?dist}
|
||||||
# NEVER CHANGE THE EPOCH on this package. The previous maintainer (prior to
|
# NEVER CHANGE THE EPOCH on this package. The previous maintainer (prior to
|
||||||
# dcantrell maintaining the package) made incorrect use of the epoch and
|
# dcantrell maintaining the package) made incorrect use of the epoch and
|
||||||
# that's why it is at 12 now. It should have never been used, but it was.
|
# that's why it is at 12 now. It should have never been used, but it was.
|
||||||
@ -78,6 +78,7 @@ Patch38: dhcp-range6.patch
|
|||||||
Patch39: dhcp-next-server.patch
|
Patch39: dhcp-next-server.patch
|
||||||
Patch40: dhcp-no-subnet-error2info.patch
|
Patch40: dhcp-no-subnet-error2info.patch
|
||||||
Patch41: dhcp-ffff-checksum.patch
|
Patch41: dhcp-ffff-checksum.patch
|
||||||
|
Patch42: dhcp-430a1.patch
|
||||||
|
|
||||||
BuildRequires: autoconf
|
BuildRequires: autoconf
|
||||||
BuildRequires: automake
|
BuildRequires: automake
|
||||||
@ -341,6 +342,10 @@ rm -rf includes/isc-dhcp
|
|||||||
# (Submitted to dhcp-bugs@isc.org - [ISC-Bugs #25587])
|
# (Submitted to dhcp-bugs@isc.org - [ISC-Bugs #25587])
|
||||||
%patch41 -p1 -b .ffff
|
%patch41 -p1 -b .ffff
|
||||||
|
|
||||||
|
# make 4.3.0a1 build with LDAP support
|
||||||
|
# (Submitted to dhcp-bugs@isc.org - [ISC-Bugs #35159])
|
||||||
|
%patch42 -p1 -b .430a1
|
||||||
|
|
||||||
# Update paths in all man pages
|
# Update paths in all man pages
|
||||||
for page in client/dhclient.conf.5 client/dhclient.leases.5 \
|
for page in client/dhclient.conf.5 client/dhclient.leases.5 \
|
||||||
client/dhclient-script.8 client/dhclient.8 ; do
|
client/dhclient-script.8 client/dhclient.8 ; do
|
||||||
@ -625,6 +630,9 @@ done
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jan 07 2014 Jiri Popelka <jpopelka@redhat.com> - 12:4.3.0-0.2.a1
|
||||||
|
- make it actually build
|
||||||
|
|
||||||
* Thu Dec 19 2013 Jiri Popelka <jpopelka@redhat.com> - 12:4.3.0-0.1.a1
|
* Thu Dec 19 2013 Jiri Popelka <jpopelka@redhat.com> - 12:4.3.0-0.1.a1
|
||||||
- 4.3.0a1: requires bind-9.9.5
|
- 4.3.0a1: requires bind-9.9.5
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user