VLAN ID is only bottom 12-bits of TCI (#1259552)
This commit is contained in:
parent
48bc1f5d15
commit
9262a0840d
35
dhcp-VLAN-ID.patch
Normal file
35
dhcp-VLAN-ID.patch
Normal file
@ -0,0 +1,35 @@
|
||||
From 7a1862a392038407371d6889e49b06848efa637f Mon Sep 17 00:00:00 2001
|
||||
From: Jiri Popelka <jpopelka@redhat.com>
|
||||
Date: Thu, 3 Sep 2015 18:25:42 +0200
|
||||
Subject: [PATCH] VLAN ID is only bottom 12-bits of TCI
|
||||
|
||||
The upper 4 bits contain metadata used for quality of service
|
||||
management.
|
||||
|
||||
TCI(16b) = PCP(3b) + DEI(1b) + VID(12b)
|
||||
|
||||
TCI = Tag control information
|
||||
PCP = Priority code point
|
||||
DEI = Drop eligible indicator
|
||||
VID = VLAN identifier
|
||||
---
|
||||
common/lpf.c | 3 ++-
|
||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/common/lpf.c b/common/lpf.c
|
||||
index 7889b6b..4c835e6 100644
|
||||
--- a/common/lpf.c
|
||||
+++ b/common/lpf.c
|
||||
@@ -425,7 +425,8 @@ ssize_t receive_packet (interface, buf, len, from, hfrom)
|
||||
/* Discard packets with stripped vlan id */
|
||||
|
||||
#ifdef VLAN_TCI_PRESENT
|
||||
- if (aux->tp_vlan_tci != 0)
|
||||
+ /* VLAN ID is only bottom 12-bits of TCI */
|
||||
+ if (aux->tp_vlan_tci & 0x0fff)
|
||||
return 0;
|
||||
#endif
|
||||
|
||||
--
|
||||
2.5.0
|
||||
|
15
dhcp.spec
15
dhcp.spec
@ -11,14 +11,14 @@
|
||||
#%%global patchver P2
|
||||
%global prever b1
|
||||
|
||||
#%%global VERSION %{version}-%{patchver}
|
||||
#%%global VERSION %{version}%{prever}
|
||||
#%%global VERSION %%{version}-%%{patchver}
|
||||
#%%global VERSION %%{version}%%{prever}
|
||||
%global VERSION %{version}
|
||||
|
||||
Summary: Dynamic host configuration protocol software
|
||||
Name: dhcp
|
||||
Version: 4.3.3
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
# NEVER CHANGE THE EPOCH on this package. The previous maintainer (prior to
|
||||
# dcantrell maintaining the package) made incorrect use of the epoch and
|
||||
# that's why it is at 12 now. It should have never been used, but it was.
|
||||
@ -71,7 +71,7 @@ Patch30: dhcp-omapi-leak.patch
|
||||
Patch32: dhcp-interval.patch
|
||||
Patch33: dhcp-no-subnet-error2info.patch
|
||||
Patch34: dhcp-sd_notify.patch
|
||||
|
||||
Patch35: dhcp-VLAN-ID.patch
|
||||
Patch36: dhcp-option97-pxe-client-id.patch
|
||||
Patch37: dhcp-stateless-DUID-LLT.patch
|
||||
Patch38: dhcp-client-request-release-bind-iface.patch
|
||||
@ -321,6 +321,10 @@ rm bind/bind.tar.gz
|
||||
# support for sending startup notification to systemd (#1077666)
|
||||
%patch34 -p1 -b .sd_notify
|
||||
|
||||
# VLAN ID is only bottom 12-bits of TCI (#1259552)
|
||||
# (Submitted to dhcp-bugs@isc.org - [ISC-Bugs #40591])
|
||||
%patch35 -p1 -b .vlanid
|
||||
|
||||
# option 97 - pxe-client-id (#1058674)
|
||||
# (Submitted to dhcp-bugs@isc.org - [ISC-Bugs #38110])
|
||||
%patch36 -p1 -b .option97
|
||||
@ -656,6 +660,9 @@ done
|
||||
%doc doc/html/
|
||||
|
||||
%changelog
|
||||
* Mon Sep 07 2015 Jiri Popelka <jpopelka@redhat.com> - 12:4.3.3-2
|
||||
- VLAN ID is only bottom 12-bits of TCI (#1259552)
|
||||
|
||||
* Fri Sep 04 2015 Jiri Popelka <jpopelka@redhat.com> - 12:4.3.3-1
|
||||
- 4.3.3
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user