DHCPv6 over PPP support (#626514)
This commit is contained in:
parent
90ba4e9d04
commit
76c2a1e49b
@ -557,6 +557,12 @@ add_ipv6_addr_with_DAD() {
|
|||||||
}
|
}
|
||||||
|
|
||||||
dh6config() {
|
dh6config() {
|
||||||
|
if [ -n ${old_ip6_prefix} ] ||
|
||||||
|
[ -n ${new_ip6_prefix} ]; then
|
||||||
|
echo Prefix ${reason} old=${old_ip6_prefix} new=${new_ip6_prefix}
|
||||||
|
exit_with_hooks 0
|
||||||
|
fi
|
||||||
|
|
||||||
case "${reason}" in
|
case "${reason}" in
|
||||||
BOUND6)
|
BOUND6)
|
||||||
if [ -z "${new_ip6_address}" ] ||
|
if [ -z "${new_ip6_address}" ] ||
|
||||||
|
150
dhcp-4.2.0-PPP.patch
Normal file
150
dhcp-4.2.0-PPP.patch
Normal file
@ -0,0 +1,150 @@
|
|||||||
|
diff -up dhcp-4.2.0-P1/client/dhc6.c.PPP dhcp-4.2.0-P1/client/dhc6.c
|
||||||
|
--- dhcp-4.2.0-P1/client/dhc6.c.PPP 2010-11-05 10:47:37.000000000 +0100
|
||||||
|
+++ dhcp-4.2.0-P1/client/dhc6.c 2010-11-09 15:54:12.000000000 +0100
|
||||||
|
@@ -129,7 +129,7 @@ extern int stateless;
|
||||||
|
* is not how it is intended. Upcoming rearchitecting the client should
|
||||||
|
* address this "one daemon model."
|
||||||
|
*/
|
||||||
|
-void
|
||||||
|
+isc_result_t
|
||||||
|
form_duid(struct data_string *duid, const char *file, int line)
|
||||||
|
{
|
||||||
|
struct interface_info *ip;
|
||||||
|
@@ -141,6 +141,15 @@ form_duid(struct data_string *duid, cons
|
||||||
|
if (ip == NULL)
|
||||||
|
log_fatal("Impossible condition at %s:%d.", MDL);
|
||||||
|
|
||||||
|
+ while (ip && ip->hw_address.hbuf[0] == HTYPE_RESERVED) {
|
||||||
|
+ /* Try the other interfaces */
|
||||||
|
+ log_debug("Cannot form default DUID from interface %s.", ip->name);
|
||||||
|
+ ip = ip->next;
|
||||||
|
+ }
|
||||||
|
+ if (ip == NULL) {
|
||||||
|
+ return ISC_R_UNEXPECTED;
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
if ((ip->hw_address.hlen == 0) ||
|
||||||
|
(ip->hw_address.hlen > sizeof(ip->hw_address.hbuf)))
|
||||||
|
log_fatal("Impossible hardware address length at %s:%d.", MDL);
|
||||||
|
@@ -176,6 +185,8 @@ form_duid(struct data_string *duid, cons
|
||||||
|
memcpy(duid->buffer->data + 4, ip->hw_address.hbuf + 1,
|
||||||
|
ip->hw_address.hlen - 1);
|
||||||
|
}
|
||||||
|
+
|
||||||
|
+ return ISC_R_SUCCESS;
|
||||||
|
}
|
||||||
|
|
||||||
|
/*
|
||||||
|
@@ -5289,7 +5300,8 @@ make_client6_options(struct client_state
|
||||||
|
*/
|
||||||
|
if ((oc = lookup_option(&dhcpv6_universe, *op,
|
||||||
|
D6O_CLIENTID)) == NULL) {
|
||||||
|
- if (!option_cache(&oc, &default_duid, NULL, clientid_option,
|
||||||
|
+ if (default_duid.len == 0 ||
|
||||||
|
+ !option_cache(&oc, &default_duid, NULL, clientid_option,
|
||||||
|
MDL))
|
||||||
|
log_fatal("Failure assembling a DUID.");
|
||||||
|
|
||||||
|
diff -up dhcp-4.2.0-P1/client/dhclient.c.PPP dhcp-4.2.0-P1/client/dhclient.c
|
||||||
|
--- dhcp-4.2.0-P1/client/dhclient.c.PPP 2010-11-05 10:47:37.000000000 +0100
|
||||||
|
+++ dhcp-4.2.0-P1/client/dhclient.c 2010-11-09 15:37:26.000000000 +0100
|
||||||
|
@@ -911,8 +911,8 @@ main(int argc, char **argv) {
|
||||||
|
if (default_duid.buffer != NULL)
|
||||||
|
data_string_forget(&default_duid, MDL);
|
||||||
|
|
||||||
|
- form_duid(&default_duid, MDL);
|
||||||
|
- write_duid(&default_duid);
|
||||||
|
+ if (form_duid(&default_duid, MDL) == ISC_R_SUCCESS)
|
||||||
|
+ write_duid(&default_duid);
|
||||||
|
}
|
||||||
|
|
||||||
|
for (ip = interfaces ; ip != NULL ; ip = ip->next) {
|
||||||
|
diff -up dhcp-4.2.0-P1/common/bpf.c.PPP dhcp-4.2.0-P1/common/bpf.c
|
||||||
|
--- dhcp-4.2.0-P1/common/bpf.c.PPP 2010-11-05 10:47:37.000000000 +0100
|
||||||
|
+++ dhcp-4.2.0-P1/common/bpf.c 2010-11-09 15:42:42.000000000 +0100
|
||||||
|
@@ -599,6 +599,22 @@ get_hw_addr(const char *name, struct har
|
||||||
|
memcpy(&hw->hbuf[1], LLADDR(sa), sa->sdl_alen);
|
||||||
|
break;
|
||||||
|
#endif /* IFT_FDDI */
|
||||||
|
+#if defined(IFT_PPP)
|
||||||
|
+ case IFT_PPP:
|
||||||
|
+ if (local_family != AF_INET6)
|
||||||
|
+ log_fatal("Unsupported device type %d for \"%s\"",
|
||||||
|
+ sa->sdl_type, name);
|
||||||
|
+ hw->hlen = 0;
|
||||||
|
+ hw->hbuf[0] = HTYPE_RESERVED;
|
||||||
|
+ /* 0xdeadbeef should never occur on the wire,
|
||||||
|
+ * and is a signature that something went wrong.
|
||||||
|
+ */
|
||||||
|
+ hw->hbuf[1] = 0xde;
|
||||||
|
+ hw->hbuf[2] = 0xad;
|
||||||
|
+ hw->hbuf[3] = 0xbe;
|
||||||
|
+ hw->hbuf[4] = 0xef;
|
||||||
|
+ break;
|
||||||
|
+#endif
|
||||||
|
default:
|
||||||
|
log_fatal("Unsupported device type %d for \"%s\"",
|
||||||
|
sa->sdl_type, name);
|
||||||
|
diff -up dhcp-4.2.0-P1/common/lpf.c.PPP dhcp-4.2.0-P1/common/lpf.c
|
||||||
|
--- dhcp-4.2.0-P1/common/lpf.c.PPP 2010-11-05 10:47:37.000000000 +0100
|
||||||
|
+++ dhcp-4.2.0-P1/common/lpf.c 2010-11-09 15:45:40.000000000 +0100
|
||||||
|
@@ -502,6 +502,22 @@ get_hw_addr(const char *name, struct har
|
||||||
|
hw->hbuf[0] = HTYPE_FDDI;
|
||||||
|
memcpy(&hw->hbuf[1], sa->sa_data, 16);
|
||||||
|
break;
|
||||||
|
+#if defined(ARPHRD_PPP)
|
||||||
|
+ case ARPHRD_PPP:
|
||||||
|
+ if (local_family != AF_INET6)
|
||||||
|
+ log_fatal("Unsupported device type %d for \"%s\"",
|
||||||
|
+ sa->sa_family, name);
|
||||||
|
+ hw->hlen = 0;
|
||||||
|
+ hw->hbuf[0] = HTYPE_RESERVED;
|
||||||
|
+ /* 0xdeadbeef should never occur on the wire,
|
||||||
|
+ * and is a signature that something went wrong.
|
||||||
|
+ */
|
||||||
|
+ hw->hbuf[1] = 0xde;
|
||||||
|
+ hw->hbuf[2] = 0xad;
|
||||||
|
+ hw->hbuf[3] = 0xbe;
|
||||||
|
+ hw->hbuf[4] = 0xef;
|
||||||
|
+ break;
|
||||||
|
+#endif
|
||||||
|
default:
|
||||||
|
log_fatal("Unsupported device type %ld for \"%s\"",
|
||||||
|
(long int)sa->sa_family, name);
|
||||||
|
diff -up dhcp-4.2.0-P1/includes/dhcpd.h.PPP dhcp-4.2.0-P1/includes/dhcpd.h
|
||||||
|
--- dhcp-4.2.0-P1/includes/dhcpd.h.PPP 2010-11-05 10:47:37.000000000 +0100
|
||||||
|
+++ dhcp-4.2.0-P1/includes/dhcpd.h 2010-11-09 15:46:58.000000000 +0100
|
||||||
|
@@ -2733,7 +2733,7 @@ void dhcpv4_client_assignments(void);
|
||||||
|
void dhcpv6_client_assignments(void);
|
||||||
|
|
||||||
|
/* dhc6.c */
|
||||||
|
-void form_duid(struct data_string *duid, const char *file, int line);
|
||||||
|
+isc_result_t form_duid(struct data_string *duid, const char *file, int line);
|
||||||
|
void dhc6_lease_destroy(struct dhc6_lease **src, const char *file, int line);
|
||||||
|
void start_init6(struct client_state *client);
|
||||||
|
void start_info_request6(struct client_state *client);
|
||||||
|
diff -up dhcp-4.2.0-P1/includes/dhcp.h.PPP dhcp-4.2.0-P1/includes/dhcp.h
|
||||||
|
--- dhcp-4.2.0-P1/includes/dhcp.h.PPP 2010-11-05 10:47:37.000000000 +0100
|
||||||
|
+++ dhcp-4.2.0-P1/includes/dhcp.h 2010-11-09 15:48:53.000000000 +0100
|
||||||
|
@@ -80,6 +80,8 @@ struct dhcp_packet {
|
||||||
|
#define HTYPE_IEEE802 6 /* IEEE 802.2 Token Ring... */
|
||||||
|
#define HTYPE_FDDI 8 /* FDDI... */
|
||||||
|
|
||||||
|
+#define HTYPE_RESERVED 0 /* RFC 5494 */
|
||||||
|
+
|
||||||
|
/* Magic cookie validating dhcp options field (and bootp vendor
|
||||||
|
extensions field). */
|
||||||
|
#define DHCP_OPTIONS_COOKIE "\143\202\123\143"
|
||||||
|
diff -up dhcp-4.2.0-P1/server/dhcpv6.c.PPP dhcp-4.2.0-P1/server/dhcpv6.c
|
||||||
|
--- dhcp-4.2.0-P1/server/dhcpv6.c.PPP 2010-11-05 10:47:37.000000000 +0100
|
||||||
|
+++ dhcp-4.2.0-P1/server/dhcpv6.c 2010-11-09 15:50:17.000000000 +0100
|
||||||
|
@@ -300,6 +300,9 @@ generate_new_server_duid(void) {
|
||||||
|
if (p->hw_address.hlen > 0) {
|
||||||
|
break;
|
||||||
|
}
|
||||||
|
+ if (p->next == NULL && p->hw_address.hbuf[0] == HTYPE_RESERVED) {
|
||||||
|
+ log_error("Can not generate DUID from interfaces which do not have hardware addresses, please configure server-duid!");
|
||||||
|
+ }
|
||||||
|
}
|
||||||
|
if (p == NULL) {
|
||||||
|
return ISC_R_UNEXPECTED;
|
10
dhcp.spec
10
dhcp.spec
@ -12,7 +12,7 @@
|
|||||||
Summary: Dynamic host configuration protocol software
|
Summary: Dynamic host configuration protocol software
|
||||||
Name: dhcp
|
Name: dhcp
|
||||||
Version: 4.2.0
|
Version: 4.2.0
|
||||||
Release: 17.%{patchver}%{?dist}
|
Release: 18.%{patchver}%{?dist}
|
||||||
# NEVER CHANGE THE EPOCH on this package. The previous maintainer (prior to
|
# NEVER CHANGE THE EPOCH on this package. The previous maintainer (prior to
|
||||||
# dcantrell maintaining the package) made incorrect use of the epoch and
|
# dcantrell maintaining the package) made incorrect use of the epoch and
|
||||||
# that's why it is at 12 now. It should have never been used, but it was.
|
# that's why it is at 12 now. It should have never been used, but it was.
|
||||||
@ -64,6 +64,7 @@ Patch30: dhcp-4.2.0-honor-expired.patch
|
|||||||
Patch31: dhcp-4.2.0-noprefixavail.patch
|
Patch31: dhcp-4.2.0-noprefixavail.patch
|
||||||
Patch32: dhcp420-rh637017.patch
|
Patch32: dhcp420-rh637017.patch
|
||||||
Patch33: dhcp420-sharedlib.patch
|
Patch33: dhcp420-sharedlib.patch
|
||||||
|
Patch34: dhcp-4.2.0-PPP.patch
|
||||||
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
BuildRequires: autoconf
|
BuildRequires: autoconf
|
||||||
@ -267,9 +268,13 @@ rm bind/bind.tar.gz
|
|||||||
# Without this patch server ignored client's Solicit in which the client was sending
|
# Without this patch server ignored client's Solicit in which the client was sending
|
||||||
# prefix in IA_PD (as a preference) and this prefix was not in any of server's pools.
|
# prefix in IA_PD (as a preference) and this prefix was not in any of server's pools.
|
||||||
%patch31 -p1 -b .noprefixavail
|
%patch31 -p1 -b .noprefixavail
|
||||||
|
|
||||||
%patch32 -p1 -b .rh637017
|
%patch32 -p1 -b .rh637017
|
||||||
%patch33 -p1 -b .sharedlib
|
%patch33 -p1 -b .sharedlib
|
||||||
|
|
||||||
|
# DHCPv6 over PPP support (#626514)
|
||||||
|
%patch34 -p1 -b .PPP
|
||||||
|
|
||||||
# Copy in the Fedora/RHEL dhclient script
|
# Copy in the Fedora/RHEL dhclient script
|
||||||
%{__install} -p -m 0755 %{SOURCE4} client/scripts/linux
|
%{__install} -p -m 0755 %{SOURCE4} client/scripts/linux
|
||||||
%{__install} -p -m 0644 %{SOURCE5} .
|
%{__install} -p -m 0644 %{SOURCE5} .
|
||||||
@ -575,6 +580,9 @@ fi
|
|||||||
%attr(0644,root,root) %{_mandir}/man3/omapi.3.gz
|
%attr(0644,root,root) %{_mandir}/man3/omapi.3.gz
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Nov 09 2010 Jiri Popelka <jpopelka@redhat.com> - 12:4.2.0-18.P1
|
||||||
|
- Applied Patrik Lahti's patch for DHCPv6 over PPP support (#626514)
|
||||||
|
|
||||||
* Fri Nov 05 2010 Jiri Popelka <jpopelka@redhat.com> - 12:4.2.0-17.P1
|
* Fri Nov 05 2010 Jiri Popelka <jpopelka@redhat.com> - 12:4.2.0-17.P1
|
||||||
- fix broken dependencies
|
- fix broken dependencies
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user