Use StandardError=null instead of log_perror.patch
[ISC-Bugs #28049] has been closed upstream without applying the patch.
This commit is contained in:
parent
0ae0d118cb
commit
6756a54bda
@ -1,11 +0,0 @@
|
|||||||
diff -up dhcp-4.3.0a1/server/dhcpd.c.log_perror dhcp-4.3.0a1/server/dhcpd.c
|
|
||||||
--- dhcp-4.3.0a1/server/dhcpd.c.log_perror 2013-12-20 13:38:15.904106904 +0100
|
|
||||||
+++ dhcp-4.3.0a1/server/dhcpd.c 2013-12-20 13:38:15.918106709 +0100
|
|
||||||
@@ -241,6 +241,7 @@ main(int argc, char **argv) {
|
|
||||||
#ifndef DEBUG
|
|
||||||
daemon = 0;
|
|
||||||
#endif
|
|
||||||
+ log_perror = 0;
|
|
||||||
} else if (!strcmp (argv [i], "-d")) {
|
|
||||||
#ifndef DEBUG
|
|
||||||
daemon = 0;
|
|
10
dhcp.spec
10
dhcp.spec
@ -18,7 +18,7 @@
|
|||||||
Summary: Dynamic host configuration protocol software
|
Summary: Dynamic host configuration protocol software
|
||||||
Name: dhcp
|
Name: dhcp
|
||||||
Version: 4.3.0
|
Version: 4.3.0
|
||||||
Release: 9%{?dist}
|
Release: 10%{?dist}
|
||||||
# NEVER CHANGE THE EPOCH on this package. The previous maintainer (prior to
|
# NEVER CHANGE THE EPOCH on this package. The previous maintainer (prior to
|
||||||
# dcantrell maintaining the package) made incorrect use of the epoch and
|
# dcantrell maintaining the package) made incorrect use of the epoch and
|
||||||
# that's why it is at 12 now. It should have never been used, but it was.
|
# that's why it is at 12 now. It should have never been used, but it was.
|
||||||
@ -68,7 +68,6 @@ Patch28: dhcp-gpxe-cid.patch
|
|||||||
Patch29: dhcp-duidv4.patch
|
Patch29: dhcp-duidv4.patch
|
||||||
Patch30: dhcp-systemtap.patch
|
Patch30: dhcp-systemtap.patch
|
||||||
Patch31: dhcp-dhclient-decline-onetry.patch
|
Patch31: dhcp-dhclient-decline-onetry.patch
|
||||||
Patch32: dhcp-log_perror.patch
|
|
||||||
Patch33: dhcp-getifaddrs.patch
|
Patch33: dhcp-getifaddrs.patch
|
||||||
Patch34: dhcp-omapi-leak.patch
|
Patch34: dhcp-omapi-leak.patch
|
||||||
Patch35: dhcp-failOverPeer.patch
|
Patch35: dhcp-failOverPeer.patch
|
||||||
@ -310,10 +309,6 @@ rm -rf includes/isc-dhcp
|
|||||||
# (Submitted to dhcp-bugs@isc.org - [ISC-Bugs #26735])
|
# (Submitted to dhcp-bugs@isc.org - [ISC-Bugs #26735])
|
||||||
%patch31 -p1 -b .decline-onetry
|
%patch31 -p1 -b .decline-onetry
|
||||||
|
|
||||||
# Don't send log messages to the standard error descriptor by default (#790387)
|
|
||||||
# (Submitted to dhcp-bugs@isc.org - [ISC-Bugs #28049])
|
|
||||||
%patch32 -p1 -b .log_perror
|
|
||||||
|
|
||||||
# Use getifaddrs() to scan for interfaces on Linux (#449946)
|
# Use getifaddrs() to scan for interfaces on Linux (#449946)
|
||||||
# (Submitted to dhcp-bugs@isc.org - [ISC-Bugs #28761])
|
# (Submitted to dhcp-bugs@isc.org - [ISC-Bugs #28761])
|
||||||
%patch33 -p1 -b .getifaddrs
|
%patch33 -p1 -b .getifaddrs
|
||||||
@ -627,6 +622,9 @@ done
|
|||||||
%doc doc/html/
|
%doc doc/html/
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed May 07 2014 Jiri Popelka <jpopelka@redhat.com> - 12:4.3.0-10
|
||||||
|
- use StandardError=null instead of log_perror.patch
|
||||||
|
|
||||||
* Tue Mar 18 2014 Jiri Popelka <jpopelka@redhat.com> - 12:4.3.0-9
|
* Tue Mar 18 2014 Jiri Popelka <jpopelka@redhat.com> - 12:4.3.0-9
|
||||||
- support for sending startup notifications to systemd (#1077666)
|
- support for sending startup notifications to systemd (#1077666)
|
||||||
|
|
||||||
|
@ -7,6 +7,7 @@ After=time-sync.target
|
|||||||
[Service]
|
[Service]
|
||||||
Type=notify
|
Type=notify
|
||||||
ExecStart=/usr/sbin/dhcpd -f -cf /etc/dhcp/dhcpd.conf -user dhcpd -group dhcpd --no-pid
|
ExecStart=/usr/sbin/dhcpd -f -cf /etc/dhcp/dhcpd.conf -user dhcpd -group dhcpd --no-pid
|
||||||
|
StandardError=null
|
||||||
|
|
||||||
[Install]
|
[Install]
|
||||||
WantedBy=multi-user.target
|
WantedBy=multi-user.target
|
||||||
|
@ -7,6 +7,7 @@ After=time-sync.target
|
|||||||
[Service]
|
[Service]
|
||||||
Type=notify
|
Type=notify
|
||||||
ExecStart=/usr/sbin/dhcpd -f -6 -cf /etc/dhcp/dhcpd6.conf -user dhcpd -group dhcpd --no-pid
|
ExecStart=/usr/sbin/dhcpd -f -6 -cf /etc/dhcp/dhcpd6.conf -user dhcpd -group dhcpd --no-pid
|
||||||
|
StandardError=null
|
||||||
|
|
||||||
[Install]
|
[Install]
|
||||||
WantedBy=multi-user.target
|
WantedBy=multi-user.target
|
||||||
|
@ -6,6 +6,7 @@ After=network.target
|
|||||||
[Service]
|
[Service]
|
||||||
Type=notify
|
Type=notify
|
||||||
ExecStart=/usr/sbin/dhcrelay -d --no-pid
|
ExecStart=/usr/sbin/dhcrelay -d --no-pid
|
||||||
|
StandardError=null
|
||||||
|
|
||||||
[Install]
|
[Install]
|
||||||
WantedBy=multi-user.target
|
WantedBy=multi-user.target
|
||||||
|
Loading…
Reference in New Issue
Block a user