added test.sh to run upstream shipped tests.
This commit is contained in:
parent
5e9e3f36a8
commit
5c346262c0
@ -1,7 +1,7 @@
|
||||
diff -up dhcp-4.2.0/client/Makefile.am.rh637017 dhcp-4.2.0/client/Makefile.am
|
||||
--- dhcp-4.2.0/client/Makefile.am.rh637017 2010-10-01 13:41:16.320002774 +0200
|
||||
+++ dhcp-4.2.0/client/Makefile.am 2010-10-01 13:41:16.320002774 +0200
|
||||
@@ -5,7 +5,7 @@ dhclient_SOURCES = clparse.c dhclient.c dhc6.c \
|
||||
diff -up dhcp-4.2.2/client/Makefile.am.rh637017 dhcp-4.2.2/client/Makefile.am
|
||||
--- dhcp-4.2.2/client/Makefile.am.rh637017 2010-09-15 00:32:36.000000000 +0200
|
||||
+++ dhcp-4.2.2/client/Makefile.am 2011-08-11 17:28:58.923897561 +0200
|
||||
@@ -5,7 +5,7 @@ dhclient_SOURCES = clparse.c dhclient.c
|
||||
scripts/netbsd scripts/nextstep scripts/openbsd \
|
||||
scripts/solaris scripts/openwrt
|
||||
dhclient_LDADD = ../common/libdhcp.a ../omapip/libomapi.a \
|
||||
@ -10,11 +10,22 @@ diff -up dhcp-4.2.0/client/Makefile.am.rh637017 dhcp-4.2.0/client/Makefile.am
|
||||
man_MANS = dhclient.8 dhclient-script.8 dhclient.conf.5 dhclient.leases.5
|
||||
EXTRA_DIST = $(man_MANS)
|
||||
|
||||
man_MANS = dhclient.8 dhclient-script.8 dhclient.conf.5 dhclient.leases.5
|
||||
diff -up dhcp-4.2.0/configure.ac.rh637017 dhcp-4.2.0/configure.ac
|
||||
--- dhcp-4.2.0/configure.ac.rh637017 2010-10-01 13:41:16.280002774 +0200
|
||||
+++ dhcp-4.2.0/configure.ac 2010-10-01 13:44:24.790002776 +0200
|
||||
@@ -488,20 +488,37 @@ AC_CHECK_MEMBER(struct msghdr.msg_control,,
|
||||
diff -up dhcp-4.2.2/common/tests/Makefile.am.rh637017 dhcp-4.2.2/common/tests/Makefile.am
|
||||
--- dhcp-4.2.2/common/tests/Makefile.am.rh637017 2009-10-28 05:12:30.000000000 +0100
|
||||
+++ dhcp-4.2.2/common/tests/Makefile.am 2011-08-11 17:33:45.258637236 +0200
|
||||
@@ -6,6 +6,5 @@ TESTS = test_alloc
|
||||
|
||||
test_alloc_SOURCES = test_alloc.c
|
||||
test_alloc_LDADD = ../libdhcp.a ../../tests/libt_api.a \
|
||||
- ../../omapip/libomapi.a ../../bind/lib/libdns.a \
|
||||
- ../../bind/lib/libisc.a
|
||||
-
|
||||
+ ../../omapip/libomapi.a \
|
||||
+ $(BIND9_LIBDIR) -ldns-export -lisc-export
|
||||
diff -up dhcp-4.2.2/configure.ac.rh637017 dhcp-4.2.2/configure.ac
|
||||
--- dhcp-4.2.2/configure.ac.rh637017 2011-07-20 02:32:18.000000000 +0200
|
||||
+++ dhcp-4.2.2/configure.ac 2011-08-11 17:28:58.924897535 +0200
|
||||
@@ -512,20 +512,37 @@ AC_CHECK_MEMBER(struct msghdr.msg_contro
|
||||
libbind=
|
||||
AC_ARG_WITH(libbind,
|
||||
AC_HELP_STRING([--with-libbind=PATH],
|
||||
@ -57,7 +68,7 @@ diff -up dhcp-4.2.0/configure.ac.rh637017 dhcp-4.2.0/configure.ac
|
||||
|
||||
# OpenLDAP support.
|
||||
AC_ARG_WITH(ldap,
|
||||
@@ -538,7 +555,7 @@ fi
|
||||
@@ -562,7 +579,7 @@ fi
|
||||
CFLAGS="$CFLAGS $STD_CWARNINGS"
|
||||
|
||||
# Try to add the bind include directory
|
||||
@ -66,9 +77,9 @@ diff -up dhcp-4.2.0/configure.ac.rh637017 dhcp-4.2.0/configure.ac
|
||||
|
||||
AC_C_FLEXIBLE_ARRAY_MEMBER
|
||||
|
||||
diff -up dhcp-4.2.0/dhcpctl/Makefile.am.rh637017 dhcp-4.2.0/dhcpctl/Makefile.am
|
||||
--- dhcp-4.2.0/dhcpctl/Makefile.am.rh637017 2009-10-28 05:12:30.000000000 +0100
|
||||
+++ dhcp-4.2.0/dhcpctl/Makefile.am 2010-10-01 13:41:16.320002774 +0200
|
||||
diff -up dhcp-4.2.2/dhcpctl/Makefile.am.rh637017 dhcp-4.2.2/dhcpctl/Makefile.am
|
||||
--- dhcp-4.2.2/dhcpctl/Makefile.am.rh637017 2009-10-28 05:12:30.000000000 +0100
|
||||
+++ dhcp-4.2.2/dhcpctl/Makefile.am 2011-08-11 17:28:58.924897535 +0200
|
||||
@@ -6,10 +6,10 @@ EXTRA_DIST = $(man_MANS)
|
||||
|
||||
omshell_SOURCES = omshell.c
|
||||
@ -83,9 +94,9 @@ diff -up dhcp-4.2.0/dhcpctl/Makefile.am.rh637017 dhcp-4.2.0/dhcpctl/Makefile.am
|
||||
- ../bind/lib/libdns.a ../bind/lib/libisc.a
|
||||
\ No newline at end of file
|
||||
+ $(BIND9_LIBDIR) -ldns-export -lisc-export
|
||||
diff -up dhcp-4.2.0/Makefile.am.rh637017 dhcp-4.2.0/Makefile.am
|
||||
--- dhcp-4.2.0/Makefile.am.rh637017 2010-03-25 00:30:38.000000000 +0100
|
||||
+++ dhcp-4.2.0/Makefile.am 2010-10-01 13:41:16.320002774 +0200
|
||||
diff -up dhcp-4.2.2/Makefile.am.rh637017 dhcp-4.2.2/Makefile.am
|
||||
--- dhcp-4.2.2/Makefile.am.rh637017 2010-03-25 00:30:38.000000000 +0100
|
||||
+++ dhcp-4.2.2/Makefile.am 2011-08-11 17:28:58.925897509 +0200
|
||||
@@ -21,7 +21,13 @@ EXTRA_DIST = RELNOTES LICENSE \
|
||||
util/bindvar.sh \
|
||||
bind/Makefile bind/bind.tar.gz bind/version.tmp
|
||||
@ -101,9 +112,9 @@ diff -up dhcp-4.2.0/Makefile.am.rh637017 dhcp-4.2.0/Makefile.am
|
||||
|
||||
nobase_include_HEADERS = dhcpctl/dhcpctl.h
|
||||
|
||||
diff -up dhcp-4.2.0/omapip/Makefile.am.rh637017 dhcp-4.2.0/omapip/Makefile.am
|
||||
--- dhcp-4.2.0/omapip/Makefile.am.rh637017 2010-10-01 13:41:16.320002774 +0200
|
||||
+++ dhcp-4.2.0/omapip/Makefile.am 2010-10-01 13:41:16.320002774 +0200
|
||||
diff -up dhcp-4.2.2/omapip/Makefile.am.rh637017 dhcp-4.2.2/omapip/Makefile.am
|
||||
--- dhcp-4.2.2/omapip/Makefile.am.rh637017 2010-02-12 01:13:54.000000000 +0100
|
||||
+++ dhcp-4.2.2/omapip/Makefile.am 2011-08-11 17:28:58.939897149 +0200
|
||||
@@ -10,5 +10,5 @@ man_MANS = omapi.3
|
||||
EXTRA_DIST = $(man_MANS)
|
||||
|
||||
@ -111,10 +122,10 @@ diff -up dhcp-4.2.0/omapip/Makefile.am.rh637017 dhcp-4.2.0/omapip/Makefile.am
|
||||
-svtest_LDADD = libomapi.a ../bind/lib/libdns.a ../bind/lib/libisc.a
|
||||
+svtest_LDADD = libomapi.a $(BIND9_LIBDIR) -ldns-export -lisc-export
|
||||
|
||||
diff -up dhcp-4.2.0/relay/Makefile.am.rh637017 dhcp-4.2.0/relay/Makefile.am
|
||||
--- dhcp-4.2.0/relay/Makefile.am.rh637017 2010-10-01 13:41:16.320002774 +0200
|
||||
+++ dhcp-4.2.0/relay/Makefile.am 2010-10-01 13:41:16.320002774 +0200
|
||||
@@ -3,7 +3,7 @@ AM_CPPFLAGS = -DLOCALSTATEDIR='"@localstatedir@"'
|
||||
diff -up dhcp-4.2.2/relay/Makefile.am.rh637017 dhcp-4.2.2/relay/Makefile.am
|
||||
--- dhcp-4.2.2/relay/Makefile.am.rh637017 2009-10-28 05:12:30.000000000 +0100
|
||||
+++ dhcp-4.2.2/relay/Makefile.am 2011-08-11 17:28:58.940897123 +0200
|
||||
@@ -3,7 +3,7 @@ AM_CPPFLAGS = -DLOCALSTATEDIR='"@localst
|
||||
sbin_PROGRAMS = dhcrelay
|
||||
dhcrelay_SOURCES = dhcrelay.c
|
||||
dhcrelay_LDADD = ../common/libdhcp.a ../omapip/libomapi.a \
|
||||
@ -123,10 +134,9 @@ diff -up dhcp-4.2.0/relay/Makefile.am.rh637017 dhcp-4.2.0/relay/Makefile.am
|
||||
man_MANS = dhcrelay.8
|
||||
EXTRA_DIST = $(man_MANS)
|
||||
|
||||
man_MANS = dhcrelay.8
|
||||
diff -up dhcp-4.2.0/server/Makefile.am.rh637017 dhcp-4.2.0/server/Makefile.am
|
||||
--- dhcp-4.2.0/server/Makefile.am.rh637017 2010-10-01 13:41:16.320002774 +0200
|
||||
+++ dhcp-4.2.0/server/Makefile.am 2010-10-01 13:41:16.320002774 +0200
|
||||
diff -up dhcp-4.2.2/server/Makefile.am.rh637017 dhcp-4.2.2/server/Makefile.am
|
||||
--- dhcp-4.2.2/server/Makefile.am.rh637017 2010-03-24 22:49:47.000000000 +0100
|
||||
+++ dhcp-4.2.2/server/Makefile.am 2011-08-11 17:28:58.944897021 +0200
|
||||
@@ -8,8 +8,7 @@ dhcpd_SOURCES = dhcpd.c dhcp.c bootp.c c
|
||||
|
||||
dhcpd_CFLAGS = $(LDAP_CFLAGS)
|
@ -1,6 +1,6 @@
|
||||
diff -up dhcp-4.2.1-P1/client/Makefile.am.sharedlib dhcp-4.2.1-P1/client/Makefile.am
|
||||
--- dhcp-4.2.1-P1/client/Makefile.am.sharedlib 2011-06-30 17:04:29.476676590 +0200
|
||||
+++ dhcp-4.2.1-P1/client/Makefile.am 2011-06-30 17:04:29.488676414 +0200
|
||||
diff -up dhcp-4.2.2/client/Makefile.am.sharedlib dhcp-4.2.2/client/Makefile.am
|
||||
--- dhcp-4.2.2/client/Makefile.am.sharedlib 2011-08-11 17:36:03.994182909 +0200
|
||||
+++ dhcp-4.2.2/client/Makefile.am 2011-08-11 17:36:04.008182564 +0200
|
||||
@@ -6,7 +6,7 @@ dhclient_SOURCES = clparse.c dhclient.c
|
||||
scripts/solaris scripts/openwrt
|
||||
dhclient_CPPFLAGS = -DCLIENT_PATH='"$(sbindir)"' -DLOCALSTATEDIR='"$(localstatedir)"'
|
||||
@ -10,9 +10,19 @@ diff -up dhcp-4.2.1-P1/client/Makefile.am.sharedlib dhcp-4.2.1-P1/client/Makefil
|
||||
$(BIND9_LIBDIR) -ldns-export -lisc-export $(CAPNG_LDADD)
|
||||
dhclient_LDFLAGS = -pie -Wl,-z,relro -Wl,-z,now
|
||||
|
||||
diff -up dhcp-4.2.1-P1/configure.ac.sharedlib dhcp-4.2.1-P1/configure.ac
|
||||
--- dhcp-4.2.1-P1/configure.ac.sharedlib 2011-06-30 17:04:29.428677294 +0200
|
||||
+++ dhcp-4.2.1-P1/configure.ac 2011-06-30 17:04:29.707673194 +0200
|
||||
diff -up dhcp-4.2.2/common/tests/Makefile.am.sharedlib dhcp-4.2.2/common/tests/Makefile.am
|
||||
--- dhcp-4.2.2/common/tests/Makefile.am.sharedlib 2011-08-11 17:36:03.000000000 +0200
|
||||
+++ dhcp-4.2.2/common/tests/Makefile.am 2011-08-11 17:36:38.586327826 +0200
|
||||
@@ -6,5 +6,5 @@ TESTS = test_alloc
|
||||
|
||||
test_alloc_SOURCES = test_alloc.c
|
||||
test_alloc_LDADD = ../libdhcp.a ../../tests/libt_api.a \
|
||||
- ../../omapip/libomapi.a \
|
||||
+ ../../omapip/libomapi.la \
|
||||
$(BIND9_LIBDIR) -ldns-export -lisc-export
|
||||
diff -up dhcp-4.2.2/configure.ac.sharedlib dhcp-4.2.2/configure.ac
|
||||
--- dhcp-4.2.2/configure.ac.sharedlib 2011-08-11 17:36:03.960183753 +0200
|
||||
+++ dhcp-4.2.2/configure.ac 2011-08-11 17:36:04.009182540 +0200
|
||||
@@ -30,7 +30,8 @@ fi
|
||||
# Use this to define _GNU_SOURCE to pull in the IPv6 Advanced Socket API.
|
||||
AC_USE_SYSTEM_EXTENSIONS
|
||||
@ -23,9 +33,9 @@ diff -up dhcp-4.2.1-P1/configure.ac.sharedlib dhcp-4.2.1-P1/configure.ac
|
||||
AC_CONFIG_HEADERS([includes/config.h])
|
||||
|
||||
# we sometimes need to know byte order for building packets
|
||||
diff -up dhcp-4.2.1-P1/dhcpctl/Makefile.am.sharedlib dhcp-4.2.1-P1/dhcpctl/Makefile.am
|
||||
--- dhcp-4.2.1-P1/dhcpctl/Makefile.am.sharedlib 2011-06-30 17:04:29.311679013 +0200
|
||||
+++ dhcp-4.2.1-P1/dhcpctl/Makefile.am 2011-06-30 17:04:29.489676399 +0200
|
||||
diff -up dhcp-4.2.2/dhcpctl/Makefile.am.sharedlib dhcp-4.2.2/dhcpctl/Makefile.am
|
||||
--- dhcp-4.2.2/dhcpctl/Makefile.am.sharedlib 2011-08-11 17:36:03.824187118 +0200
|
||||
+++ dhcp-4.2.2/dhcpctl/Makefile.am 2011-08-11 17:36:04.010182515 +0200
|
||||
@@ -1,15 +1,15 @@
|
||||
bin_PROGRAMS = omshell
|
||||
-lib_LIBRARIES = libdhcpctl.a
|
||||
@ -46,9 +56,9 @@ diff -up dhcp-4.2.1-P1/dhcpctl/Makefile.am.sharedlib dhcp-4.2.1-P1/dhcpctl/Makef
|
||||
-cltest_LDADD = libdhcpctl.a ../common/libdhcp.a ../omapip/libomapi.a \
|
||||
+cltest_LDADD = libdhcpctl.la ../common/libdhcp.a ../omapip/libomapi.la \
|
||||
$(BIND9_LIBDIR) -ldns-export -lisc-export
|
||||
diff -up dhcp-4.2.1-P1/dst/base64.c.sharedlib dhcp-4.2.1-P1/dst/base64.c
|
||||
--- dhcp-4.2.1-P1/dst/base64.c.sharedlib 2009-11-20 02:49:01.000000000 +0100
|
||||
+++ dhcp-4.2.1-P1/dst/base64.c 2011-06-30 17:04:29.489676399 +0200
|
||||
diff -up dhcp-4.2.2/dst/base64.c.sharedlib dhcp-4.2.2/dst/base64.c
|
||||
--- dhcp-4.2.2/dst/base64.c.sharedlib 2009-11-20 02:49:01.000000000 +0100
|
||||
+++ dhcp-4.2.2/dst/base64.c 2011-08-11 17:36:04.010182515 +0200
|
||||
@@ -64,6 +64,7 @@ static const char rcsid[] = "$Id: base64
|
||||
|
||||
#include <sys/socket.h>
|
||||
@ -57,9 +67,9 @@ diff -up dhcp-4.2.1-P1/dst/base64.c.sharedlib dhcp-4.2.1-P1/dst/base64.c
|
||||
#include "cdefs.h"
|
||||
#include "osdep.h"
|
||||
#include "arpa/nameser.h"
|
||||
diff -up dhcp-4.2.1-P1/dst/Makefile.am.sharedlib dhcp-4.2.1-P1/dst/Makefile.am
|
||||
--- dhcp-4.2.1-P1/dst/Makefile.am.sharedlib 2007-05-29 18:32:10.000000000 +0200
|
||||
+++ dhcp-4.2.1-P1/dst/Makefile.am 2011-06-30 17:04:29.490676384 +0200
|
||||
diff -up dhcp-4.2.2/dst/Makefile.am.sharedlib dhcp-4.2.2/dst/Makefile.am
|
||||
--- dhcp-4.2.2/dst/Makefile.am.sharedlib 2007-05-29 18:32:10.000000000 +0200
|
||||
+++ dhcp-4.2.2/dst/Makefile.am 2011-08-11 17:36:04.011182490 +0200
|
||||
@@ -1,8 +1,8 @@
|
||||
AM_CPPFLAGS = -DMINIRES_LIB -DHMAC_MD5
|
||||
|
||||
@ -71,9 +81,9 @@ diff -up dhcp-4.2.1-P1/dst/Makefile.am.sharedlib dhcp-4.2.1-P1/dst/Makefile.am
|
||||
base64.c prandom.c
|
||||
|
||||
EXTRA_DIST = dst_internal.h md5.h md5_locl.h
|
||||
diff -up dhcp-4.2.1-P1/omapip/Makefile.am.sharedlib dhcp-4.2.1-P1/omapip/Makefile.am
|
||||
--- dhcp-4.2.1-P1/omapip/Makefile.am.sharedlib 2011-06-30 17:04:29.477676575 +0200
|
||||
+++ dhcp-4.2.1-P1/omapip/Makefile.am 2011-06-30 17:04:29.490676384 +0200
|
||||
diff -up dhcp-4.2.2/omapip/Makefile.am.sharedlib dhcp-4.2.2/omapip/Makefile.am
|
||||
--- dhcp-4.2.2/omapip/Makefile.am.sharedlib 2011-08-11 17:36:03.995182885 +0200
|
||||
+++ dhcp-4.2.2/omapip/Makefile.am 2011-08-11 17:36:04.011182490 +0200
|
||||
@@ -1,9 +1,9 @@
|
||||
AM_CFLAGS = -fpic
|
||||
|
||||
@ -93,9 +103,9 @@ diff -up dhcp-4.2.1-P1/omapip/Makefile.am.sharedlib dhcp-4.2.1-P1/omapip/Makefil
|
||||
-svtest_LDADD = libomapi.a $(BIND9_LIBDIR) -ldns-export -lisc-export
|
||||
+svtest_LDADD = libomapi.la $(BIND9_LIBDIR) -ldns-export -lisc-export
|
||||
|
||||
diff -up dhcp-4.2.1-P1/relay/Makefile.am.sharedlib dhcp-4.2.1-P1/relay/Makefile.am
|
||||
--- dhcp-4.2.1-P1/relay/Makefile.am.sharedlib 2011-06-30 17:04:29.478676560 +0200
|
||||
+++ dhcp-4.2.1-P1/relay/Makefile.am 2011-06-30 17:04:29.490676384 +0200
|
||||
diff -up dhcp-4.2.2/relay/Makefile.am.sharedlib dhcp-4.2.2/relay/Makefile.am
|
||||
--- dhcp-4.2.2/relay/Makefile.am.sharedlib 2011-08-11 17:36:03.996182861 +0200
|
||||
+++ dhcp-4.2.2/relay/Makefile.am 2011-08-11 17:36:04.012182465 +0200
|
||||
@@ -3,7 +3,7 @@ AM_CPPFLAGS = -DLOCALSTATEDIR='"@localst
|
||||
sbin_PROGRAMS = dhcrelay
|
||||
dhcrelay_SOURCES = dhcrelay.c
|
||||
@ -105,9 +115,9 @@ diff -up dhcp-4.2.1-P1/relay/Makefile.am.sharedlib dhcp-4.2.1-P1/relay/Makefile.
|
||||
$(BIND9_LIBDIR) -ldns-export -lisc-export $(CAPNG_LDADD)
|
||||
dhcrelay_LDFLAGS = -pie -Wl,-z,relro -Wl,-z,now
|
||||
|
||||
diff -up dhcp-4.2.1-P1/server/Makefile.am.sharedlib dhcp-4.2.1-P1/server/Makefile.am
|
||||
--- dhcp-4.2.1-P1/server/Makefile.am.sharedlib 2011-06-30 17:04:29.478676560 +0200
|
||||
+++ dhcp-4.2.1-P1/server/Makefile.am 2011-06-30 17:06:32.831862566 +0200
|
||||
diff -up dhcp-4.2.2/server/Makefile.am.sharedlib dhcp-4.2.2/server/Makefile.am
|
||||
--- dhcp-4.2.2/server/Makefile.am.sharedlib 2011-08-11 17:36:03.996182861 +0200
|
||||
+++ dhcp-4.2.2/server/Makefile.am 2011-08-11 17:36:04.012182465 +0200
|
||||
@@ -7,9 +7,9 @@ dhcpd_SOURCES = dhcpd.c dhcp.c bootp.c c
|
||||
dhcpv6.c mdb6.c ldap.c ldap_casa.c
|
||||
|
@ -63,8 +63,8 @@ Patch25: dhcp-4.2.2-rfc3442-classless-static-routes.patch
|
||||
Patch26: dhcp-4.2.2-PIE-RELRO.patch
|
||||
Patch27: dhcp-4.2.0-honor-expired.patch
|
||||
Patch28: dhcp-4.2.0-noprefixavail.patch
|
||||
Patch29: dhcp420-rh637017.patch
|
||||
Patch30: dhcp420-sharedlib.patch
|
||||
Patch29: dhcp-4.2.2-remove-bind.patch
|
||||
Patch30: dhcp-4.2.2-sharedlib.patch
|
||||
Patch31: dhcp-4.2.0-PPP.patch
|
||||
|
||||
BuildRequires: autoconf
|
||||
@ -187,7 +187,7 @@ which do not support the systemd unit file format.
|
||||
rm bind/bind.tar.gz
|
||||
|
||||
# Fire away bundled BIND source.
|
||||
%patch29 -p1 -b .rh637017 %{?_rawbuild}
|
||||
%patch29 -p1 -b .remove-bind %{?_rawbuild}
|
||||
|
||||
# Replace the standard ISC warning message about requesting help with an
|
||||
# explanation that this is a patched build of ISC DHCP and bugs should be
|
||||
|
Loading…
Reference in New Issue
Block a user