- Upgrade to dhcp-4.1.0p1, which is the official upstream release to fix
CVE-2009-0692
This commit is contained in:
parent
c604925908
commit
441afc0d96
@ -1,2 +1,2 @@
|
||||
dhcp-4.1.0.tar.gz
|
||||
ldap-for-dhcp-4.1.0-4.tar.gz
|
||||
dhcp-4.1.0p1.tar.gz
|
||||
|
@ -1,21 +0,0 @@
|
||||
diff -up dhcp-4.1.0/client/dhclient.c.CVE-2009-0692 dhcp-4.1.0/client/dhclient.c
|
||||
--- dhcp-4.1.0/client/dhclient.c.CVE-2009-0692 2008-06-11 10:17:10.000000000 -1000
|
||||
+++ dhcp-4.1.0/client/dhclient.c 2009-08-05 11:32:24.000000000 -1000
|
||||
@@ -3054,8 +3054,15 @@ void script_write_params (client, prefix
|
||||
if (data.len > 3) {
|
||||
struct iaddr netmask, subnet, broadcast;
|
||||
|
||||
- memcpy (netmask.iabuf, data.data, data.len);
|
||||
- netmask.len = data.len;
|
||||
+ /*
|
||||
+ * No matter the length of the subnet-mask option,
|
||||
+ * use only the first four octets. Note that
|
||||
+ * subnet-mask options longer than 4 octets are not
|
||||
+ * in conformance with RFC 2132, but servers with this
|
||||
+ * flaw do exist.
|
||||
+ */
|
||||
+ memcpy(netmask.iabuf, data.data, 4);
|
||||
+ netmask.len = 4;
|
||||
data_string_forget (&data, MDL);
|
||||
|
||||
subnet = subnet_number (lease -> address, netmask);
|
24
dhcp.spec
24
dhcp.spec
@ -4,13 +4,16 @@
|
||||
# Where dhcp configuration files are stored
|
||||
%define dhcpconfdir %{_sysconfdir}/dhcp
|
||||
|
||||
# Base version number from ISC
|
||||
%define basever 4.1.0
|
||||
|
||||
# LDAP patch version
|
||||
%define ldappatchver %{version}-4
|
||||
%define ldappatchver %{basever}-4
|
||||
|
||||
Summary: Dynamic host configuration protocol software
|
||||
Name: dhcp
|
||||
Version: 4.1.0
|
||||
Release: 27%{?dist}
|
||||
Version: %{basever}p1
|
||||
Release: 1%{?dist}
|
||||
# NEVER CHANGE THE EPOCH on this package. The previous maintainer (prior to
|
||||
# dcantrell maintaining the package) made incorrect use of the epoch and
|
||||
# that's why it is at 12 now. It should have never been used, but it was.
|
||||
@ -49,8 +52,7 @@ Patch18: %{name}-4.1.0-missing-ipv6-not-fatal.patch
|
||||
Patch19: %{name}-4.1.0-IFNAMSIZ.patch
|
||||
Patch20: %{name}-4.1.0-add_timeout_when_NULL.patch
|
||||
Patch21: %{name}-4.1.0-64_bit_lease_parse.patch
|
||||
Patch22: %{name}-4.1.0-CVE-2009-0692.patch
|
||||
Patch23: %{name}-4.1.0-CVE-2009-1892.patch
|
||||
Patch22: %{name}-4.1.0-CVE-2009-1892.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: autoconf
|
||||
@ -116,7 +118,7 @@ libdhcpctl and libomapi static libraries are also included in this package.
|
||||
%setup -T -D -a 1
|
||||
|
||||
# Add in LDAP support
|
||||
%{__patch} -p1 < ldap-for-dhcp-%{ldappatchver}/%{name}-%{version}-ldap.patch
|
||||
%{__patch} -p1 < ldap-for-dhcp-%{ldappatchver}/%{name}-%{basever}-ldap.patch
|
||||
|
||||
# Replace the standard ISC warning message about requesting help with an
|
||||
# explanation that this is a patched build of ISC DHCP and bugs should be
|
||||
@ -205,13 +207,9 @@ libdhcpctl and libomapi static libraries are also included in this package.
|
||||
# Ensure 64-bit platforms parse lease file dates & times correctly (#448615)
|
||||
%patch21 -p1
|
||||
|
||||
# Fix for CVE-2009-0692 (patch from Mandriva SRPM)
|
||||
# http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-0692
|
||||
%patch22 -p1
|
||||
|
||||
# Fix for CVE-2009-1892 (patch from Mandriva SRPM)
|
||||
# http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-1892
|
||||
%patch23 -p1
|
||||
%patch22 -p1
|
||||
|
||||
# Copy in documentation and example scripts for LDAP patch to dhcpd
|
||||
%{__install} -p -m 0755 ldap-for-dhcp-%{ldappatchver}/dhcpd-conf-to-ldap contrib/
|
||||
@ -467,6 +465,10 @@ fi
|
||||
%attr(0644,root,root) %{_mandir}/man3/omapi.3.gz
|
||||
|
||||
%changelog
|
||||
* Wed Aug 05 2009 David Cantrell <dcantrell@redhat.com> - 12:4.1.0p1-1
|
||||
- Upgrade to dhcp-4.1.0p1, which is the official upstream release to fix
|
||||
CVE-2009-0692
|
||||
|
||||
* Wed Aug 05 2009 David Cantrell <dcantrell@redhat.com> - 12:4.1.0-27
|
||||
- Fix for CVE-2009-0692
|
||||
- Fix for CVE-2009-1892 (#511834)
|
||||
|
Loading…
Reference in New Issue
Block a user