- There was a useless 0-4 second delay before sending first DHCPDISCOVER. I
didn't remove it at all, but made it 0-1 second. (#587070)
This commit is contained in:
parent
262beb6e04
commit
2f26ada950
21
dhcp-4.1.1-initialization-delay.patch
Normal file
21
dhcp-4.1.1-initialization-delay.patch
Normal file
@ -0,0 +1,21 @@
|
||||
diff -up dhcp-4.1.1/client/dhclient.c.initialization-delay dhcp-4.1.1/client/dhclient.c
|
||||
--- dhcp-4.1.1/client/dhclient.c.initialization-delay 2010-04-29 17:02:09.000000000 +0200
|
||||
+++ dhcp-4.1.1/client/dhclient.c 2010-04-29 17:03:27.000000000 +0200
|
||||
@@ -930,7 +930,7 @@ main(int argc, char **argv) {
|
||||
/* Set up a timeout to start the
|
||||
* initialization process.
|
||||
*/
|
||||
- tv.tv_sec = cur_time + random() % 5;
|
||||
+ tv.tv_sec = cur_time + random() % 1;
|
||||
tv.tv_usec = 0;
|
||||
add_timeout(&tv, state_reboot,
|
||||
client, 0, 0);
|
||||
@@ -3913,7 +3913,7 @@ isc_result_t dhclient_interface_startup_
|
||||
client -> state = S_INIT;
|
||||
/* Set up a timeout to start the initialization
|
||||
process. */
|
||||
- tv . tv_sec = cur_time + random () % 5;
|
||||
+ tv . tv_sec = cur_time + random () % 1;
|
||||
tv . tv_usec = 0;
|
||||
add_timeout (&tv, state_reboot, client, 0, 0);
|
||||
}
|
11
dhcp.spec
11
dhcp.spec
@ -13,7 +13,7 @@
|
||||
Summary: Dynamic host configuration protocol software
|
||||
Name: dhcp
|
||||
Version: %{basever}
|
||||
Release: 20%{?dist}
|
||||
Release: 21%{?dist}
|
||||
# NEVER CHANGE THE EPOCH on this package. The previous maintainer (prior to
|
||||
# dcantrell maintaining the package) made incorrect use of the epoch and
|
||||
# that's why it is at 12 now. It should have never been used, but it was.
|
||||
@ -58,6 +58,7 @@ Patch22: %{name}-4.1.1-UseMulticast.patch
|
||||
Patch23: %{name}-4.1.1-sendDecline.patch
|
||||
Patch24: %{name}-4.1.1-retransmission.patch
|
||||
Patch25: %{name}-4.1.1-release6-elapsed.patch
|
||||
Patch26: %{name}-4.1.1-initialization-delay.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: autoconf
|
||||
@ -229,6 +230,10 @@ libdhcpctl and libomapi static libraries are also included in this package.
|
||||
# (Submitted to dhcp-bugs@isc.org - [ISC-Bugs #21171])
|
||||
%patch25 -p1 -b .release6-elapsed
|
||||
|
||||
# There was a useless 0-4 second delay before sending first DHCPDISCOVER.
|
||||
# I didn't remove it at all, but made it 0-1 second. (#587070)
|
||||
%patch26 -p1 -b .initialization-delay
|
||||
|
||||
# Copy in documentation and example scripts for LDAP patch to dhcpd
|
||||
%{__install} -p -m 0755 ldap-for-dhcp-%{ldappatchver}/dhcpd-conf-to-ldap contrib/
|
||||
|
||||
@ -511,6 +516,10 @@ fi
|
||||
%attr(0644,root,root) %{_mandir}/man3/omapi.3.gz
|
||||
|
||||
%changelog
|
||||
* Thu Apr 29 2010 Jiri Popelka <jpopelka@redhat.com> - 12:4.1.1-21
|
||||
- There was a useless 0-4 second delay before sending first DHCPDISCOVER.
|
||||
I didn't remove it at all, but made it 0-1 second. (#587070)
|
||||
|
||||
* Wed Apr 28 2010 Jiri Popelka <jpopelka@redhat.com> - 12:4.1.1-20
|
||||
- Move /etc/NetworkManager/dispatcher.d/10-dhclient script
|
||||
from dhcp to dhclient subpackage (#586999).
|
||||
|
Loading…
Reference in New Issue
Block a user