revert previous change (#782499) + remove sysvinit scriptlets
This commit is contained in:
parent
fbbf7bf10d
commit
035872d4ac
@ -1,422 +0,0 @@
|
|||||||
diff -up dhcp-4.2.0/client/clparse.c.cloexec dhcp-4.2.0/client/clparse.c
|
|
||||||
--- dhcp-4.2.0/client/clparse.c.cloexec 2010-07-21 13:55:42.000000000 +0200
|
|
||||||
+++ dhcp-4.2.0/client/clparse.c 2010-07-21 14:31:13.000000000 +0200
|
|
||||||
@@ -211,7 +211,7 @@ int read_client_conf_file (const char *n
|
|
||||||
int token;
|
|
||||||
isc_result_t status;
|
|
||||||
|
|
||||||
- if ((file = open (name, O_RDONLY)) < 0)
|
|
||||||
+ if ((file = open (name, O_RDONLY | O_CLOEXEC)) < 0)
|
|
||||||
return uerr2isc (errno);
|
|
||||||
|
|
||||||
cfile = NULL;
|
|
||||||
@@ -248,7 +248,7 @@ void read_client_leases ()
|
|
||||||
|
|
||||||
/* Open the lease file. If we can't open it, just return -
|
|
||||||
we can safely trust the server to remember our state. */
|
|
||||||
- if ((file = open (path_dhclient_db, O_RDONLY)) < 0)
|
|
||||||
+ if ((file = open (path_dhclient_db, O_RDONLY | O_CLOEXEC)) < 0)
|
|
||||||
return;
|
|
||||||
|
|
||||||
cfile = NULL;
|
|
||||||
diff -up dhcp-4.2.0/client/dhclient.c.cloexec dhcp-4.2.0/client/dhclient.c
|
|
||||||
--- dhcp-4.2.0/client/dhclient.c.cloexec 2010-07-21 13:55:42.000000000 +0200
|
|
||||||
+++ dhcp-4.2.0/client/dhclient.c 2010-07-21 14:33:44.000000000 +0200
|
|
||||||
@@ -137,11 +137,11 @@ main(int argc, char **argv) {
|
|
||||||
/* Make sure that file descriptors 0 (stdin), 1, (stdout), and
|
|
||||||
2 (stderr) are open. To do this, we assume that when we
|
|
||||||
open a file the lowest available file descriptor is used. */
|
|
||||||
- fd = open("/dev/null", O_RDWR);
|
|
||||||
+ fd = open("/dev/null", O_RDWR | O_CLOEXEC);
|
|
||||||
if (fd == 0)
|
|
||||||
- fd = open("/dev/null", O_RDWR);
|
|
||||||
+ fd = open("/dev/null", O_RDWR | O_CLOEXEC);
|
|
||||||
if (fd == 1)
|
|
||||||
- fd = open("/dev/null", O_RDWR);
|
|
||||||
+ fd = open("/dev/null", O_RDWR | O_CLOEXEC);
|
|
||||||
if (fd == 2)
|
|
||||||
log_perror = 0; /* No sense logging to /dev/null. */
|
|
||||||
else if (fd != -1)
|
|
||||||
@@ -488,7 +488,7 @@ main(int argc, char **argv) {
|
|
||||||
int e;
|
|
||||||
|
|
||||||
oldpid = 0;
|
|
||||||
- if ((pidfd = fopen(path_dhclient_pid, "r")) != NULL) {
|
|
||||||
+ if ((pidfd = fopen(path_dhclient_pid, "re")) != NULL) {
|
|
||||||
e = fscanf(pidfd, "%ld\n", &temp);
|
|
||||||
oldpid = (pid_t)temp;
|
|
||||||
|
|
||||||
@@ -530,7 +530,7 @@ main(int argc, char **argv) {
|
|
||||||
strncpy(new_path_dhclient_pid, path_dhclient_pid, pfx);
|
|
||||||
sprintf(new_path_dhclient_pid + pfx, "-%s.pid", ip->name);
|
|
||||||
|
|
||||||
- if ((pidfd = fopen(new_path_dhclient_pid, "r")) != NULL) {
|
|
||||||
+ if ((pidfd = fopen(new_path_dhclient_pid, "re")) != NULL) {
|
|
||||||
e = fscanf(pidfd, "%ld\n", &temp);
|
|
||||||
oldpid = (pid_t)temp;
|
|
||||||
|
|
||||||
@@ -555,7 +555,7 @@ main(int argc, char **argv) {
|
|
||||||
int dhc_running = 0;
|
|
||||||
char procfn[256] = "";
|
|
||||||
|
|
||||||
- if ((pidfp = fopen(path_dhclient_pid, "r")) != NULL) {
|
|
||||||
+ if ((pidfp = fopen(path_dhclient_pid, "re")) != NULL) {
|
|
||||||
if ((fscanf(pidfp, "%ld", &temp)==1) && ((dhcpid=(pid_t)temp) > 0)) {
|
|
||||||
snprintf(procfn,256,"/proc/%u",dhcpid);
|
|
||||||
dhc_running = (access(procfn, F_OK) == 0);
|
|
||||||
@@ -2931,7 +2931,7 @@ void rewrite_client_leases ()
|
|
||||||
|
|
||||||
if (leaseFile != NULL)
|
|
||||||
fclose (leaseFile);
|
|
||||||
- leaseFile = fopen (path_dhclient_db, "w");
|
|
||||||
+ leaseFile = fopen (path_dhclient_db, "we");
|
|
||||||
if (leaseFile == NULL) {
|
|
||||||
log_error ("can't create %s: %m", path_dhclient_db);
|
|
||||||
return;
|
|
||||||
@@ -3035,7 +3035,7 @@ write_duid(struct data_string *duid)
|
|
||||||
return DHCP_R_INVALIDARG;
|
|
||||||
|
|
||||||
if (leaseFile == NULL) { /* XXX? */
|
|
||||||
- leaseFile = fopen(path_dhclient_db, "w");
|
|
||||||
+ leaseFile = fopen(path_dhclient_db, "we");
|
|
||||||
if (leaseFile == NULL) {
|
|
||||||
log_error("can't create %s: %m", path_dhclient_db);
|
|
||||||
return ISC_R_IOERROR;
|
|
||||||
@@ -3215,7 +3215,7 @@ int write_client_lease (client, lease, r
|
|
||||||
return 1;
|
|
||||||
|
|
||||||
if (leaseFile == NULL) { /* XXX */
|
|
||||||
- leaseFile = fopen (path_dhclient_db, "w");
|
|
||||||
+ leaseFile = fopen (path_dhclient_db, "we");
|
|
||||||
if (leaseFile == NULL) {
|
|
||||||
log_error ("can't create %s: %m", path_dhclient_db);
|
|
||||||
return 0;
|
|
||||||
@@ -3668,9 +3668,9 @@ void go_daemon ()
|
|
||||||
close(2);
|
|
||||||
|
|
||||||
/* Reopen them on /dev/null. */
|
|
||||||
- open("/dev/null", O_RDWR);
|
|
||||||
- open("/dev/null", O_RDWR);
|
|
||||||
- open("/dev/null", O_RDWR);
|
|
||||||
+ open("/dev/null", O_RDWR | O_CLOEXEC);
|
|
||||||
+ open("/dev/null", O_RDWR | O_CLOEXEC);
|
|
||||||
+ open("/dev/null", O_RDWR | O_CLOEXEC);
|
|
||||||
|
|
||||||
write_client_pid_file ();
|
|
||||||
|
|
||||||
@@ -3682,14 +3682,14 @@ void write_client_pid_file ()
|
|
||||||
FILE *pf;
|
|
||||||
int pfdesc;
|
|
||||||
|
|
||||||
- pfdesc = open (path_dhclient_pid, O_CREAT | O_TRUNC | O_WRONLY, 0644);
|
|
||||||
+ pfdesc = open (path_dhclient_pid, O_CREAT | O_TRUNC | O_WRONLY | O_CLOEXEC, 0644);
|
|
||||||
|
|
||||||
if (pfdesc < 0) {
|
|
||||||
log_error ("Can't create %s: %m", path_dhclient_pid);
|
|
||||||
return;
|
|
||||||
}
|
|
||||||
|
|
||||||
- pf = fdopen (pfdesc, "w");
|
|
||||||
+ pf = fdopen (pfdesc, "we");
|
|
||||||
if (!pf)
|
|
||||||
log_error ("Can't fdopen %s: %m", path_dhclient_pid);
|
|
||||||
else {
|
|
||||||
diff -up dhcp-4.2.0/common/bpf.c.cloexec dhcp-4.2.0/common/bpf.c
|
|
||||||
--- dhcp-4.2.0/common/bpf.c.cloexec 2009-11-20 02:48:59.000000000 +0100
|
|
||||||
+++ dhcp-4.2.0/common/bpf.c 2010-07-21 14:31:13.000000000 +0200
|
|
||||||
@@ -94,7 +94,7 @@ int if_register_bpf (info)
|
|
||||||
for (b = 0; 1; b++) {
|
|
||||||
/* %Audit% 31 bytes max. %2004.06.17,Safe% */
|
|
||||||
sprintf(filename, BPF_FORMAT, b);
|
|
||||||
- sock = open (filename, O_RDWR, 0);
|
|
||||||
+ sock = open (filename, O_RDWR | O_CLOEXEC, 0);
|
|
||||||
if (sock < 0) {
|
|
||||||
if (errno == EBUSY) {
|
|
||||||
continue;
|
|
||||||
diff -up dhcp-4.2.0/common/discover.c.cloexec dhcp-4.2.0/common/discover.c
|
|
||||||
--- dhcp-4.2.0/common/discover.c.cloexec 2009-10-28 05:12:29.000000000 +0100
|
|
||||||
+++ dhcp-4.2.0/common/discover.c 2010-07-21 14:31:13.000000000 +0200
|
|
||||||
@@ -409,7 +409,7 @@ begin_iface_scan(struct iface_conf_list
|
|
||||||
int len;
|
|
||||||
int i;
|
|
||||||
|
|
||||||
- ifaces->fp = fopen("/proc/net/dev", "r");
|
|
||||||
+ ifaces->fp = fopen("/proc/net/dev", "re");
|
|
||||||
if (ifaces->fp == NULL) {
|
|
||||||
log_error("Error opening '/proc/net/dev' to list interfaces");
|
|
||||||
return 0;
|
|
||||||
@@ -444,7 +444,7 @@ begin_iface_scan(struct iface_conf_list
|
|
||||||
|
|
||||||
#ifdef DHCPv6
|
|
||||||
if (local_family == AF_INET6) {
|
|
||||||
- ifaces->fp6 = fopen("/proc/net/if_inet6", "r");
|
|
||||||
+ ifaces->fp6 = fopen("/proc/net/if_inet6", "re");
|
|
||||||
if (ifaces->fp6 == NULL) {
|
|
||||||
log_error("Error opening '/proc/net/if_inet6' to "
|
|
||||||
"list IPv6 interfaces; %m");
|
|
||||||
diff -up dhcp-4.2.0/common/dlpi.c.cloexec dhcp-4.2.0/common/dlpi.c
|
|
||||||
--- dhcp-4.2.0/common/dlpi.c.cloexec 2009-11-20 02:49:00.000000000 +0100
|
|
||||||
+++ dhcp-4.2.0/common/dlpi.c 2010-07-21 14:31:13.000000000 +0200
|
|
||||||
@@ -807,7 +807,7 @@ dlpiopen(const char *ifname) {
|
|
||||||
}
|
|
||||||
*dp = '\0';
|
|
||||||
|
|
||||||
- return open (devname, O_RDWR, 0);
|
|
||||||
+ return open (devname, O_RDWR | O_CLOEXEC, 0);
|
|
||||||
}
|
|
||||||
|
|
||||||
/*
|
|
||||||
diff -up dhcp-4.2.0/common/nit.c.cloexec dhcp-4.2.0/common/nit.c
|
|
||||||
--- dhcp-4.2.0/common/nit.c.cloexec 2009-11-20 02:49:01.000000000 +0100
|
|
||||||
+++ dhcp-4.2.0/common/nit.c 2010-07-21 14:31:13.000000000 +0200
|
|
||||||
@@ -81,7 +81,7 @@ int if_register_nit (info)
|
|
||||||
struct strioctl sio;
|
|
||||||
|
|
||||||
/* Open a NIT device */
|
|
||||||
- sock = open ("/dev/nit", O_RDWR);
|
|
||||||
+ sock = open ("/dev/nit", O_RDWR | O_CLOEXEC);
|
|
||||||
if (sock < 0)
|
|
||||||
log_fatal ("Can't open NIT device for %s: %m", info -> name);
|
|
||||||
|
|
||||||
diff -up dhcp-4.2.0/common/resolv.c.cloexec dhcp-4.2.0/common/resolv.c
|
|
||||||
--- dhcp-4.2.0/common/resolv.c.cloexec 2009-11-20 02:49:01.000000000 +0100
|
|
||||||
+++ dhcp-4.2.0/common/resolv.c 2010-07-21 14:31:13.000000000 +0200
|
|
||||||
@@ -49,7 +49,7 @@ void read_resolv_conf (parse_time)
|
|
||||||
struct domain_search_list *dp, *dl, *nd;
|
|
||||||
isc_result_t status;
|
|
||||||
|
|
||||||
- if ((file = open (path_resolv_conf, O_RDONLY)) < 0) {
|
|
||||||
+ if ((file = open (path_resolv_conf, O_RDONLY | O_CLOEXEC)) < 0) {
|
|
||||||
log_error ("Can't open %s: %m", path_resolv_conf);
|
|
||||||
return;
|
|
||||||
}
|
|
||||||
diff -up dhcp-4.2.0/common/upf.c.cloexec dhcp-4.2.0/common/upf.c
|
|
||||||
--- dhcp-4.2.0/common/upf.c.cloexec 2009-11-20 02:49:01.000000000 +0100
|
|
||||||
+++ dhcp-4.2.0/common/upf.c 2010-07-21 14:31:13.000000000 +0200
|
|
||||||
@@ -77,7 +77,7 @@ int if_register_upf (info)
|
|
||||||
/* %Audit% Cannot exceed 36 bytes. %2004.06.17,Safe% */
|
|
||||||
sprintf(filename, "/dev/pf/pfilt%d", b);
|
|
||||||
|
|
||||||
- sock = open (filename, O_RDWR, 0);
|
|
||||||
+ sock = open (filename, O_RDWR | O_CLOEXEC, 0);
|
|
||||||
if (sock < 0) {
|
|
||||||
if (errno == EBUSY) {
|
|
||||||
continue;
|
|
||||||
diff -up dhcp-4.2.0/dst/dst_api.c.cloexec dhcp-4.2.0/dst/dst_api.c
|
|
||||||
--- dhcp-4.2.0/dst/dst_api.c.cloexec 2009-10-29 01:46:48.000000000 +0100
|
|
||||||
+++ dhcp-4.2.0/dst/dst_api.c 2010-07-21 14:31:13.000000000 +0200
|
|
||||||
@@ -437,7 +437,7 @@ dst_s_write_private_key(const DST_KEY *k
|
|
||||||
PRIVATE_KEY, PATH_MAX);
|
|
||||||
|
|
||||||
/* Do not overwrite an existing file */
|
|
||||||
- if ((fp = dst_s_fopen(file, "w", 0600)) != NULL) {
|
|
||||||
+ if ((fp = dst_s_fopen(file, "we", 0600)) != NULL) {
|
|
||||||
int nn;
|
|
||||||
if ((nn = fwrite(encoded_block, 1, len, fp)) != len) {
|
|
||||||
EREPORT(("dst_write_private_key(): Write failure on %s %d != %d errno=%d\n",
|
|
||||||
@@ -494,7 +494,7 @@ dst_s_read_public_key(const char *in_nam
|
|
||||||
* flags, proto, alg stored as decimal (or hex numbers FIXME).
|
|
||||||
* (FIXME: handle parentheses for line continuation.)
|
|
||||||
*/
|
|
||||||
- if ((fp = dst_s_fopen(name, "r", 0)) == NULL) {
|
|
||||||
+ if ((fp = dst_s_fopen(name, "re", 0)) == NULL) {
|
|
||||||
EREPORT(("dst_read_public_key(): Public Key not found %s\n",
|
|
||||||
name));
|
|
||||||
return (NULL);
|
|
||||||
@@ -620,7 +620,7 @@ dst_s_write_public_key(const DST_KEY *ke
|
|
||||||
return (0);
|
|
||||||
}
|
|
||||||
/* create public key file */
|
|
||||||
- if ((fp = dst_s_fopen(filename, "w+", 0644)) == NULL) {
|
|
||||||
+ if ((fp = dst_s_fopen(filename, "w+e", 0644)) == NULL) {
|
|
||||||
EREPORT(("DST_write_public_key: open of file:%s failed (errno=%d)\n",
|
|
||||||
filename, errno));
|
|
||||||
return (0);
|
|
||||||
@@ -854,7 +854,7 @@ dst_s_read_private_key_file(char *name,
|
|
||||||
return (0);
|
|
||||||
}
|
|
||||||
/* first check if we can find the key file */
|
|
||||||
- if ((fp = dst_s_fopen(filename, "r", 0)) == NULL) {
|
|
||||||
+ if ((fp = dst_s_fopen(filename, "re", 0)) == NULL) {
|
|
||||||
EREPORT(("dst_s_read_private_key_file: Could not open file %s in directory %s\n",
|
|
||||||
filename, dst_path[0] ? dst_path :
|
|
||||||
(char *) getcwd(NULL, PATH_MAX - 1)));
|
|
||||||
diff -up dhcp-4.2.0/dst/prandom.c.cloexec dhcp-4.2.0/dst/prandom.c
|
|
||||||
--- dhcp-4.2.0/dst/prandom.c.cloexec 2009-11-20 02:49:01.000000000 +0100
|
|
||||||
+++ dhcp-4.2.0/dst/prandom.c 2010-07-21 14:31:13.000000000 +0200
|
|
||||||
@@ -269,7 +269,7 @@ get_dev_random(u_char *output, unsigned
|
|
||||||
|
|
||||||
s = stat("/dev/random", &st);
|
|
||||||
if (s == 0 && S_ISCHR(st.st_mode)) {
|
|
||||||
- if ((fd = open("/dev/random", O_RDONLY | O_NONBLOCK)) != -1) {
|
|
||||||
+ if ((fd = open("/dev/random", O_RDONLY | O_NONBLOCK | O_CLOEXEC)) != -1) {
|
|
||||||
if ((n = read(fd, output, size)) < 0)
|
|
||||||
n = 0;
|
|
||||||
close(fd);
|
|
||||||
@@ -480,7 +480,7 @@ digest_file(dst_work *work)
|
|
||||||
work->file_digest = dst_free_key(work->file_digest);
|
|
||||||
return (0);
|
|
||||||
}
|
|
||||||
- if ((fp = fopen(name, "r")) == NULL)
|
|
||||||
+ if ((fp = fopen(name, "re")) == NULL)
|
|
||||||
return (0);
|
|
||||||
for (no = 0; (i = fread(buf, sizeof(*buf), sizeof(buf), fp)) > 0;
|
|
||||||
no += i)
|
|
||||||
diff -up dhcp-4.2.0/omapip/trace.c.cloexec dhcp-4.2.0/omapip/trace.c
|
|
||||||
--- dhcp-4.2.0/omapip/trace.c.cloexec 2010-06-01 19:29:59.000000000 +0200
|
|
||||||
+++ dhcp-4.2.0/omapip/trace.c 2010-07-21 14:36:48.000000000 +0200
|
|
||||||
@@ -141,10 +141,10 @@ isc_result_t trace_begin (const char *fi
|
|
||||||
return DHCP_R_INVALIDARG;
|
|
||||||
}
|
|
||||||
|
|
||||||
- traceoutfile = open (filename, O_CREAT | O_WRONLY | O_EXCL, 0600);
|
|
||||||
+ traceoutfile = open (filename, O_CREAT | O_WRONLY | O_EXCL | O_CLOEXEC, 0600);
|
|
||||||
if (traceoutfile < 0 && errno == EEXIST) {
|
|
||||||
log_error ("WARNING: Overwriting trace file \"%s\"", filename);
|
|
||||||
- traceoutfile = open (filename, O_WRONLY | O_EXCL | O_TRUNC,
|
|
||||||
+ traceoutfile = open (filename, O_WRONLY | O_EXCL | O_TRUNC | O_CLOEXEC,
|
|
||||||
0600);
|
|
||||||
}
|
|
||||||
|
|
||||||
@@ -431,7 +431,7 @@ void trace_file_replay (const char *file
|
|
||||||
isc_result_t result;
|
|
||||||
int len;
|
|
||||||
|
|
||||||
- traceinfile = fopen (filename, "r");
|
|
||||||
+ traceinfile = fopen (filename, "re");
|
|
||||||
if (!traceinfile) {
|
|
||||||
log_error("Can't open tracefile %s: %m", filename);
|
|
||||||
return;
|
|
||||||
diff -up dhcp-4.2.0/relay/dhcrelay.c.cloexec dhcp-4.2.0/relay/dhcrelay.c
|
|
||||||
--- dhcp-4.2.0/relay/dhcrelay.c.cloexec 2010-02-17 21:33:55.000000000 +0100
|
|
||||||
+++ dhcp-4.2.0/relay/dhcrelay.c 2010-07-21 14:31:39.000000000 +0200
|
|
||||||
@@ -177,11 +177,11 @@ main(int argc, char **argv) {
|
|
||||||
/* Make sure that file descriptors 0(stdin), 1,(stdout), and
|
|
||||||
2(stderr) are open. To do this, we assume that when we
|
|
||||||
open a file the lowest available file descriptor is used. */
|
|
||||||
- fd = open("/dev/null", O_RDWR);
|
|
||||||
+ fd = open("/dev/null", O_RDWR | O_CLOEXEC);
|
|
||||||
if (fd == 0)
|
|
||||||
- fd = open("/dev/null", O_RDWR);
|
|
||||||
+ fd = open("/dev/null", O_RDWR | O_CLOEXEC);
|
|
||||||
if (fd == 1)
|
|
||||||
- fd = open("/dev/null", O_RDWR);
|
|
||||||
+ fd = open("/dev/null", O_RDWR | O_CLOEXEC);
|
|
||||||
if (fd == 2)
|
|
||||||
log_perror = 0; /* No sense logging to /dev/null. */
|
|
||||||
else if (fd != -1)
|
|
||||||
@@ -520,12 +520,12 @@ main(int argc, char **argv) {
|
|
||||||
exit(0);
|
|
||||||
|
|
||||||
pfdesc = open(path_dhcrelay_pid,
|
|
||||||
- O_CREAT | O_TRUNC | O_WRONLY, 0644);
|
|
||||||
+ O_CREAT | O_TRUNC | O_WRONLY | O_CLOEXEC, 0644);
|
|
||||||
|
|
||||||
if (pfdesc < 0) {
|
|
||||||
log_error("Can't create %s: %m", path_dhcrelay_pid);
|
|
||||||
} else {
|
|
||||||
- pf = fdopen(pfdesc, "w");
|
|
||||||
+ pf = fdopen(pfdesc, "we");
|
|
||||||
if (!pf)
|
|
||||||
log_error("Can't fdopen %s: %m",
|
|
||||||
path_dhcrelay_pid);
|
|
||||||
diff -up dhcp-4.2.0/server/confpars.c.cloexec dhcp-4.2.0/server/confpars.c
|
|
||||||
--- dhcp-4.2.0/server/confpars.c.cloexec 2010-03-24 22:49:47.000000000 +0100
|
|
||||||
+++ dhcp-4.2.0/server/confpars.c 2010-07-21 14:31:39.000000000 +0200
|
|
||||||
@@ -116,7 +116,7 @@ isc_result_t read_conf_file (const char
|
|
||||||
}
|
|
||||||
#endif
|
|
||||||
|
|
||||||
- if ((file = open (filename, O_RDONLY)) < 0) {
|
|
||||||
+ if ((file = open (filename, O_RDONLY | O_CLOEXEC)) < 0) {
|
|
||||||
if (leasep) {
|
|
||||||
log_error ("Can't open lease database %s: %m --",
|
|
||||||
path_dhcpd_db);
|
|
||||||
diff -up dhcp-4.2.0/server/db.c.cloexec dhcp-4.2.0/server/db.c
|
|
||||||
--- dhcp-4.2.0/server/db.c.cloexec 2010-02-17 21:33:55.000000000 +0100
|
|
||||||
+++ dhcp-4.2.0/server/db.c 2010-07-21 14:31:39.000000000 +0200
|
|
||||||
@@ -1035,7 +1035,7 @@ void db_startup (testp)
|
|
||||||
}
|
|
||||||
#endif
|
|
||||||
if (!testp) {
|
|
||||||
- db_file = fopen (path_dhcpd_db, "a");
|
|
||||||
+ db_file = fopen (path_dhcpd_db, "ae");
|
|
||||||
if (!db_file)
|
|
||||||
log_fatal ("Can't open %s for append.", path_dhcpd_db);
|
|
||||||
expire_all_pools ();
|
|
||||||
@@ -1083,12 +1083,12 @@ int new_lease_file ()
|
|
||||||
path_dhcpd_db, (int)t) >= sizeof newfname)
|
|
||||||
log_fatal("new_lease_file: lease file path too long");
|
|
||||||
|
|
||||||
- db_fd = open (newfname, O_WRONLY | O_TRUNC | O_CREAT, 0664);
|
|
||||||
+ db_fd = open (newfname, O_WRONLY | O_TRUNC | O_CREAT | O_CLOEXEC, 0664);
|
|
||||||
if (db_fd < 0) {
|
|
||||||
log_error ("Can't create new lease file: %m");
|
|
||||||
return 0;
|
|
||||||
}
|
|
||||||
- if ((new_db_file = fdopen(db_fd, "w")) == NULL) {
|
|
||||||
+ if ((new_db_file = fdopen(db_fd, "we")) == NULL) {
|
|
||||||
log_error("Can't fdopen new lease file: %m");
|
|
||||||
close(db_fd);
|
|
||||||
goto fdfail;
|
|
||||||
diff -up dhcp-4.2.0/server/dhcpd.c.cloexec dhcp-4.2.0/server/dhcpd.c
|
|
||||||
--- dhcp-4.2.0/server/dhcpd.c.cloexec 2010-06-01 19:29:59.000000000 +0200
|
|
||||||
+++ dhcp-4.2.0/server/dhcpd.c 2010-07-21 14:31:39.000000000 +0200
|
|
||||||
@@ -268,11 +268,11 @@ main(int argc, char **argv) {
|
|
||||||
/* Make sure that file descriptors 0 (stdin), 1, (stdout), and
|
|
||||||
2 (stderr) are open. To do this, we assume that when we
|
|
||||||
open a file the lowest available file descriptor is used. */
|
|
||||||
- fd = open("/dev/null", O_RDWR);
|
|
||||||
+ fd = open("/dev/null", O_RDWR | O_CLOEXEC);
|
|
||||||
if (fd == 0)
|
|
||||||
- fd = open("/dev/null", O_RDWR);
|
|
||||||
+ fd = open("/dev/null", O_RDWR | O_CLOEXEC);
|
|
||||||
if (fd == 1)
|
|
||||||
- fd = open("/dev/null", O_RDWR);
|
|
||||||
+ fd = open("/dev/null", O_RDWR | O_CLOEXEC);
|
|
||||||
if (fd == 2)
|
|
||||||
log_perror = 0; /* No sense logging to /dev/null. */
|
|
||||||
else if (fd != -1)
|
|
||||||
@@ -780,7 +780,7 @@ main(int argc, char **argv) {
|
|
||||||
#endif /* PARANOIA */
|
|
||||||
|
|
||||||
/* Read previous pid file. */
|
|
||||||
- if ((i = open (path_dhcpd_pid, O_RDONLY)) >= 0) {
|
|
||||||
+ if ((i = open (path_dhcpd_pid, O_RDONLY | O_CLOEXEC)) >= 0) {
|
|
||||||
status = read(i, pbuf, (sizeof pbuf) - 1);
|
|
||||||
close (i);
|
|
||||||
if (status > 0) {
|
|
||||||
@@ -798,7 +798,7 @@ main(int argc, char **argv) {
|
|
||||||
}
|
|
||||||
|
|
||||||
/* Write new pid file. */
|
|
||||||
- if ((i = open(path_dhcpd_pid, O_WRONLY|O_CREAT|O_TRUNC, 0644)) >= 0) {
|
|
||||||
+ if ((i = open(path_dhcpd_pid, O_WRONLY|O_CREAT|O_TRUNC|O_CLOEXEC, 0644)) >= 0) {
|
|
||||||
sprintf(pbuf, "%d\n", (int) getpid());
|
|
||||||
IGNORE_RET (write(i, pbuf, strlen(pbuf)));
|
|
||||||
close(i);
|
|
||||||
@@ -824,9 +824,9 @@ main(int argc, char **argv) {
|
|
||||||
close(2);
|
|
||||||
|
|
||||||
/* Reopen them on /dev/null. */
|
|
||||||
- open("/dev/null", O_RDWR);
|
|
||||||
- open("/dev/null", O_RDWR);
|
|
||||||
- open("/dev/null", O_RDWR);
|
|
||||||
+ open("/dev/null", O_RDWR | O_CLOEXEC);
|
|
||||||
+ open("/dev/null", O_RDWR | O_CLOEXEC);
|
|
||||||
+ open("/dev/null", O_RDWR | O_CLOEXEC);
|
|
||||||
log_perror = 0; /* No sense logging to /dev/null. */
|
|
||||||
|
|
||||||
IGNORE_RET (chdir("/"));
|
|
||||||
diff -up dhcp-4.2.0/server/ldap.c.cloexec dhcp-4.2.0/server/ldap.c
|
|
||||||
--- dhcp-4.2.0/server/ldap.c.cloexec 2010-03-25 16:26:58.000000000 +0100
|
|
||||||
+++ dhcp-4.2.0/server/ldap.c 2010-07-21 14:31:39.000000000 +0200
|
|
||||||
@@ -685,7 +685,7 @@ ldap_start (void)
|
|
||||||
|
|
||||||
if (ldap_debug_file != NULL && ldap_debug_fd == -1)
|
|
||||||
{
|
|
||||||
- if ((ldap_debug_fd = open (ldap_debug_file, O_CREAT | O_TRUNC | O_WRONLY,
|
|
||||||
+ if ((ldap_debug_fd = open (ldap_debug_file, O_CREAT | O_TRUNC | O_WRONLY | O_CLOEXEC,
|
|
||||||
S_IRUSR | S_IWUSR)) < 0)
|
|
||||||
log_error ("Error opening debug LDAP log file %s: %s", ldap_debug_file,
|
|
||||||
strerror (errno));
|
|
@ -1,16 +0,0 @@
|
|||||||
diff -up dhcp-4.2.1-P1/client/dhclient.c.CVE-2011-0997 dhcp-4.2.1-P1/client/dhclient.c
|
|
||||||
--- dhcp-4.2.1-P1/client/dhclient.c.CVE-2011-0997 2011-04-06 20:21:43.000000000 +0200
|
|
||||||
+++ dhcp-4.2.1-P1/client/dhclient.c 2011-04-06 20:22:31.000000000 +0200
|
|
||||||
@@ -4545,11 +4545,11 @@ static int check_option_values(struct un
|
|
||||||
if ((universe == NULL) || (universe == &dhcp_universe)) {
|
|
||||||
switch(opt) {
|
|
||||||
case DHO_HOST_NAME:
|
|
||||||
- case DHO_DOMAIN_NAME:
|
|
||||||
case DHO_NIS_DOMAIN:
|
|
||||||
case DHO_NETBIOS_SCOPE:
|
|
||||||
return check_domain_name(ptr, len, 0);
|
|
||||||
break;
|
|
||||||
+ case DHO_DOMAIN_NAME: /* accept a list for compatibiliy */
|
|
||||||
case DHO_DOMAIN_SEARCH:
|
|
||||||
return check_domain_name_list(ptr, len, 0);
|
|
||||||
break;
|
|
@ -1,12 +0,0 @@
|
|||||||
diff -up dhcp-4.2.1b1/client/dhclient.conf.supersede dhcp-4.2.1b1/client/dhclient.conf
|
|
||||||
--- dhcp-4.2.1b1/client/dhclient.conf.supersede 2010-09-15 01:03:56.000000000 +0200
|
|
||||||
+++ dhcp-4.2.1b1/client/dhclient.conf 2011-01-27 18:38:28.000000000 +0100
|
|
||||||
@@ -4,7 +4,7 @@ send dhcp-lease-time 3600;
|
|
||||||
supersede domain-search "fugue.com", "home.vix.com";
|
|
||||||
prepend domain-name-servers 127.0.0.1;
|
|
||||||
request subnet-mask, broadcast-address, time-offset, routers,
|
|
||||||
- domain-name, domain-name-servers, host-name;
|
|
||||||
+ domain-search, domain-name-servers, host-name;
|
|
||||||
require subnet-mask, domain-name-servers;
|
|
||||||
timeout 60;
|
|
||||||
retry 60;
|
|
42
dhcp.spec
42
dhcp.spec
@ -22,7 +22,7 @@
|
|||||||
Summary: Dynamic host configuration protocol software
|
Summary: Dynamic host configuration protocol software
|
||||||
Name: dhcp
|
Name: dhcp
|
||||||
Version: 4.2.3
|
Version: 4.2.3
|
||||||
Release: 14.%{patchver}%{?dist}
|
Release: 15.%{patchver}%{?dist}
|
||||||
# NEVER CHANGE THE EPOCH on this package. The previous maintainer (prior to
|
# NEVER CHANGE THE EPOCH on this package. The previous maintainer (prior to
|
||||||
# dcantrell maintaining the package) made incorrect use of the epoch and
|
# dcantrell maintaining the package) made incorrect use of the epoch and
|
||||||
# that's why it is at 12 now. It should have never been used, but it was.
|
# that's why it is at 12 now. It should have never been used, but it was.
|
||||||
@ -89,15 +89,9 @@ BuildRequires: systemtap-sdt-devel
|
|||||||
Requires: %{name}-common = %{epoch}:%{version}-%{release}
|
Requires: %{name}-common = %{epoch}:%{version}-%{release}
|
||||||
Requires: %{name}-libs%{?_isa} = %{epoch}:%{version}-%{release}
|
Requires: %{name}-libs%{?_isa} = %{epoch}:%{version}-%{release}
|
||||||
Requires(pre): shadow-utils
|
Requires(pre): shadow-utils
|
||||||
Requires(post): chkconfig
|
|
||||||
Requires(post): coreutils
|
Requires(post): coreutils
|
||||||
Requires(post): systemd-units
|
Requires(post): systemd-units
|
||||||
# This is actually needed for the %%triggerun script but Requires(triggerun) is not valid.
|
|
||||||
Requires(post): systemd-sysv
|
|
||||||
Requires(preun): chkconfig
|
|
||||||
Requires(preun): initscripts
|
|
||||||
Requires(preun): systemd-units
|
Requires(preun): systemd-units
|
||||||
Requires(postun): initscripts
|
|
||||||
Requires(postun): systemd-units
|
Requires(postun): systemd-units
|
||||||
|
|
||||||
# In _docdir we ship some perl scripts and module from contrib subdirectory.
|
# In _docdir we ship some perl scripts and module from contrib subdirectory.
|
||||||
@ -168,14 +162,6 @@ Requires: %{name}-libs%{?_isa} = %{epoch}:%{version}-%{release}
|
|||||||
Header files and API documentation for using the ISC DHCP libraries. The
|
Header files and API documentation for using the ISC DHCP libraries. The
|
||||||
libdhcpctl and libomapi static libraries are also included in this package.
|
libdhcpctl and libomapi static libraries are also included in this package.
|
||||||
|
|
||||||
%package sysvinit
|
|
||||||
Summary: Legacy SysV initscripts for DHCP server and relay agent
|
|
||||||
Group: System Environment/Base
|
|
||||||
|
|
||||||
%description sysvinit
|
|
||||||
Legacy SysV initscripts for init mechanisms such as upstart
|
|
||||||
which do not support the systemd unit file format.
|
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n dhcp-%{VERSION}
|
%setup -q -n dhcp-%{VERSION}
|
||||||
|
|
||||||
@ -552,28 +538,6 @@ fi
|
|||||||
%postun libs -p /sbin/ldconfig
|
%postun libs -p /sbin/ldconfig
|
||||||
|
|
||||||
|
|
||||||
%triggerun -- dhcp < 12:4.2.0-21.P1
|
|
||||||
# https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Systemd
|
|
||||||
# Save the current service runlevel info
|
|
||||||
# User must manually run systemd-sysv-convert --apply dhcpd
|
|
||||||
# to migrate them to systemd targets
|
|
||||||
/usr/bin/systemd-sysv-convert --save dhcpd >/dev/null 2>&1 ||:
|
|
||||||
/usr/bin/systemd-sysv-convert --save dhcpd6 >/dev/null 2>&1 ||:
|
|
||||||
/usr/bin/systemd-sysv-convert --save dhcrelay >/dev/null 2>&1 ||:
|
|
||||||
# Run these because the SysV package being removed won't do them
|
|
||||||
/sbin/chkconfig --del dhcpd >/dev/null 2>&1 || :
|
|
||||||
/sbin/chkconfig --del dhcpd6 >/dev/null 2>&1 || :
|
|
||||||
/sbin/chkconfig --del dhcrelay >/dev/null 2>&1 || :
|
|
||||||
/bin/systemctl try-restart dhcpd.service >/dev/null 2>&1 || :
|
|
||||||
/bin/systemctl try-restart dhcpd6.service >/dev/null 2>&1 || :
|
|
||||||
/bin/systemctl try-restart dhcrelay.service >/dev/null 2>&1 || :
|
|
||||||
|
|
||||||
%triggerpostun -n dhcp-sysvinit -- dhcp < 12:4.2.0-21.P1
|
|
||||||
# https://fedoraproject.org/wiki/Packaging:SysVInitScript#Initscripts_in_addition_to_systemd_unit_files
|
|
||||||
/sbin/chkconfig --add dhcpd >/dev/null 2>&1 || :
|
|
||||||
/sbin/chkconfig --add dhcpd6 >/dev/null 2>&1 || :
|
|
||||||
/sbin/chkconfig --add dhcrelay >/dev/null 2>&1 || :
|
|
||||||
|
|
||||||
%files
|
%files
|
||||||
%doc dhcpd.conf.sample dhcpd6.conf.sample
|
%doc dhcpd.conf.sample dhcpd6.conf.sample
|
||||||
%doc contrib/*
|
%doc contrib/*
|
||||||
@ -643,6 +607,10 @@ fi
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jan 31 2012 Jiri Popelka <jpopelka@redhat.com> - 12:4.2.3-15.P2
|
||||||
|
- revert previous change (#782499)
|
||||||
|
- remove the rest of the sysvinit scriptlets
|
||||||
|
|
||||||
* Tue Jan 17 2012 Jiri Popelka <jpopelka@redhat.com> - 12:4.2.3-14.P2
|
* Tue Jan 17 2012 Jiri Popelka <jpopelka@redhat.com> - 12:4.2.3-14.P2
|
||||||
- use PrivateTmp=true in service files (#782499)
|
- use PrivateTmp=true in service files (#782499)
|
||||||
|
|
||||||
|
@ -4,8 +4,7 @@ After=syslog.target network.target
|
|||||||
|
|
||||||
[Service]
|
[Service]
|
||||||
EnvironmentFile=/etc/sysconfig/dhcpd
|
EnvironmentFile=/etc/sysconfig/dhcpd
|
||||||
ExecStart=/usr/sbin/dhcpd -d -user dhcpd -group dhcpd --no-pid $DHCPDARGS
|
ExecStart=/usr/sbin/dhcpd -f -user dhcpd -group dhcpd --no-pid $DHCPDARGS
|
||||||
PrivateTmp=true
|
|
||||||
|
|
||||||
[Install]
|
[Install]
|
||||||
WantedBy=multi-user.target
|
WantedBy=multi-user.target
|
||||||
|
@ -4,8 +4,7 @@ After=syslog.target network.target
|
|||||||
|
|
||||||
[Service]
|
[Service]
|
||||||
EnvironmentFile=/etc/sysconfig/dhcpd6
|
EnvironmentFile=/etc/sysconfig/dhcpd6
|
||||||
ExecStart=/usr/sbin/dhcpd -d -6 -cf /etc/dhcp/dhcpd6.conf -user dhcpd -group dhcpd --no-pid $DHCPDARGS
|
ExecStart=/usr/sbin/dhcpd -f -6 -cf /etc/dhcp/dhcpd6.conf -user dhcpd -group dhcpd --no-pid $DHCPDARGS
|
||||||
PrivateTmp=true
|
|
||||||
|
|
||||||
[Install]
|
[Install]
|
||||||
WantedBy=multi-user.target
|
WantedBy=multi-user.target
|
||||||
|
Loading…
Reference in New Issue
Block a user