5c9a2d488e
Resolves: #2175198
40 lines
1.2 KiB
Diff
40 lines
1.2 KiB
Diff
From a6afd3ee7c9b5a6ab2906c827464acceb75123b2 Mon Sep 17 00:00:00 2001
|
|
From: Marian Csontos <mcsontos@redhat.com>
|
|
Date: Wed, 22 Mar 2023 09:42:15 +0100
|
|
Subject: [PATCH] Tweak cargo.toml to work with vendor directory
|
|
|
|
Mock works offline, cargo would try to download the files from github.
|
|
So cargo vendor has to be run first, and then change the Cargo.toml to
|
|
make mock happy.
|
|
---
|
|
Cargo.toml | 6 ++++--
|
|
1 file changed, 4 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/Cargo.toml b/Cargo.toml
|
|
index 135ba5f8..cbb73ec1 100644
|
|
--- a/Cargo.toml
|
|
+++ b/Cargo.toml
|
|
@@ -11,7 +11,8 @@ anyhow = "1.0"
|
|
base64 = "0.20"
|
|
byteorder = "1.4"
|
|
clap = "3.2"
|
|
-crc32c = { git = "https://github.com/zowens/crc32c", branch = "master" }
|
|
+#crc32c = { git = "https://github.com/zowens/crc32c", branch = "master" }
|
|
+crc32c = "0.6"
|
|
data-encoding = "2.3"
|
|
exitcode = "1.1.2"
|
|
fixedbitset = "0.4"
|
|
@@ -28,7 +29,8 @@ quick-xml = "0.23.1"
|
|
rand = "0.8"
|
|
rangemap = "1.1"
|
|
roaring = "0.10"
|
|
-rio = { git = "https://github.com/jthornber/rio", branch = "master", optional = true }
|
|
+#rio = { git = "https://github.com/jthornber/rio", branch = "master", optional = true }
|
|
+rio = { version = "0.9.4", optional = true }
|
|
safemem = "0.3"
|
|
threadpool = "1.8"
|
|
thiserror = "1.0"
|
|
--
|
|
2.40.1
|
|
|